source: projects/specs/trunk/c/clearsilver/clearsilver-vl.spec @ 521

Revision 521, 2.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name clearsilver
2%define version 0.10.5
3%define release 4%{_dist_release}
4%define python_sitelib %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')
5
6Summary: A fast, powerful, and language-neutral HTML template system.
7Summary(ja): 高速、パワフルで言語中立なHTMLテンプレートシステム
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Source0: http://clearsilver.net/downloads/%{name}-%{version}.tar.gz
12Patch0: clearsilver-0.10.5-conf.patch
13License: Neotonic ClearSilver Software License
14Group: Applications/Documentation
15URL: http://clearsilver.net/
16
17BuildRequires: perl, ruby-devel, python-devel, zlib-devel
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24ClearSilver is a fast, powerful, and language-neutral template system.
25It is designed to make it easy to create template driven static or
26dynamic websites.
27
28%description -l ja
29Clearsilver は高速、強力で言語中立なテンプレートシステムです。
30テンプレート駆動の静的あるいは動的な Web サイトの構築を
31容易にすることを目指して設計されています。
32
33%prep
34%setup -q
35%patch0 -p1 -b .conf
36
37%build
38%configure --disable-csharp
39
40%ifarch x86_64
41perl -pi -e 's/^(TARGETS =.+) test/$1/' cs/Makefile
42%endif
43
44%__make %{_smp_mflags}
45
46%install
47rm -rf $RPM_BUILD_ROOT
48cd ruby
49%ruby install.rb config --rb-dir=${RPM_BUILD_ROOT}%{rlibdir} --so-dir=${RPM_BUILD_ROOT}%{rarchdir}
50cd ..
51make DESTDIR=${RPM_BUILD_ROOT} install
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(-,root,root)
58%doc CS_LICENSE INSTALL LICENSE README README.python
59%{_bindir}/*
60%{_includedir}/ClearSilver/
61%{perl_sitearch}/*.pm
62%{perl_sitearch}/auto/ClearSilver/
63%{rarchdir}/*.so
64%{rlibdir}/*.rb
65%{python_sitelib}/*.so
66%{_libdir}/*.a
67%{_mandir}/man*/*.gz
68
69%changelog
70* Mon Jun 22 2009 Shu KONNO <owa@bg.wakwak.com> 0.10.5-4
71- applied new versioning policy, spec in utf-8
72
73* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.5-3
74- rebuilt with python-2.5.2
75- added clearsilver-0.10.5-conf.patch
76
77* Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-2
78- rebuilt with perl-5.10.0.
79
80* Mon Apr 28 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-1
81- x86_64: make to skip testing.
82
83* Fri Nov 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.5-0vl4
84- add --disable-csharp for configure script
85
86* Tue Aug 28 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.10.5-0vl2
87- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.