source: projects/specs/trunk/c/clearsilver/clearsilver-vl.spec @ 11287

Revision 11287, 4.4 KB checked in by tomop, 6 years ago (diff)

clearsilver-0.10.5-11,php-ext-clearsilver-0.4-1

Line 
1%bcond_with ruby
2
3%define name clearsilver
4%define version 0.10.5
5%define release 11%{_dist_release}
6
7Summary: A fast, powerful, and language-neutral HTML template system.
8Summary(ja): 高速、パワフルで言語中立なHTMLテンプレートシステム
9Name: %{name}
10Version: %{version}
11Release: %{release}
12
13License: Neotonic ClearSilver Software License
14Group: Applications/Text
15URL: http://clearsilver.net/
16
17Source0: http://clearsilver.net/downloads/%{name}-%{version}.tar.gz
18Patch0: clearsilver-0.10.5-conf.patch
19Patch1: clearsilver-0.10.5-regression.patch
20Patch2: clearsilver-0.10.5-CVE-2011-4357.patch
21Patch3: clearsilver-ruby-1.9.patch
22Patch4: clearsilver-ruby-2.2.patch
23# GCC 5 compatibility, bug #1190760
24Patch5: clearsilver-0.10.5-gcc5.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: perl
28BuildRequires: python-devel
29%if %{with ruby}
30BuildRequires: ruby
31BuildRequires: ruby-devel >= 1.9.3
32%endif
33BuildRequires: zlib-devel
34Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
35Provides: ruby(clearsilver)
36
37Vendor: Project Vine
38Distribution: Vine Linux
39
40%description
41ClearSilver is a fast, powerful, and language-neutral template system.
42It is designed to make it easy to create template driven static or
43dynamic websites.
44
45%description -l ja
46Clearsilver は高速、強力で言語中立なテンプレートシステムです。
47テンプレート駆動の静的あるいは動的な Web サイトの構築を
48容易にすることを目指して設計されています。
49
50%prep
51%setup -q
52%patch0 -p1 -b .conf
53%patch1 -p1
54%patch2 -p1
55%if %{with ruby}
56%patch3 -p1
57%patch4 -p1
58%endif
59%patch5 -p2
60
61touch configure
62perl -pi -e 's/python_versions="2\.5/python_versions="2.7 2.6 2.5/' configure
63sed -i 's|/neo/opt/bin/python|%{__python}|' python/examples/*/*.py
64sed -i 's|PYTHON_SITE = @PYTHON_SITE@|PYTHON_SITE = %{python_sitearch}|' rules.mk.in
65sed -i -r 's|(\$\(RUBY\) install.rb config) (--.*)|\1 --rb-dir="$(DESTDIR)%{ruby_vendorlibdir}" --so-dir="$(DESTDIR)%{ruby_vendorarchdir}" \2|' ruby/Makefile
66find python/examples -type f | xargs chmod -x
67
68%build
69%configure \
70%if ! %{with ruby}
71 --disable-ruby \
72%endif
73 --disable-csharp
74
75%ifarch x86_64
76perl -pi -e 's/^(TARGETS =.+) test/$1/' cs/Makefile
77%endif
78
79%__make %{_smp_mflags}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83make DESTDIR=${RPM_BUILD_ROOT} install
84
85find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
86find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
87find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
88find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
89chmod -R u+w $RPM_BUILD_ROOT/*
90
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%files
96%defattr(-,root,root)
97%doc CS_LICENSE INSTALL LICENSE README README.python
98%{_bindir}/*
99%{_includedir}/ClearSilver/
100%{perl_sitearch}/*.pm
101%{perl_sitearch}/auto/ClearSilver/
102%{python_sitearch}/*.so
103%if %{with ruby}
104%{ruby_vendorarchdir}/*.so
105%{ruby_vendorlibdir}/*.rb
106%endif
107%{_libdir}/*.a
108%{_mandir}/man*/*.gz
109
110%changelog
111* Tue Dec 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-11
112- added Patch5 for gcc5.
113- disabled ruby stuff.
114
115* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.5-10
116- rebuild with ruby-2.2.3
117- add Patch4 (clearsilver-ruby-2.2.patch) from fedora
118
119* Wed Dec 17 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.5-9
120- rebuilt with perl 5.16.3 and ruby 2.1.5
121
122* Sun Dec 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-8
123- rebuilt with ruby-2.0.0.353.
124
125* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.5-7
126- rebuild with ruby-1.9.3
127- add patch3 to build with ruby-1.9
128- add patch2 for CVE-2011-4357
129
130* Sat Feb 25 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-6
131- rebuilt with python-2.7.
132
133* Sun May 15 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-5
134- rebuilt with perl-5.12.3 and python-2.6.
135
136* Mon Jun 22 2009 Shu KONNO <owa@bg.wakwak.com> 0.10.5-4
137- applied new versioning policy, spec in utf-8
138
139* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.5-3
140- rebuilt with python-2.5.2
141- added clearsilver-0.10.5-conf.patch
142
143* Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-2
144- rebuilt with perl-5.10.0.
145
146* Mon Apr 28 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-1
147- x86_64: make to skip testing.
148
149* Fri Nov 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.5-0vl4
150- add --disable-csharp for configure script
151
152* Tue Aug 28 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.10.5-0vl2
153- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.