source: projects/specs/trunk/c/chromium/chromium17-vl.spec @ 5680

Revision 5680, 31.1 KB checked in by munepi, 12 years ago (diff)

updated chromium

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_jpeg 1
8
9#% define with_system_icu 1
10#% define with_system_v8 1
11%define with_system_vpx 1
12
13#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
14# There's a couple key GYP variables that control how FFmpeg is built:
15#   ffmpeg_branding
16#     Controls whether we build the Chromium or Google Chrome version of
17#     FFmpeg.  The Google Chrome version contains additional codecs.
18#     Typical values are Chromium, Chrome, ChromiumOS, and ChromeOS.
19#   use_system_ffmpeg
20#     When set to non-zero will build Chromium against the system FFmpeg
21#     headers via pkg-config.  When Chromium is launched it will assume that
22#     FFmpeg is present in the system library path.  Default value is 0.
23#   build_ffmpegsumo
24#     When set to zero will build Chromium against the patched ffmpegsumo
25#     headers, but not build ffmpegsumo itself.  Users are expected to build
26#     and provide their own version of ffmpegsumo.  Default value is 1.
27%define with_system_ffmpeg 1
28
29%global chrome_sandbox %{_prefix}/lib/chrome_sandbox
30
31#Name:           chromium17
32Name:           chromium
33Summary:        Google's opens source browser project
34Summary(ja):    Googleのオープンソースウェブブラウザ
35#'
36Version:        17.0.963.57
37Release:        1%{?_dist_release}
38License:        BSD
39Group:          Applications/Internet
40Source0:        %{pkgname}-%{version}.tar.xz
41# Script used to create the %{pkgname}-%{version}.tar.xz archive from
42# a official tarball:
43# http://gsdview.appspot.com/chromium-browser-official/chromium-17.0.963.XXX.tar.bz2
44Source3:        pack_chromium17_source-vine.sh
45# Official ffmpeg headers
46Source8:        ffmpeg-0.6-headers.tar.xz
47#Source8:        ffmpeg-0.9-headers.tar.xz
48# Patch template which adds vendor to user agent
49##!!Source20:       chromium-vendor.patch.in
50Source20:       chromium-vendor-vine.patch.in
51# Set default prefs
52##!!Source30:       master_preferences
53Source30:       master_preferences.vine
54##!!Source31:       default_bookmarks.html
55#Source31:       default_bookmarks.html.vine
56Source99:       chrome-wrapper
57##!!Source100:      chromium-browser.sh
58Source100:      chromium-browser-vine.sh
59##!!Source101:      chromium-browser.desktop
60Source101:      chromium-browser-vine.desktop
61Source102:      chromium-browser.xml
62#Source103:      chromium-browser-rpmlintrc
63##!!Source104:      chromium-icons.tar.bz2
64
65%{?nosrc:NoSource: 0}
66
67# Provides:       chromium-unstable = %{version}-%{release}
68# Obsoletes:      chromium13 chromium14 chromium15
69# Conflicts:      chromium-stable
70Provides:       chromium-stable = %{version}-%{release}
71Conflicts:      chromium-unstable
72
73## Start Patches
74# OpenSuse and Fedora
75# Many changes to the gyp systems so we can use system libraries
76Patch1:         chromium-gcc46.patch
77Patch4:         chromium-no-sqlite-debug.patch
78Patch8:         chromium-codechanges-zlib.patch
79Patch13:        chromium-no-courgette.patch
80Patch14:        chromium-master-prefs-path.patch
81Patch17:        chromium-system-glew.patch
82Patch18:        chromium-system-expat.patch
83Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
84Patch25:        tcmalloc-factory.patch
85Patch26:        chromium-remoting-build-fix.diff
86Patch28:        chromium-7.0.500.0-system-speex.patch
87Patch32:        chromium-7.0.542.0-system-libvpx.patch
88Patch62:        chromium-norpath.patch
89Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
90Patch64:        chromium-more-codec-aliases.patch
91
92# Vine
93#Patch100:       chromium-15.0.874.116-no-tests.patch
94
95
96##!!BuildRequires:  Mesa-devel
97BuildRequires:  mesa-libGLU-devel
98##!!BuildRequires:  alsa-devel
99BuildRequires:  alsa-lib-devel
100BuildRequires:  pulseaudio-libs-devel
101BuildRequires:  bison
102BuildRequires:  cups-devel
103BuildRequires:  desktop-file-utils
104BuildRequires:  fdupes
105BuildRequires:  flex
106BuildRequires:  freetype2-devel
107BuildRequires:  gcc gcc-c++
108BuildRequires:  gperf
109BuildRequires:  hunspell-devel
110##!!BuildRequires:  libbz2-devel
111BuildRequires:  bzip2-devel
112BuildRequires:  libevent
113##!!BuildRequires:  libexpat-devel
114BuildRequires:  expat-devel
115##!!BuildRequires:  libgnutls-devel
116BuildRequires:  gnutls-devel
117%{?with_system_jpeg:BuildRequires:  libjpeg-devel}
118BuildRequires:  libpng-devel
119BuildRequires:  libstdc++-devel >= 4.4
120%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
121BuildRequires:  libxslt-devel
122BuildRequires:  libzip-devel
123##!!BuildRequires:  lzma
124BuildRequires:  xz
125##!!BuildRequires:  mozilla-nspr-devel
126BuildRequires:  nspr-devel
127##!!BuildRequires:  mozilla-nss-devel
128BuildRequires:  nss-devel
129BuildRequires:  openssl-devel
130BuildRequires:  pam-devel
131##!!BuildRequires:  perl(Switch)
132BuildRequires:  perl
133##!!BuildRequires:  pkg-config
134BuildRequires:  cairo-devel >= 1.6
135BuildRequires:  dbus-devel
136BuildRequires:  dbus-glib-devel
137##!!BuildRequires:  gconf2-devel
138BuildRequires:  GConf2-devel
139BuildRequires:  glib2-devel
140BuildRequires:  gtk2-devel
141BuildRequires:  libxml2-devel
142BuildRequires:  python
143##!!BuildRequires:  python-xml
144BuildRequires:  python-pyxml
145BuildRequires:  sqlite3-devel
146##!!BuildRequires:  update-desktop-files
147%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
148##!!BuildRequires:  wdiff
149BuildRequires:  zlib-devel
150
151BuildRequires:  libgnome-keyring-devel
152BuildRequires:  python-devel
153
154#BuildRequires:  glew-devel
155BuildRequires:  libevent-devel
156%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
157#BuildRequires:  libjingle-devel >= 0.4.0-7
158#BuildRequires:  srtp-devel
159BuildRequires:  speex-devel
160
161##Vine Linux
162#BuildRequires:  libpaper-devel
163BuildRequires:  libXScrnSaver-devel
164BuildRequires:  libXtst-devel
165BuildRequires:  libXdamage-devel
166BuildRequires:  libXt-devel
167%ifarch x86_64
168Requires:  nspluginwrapper
169%endif
170
171##!!Requires:       alsa
172Requires:       alsa-lib
173Requires:       pulseaudio-libs
174Requires:       xdg-utils
175%{?with_system_v8:Requires:       v8 = %{v8_ver}}
176
177BuildRoot:      %{_tmppath}/%{name}-%{version}-root
178
179%description
180Chromium is the open-source project behind Google Chrome.
181We invite you to join us in our effort to help build a safer, faster,
182and more stable way for all Internet users to experience the web,
183and to create a powerful platform for developing a new generation of
184web applications.
185
186%description -l ja
187Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
188ウェブを体験しているすべてのインターネットユーザに対して
189より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
190そして、ウェブアプリケーションの新しい世代を発展させ、
191強力なプラットホームを作成するために、
192私たちの取り組みにぜひ参加してください。
193
194
195%prep
196#%setup -q
197[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
198xz -dc %{SOURCE0} | %__tar -xf - || exit 1
199%setup -D -T -n %{pkgname}-%{version}
200
201%if %{?_dist_release} == "vl7"
202%patch1 -p1
203%endif
204%patch62 -p1
205%{?with_system_v8:%patch63 -p1}
206%patch64
207#%patch100 -p1 -b .vine
208%patch8 -p1
209%patch13 -p1
210%patch14 -p1
211%patch17 -p1
212%patch18 -p1
213%patch20 -p1
214#%patch25 -p1
215%patch26 -p1
216%patch28 -p1
217%{?with_system_vpx:%patch32 -p1}
218%patch4 -p1
219
220
221pushd src/third_party/ffmpeg/
222%__tar xf %{SOURCE8} || exit 1
223## built header file: avconfig.h
224[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
225cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
226/* Generated by ffconf */
227#ifndef AVUTIL_AVCONFIG_H
228#define AVUTIL_AVCONFIG_H
229#define AV_HAVE_BIGENDIAN 0
230#define AV_HAVE_FAST_UNALIGNED 1
231#endif /* AVUTIL_AVCONFIG_H */
232EOF
233popd
234
235# apply vendor patch after substitution
236%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
237
238# Make sure that the requires legal files can be found
239%__cp -a src/AUTHORS src/LICENSE . || exit 1
240
241%build
242
243## create make files
244
245PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
246for i in src/build/common.gypi; do
247        %__sed -i "s|'-march=pentium4',||g" $i
248        %__sed -i "s|'-mfpmath=sse',||g" $i
249        %__sed -i "s|'-O<(debug_optimize)',||g" $i
250        %__sed -i "s|'-m32',||g" $i
251        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
252        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
253done
254# '
255
256pushd src
257
258./build/gyp_chromium -f make build/all.gyp \
259    -Dlinux_sandbox_path=%{chrome_sandbox} \
260    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium \
261    -Duse_openssl=0 \
262    %{?with_system_ffmpeg:-Duse_system_ffmpeg=1} \
263    %{!?with_system_ffmpeg:-Duse_system_ffmpeg=0} \
264    -Dbuild_ffmpegsumo=0 \
265    -Duse_system_zlib=1 \
266    -Duse_system_libpng=1 \
267    -Duse_system_bzip2=1 \
268    -Duse_system_libbz2=1 \
269    %{?with_system_jpeg:-Duse_system_libjpeg=1} \
270    %{!?with_system_jpeg:-Duse_system_libjpeg=0} \
271    -Duse_system_libxml=1 \
272    -Duse_system_libxslt=1 \
273    -Duse_system_libevent=1 \
274    %{?with_system_vpx:-Duse_system_vpx=1} \
275    %{!?with_system_vpx:-Duse_system_vpx=0} \
276    -Dremove_webcore_debug_symbols=1 \
277    %{?with_system_v8:-Duse_system_v8=1} \
278    %{!?with_system_v8:-Duse_system_v8=0} \
279    %{?with_system_icu:-Duse_system_icu=1} \
280    %{!?with_system_icu:-Duse_system_icu=0} \
281    %{?_with_shared_library:-Dlibrary=shared_library} \
282    -Dproprietary_codecs=1 \
283    -Ddisable_nacl=1 \
284    -Djavascript_engine=v8 \
285    -Dlinux_fpic=1 \
286    -Ddisable_sse2=1 \
287    %ifarch %{ix86}
288        -Dtarget_arch=ia32 \
289    %endif
290    %ifarch x86_64
291        -Dtarget_arch=x64 \
292    %endif
293    -Dno_strict_aliasing=1 \
294    -Drelease_extra_cflags=-fPIC \
295    %if %{?_dist_release} == "vl6"
296        -Dgcc_version=44 \
297    %endif
298    ;
299
300%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release disable_nacl=1
301
302# Build the required SUID_SANDBOX helper
303%__make -r %{?_smp_mflags} chrome_sandbox V=1 BUILDTYPE=Release disable_nacl=1
304
305popd
306
307%install
308%{__rm} -rf %{buildroot}
309
310%__mkdir -p %{buildroot}%{_bindir}
311%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
312%ifarch x86_64
313mkdir -p %{buildroot}%{_prefix}/lib/
314%endif
315# x86_64 capable systems need this
316%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
317%__mkdir -p %{buildroot}%{_libdir}/chromium/
318%__mkdir -p %{buildroot}%{_mandir}/man1/
319pushd src/out/Release
320%__cp -a chrome_sandbox %{buildroot}%{_prefix}/lib/
321%__cp -a chrome.pak locales resources xdg-mime xdg-settings %{buildroot}%{_libdir}/chromium/
322%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
323%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
324%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
325%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
326%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
327%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
328fdupes %{buildroot}%{_mandir}/man1/
329popd
330
331%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
332%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
333for i in 16 22 24 32 48 64 128 256; do
334    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
335    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
336done
337
338%__mkdir_p %{buildroot}%{_datadir}/applications/
339desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
340
341%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
342%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
343
344# # link to browser plugin path.  Plugin patch doesn't work. Why?
345# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
346# pushd %{buildroot}%{_libdir}/%{pkgname}
347# %{__ln_s} %{_libdir}/browser-plugins plugins
348# popd
349pushd %{buildroot}%{_libdir}/%{pkgname}
350%ifarch x86_64
351%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
352%else
353%{__ln_s} %{_libdir}/mozilla/plugins plugins
354%endif
355popd
356
357# Install the master_preferences file
358%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
359#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
360%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
361#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
362
363%clean
364%{__rm} -rf %{buildroot}
365
366%post
367touch --no-create %{_datadir}/icons/hicolor
368if [ -x %{_bindir}/gtk-update-icon-cache ]; then
369  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
370fi
371%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
372
373%postun
374%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
375touch --no-create %{_datadir}/icons/hicolor
376if [ -x %{_bindir}/gtk-update-icon-cache ]; then
377  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
378fi || :
379
380
381%files
382%defattr(-,root,root,-)
383%config %{_sysconfdir}/%{pkgname}
384%dir %{_datadir}/gnome-control-center
385%dir %{_datadir}/gnome-control-center/default-apps
386%dir %{_libdir}/chromium/
387%{_bindir}/chromium
388%{_libdir}/chromium/chromium
389%{_libdir}/chromium/plugins/
390%{_libdir}/chromium/resources/
391%attr(755,root,root) %{_libdir}/chromium/xdg-settings
392%attr(755,root,root) %{_libdir}/chromium/xdg-mime
393%{_mandir}/man1/chrom*
394%{_datadir}/pixmaps/chromium-browser.png
395%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
396%{_datadir}/applications/*.desktop
397%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
398#%{_datadir}/icons/oxygen/
399%{_libdir}/chromium/chrome.pak
400%{_libdir}/chromium/resources.pak
401%{_libdir}/chromium/locales/
402%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
403%attr(4755,root,root) %{chrome_sandbox}
404
405%changelog
406* Fri Feb 17 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.57-1
407- updated to 17.0.963.57
408
409* Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
410- updated to 17.0.963.54
411
412* Sat Feb 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.52-1
413- updated to 17.0.963.52
414
415* Sat Feb  4 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.77-1
416- updated to 16.0.912.77
417
418* Sun Jan  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.75-1
419- updated to 16.0.912.75
420
421* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.63-1
422- updated to 16.0.912.63
423
424* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.57-1
425- updated to 16.0.912.57
426
427* Sat Oct 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 15.0.874.116-1
428- updated to 15.0.874.116
429
430* Wed Oct 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.204-1
431- updated to 14.0.835.204
432- added BuildRequires: dbus-glib-devel
433
434* Sat Sep 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.186-1
435- updated to 14.0.835.186
436
437* Sun Sep 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.163-1
438- updated to 14.0.835.163
439
440* Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
441- updated to 14.0.835.157
442
443* Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
444- updated to 14.0.835.102
445
446* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
447- updated to 14.0.835.89
448- added Obsoletes: chromium-unstable < %{version}-%{release}
449
450* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
451- updated to 14.0.835.35
452- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
453- changed to Name: chromium14
454  - Provides:  chromium-unstable = %%{version}
455  - Conflicts: chromium-stable
456
457* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
458- changed to Name: chromium
459- updated to 13.0.782.107
460
461* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
462- updated to 13.0.782.88
463- added BuildRequires: libzip-devel
464- added Provides: chromium-unstable = %%{version}
465- added Conflicts: chromium-stable
466
467* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
468- fix user-agent string (chromium-vendor-vine.patch.in)
469  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
470
471* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
472- updated to 12.0.742.93
473- fixed icon field of chromium-browser-vine.desktop
474
475* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
476- updated to 12.0.742.91
477
478* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
479- updated to 12.0.742.77
480
481* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
482- updated to 12.0.742.63
483
484* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
485- updated to 12.0.742.42
486
487* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
488- updated to 12.0.742.6
489- dropped/upstreamed patches
490- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
491
492* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
493- updated to 11.0.696.50
494- dropped some Patches for MeeGo Netbook
495
496* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
497- updated to 11.0.696.35
498
499* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
500- updated to 11.0.696.29
501- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
502
503* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
504- updated to 11.0.696.22
505- improved chromium-browser-vine.sh
506  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
507
508* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
509- updated to 11.0.696.20
510- improved chromium-browser-vine.desktop
511
512* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
513- updated to 11.0.696.17
514
515* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
516- updated to 11.0.696.15
517  - ready for Vine Linux 6 release
518- dropped BuildRequires: v8-devel, libicu-devel
519
520* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
521- updated to 11.0.696.5 with v8 3.2.0
522- added BuildRequires: pam-devel
523
524* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
525- rebuilt with libevent-2.0.10
526
527* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
528- updated to 10.0.651.0 with v8 3.0.12
529- added BuildRequires:
530  - libpaper-devel
531  - python-devel
532- added built header file: libavutil/avconfig.h %%prep
533- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
534
535* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
536- updated to 10.0.622.0
537- added BuildRequires: libXt-devel
538
539* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
540- updated to 10.0.605.0
541- added BuildRequires:
542  - libXdamage-devel
543  - hunspell-devel
544
545* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
546- updated to 9.0.598
547
548* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
549- updated to 9.0.593
550
551* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
552- updated to 9.0.582
553- added Requires: xdg-utils
554
555* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
556- updated to 9.0.578
557
558* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
559- updated to 9.0.569
560
561  * Mon Oct 25 2010 tittiatcoke@gmail.com
562  - Update to 9.0.564 build
563    * Added specific patches for MeeGo.
564    * We are now using shared libraries for Chromium
565    * Spec-file cleanup (Thanks to prusnak)
566
567* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
568- updated to snapshot 8.0.556
569
570* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
571- updated to snapshot 8.0.551
572
573* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
574- updated to snapshot 7.0.527
575
576* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
577- updated to snapshot 7.0.519
578
579* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
580- updated to snapshot 7.0.513
581  - updated chromium-vendor-vine.patch.in
582
583* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
584- updated to snapshot 7.0.507
585
586* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
587- updated to snapshot 7.0.498
588
589* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
590- updated to snapshot 6.0.493
591- used with_system_icu (for vl6)
592  - added BuildRequires: libicu-devel
593
594* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
595- build for Vine Linux 5.x
596  - add BuildRequires: gnome-keyring-devel
597
598* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
599- updated to snapshot 6.0.454
600- added BuildRequires:
601  - sqlite3-devel
602  - gnutls-devel
603  - libgnome-keyring-devel
604
605* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
606- updated to snapshot 6.0.431.0 r49253
607- added BuildRequires: cups-devel
608
609* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
610- updated to snapshot 6.0.405.0 r47263
611
612* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
613- unused with_system_icu (for vl6)
614  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
615
616* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
617- updated to snapshot 5.0.378.0 r44472
618  - used with_system_icu (for vl6)
619  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
620
621* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
622- updated to snapshot 5.0.372.0 r43947
623- added BuildRequires: glew-devel
624- changed Group tag to Applications/Internet
625- added Summary(ja) and %%description -l ja
626
627* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
628- updated to snapshot 5.0.365.0 r42966
629- merged 5.0.353.0-4vl5
630 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
631 - build on Vine Linux 5.1
632   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
633
634* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
635- updated to snapshot 5.0.364.0 r42779
636
637* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
638- updated to snapshot 5.0.359.0 r42116
639- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
640
641* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
642- fixed master_preferences.vine, little
643
644* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
645- fixed to install master_preferences
646- dropped chromium-5.0.353-no-ffmpeg-vine.patch
647
648* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
649- applied chromium-5.0.353-no-ffmpeg-vine.patch
650
651* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
652- updated to snapshot 5.0.353.0 r41449
653  * Wed Mar 10 2010 bgmerrell@novell.com
654  - Add master_preferences source file and install it to /etc/chromium.
655  - Create a new patch (chromium-master-prefs-path.patch) which tells
656    chromium to look in /etc/chromium for the master_preferences file
657    (instead of looking in the default directory, which is the same
658    directory as the 'chrome' binary).
659
660* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
661- updated to snapshot 5.0.335.0 r39556
662
663* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
664- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
665
666* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
667- updated to snapshot 5.0.330.0 r39074
668
669* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
670- use_system_ffmpeg
671
672* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
673- added Requires:  nspluginwrapper
674- fixed a symbolic link of plugins directory with nspluginwrapper
675
676* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
677- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
678
679* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
680- added BuildRequires: mesa-libGLU-devel
681- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
682
683* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
684- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
685
686  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
687  - Update to 4.0.260
688  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
689  - Update to 4.0.259
690  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
691  - Update to 4.0.258
692  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
693  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
694    changed to having an built-in v8
695  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
696  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
697  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
698  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
699  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
700  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
701  - update to newer svn snapshot
702    + Obsoletes fwrite patch (included upstream)
703  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
704  - update to newer svn snapshot
705    + Requires newer version of v8
706  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
707  - do not force SSE on x86 (drop-sse.patch)
708  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
709  - Update to newer svn snapshot
710  - Fixed spec file in order to build
711  - Included patch to build with system zlib
712  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
713  - package renamed to chromium
714  - cleaned up spec file
715  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
716  - v8 is now built as a separate package, and is required
717  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
718  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
719  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
720  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
721  - initial build
722
723#% changelog
724* Sun Jan 24 2010 prusnak@suse.cz
725- added vendor to user agent (chromium-vendor.patch.in)
726* Sun Nov 29 2009 prusnak@suse.cz
727- added --enable-sync to wrapper to enable bookmark sync
728* Sun Nov 29 2009 tittiatcoke@gmail.com 
729- Update to 4.0.260
730* Fri Nov 27 2009 tittiatcoke@gmail.com 
731- Update to 4.0.259
732* Thu Nov 26 2009 tittiatcoke@gmail.com 
733- Update to 4.0.258
734* Tue Nov 24 2009 tittatcoke@gmai.com 
735- In order to complete prevent the wrong v8 version to be used,
736  the Chromium build has been changed to having an built-in v8
737* Tue Nov 24 2009 dbuck@example.com 
738- Re-base patches.
739- Fixed a few patch errors.
740- Rename some patches to better correspond with function.
741- Removed some patches.
742- Minor SPEC changes.
743- I changed the v8 requirement to be exact, instead of greater than a specific version.
744* Fri Nov 13 2009 tittiatcoke@gmail.com
745- update to 247.0 svn 31928
746* Fri Oct 30 2009 tittiatcoke@gmail.com
747- update to 229.0 svn 30454
748  + Fix regression where popups and app frames lost their titlebars.
749  + Makes it so that when a folder is open on the bookmark bar
750    and the mouse moves over another folder, the menu for that
751    folder is shown.
752  + Lazily create the find bar.
753  + Polish to the gmail checker sample.
754  * New, crisper icons that are exactly 19x19
755  * Add a loading animation at the beginning before Gmail
756    responds.
757  * Fix a bug where we sometimes don't update the UI after a
758    logout/login cycle.
759  + Refactor widget methods to support desktop notifications,
760    including GTK stubs.
761  + Find-in-page should not ding while deleting characters.
762  + Add SSL wrapper for linux and mac.  This allows notifier to
763    use chrome's SSL layer instead of OpenSSL.
764  + Add three of the six extensions to PAC that Internet Explorer supports.
765  + WebSocket support in chromium. (Run with --enable-web-sockets
766    enables WebSocket features.)
767  + Do not allow GTK File Chooser dialogs to return directories.
768  + Fix the notifier SSL layer to make notifications work for
769    Linux Bookmark sync.
770  + linux: don't override mouse selection behavior in omnibox
771* Sun Oct 25 2009 tittiatcoke@gmail.com
772- Update to 224.4 svn 30027
773  + First cut at new page and browser action docs based
774    on new API. Deleted old stuff.
775  + Add suppression for new memory leak caused by WebKit merge 49830:49844
776  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
777  + Minimize dependency of user scripts
778  + Fixup the flip_framer eof-handling semantics now that we have
779    the FIN bit in place
780  + app depends on x11 because of active_window_watcher_x
781  + Adding two images for the new Extension managment UI
782  + Removing hard-coded Chrome Frame output path
783  + Rearrange clipboard code
784  + Fix crash bug when attempting to download a url with unsupported scheme,
785    e.g. 'data:', by 'Alt + Click'
786  + GTK: Change text for extension download UI
787  + Ignore invalid urls on command line
788  + Make dropped tabs animate from where they were dropped.
789  + Make room for the full width of the tab placeholder.
790  + Make tab dragging as smooth as glass.
791  + Remove an annoying NOTIMPLEMNETED
792  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
793  + If we're in the middle of a drag, don't allow the user to middle
794    click to close or right click for the context menu
795  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
796  + Remove +x bit from files that shouldn't have it
797  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
798  + Adding new image needed for the managment UI
799  + Fix a race bug where content scripts would not apply to the first page load
800  + Make escape remove a bookmark if it's just been added (but not if it already existed)
801  + Fix bubbles deactivating the opaque frame
802  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
803  + ake all pepper plugins default to windowless and transparent
804  + Add styles for printing
805  + Implement the new extension management UI
806  + Add support for to automation interface load install and load extensions
807  + GTK: theme the info bar border
808  + Update V8 to version 1.3.16.1
809  + Introduce WebSecurityPolicy for security related methods
810  + New button scheme...borders are separate from the inner contents so
811    that they can be highlighted / depressed independently
812  + When opening Chrome maximized with an application window already
813    running, the Chrome window was not activated
814  + Fix compatibility problems with FileZilla FTP Server
815  + Remove the extension shelf on Linux
816  + Fix the proxy host and port string to start with http:// if it does not already
817  + Enable HTML5 databases for all extension renderer processes
818* Sat Oct 24 2009 prusnak@opensuse.org 
819- don't create desktop files in wrapper
820- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
821* Tue Oct 20 2009 tittiatcoke@gmail.com 
822- update to newer svn snapshot
823  + Obsoletes fwrite patch (included upstream)
824* Fri Oct 16 2009 tittiatcoke@gmail.com 
825- update to newer svn snapshot
826  + Requires newer version of v8
827* Thu Oct 15 2009 prusnak@suse.cz 
828- do not force SSE on x86 (drop-sse.patch)
829* Tue Oct 13 2009 tittiatcoke@gmail.com 
830- Update to newer svn snapshot
831- Fixed spec file in order to build
832- Included patch to build with system zlib
833* Mon Oct 12 2009 prusnak@suse.cz 
834- package renamed to chromium
835- cleaned up spec file
836* Tue Oct  6 2009 dbuck@example.com 
837- v8 is now built as a separate package, and is required
838- included many patches to use system libraries:
839    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
840* Thu Oct  1 2009 dbuck@example.com 
841- included a newer DEP than is in svn, native_client@823
842- things should compile cleanly now
843* Mon Aug 31 2009 dbuck@example.com 
844- initial build
Note: See TracBrowser for help on using the repository browser.