source: projects/specs/trunk/c/chromium/chromium17-vl.spec @ 5814

Revision 5814, 31.3 KB checked in by munepi, 12 years ago (diff)

updated chromium

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_jpeg 1
8
9#% define with_system_icu 1
10#% define with_system_v8 1
11%define with_system_vpx 1
12
13#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
14# There's a couple key GYP variables that control how FFmpeg is built:
15#   ffmpeg_branding
16#     Controls whether we build the Chromium or Google Chrome version of
17#     FFmpeg.  The Google Chrome version contains additional codecs.
18#     Typical values are Chromium, Chrome, ChromiumOS, and ChromeOS.
19#   use_system_ffmpeg
20#     When set to non-zero will build Chromium against the system FFmpeg
21#     headers via pkg-config.  When Chromium is launched it will assume that
22#     FFmpeg is present in the system library path.  Default value is 0.
23#   build_ffmpegsumo
24#     When set to zero will build Chromium against the patched ffmpegsumo
25#     headers, but not build ffmpegsumo itself.  Users are expected to build
26#     and provide their own version of ffmpegsumo.  Default value is 1.
27%define with_system_ffmpeg 1
28
29%global chrome_sandbox %{_prefix}/lib/chrome_sandbox
30
31#Name:           chromium17
32Name:           chromium
33Summary:        Google's opens source browser project
34Summary(ja):    Googleのオープンソースウェブブラウザ
35#'
36Version:        17.0.963.65
37Release:        1%{?_dist_release}
38License:        BSD
39Group:          Applications/Internet
40Source0:        %{pkgname}-%{version}.tar.xz
41# Script used to create the %{pkgname}-%{version}.tar.xz archive from
42# a official tarball:
43# http://gsdview.appspot.com/chromium-browser-official/chromium-17.0.963.XXX.tar.bz2
44Source3:        pack_chromium17_source-vine.sh
45# Official ffmpeg headers
46Source8:        ffmpeg-0.6-headers.tar.xz
47#Source8:        ffmpeg-0.9-headers.tar.xz
48# Patch template which adds vendor to user agent
49##!!Source20:       chromium-vendor.patch.in
50Source20:       chromium-vendor-vine.patch.in
51# Set default prefs
52##!!Source30:       master_preferences
53Source30:       master_preferences.vine
54##!!Source31:       default_bookmarks.html
55#Source31:       default_bookmarks.html.vine
56Source99:       chrome-wrapper
57##!!Source100:      chromium-browser.sh
58Source100:      chromium-browser-vine.sh
59##!!Source101:      chromium-browser.desktop
60Source101:      chromium-browser-vine.desktop
61Source102:      chromium-browser.xml
62#Source103:      chromium-browser-rpmlintrc
63##!!Source104:      chromium-icons.tar.bz2
64
65%{?nosrc:NoSource: 0}
66
67# Provides:       chromium-unstable = %{version}-%{release}
68# Obsoletes:      chromium13 chromium14 chromium15
69# Conflicts:      chromium-stable
70Provides:       chromium-stable = %{version}-%{release}
71Conflicts:      chromium-unstable
72
73## Start Patches
74# OpenSuse and Fedora
75# Many changes to the gyp systems so we can use system libraries
76Patch1:         chromium-gcc46.patch
77Patch4:         chromium-no-sqlite-debug.patch
78Patch8:         chromium-codechanges-zlib.patch
79Patch13:        chromium-no-courgette.patch
80Patch14:        chromium-master-prefs-path.patch
81Patch17:        chromium-system-glew.patch
82Patch18:        chromium-system-expat.patch
83Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
84Patch25:        tcmalloc-factory.patch
85Patch26:        chromium-remoting-build-fix.diff
86Patch28:        chromium-7.0.500.0-system-speex.patch
87Patch32:        chromium-7.0.542.0-system-libvpx.patch
88Patch62:        chromium-norpath.patch
89Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
90Patch64:        chromium-more-codec-aliases.patch
91
92# Vine
93#Patch100:       chromium-15.0.874.116-no-tests.patch
94
95
96##!!BuildRequires:  Mesa-devel
97BuildRequires:  mesa-libGLU-devel
98##!!BuildRequires:  alsa-devel
99BuildRequires:  alsa-lib-devel
100BuildRequires:  pulseaudio-libs-devel
101BuildRequires:  bison
102BuildRequires:  cups-devel
103BuildRequires:  desktop-file-utils
104BuildRequires:  fdupes
105BuildRequires:  flex
106BuildRequires:  freetype2-devel
107BuildRequires:  gcc gcc-c++
108BuildRequires:  gperf
109BuildRequires:  hunspell-devel
110##!!BuildRequires:  libbz2-devel
111BuildRequires:  bzip2-devel
112BuildRequires:  libevent
113##!!BuildRequires:  libexpat-devel
114BuildRequires:  expat-devel
115##!!BuildRequires:  libgnutls-devel
116BuildRequires:  gnutls-devel
117%{?with_system_jpeg:BuildRequires:  libjpeg-devel}
118BuildRequires:  libpng-devel
119BuildRequires:  libstdc++-devel >= 4.4
120%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
121BuildRequires:  libxslt-devel
122BuildRequires:  libzip-devel
123##!!BuildRequires:  lzma
124BuildRequires:  xz
125##!!BuildRequires:  mozilla-nspr-devel
126BuildRequires:  nspr-devel
127##!!BuildRequires:  mozilla-nss-devel
128BuildRequires:  nss-devel
129BuildRequires:  openssl-devel
130BuildRequires:  pam-devel
131##!!BuildRequires:  perl(Switch)
132BuildRequires:  perl
133##!!BuildRequires:  pkg-config
134BuildRequires:  cairo-devel >= 1.6
135BuildRequires:  dbus-devel
136BuildRequires:  dbus-glib-devel
137##!!BuildRequires:  gconf2-devel
138BuildRequires:  GConf2-devel
139BuildRequires:  glib2-devel
140BuildRequires:  gtk2-devel
141BuildRequires:  libxml2-devel
142BuildRequires:  python
143##!!BuildRequires:  python-xml
144BuildRequires:  python-pyxml
145BuildRequires:  sqlite3-devel
146##!!BuildRequires:  update-desktop-files
147%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
148##!!BuildRequires:  wdiff
149BuildRequires:  zlib-devel
150
151BuildRequires:  libgnome-keyring-devel
152BuildRequires:  python-devel
153
154#BuildRequires:  glew-devel
155BuildRequires:  libevent-devel
156%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
157#BuildRequires:  libjingle-devel >= 0.4.0-7
158#BuildRequires:  srtp-devel
159BuildRequires:  speex-devel
160
161##Vine Linux
162#BuildRequires:  libpaper-devel
163BuildRequires:  libXScrnSaver-devel
164BuildRequires:  libXtst-devel
165BuildRequires:  libXdamage-devel
166BuildRequires:  libXt-devel
167%ifarch x86_64
168Requires:  nspluginwrapper
169%endif
170
171##!!Requires:       alsa
172Requires:       alsa-lib
173Requires:       pulseaudio-libs
174Requires:       xdg-utils
175%{?with_system_v8:Requires:       v8 = %{v8_ver}}
176
177BuildRoot:      %{_tmppath}/%{name}-%{version}-root
178
179%description
180Chromium is the open-source project behind Google Chrome.
181We invite you to join us in our effort to help build a safer, faster,
182and more stable way for all Internet users to experience the web,
183and to create a powerful platform for developing a new generation of
184web applications.
185
186%description -l ja
187Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
188ウェブを体験しているすべてのインターネットユーザに対して
189より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
190そして、ウェブアプリケーションの新しい世代を発展させ、
191強力なプラットホームを作成するために、
192私たちの取り組みにぜひ参加してください。
193
194
195%prep
196#%setup -q
197[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
198xz -dc %{SOURCE0} | %__tar -xf - || exit 1
199%setup -D -T -n %{pkgname}-%{version}
200
201%if %{?_dist_release} == "vl7"
202%patch1 -p1
203%endif
204%patch62 -p1
205%{?with_system_v8:%patch63 -p1}
206%patch64
207#%patch100 -p1 -b .vine
208%patch8 -p1
209%patch13 -p1
210%patch14 -p1
211%patch17 -p1
212%patch18 -p1
213%patch20 -p1
214#%patch25 -p1
215%patch26 -p1
216%patch28 -p1
217%{?with_system_vpx:%patch32 -p1}
218%patch4 -p1
219
220
221pushd src/third_party/ffmpeg/
222%__tar xf %{SOURCE8} || exit 1
223## built header file: avconfig.h
224[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
225cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
226/* Generated by ffconf */
227#ifndef AVUTIL_AVCONFIG_H
228#define AVUTIL_AVCONFIG_H
229#define AV_HAVE_BIGENDIAN 0
230#define AV_HAVE_FAST_UNALIGNED 1
231#endif /* AVUTIL_AVCONFIG_H */
232EOF
233popd
234
235# apply vendor patch after substitution
236%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
237
238# Make sure that the requires legal files can be found
239%__cp -a src/AUTHORS src/LICENSE . || exit 1
240
241%build
242
243## create make files
244
245PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
246for i in src/build/common.gypi; do
247        %__sed -i "s|'-march=pentium4',||g" $i
248        %__sed -i "s|'-mfpmath=sse',||g" $i
249        %__sed -i "s|'-O<(debug_optimize)',||g" $i
250        %__sed -i "s|'-m32',||g" $i
251        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
252        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
253done
254# '
255
256pushd src
257
258./build/gyp_chromium -f make build/all.gyp \
259    -Dlinux_sandbox_path=%{chrome_sandbox} \
260    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium \
261    -Duse_openssl=0 \
262    %{?with_system_ffmpeg:-Duse_system_ffmpeg=1} \
263    %{!?with_system_ffmpeg:-Duse_system_ffmpeg=0} \
264    -Dbuild_ffmpegsumo=0 \
265    -Duse_system_zlib=1 \
266    -Duse_system_libpng=1 \
267    -Duse_system_bzip2=1 \
268    -Duse_system_libbz2=1 \
269    %{?with_system_jpeg:-Duse_system_libjpeg=1} \
270    %{!?with_system_jpeg:-Duse_system_libjpeg=0} \
271    -Duse_system_libxml=1 \
272    -Duse_system_libxslt=1 \
273    -Duse_system_libevent=1 \
274    %{?with_system_vpx:-Duse_system_vpx=1} \
275    %{!?with_system_vpx:-Duse_system_vpx=0} \
276    -Dremove_webcore_debug_symbols=1 \
277    %{?with_system_v8:-Duse_system_v8=1} \
278    %{!?with_system_v8:-Duse_system_v8=0} \
279    %{?with_system_icu:-Duse_system_icu=1} \
280    %{!?with_system_icu:-Duse_system_icu=0} \
281    %{?_with_shared_library:-Dlibrary=shared_library} \
282    -Dproprietary_codecs=1 \
283    -Ddisable_nacl=1 \
284    -Djavascript_engine=v8 \
285    -Dlinux_fpic=1 \
286    -Ddisable_sse2=1 \
287    %ifarch %{ix86}
288        -Dtarget_arch=ia32 \
289    %endif
290    %ifarch x86_64
291        -Dtarget_arch=x64 \
292    %endif
293    -Dno_strict_aliasing=1 \
294    -Drelease_extra_cflags=-fPIC \
295    %if %{?_dist_release} == "vl6"
296        -Dgcc_version=44 \
297    %endif
298    ;
299
300%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release disable_nacl=1
301
302# Build the required SUID_SANDBOX helper
303%__make -r %{?_smp_mflags} chrome_sandbox V=1 BUILDTYPE=Release disable_nacl=1
304
305popd
306
307%install
308%{__rm} -rf %{buildroot}
309
310%__mkdir -p %{buildroot}%{_bindir}
311%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
312%ifarch x86_64
313mkdir -p %{buildroot}%{_prefix}/lib/
314%endif
315# x86_64 capable systems need this
316%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
317%__mkdir -p %{buildroot}%{_libdir}/chromium/
318%__mkdir -p %{buildroot}%{_mandir}/man1/
319pushd src/out/Release
320%__cp -a chrome_sandbox %{buildroot}%{_prefix}/lib/
321%__cp -a chrome.pak locales resources xdg-mime xdg-settings %{buildroot}%{_libdir}/chromium/
322%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
323%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
324%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
325%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
326%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
327%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
328fdupes %{buildroot}%{_mandir}/man1/
329popd
330
331%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
332%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
333for i in 16 22 24 32 48 64 128 256; do
334    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
335    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
336done
337
338%__mkdir_p %{buildroot}%{_datadir}/applications/
339desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
340
341%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
342%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
343
344# # link to browser plugin path.  Plugin patch doesn't work. Why?
345# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
346# pushd %{buildroot}%{_libdir}/%{pkgname}
347# %{__ln_s} %{_libdir}/browser-plugins plugins
348# popd
349pushd %{buildroot}%{_libdir}/%{pkgname}
350%ifarch x86_64
351%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
352%else
353%{__ln_s} %{_libdir}/mozilla/plugins plugins
354%endif
355popd
356
357# Install the master_preferences file
358%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
359#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
360%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
361#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
362
363%clean
364%{__rm} -rf %{buildroot}
365
366%post
367touch --no-create %{_datadir}/icons/hicolor
368if [ -x %{_bindir}/gtk-update-icon-cache ]; then
369  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
370fi
371%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
372
373%postun
374%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
375touch --no-create %{_datadir}/icons/hicolor
376if [ -x %{_bindir}/gtk-update-icon-cache ]; then
377  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
378fi || :
379
380
381%files
382%defattr(-,root,root,-)
383%config %{_sysconfdir}/%{pkgname}
384%dir %{_datadir}/gnome-control-center
385%dir %{_datadir}/gnome-control-center/default-apps
386%dir %{_libdir}/chromium/
387%{_bindir}/chromium
388%{_libdir}/chromium/chromium
389%{_libdir}/chromium/plugins/
390%{_libdir}/chromium/resources/
391%attr(755,root,root) %{_libdir}/chromium/xdg-settings
392%attr(755,root,root) %{_libdir}/chromium/xdg-mime
393%{_mandir}/man1/chrom*
394%{_datadir}/pixmaps/chromium-browser.png
395%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
396%{_datadir}/applications/*.desktop
397%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
398#%{_datadir}/icons/oxygen/
399%{_libdir}/chromium/chrome.pak
400%{_libdir}/chromium/resources.pak
401%{_libdir}/chromium/locales/
402%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
403%attr(4755,root,root) %{chrome_sandbox}
404
405%changelog
406* Sat Mar  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.65-1
407- updated to 17.0.963.65
408
409* Wed Feb 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.60-1
410- updated to 17.0.963.60
411
412* Fri Feb 17 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.57-1
413- updated to 17.0.963.57
414
415* Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
416- updated to 17.0.963.54
417
418* Sat Feb 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.52-1
419- updated to 17.0.963.52
420
421* Sat Feb  4 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.77-1
422- updated to 16.0.912.77
423
424* Sun Jan  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.75-1
425- updated to 16.0.912.75
426
427* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.63-1
428- updated to 16.0.912.63
429
430* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.57-1
431- updated to 16.0.912.57
432
433* Sat Oct 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 15.0.874.116-1
434- updated to 15.0.874.116
435
436* Wed Oct 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.204-1
437- updated to 14.0.835.204
438- added BuildRequires: dbus-glib-devel
439
440* Sat Sep 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.186-1
441- updated to 14.0.835.186
442
443* Sun Sep 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.163-1
444- updated to 14.0.835.163
445
446* Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
447- updated to 14.0.835.157
448
449* Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
450- updated to 14.0.835.102
451
452* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
453- updated to 14.0.835.89
454- added Obsoletes: chromium-unstable < %{version}-%{release}
455
456* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
457- updated to 14.0.835.35
458- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
459- changed to Name: chromium14
460  - Provides:  chromium-unstable = %%{version}
461  - Conflicts: chromium-stable
462
463* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
464- changed to Name: chromium
465- updated to 13.0.782.107
466
467* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
468- updated to 13.0.782.88
469- added BuildRequires: libzip-devel
470- added Provides: chromium-unstable = %%{version}
471- added Conflicts: chromium-stable
472
473* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
474- fix user-agent string (chromium-vendor-vine.patch.in)
475  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
476
477* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
478- updated to 12.0.742.93
479- fixed icon field of chromium-browser-vine.desktop
480
481* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
482- updated to 12.0.742.91
483
484* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
485- updated to 12.0.742.77
486
487* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
488- updated to 12.0.742.63
489
490* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
491- updated to 12.0.742.42
492
493* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
494- updated to 12.0.742.6
495- dropped/upstreamed patches
496- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
497
498* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
499- updated to 11.0.696.50
500- dropped some Patches for MeeGo Netbook
501
502* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
503- updated to 11.0.696.35
504
505* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
506- updated to 11.0.696.29
507- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
508
509* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
510- updated to 11.0.696.22
511- improved chromium-browser-vine.sh
512  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
513
514* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
515- updated to 11.0.696.20
516- improved chromium-browser-vine.desktop
517
518* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
519- updated to 11.0.696.17
520
521* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
522- updated to 11.0.696.15
523  - ready for Vine Linux 6 release
524- dropped BuildRequires: v8-devel, libicu-devel
525
526* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
527- updated to 11.0.696.5 with v8 3.2.0
528- added BuildRequires: pam-devel
529
530* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
531- rebuilt with libevent-2.0.10
532
533* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
534- updated to 10.0.651.0 with v8 3.0.12
535- added BuildRequires:
536  - libpaper-devel
537  - python-devel
538- added built header file: libavutil/avconfig.h %%prep
539- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
540
541* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
542- updated to 10.0.622.0
543- added BuildRequires: libXt-devel
544
545* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
546- updated to 10.0.605.0
547- added BuildRequires:
548  - libXdamage-devel
549  - hunspell-devel
550
551* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
552- updated to 9.0.598
553
554* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
555- updated to 9.0.593
556
557* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
558- updated to 9.0.582
559- added Requires: xdg-utils
560
561* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
562- updated to 9.0.578
563
564* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
565- updated to 9.0.569
566
567  * Mon Oct 25 2010 tittiatcoke@gmail.com
568  - Update to 9.0.564 build
569    * Added specific patches for MeeGo.
570    * We are now using shared libraries for Chromium
571    * Spec-file cleanup (Thanks to prusnak)
572
573* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
574- updated to snapshot 8.0.556
575
576* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
577- updated to snapshot 8.0.551
578
579* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
580- updated to snapshot 7.0.527
581
582* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
583- updated to snapshot 7.0.519
584
585* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
586- updated to snapshot 7.0.513
587  - updated chromium-vendor-vine.patch.in
588
589* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
590- updated to snapshot 7.0.507
591
592* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
593- updated to snapshot 7.0.498
594
595* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
596- updated to snapshot 6.0.493
597- used with_system_icu (for vl6)
598  - added BuildRequires: libicu-devel
599
600* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
601- build for Vine Linux 5.x
602  - add BuildRequires: gnome-keyring-devel
603
604* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
605- updated to snapshot 6.0.454
606- added BuildRequires:
607  - sqlite3-devel
608  - gnutls-devel
609  - libgnome-keyring-devel
610
611* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
612- updated to snapshot 6.0.431.0 r49253
613- added BuildRequires: cups-devel
614
615* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
616- updated to snapshot 6.0.405.0 r47263
617
618* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
619- unused with_system_icu (for vl6)
620  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
621
622* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
623- updated to snapshot 5.0.378.0 r44472
624  - used with_system_icu (for vl6)
625  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
626
627* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
628- updated to snapshot 5.0.372.0 r43947
629- added BuildRequires: glew-devel
630- changed Group tag to Applications/Internet
631- added Summary(ja) and %%description -l ja
632
633* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
634- updated to snapshot 5.0.365.0 r42966
635- merged 5.0.353.0-4vl5
636 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
637 - build on Vine Linux 5.1
638   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
639
640* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
641- updated to snapshot 5.0.364.0 r42779
642
643* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
644- updated to snapshot 5.0.359.0 r42116
645- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
646
647* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
648- fixed master_preferences.vine, little
649
650* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
651- fixed to install master_preferences
652- dropped chromium-5.0.353-no-ffmpeg-vine.patch
653
654* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
655- applied chromium-5.0.353-no-ffmpeg-vine.patch
656
657* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
658- updated to snapshot 5.0.353.0 r41449
659  * Wed Mar 10 2010 bgmerrell@novell.com
660  - Add master_preferences source file and install it to /etc/chromium.
661  - Create a new patch (chromium-master-prefs-path.patch) which tells
662    chromium to look in /etc/chromium for the master_preferences file
663    (instead of looking in the default directory, which is the same
664    directory as the 'chrome' binary).
665
666* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
667- updated to snapshot 5.0.335.0 r39556
668
669* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
670- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
671
672* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
673- updated to snapshot 5.0.330.0 r39074
674
675* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
676- use_system_ffmpeg
677
678* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
679- added Requires:  nspluginwrapper
680- fixed a symbolic link of plugins directory with nspluginwrapper
681
682* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
683- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
684
685* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
686- added BuildRequires: mesa-libGLU-devel
687- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
688
689* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
690- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
691
692  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
693  - Update to 4.0.260
694  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
695  - Update to 4.0.259
696  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
697  - Update to 4.0.258
698  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
699  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
700    changed to having an built-in v8
701  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
702  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
703  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
704  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
705  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
706  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
707  - update to newer svn snapshot
708    + Obsoletes fwrite patch (included upstream)
709  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
710  - update to newer svn snapshot
711    + Requires newer version of v8
712  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
713  - do not force SSE on x86 (drop-sse.patch)
714  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
715  - Update to newer svn snapshot
716  - Fixed spec file in order to build
717  - Included patch to build with system zlib
718  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
719  - package renamed to chromium
720  - cleaned up spec file
721  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
722  - v8 is now built as a separate package, and is required
723  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
724  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
725  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
726  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
727  - initial build
728
729#% changelog
730* Sun Jan 24 2010 prusnak@suse.cz
731- added vendor to user agent (chromium-vendor.patch.in)
732* Sun Nov 29 2009 prusnak@suse.cz
733- added --enable-sync to wrapper to enable bookmark sync
734* Sun Nov 29 2009 tittiatcoke@gmail.com 
735- Update to 4.0.260
736* Fri Nov 27 2009 tittiatcoke@gmail.com 
737- Update to 4.0.259
738* Thu Nov 26 2009 tittiatcoke@gmail.com 
739- Update to 4.0.258
740* Tue Nov 24 2009 tittatcoke@gmai.com 
741- In order to complete prevent the wrong v8 version to be used,
742  the Chromium build has been changed to having an built-in v8
743* Tue Nov 24 2009 dbuck@example.com 
744- Re-base patches.
745- Fixed a few patch errors.
746- Rename some patches to better correspond with function.
747- Removed some patches.
748- Minor SPEC changes.
749- I changed the v8 requirement to be exact, instead of greater than a specific version.
750* Fri Nov 13 2009 tittiatcoke@gmail.com
751- update to 247.0 svn 31928
752* Fri Oct 30 2009 tittiatcoke@gmail.com
753- update to 229.0 svn 30454
754  + Fix regression where popups and app frames lost their titlebars.
755  + Makes it so that when a folder is open on the bookmark bar
756    and the mouse moves over another folder, the menu for that
757    folder is shown.
758  + Lazily create the find bar.
759  + Polish to the gmail checker sample.
760  * New, crisper icons that are exactly 19x19
761  * Add a loading animation at the beginning before Gmail
762    responds.
763  * Fix a bug where we sometimes don't update the UI after a
764    logout/login cycle.
765  + Refactor widget methods to support desktop notifications,
766    including GTK stubs.
767  + Find-in-page should not ding while deleting characters.
768  + Add SSL wrapper for linux and mac.  This allows notifier to
769    use chrome's SSL layer instead of OpenSSL.
770  + Add three of the six extensions to PAC that Internet Explorer supports.
771  + WebSocket support in chromium. (Run with --enable-web-sockets
772    enables WebSocket features.)
773  + Do not allow GTK File Chooser dialogs to return directories.
774  + Fix the notifier SSL layer to make notifications work for
775    Linux Bookmark sync.
776  + linux: don't override mouse selection behavior in omnibox
777* Sun Oct 25 2009 tittiatcoke@gmail.com
778- Update to 224.4 svn 30027
779  + First cut at new page and browser action docs based
780    on new API. Deleted old stuff.
781  + Add suppression for new memory leak caused by WebKit merge 49830:49844
782  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
783  + Minimize dependency of user scripts
784  + Fixup the flip_framer eof-handling semantics now that we have
785    the FIN bit in place
786  + app depends on x11 because of active_window_watcher_x
787  + Adding two images for the new Extension managment UI
788  + Removing hard-coded Chrome Frame output path
789  + Rearrange clipboard code
790  + Fix crash bug when attempting to download a url with unsupported scheme,
791    e.g. 'data:', by 'Alt + Click'
792  + GTK: Change text for extension download UI
793  + Ignore invalid urls on command line
794  + Make dropped tabs animate from where they were dropped.
795  + Make room for the full width of the tab placeholder.
796  + Make tab dragging as smooth as glass.
797  + Remove an annoying NOTIMPLEMNETED
798  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
799  + If we're in the middle of a drag, don't allow the user to middle
800    click to close or right click for the context menu
801  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
802  + Remove +x bit from files that shouldn't have it
803  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
804  + Adding new image needed for the managment UI
805  + Fix a race bug where content scripts would not apply to the first page load
806  + Make escape remove a bookmark if it's just been added (but not if it already existed)
807  + Fix bubbles deactivating the opaque frame
808  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
809  + ake all pepper plugins default to windowless and transparent
810  + Add styles for printing
811  + Implement the new extension management UI
812  + Add support for to automation interface load install and load extensions
813  + GTK: theme the info bar border
814  + Update V8 to version 1.3.16.1
815  + Introduce WebSecurityPolicy for security related methods
816  + New button scheme...borders are separate from the inner contents so
817    that they can be highlighted / depressed independently
818  + When opening Chrome maximized with an application window already
819    running, the Chrome window was not activated
820  + Fix compatibility problems with FileZilla FTP Server
821  + Remove the extension shelf on Linux
822  + Fix the proxy host and port string to start with http:// if it does not already
823  + Enable HTML5 databases for all extension renderer processes
824* Sat Oct 24 2009 prusnak@opensuse.org 
825- don't create desktop files in wrapper
826- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
827* Tue Oct 20 2009 tittiatcoke@gmail.com 
828- update to newer svn snapshot
829  + Obsoletes fwrite patch (included upstream)
830* Fri Oct 16 2009 tittiatcoke@gmail.com 
831- update to newer svn snapshot
832  + Requires newer version of v8
833* Thu Oct 15 2009 prusnak@suse.cz 
834- do not force SSE on x86 (drop-sse.patch)
835* Tue Oct 13 2009 tittiatcoke@gmail.com 
836- Update to newer svn snapshot
837- Fixed spec file in order to build
838- Included patch to build with system zlib
839* Mon Oct 12 2009 prusnak@suse.cz 
840- package renamed to chromium
841- cleaned up spec file
842* Tue Oct  6 2009 dbuck@example.com 
843- v8 is now built as a separate package, and is required
844- included many patches to use system libraries:
845    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
846* Thu Oct  1 2009 dbuck@example.com 
847- included a newer DEP than is in svn, native_client@823
848- things should compile cleanly now
849* Mon Aug 31 2009 dbuck@example.com 
850- initial build
Note: See TracBrowser for help on using the repository browser.