source: projects/specs/trunk/c/chromium/chromium12-vl.spec @ 4348

Revision 4348, 28.4 KB checked in by munepi, 13 years ago (diff)

updated chromum; NEW chromium13

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_icu 1
8#% define with_system_v8 1
9
10#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
11#     libvpx doesn't currently supply a pkg-config file, so we assume that
12#     -lvpx is sufficient.
13%define with_system_vpx 1
14
15#Name:           chromium12
16Name:           chromium
17Summary:        Google's opens source browser project
18Summary(ja):    Googleのオープンソースウェブブラウザ
19#'
20Version:        12.0.742.124
21Release:        1%{?_dist_release}
22License:        BSD
23Group:          Applications/Internet
24Source0:        %{pkgname}-%{version}.tar.xz
25# Script used to create the %{pkgname}-%{version}.tar.xz archive from
26# a official tarball:
27# http://build.chromium.org/official/chromium-12.0.742.XXX.tar.bz2
28Source3:        pack_chromium12_source-vine.sh
29# Official ffmpeg headers
30Source8:        ffmpeg-0.6-headers.tar.xz
31#Source10:       chromium.desktop
32#Source10:       chromium-vine.desktop
33# Patch template which adds vendor to user agent
34##!!Source20:       chromium-vendor.patch.in
35Source20:       chromium-vendor-vine.patch.in
36# Set default prefs
37##!!Source30:       master_preferences
38Source30:       master_preferences.vine
39##!!Source31:       default_bookmarks.html
40#Source31:       default_bookmarks.html.vine
41Source99:       chrome-wrapper
42##!!Source100:      chromium-browser.sh
43Source100:      chromium-browser-vine.sh
44##!!Source101:      chromium-browser.desktop
45Source101:      chromium-browser-vine.desktop
46Source102:      chromium-browser.xml
47Source103:      chromium-browser-rpmlintrc
48##!!Source104:      chromium-icons.tar.bz2
49
50%{?nosrc:NoSource: 0}
51
52Provides:       chromium-stable = %{version}
53Conflicts:      chromium-unstable
54
55## Start Patches
56# Many changes to the gyp systems so we can use system libraries
57Patch4:         chromium-no-sqlite-debug.patch
58Patch8:         chromium-codechanges-zlib.patch
59Patch12:        chromium-no-test-sources.patch
60Patch13:        chromium-no-courgette.patch
61Patch14:        chromium-master-prefs-path.patch
62Patch17:        chromium-system-glew.patch
63Patch18:        chromium-system-expat.patch
64Patch19:        chromium-system-zlib.patch
65Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
66Patch21:        chromium-7.0.542.0-media-probe.patch
67Patch25:        tcmalloc-factory.patch
68Patch26:        chromium-remoting-build-fix.diff
69Patch28:        chromium-7.0.500.0-system-speex.patch
70Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
71Patch32:        chromium-7.0.542.0-system-libvpx.patch
72Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
73Patch62:        chromium-norpath.patch
74Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
75
76# Vine
77Patch100:       chromium-12.0.742.6-no-tests.patch
78
79
80BuildRequires:  gcc gcc-c++
81BuildRequires:  libstdc++ libstdc++-devel
82BuildRequires:  libevent
83##!!BuildRequires:  pkg-config
84BuildRequires:  python
85##!!BuildRequires:  python-xml
86BuildRequires:  python-pyxml
87BuildRequires:  perl bison flex gperf
88##!!BuildRequires:  wdiff
89##!!BuildRequires:  update-desktop-files
90#BuildRequires:  lzma
91BuildRequires:  xz
92##!!BuildRequires:  mozilla-nss-devel
93BuildRequires:  nss-devel
94##!!BuildRequires:  alsa-devel
95BuildRequires:  alsa-lib-devel
96BuildRequires:  gtk2-devel
97BuildRequires:  glib2-devel
98BuildRequires:  cairo-devel >= 1.6
99##!!BuildRequires:  mozilla-nspr-devel
100BuildRequires:  nspr-devel
101##!!BuildRequires:  gconf2-devel
102BuildRequires:  GConf2-devel
103BuildRequires:  freetype2-devel
104##!!BuildRequires:  dbus-1-devel
105BuildRequires:  dbus-devel
106BuildRequires:  libxslt-devel
107BuildRequires:  libxml2-devel
108BuildRequires:  libjpeg-devel
109BuildRequires:  zlib-devel
110##!!BuildRequires:  libbz2-devel
111BuildRequires:  bzip2-devel
112BuildRequires:  cups-devel
113BuildRequires:  fdupes
114##!!BuildRequires:  libexpat-devel
115BuildRequires:  expat-devel
116BuildRequires:  libpng-devel
117BuildRequires:  sqlite3-devel
118BuildRequires:  gnutls-devel
119BuildRequires:  desktop-file-utils
120%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
121%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
122BuildRequires:  pam-devel
123BuildRequires:  libgnome-keyring-devel
124BuildRequires:  python-devel
125BuildRequires:  glew-devel
126##!!BuildRequires:  Mesa-devel
127BuildRequires:  mesa-libGLU-devel
128BuildRequires:  hunspell-devel
129
130%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
131BuildRequires:  libevent-devel
132#BuildRequires:  libjingle-devel >= 0.4.0-7
133#BuildRequires:  srtp-devel
134BuildRequires:  speex-devel
135
136##Vine Linux
137%{?with_system_v8:Requires:       v8 = %{v8_ver}}
138BuildRequires:  libpaper-devel
139BuildRequires:  libXScrnSaver-devel
140BuildRequires:  libXtst-devel
141BuildRequires:  libXdamage-devel
142BuildRequires:  libXt-devel
143#BuildRequires:  gle-devel
144#BuildRequires:  webkit-gtk-devel
145#BuildRequires:  scons
146%ifarch x86_64
147Requires:  nspluginwrapper
148%endif
149
150##!!Requires:       alsa
151Requires:       alsa-lib
152Requires:       xdg-utils
153# shouldn't be required to name all dependencies
154# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
155
156BuildRoot:      %{_tmppath}/%{name}-%{version}-root
157
158%description
159Chromium is the open-source project behind Google Chrome.
160We invite you to join us in our effort to help build a safer, faster,
161and more stable way for all Internet users to experience the web,
162and to create a powerful platform for developing a new generation of
163web applications.
164
165%description -l ja
166Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
167ウェブを体験しているすべてのインターネットユーザに対して
168より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
169そして、ウェブアプリケーションの新しい世代を発展させ、
170強力なプラットホームを作成するために、
171私たちの取り組みにぜひ参加してください。
172
173
174%prep
175#%setup -q
176[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
177xz -dc %{SOURCE0} | %__tar -xf - || exit 1
178%setup -D -T -n %{pkgname}-%{version}
179
180%patch62 -p1
181%{?with_system_v8:%patch63 -p1}
182%patch100 -p1 -b .vine
183%patch4 -p1
184%patch8 -p1
185%patch12 -p1
186%patch13 -p1
187%patch14 -p1
188%patch17 -p1
189%patch18 -p1
190%patch19 -p1
191%patch20 -p1
192%patch21 -p1
193%patch25 -p1
194%patch26 -p1
195%patch28 -p1
196%patch29 -p1
197%{?with_system_vpx:%patch32 -p1}
198%{?with_system_v8:%patch34 -p1}
199
200pushd src/third_party/ffmpeg/
201%__tar xf %{SOURCE8} || exit 1
202## built header file: avconfig.h
203[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
204cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
205/* Generated by ffconf */
206#ifndef AVUTIL_AVCONFIG_H
207#define AVUTIL_AVCONFIG_H
208#define AV_HAVE_BIGENDIAN 0
209#endif /* AVUTIL_AVCONFIG_H */
210EOF
211popd
212
213#%__rm -rf src/third_party/libvpx/
214%__rm -rf src/third_party/speex/
215%__rm -rf src/third_party/nss src/third_party/nspr
216
217# apply vendor patch after substitution
218%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
219
220%build
221
222## create make files
223
224PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
225for i in src/build/common.gypi; do
226        %__sed -i "s|'-march=pentium4',||g" $i
227        %__sed -i "s|'-mfpmath=sse',||g" $i
228        %__sed -i "s|'-O<(debug_optimize)',||g" $i
229        %__sed -i "s|'-m32',||g" $i
230        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
231        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
232done
233# '
234
235pushd src
236
237./build/gyp_chromium -f make build/all.gyp \
238    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
239    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
240    -Duse_openssl=0 \
241    -Duse_system_ffmpeg=1 \
242    -Duse_system_zlib=1 \
243    -Duse_system_libpng=1 \
244    -Duse_system_bzip2=1 \
245    -Duse_system_libbz2=1 \
246    -Duse_system_libjpeg=1 \
247    -Duse_system_libxml=1 \
248    -Duse_system_libxslt=1 \
249    -Duse_system_libevent=1 \
250    %{?with_system_vpx:-Duse_system_vpx=1} \
251    %{!?with_system_vpx:-Duse_system_vpx=0} \
252    -Dproprietary_codecs=1 \
253    -Dlibrary=shared_library \
254    -Djavascript_engine=v8 \
255    -Dlinux_fpic=1 \
256    %{?with_system_v8:-Duse_system_v8=1} \
257    %{!?with_system_v8:-Duse_system_v8=0} \
258    %{?with_system_icu:-Duse_system_icu=1} \
259    %{!?with_system_icu:-Duse_system_icu=0} \
260    %ifarch %{ix86}
261        -Dtarget_arch=ia32 \
262         -Ddisable_sse2=1 \
263    %endif
264    %ifarch x86_64
265        -Dtarget_arch=x64 \
266    %endif
267    %if %{?_dist_release} == "vl6"
268        -Dno_strict_aliasing=1 -Dgcc_version=44 \
269    %endif
270    -Drelease_extra_cflags=-fPIC \
271    ;
272
273#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
274#%__make -r -j5 chrome BUILDTYPE=Release
275%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
276
277popd
278
279%install
280%{__rm} -rf %{buildroot}
281
282%__mkdir -p %{buildroot}%{_bindir}
283%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
284# x86_64 capable systems need this
285%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
286%__mkdir -p %{buildroot}%{_libdir}/chromium/
287%__mkdir -p %{buildroot}%{_mandir}/man1/
288pushd src/out/Release
289%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
290%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
291%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
292%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
293%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
294%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
295%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
296fdupes %{buildroot}%{_mandir}/man1/
297popd
298
299%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
300%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
301for i in 16 22 24 32 48 64 128 256; do
302    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
303    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
304done
305
306%__mkdir_p %{buildroot}%{_datadir}/applications/
307desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
308
309%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
310%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
311
312# # link to browser plugin path.  Plugin patch doesn't work. Why?
313# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
314# pushd %{buildroot}%{_libdir}/%{pkgname}
315# %{__ln_s} %{_libdir}/browser-plugins plugins
316# popd
317pushd %{buildroot}%{_libdir}/%{pkgname}
318%ifarch x86_64
319%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
320%else
321%{__ln_s} %{_libdir}/mozilla/plugins plugins
322%endif
323
324## support ffmpeg libs
325touch %{buildroot}%{_libdir}/libavcodec.so.52
326%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
327touch %{buildroot}%{_libdir}/libavformat.so.52
328%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
329touch %{buildroot}%{_libdir}/libavutil.so.50
330%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
331popd
332
333# Install the master_preferences file
334%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
335#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
336%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
337#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
338
339%clean
340%{__rm} -rf %{buildroot}
341
342%post
343touch --no-create %{_datadir}/icons/hicolor
344if [ -x %{_bindir}/gtk-update-icon-cache ]; then
345  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
346fi
347%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
348
349%postun
350%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
351touch --no-create %{_datadir}/icons/hicolor
352if [ -x %{_bindir}/gtk-update-icon-cache ]; then
353  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
354fi || :
355
356
357%files
358%defattr(-,root,root,-)
359%config %{_sysconfdir}/%{pkgname}
360%dir %{_datadir}/gnome-control-center
361%dir %{_datadir}/gnome-control-center/default-apps
362%{_bindir}/chromium
363%{_libdir}/chromium/chromium
364%{_libdir}/chromium/plugins/
365%{_libdir}/chromium/resources/
366%{_libdir}/chromium/xdg-settings
367%{_mandir}/man1/chrom*
368%{_datadir}/pixmaps/chromium-browser.png
369%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
370%{_datadir}/applications/*.desktop
371%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
372%{_libdir}/chromium/libavcodec.so.52
373%{_libdir}/chromium/libavutil.so.50
374%{_libdir}/chromium/libavformat.so.52
375%exclude %{_libdir}/libavcodec.so.52
376%exclude %{_libdir}/libavutil.so.50
377%exclude %{_libdir}/libavformat.so.52
378## libs
379%dir %{_libdir}/chromium/
380%{_libdir}/chromium/chrome.pak
381%{_libdir}/chromium/resources.pak
382%{_libdir}/chromium/locales/
383%{_libdir}/chromium/lib*.so
384
385%changelog
386* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.124-1
387- updated to 12.0.742.124
388- added Provides: chromium-stable = %%{version}
389- added Conflicts: chromium-unstable
390
391* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
392- fix user-agent string (chromium-vendor-vine.patch.in)
393  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
394
395* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
396- updated to 12.0.742.93
397- fixed icon field of chromium-browser-vine.desktop
398
399* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
400- updated to 12.0.742.91
401
402* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
403- updated to 12.0.742.77
404
405* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
406- updated to 12.0.742.63
407
408* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
409- updated to 12.0.742.42
410
411* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
412- updated to 12.0.742.6
413- dropped/upstreamed patches
414- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
415
416* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
417- updated to 11.0.696.50
418- dropped some Patches for MeeGo Netbook
419
420* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
421- updated to 11.0.696.35
422
423* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
424- updated to 11.0.696.29
425- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
426
427* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
428- updated to 11.0.696.22
429- improved chromium-browser-vine.sh
430  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
431
432* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
433- updated to 11.0.696.20
434- improved chromium-browser-vine.desktop
435
436* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
437- updated to 11.0.696.17
438
439* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
440- updated to 11.0.696.15
441  - ready for Vine Linux 6 release
442- dropped BuildRequires: v8-devel, libicu-devel
443
444* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
445- updated to 11.0.696.5 with v8 3.2.0
446- added BuildRequires: pam-devel
447
448* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
449- rebuilt with libevent-2.0.10
450
451* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
452- updated to 10.0.651.0 with v8 3.0.12
453- added BuildRequires:
454  - libpaper-devel
455  - python-devel
456- added built header file: libavutil/avconfig.h %%prep
457- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
458
459* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
460- updated to 10.0.622.0
461- added BuildRequires: libXt-devel
462
463* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
464- updated to 10.0.605.0
465- added BuildRequires:
466  - libXdamage-devel
467  - hunspell-devel
468
469* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
470- updated to 9.0.598
471
472* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
473- updated to 9.0.593
474
475* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
476- updated to 9.0.582
477- added Requires: xdg-utils
478
479* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
480- updated to 9.0.578
481
482* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
483- updated to 9.0.569
484
485  * Mon Oct 25 2010 tittiatcoke@gmail.com
486  - Update to 9.0.564 build
487    * Added specific patches for MeeGo.
488    * We are now using shared libraries for Chromium
489    * Spec-file cleanup (Thanks to prusnak)
490
491* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
492- updated to snapshot 8.0.556
493
494* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
495- updated to snapshot 8.0.551
496
497* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
498- updated to snapshot 7.0.527
499
500* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
501- updated to snapshot 7.0.519
502
503* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
504- updated to snapshot 7.0.513
505  - updated chromium-vendor-vine.patch.in
506
507* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
508- updated to snapshot 7.0.507
509
510* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
511- updated to snapshot 7.0.498
512
513* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
514- updated to snapshot 6.0.493
515- used with_system_icu (for vl6)
516  - added BuildRequires: libicu-devel
517
518* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
519- build for Vine Linux 5.x
520  - add BuildRequires: gnome-keyring-devel
521
522* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
523- updated to snapshot 6.0.454
524- added BuildRequires:
525  - sqlite3-devel
526  - gnutls-devel
527  - libgnome-keyring-devel
528
529* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
530- updated to snapshot 6.0.431.0 r49253
531- added BuildRequires: cups-devel
532
533* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
534- updated to snapshot 6.0.405.0 r47263
535
536* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
537- unused with_system_icu (for vl6)
538  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
539
540* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
541- updated to snapshot 5.0.378.0 r44472
542  - used with_system_icu (for vl6)
543  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
544
545* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
546- updated to snapshot 5.0.372.0 r43947
547- added BuildRequires: glew-devel
548- changed Group tag to Applications/Internet
549- added Summary(ja) and %%description -l ja
550
551* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
552- updated to snapshot 5.0.365.0 r42966
553- merged 5.0.353.0-4vl5
554 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
555 - build on Vine Linux 5.1
556   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
557
558* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
559- updated to snapshot 5.0.364.0 r42779
560
561* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
562- updated to snapshot 5.0.359.0 r42116
563- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
564
565* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
566- fixed master_preferences.vine, little
567
568* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
569- fixed to install master_preferences
570- dropped chromium-5.0.353-no-ffmpeg-vine.patch
571
572* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
573- applied chromium-5.0.353-no-ffmpeg-vine.patch
574
575* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
576- updated to snapshot 5.0.353.0 r41449
577  * Wed Mar 10 2010 bgmerrell@novell.com
578  - Add master_preferences source file and install it to /etc/chromium.
579  - Create a new patch (chromium-master-prefs-path.patch) which tells
580    chromium to look in /etc/chromium for the master_preferences file
581    (instead of looking in the default directory, which is the same
582    directory as the 'chrome' binary).
583
584* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
585- updated to snapshot 5.0.335.0 r39556
586
587* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
588- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
589
590* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
591- updated to snapshot 5.0.330.0 r39074
592
593* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
594- use_system_ffmpeg
595
596* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
597- added Requires:  nspluginwrapper
598- fixed a symbolic link of plugins directory with nspluginwrapper
599
600* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
601- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
602
603* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
604- added BuildRequires: mesa-libGLU-devel
605- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
606
607* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
608- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
609
610  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
611  - Update to 4.0.260
612  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
613  - Update to 4.0.259
614  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
615  - Update to 4.0.258
616  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
617  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
618    changed to having an built-in v8
619  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
620  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
621  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
622  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
623  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
624  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
625  - update to newer svn snapshot
626    + Obsoletes fwrite patch (included upstream)
627  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
628  - update to newer svn snapshot
629    + Requires newer version of v8
630  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
631  - do not force SSE on x86 (drop-sse.patch)
632  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
633  - Update to newer svn snapshot
634  - Fixed spec file in order to build
635  - Included patch to build with system zlib
636  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
637  - package renamed to chromium
638  - cleaned up spec file
639  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
640  - v8 is now built as a separate package, and is required
641  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
642  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
643  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
644  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
645  - initial build
646
647#% changelog
648* Sun Jan 24 2010 prusnak@suse.cz
649- added vendor to user agent (chromium-vendor.patch.in)
650* Sun Nov 29 2009 prusnak@suse.cz
651- added --enable-sync to wrapper to enable bookmark sync
652* Sun Nov 29 2009 tittiatcoke@gmail.com 
653- Update to 4.0.260
654* Fri Nov 27 2009 tittiatcoke@gmail.com 
655- Update to 4.0.259
656* Thu Nov 26 2009 tittiatcoke@gmail.com 
657- Update to 4.0.258
658* Tue Nov 24 2009 tittatcoke@gmai.com 
659- In order to complete prevent the wrong v8 version to be used,
660  the Chromium build has been changed to having an built-in v8
661* Tue Nov 24 2009 dbuck@example.com 
662- Re-base patches.
663- Fixed a few patch errors.
664- Rename some patches to better correspond with function.
665- Removed some patches.
666- Minor SPEC changes.
667- I changed the v8 requirement to be exact, instead of greater than a specific version.
668* Fri Nov 13 2009 tittiatcoke@gmail.com
669- update to 247.0 svn 31928
670* Fri Oct 30 2009 tittiatcoke@gmail.com
671- update to 229.0 svn 30454
672  + Fix regression where popups and app frames lost their titlebars.
673  + Makes it so that when a folder is open on the bookmark bar
674    and the mouse moves over another folder, the menu for that
675    folder is shown.
676  + Lazily create the find bar.
677  + Polish to the gmail checker sample.
678  * New, crisper icons that are exactly 19x19
679  * Add a loading animation at the beginning before Gmail
680    responds.
681  * Fix a bug where we sometimes don't update the UI after a
682    logout/login cycle.
683  + Refactor widget methods to support desktop notifications,
684    including GTK stubs.
685  + Find-in-page should not ding while deleting characters.
686  + Add SSL wrapper for linux and mac.  This allows notifier to
687    use chrome's SSL layer instead of OpenSSL.
688  + Add three of the six extensions to PAC that Internet Explorer supports.
689  + WebSocket support in chromium. (Run with --enable-web-sockets
690    enables WebSocket features.)
691  + Do not allow GTK File Chooser dialogs to return directories.
692  + Fix the notifier SSL layer to make notifications work for
693    Linux Bookmark sync.
694  + linux: don't override mouse selection behavior in omnibox
695* Sun Oct 25 2009 tittiatcoke@gmail.com
696- Update to 224.4 svn 30027
697  + First cut at new page and browser action docs based
698    on new API. Deleted old stuff.
699  + Add suppression for new memory leak caused by WebKit merge 49830:49844
700  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
701  + Minimize dependency of user scripts
702  + Fixup the flip_framer eof-handling semantics now that we have
703    the FIN bit in place
704  + app depends on x11 because of active_window_watcher_x
705  + Adding two images for the new Extension managment UI
706  + Removing hard-coded Chrome Frame output path
707  + Rearrange clipboard code
708  + Fix crash bug when attempting to download a url with unsupported scheme,
709    e.g. 'data:', by 'Alt + Click'
710  + GTK: Change text for extension download UI
711  + Ignore invalid urls on command line
712  + Make dropped tabs animate from where they were dropped.
713  + Make room for the full width of the tab placeholder.
714  + Make tab dragging as smooth as glass.
715  + Remove an annoying NOTIMPLEMNETED
716  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
717  + If we're in the middle of a drag, don't allow the user to middle
718    click to close or right click for the context menu
719  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
720  + Remove +x bit from files that shouldn't have it
721  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
722  + Adding new image needed for the managment UI
723  + Fix a race bug where content scripts would not apply to the first page load
724  + Make escape remove a bookmark if it's just been added (but not if it already existed)
725  + Fix bubbles deactivating the opaque frame
726  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
727  + ake all pepper plugins default to windowless and transparent
728  + Add styles for printing
729  + Implement the new extension management UI
730  + Add support for to automation interface load install and load extensions
731  + GTK: theme the info bar border
732  + Update V8 to version 1.3.16.1
733  + Introduce WebSecurityPolicy for security related methods
734  + New button scheme...borders are separate from the inner contents so
735    that they can be highlighted / depressed independently
736  + When opening Chrome maximized with an application window already
737    running, the Chrome window was not activated
738  + Fix compatibility problems with FileZilla FTP Server
739  + Remove the extension shelf on Linux
740  + Fix the proxy host and port string to start with http:// if it does not already
741  + Enable HTML5 databases for all extension renderer processes
742* Sat Oct 24 2009 prusnak@opensuse.org 
743- don't create desktop files in wrapper
744- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
745* Tue Oct 20 2009 tittiatcoke@gmail.com 
746- update to newer svn snapshot
747  + Obsoletes fwrite patch (included upstream)
748* Fri Oct 16 2009 tittiatcoke@gmail.com 
749- update to newer svn snapshot
750  + Requires newer version of v8
751* Thu Oct 15 2009 prusnak@suse.cz 
752- do not force SSE on x86 (drop-sse.patch)
753* Tue Oct 13 2009 tittiatcoke@gmail.com 
754- Update to newer svn snapshot
755- Fixed spec file in order to build
756- Included patch to build with system zlib
757* Mon Oct 12 2009 prusnak@suse.cz 
758- package renamed to chromium
759- cleaned up spec file
760* Tue Oct  6 2009 dbuck@example.com 
761- v8 is now built as a separate package, and is required
762- included many patches to use system libraries:
763    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
764* Thu Oct  1 2009 dbuck@example.com 
765- included a newer DEP than is in svn, native_client@823
766- things should compile cleanly now
767* Mon Aug 31 2009 dbuck@example.com 
768- initial build
Note: See TracBrowser for help on using the repository browser.