source: projects/specs/trunk/c/chromium/chromium12-vl.spec @ 4241

Revision 4241, 28.3 KB checked in by daisuke, 13 years ago (diff)

chromium:

  • fix user-agent string (chromium-vendor-vine.patch.in)
    • move vendor string (Vine/12.0.742.91-1vl6) to the end.
Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_icu 1
8#% define with_system_v8 1
9
10#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
11#     libvpx doesn't currently supply a pkg-config file, so we assume that
12#     -lvpx is sufficient.
13%define with_system_vpx 1
14
15#Name:           chromium12
16Name:           chromium
17Summary:        Google's opens source browser project
18Summary(ja):    Googleのオープンソースウェブブラウザ
19#'
20Version:        12.0.742.93
21Release:        2%{?_dist_release}
22License:        BSD
23Group:          Applications/Internet
24Source0:        %{pkgname}-%{version}.tar.xz
25# Script used to create the %{pkgname}-%{version}.tar.xz archive from
26# a official tarball:
27# http://build.chromium.org/official/chromium-12.0.742.XXX.tar.bz2
28Source3:        pack_chromium12_source-vine.sh
29# Official ffmpeg headers
30Source8:        ffmpeg-0.6-headers.tar.xz
31#Source10:       chromium.desktop
32#Source10:       chromium-vine.desktop
33# Patch template which adds vendor to user agent
34##!!Source20:       chromium-vendor.patch.in
35Source20:       chromium-vendor-vine.patch.in
36# Set default prefs
37##!!Source30:       master_preferences
38Source30:       master_preferences.vine
39##!!Source31:       default_bookmarks.html
40#Source31:       default_bookmarks.html.vine
41Source99:       chrome-wrapper
42##!!Source100:      chromium-browser.sh
43Source100:      chromium-browser-vine.sh
44##!!Source101:      chromium-browser.desktop
45Source101:      chromium-browser-vine.desktop
46Source102:      chromium-browser.xml
47Source103:      chromium-browser-rpmlintrc
48##!!Source104:      chromium-icons.tar.bz2
49
50%{?nosrc:NoSource: 0}
51
52Provides:       chromium-browser = %{version}
53##Provides:     chromium-based-browser = %{version}
54##Obsoletes:      chromium-browser < %{version}
55##Conflicts:      chromium
56
57## Start Patches
58# Many changes to the gyp systems so we can use system libraries
59Patch4:         chromium-no-sqlite-debug.patch
60Patch8:         chromium-codechanges-zlib.patch
61Patch12:        chromium-no-test-sources.patch
62Patch13:        chromium-no-courgette.patch
63Patch14:        chromium-master-prefs-path.patch
64Patch17:        chromium-system-glew.patch
65Patch18:        chromium-system-expat.patch
66Patch19:        chromium-system-zlib.patch
67Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
68Patch21:        chromium-7.0.542.0-media-probe.patch
69Patch25:        tcmalloc-factory.patch
70Patch26:        chromium-remoting-build-fix.diff
71Patch28:        chromium-7.0.500.0-system-speex.patch
72Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
73Patch32:        chromium-7.0.542.0-system-libvpx.patch
74Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
75Patch62:        chromium-norpath.patch
76Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
77
78# Vine
79Patch100:       chromium-12.0.742.6-no-tests.patch
80
81
82BuildRequires:  gcc gcc-c++
83BuildRequires:  libstdc++ libstdc++-devel
84BuildRequires:  libevent
85##!!BuildRequires:  pkg-config
86BuildRequires:  python
87##!!BuildRequires:  python-xml
88BuildRequires:  python-pyxml
89BuildRequires:  perl bison flex gperf
90##!!BuildRequires:  wdiff
91##!!BuildRequires:  update-desktop-files
92#BuildRequires:  lzma
93BuildRequires:  xz
94##!!BuildRequires:  mozilla-nss-devel
95BuildRequires:  nss-devel
96##!!BuildRequires:  alsa-devel
97BuildRequires:  alsa-lib-devel
98BuildRequires:  gtk2-devel
99BuildRequires:  glib2-devel
100BuildRequires:  cairo-devel >= 1.6
101##!!BuildRequires:  mozilla-nspr-devel
102BuildRequires:  nspr-devel
103##!!BuildRequires:  gconf2-devel
104BuildRequires:  GConf2-devel
105BuildRequires:  freetype2-devel
106##!!BuildRequires:  dbus-1-devel
107BuildRequires:  dbus-devel
108BuildRequires:  libxslt-devel
109BuildRequires:  libxml2-devel
110BuildRequires:  libjpeg-devel
111BuildRequires:  zlib-devel
112##!!BuildRequires:  libbz2-devel
113BuildRequires:  bzip2-devel
114BuildRequires:  cups-devel
115BuildRequires:  fdupes
116##!!BuildRequires:  libexpat-devel
117BuildRequires:  expat-devel
118BuildRequires:  libpng-devel
119BuildRequires:  sqlite3-devel
120BuildRequires:  gnutls-devel
121BuildRequires:  desktop-file-utils
122%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
123%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
124BuildRequires:  pam-devel
125BuildRequires:  libgnome-keyring-devel
126BuildRequires:  python-devel
127BuildRequires:  glew-devel
128##!!BuildRequires:  Mesa-devel
129BuildRequires:  mesa-libGLU-devel
130BuildRequires:  hunspell-devel
131
132%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
133BuildRequires:  libevent-devel
134#BuildRequires:  libjingle-devel >= 0.4.0-7
135#BuildRequires:  srtp-devel
136BuildRequires:  speex-devel
137
138##Vine Linux
139%{?with_system_v8:Requires:       v8 = %{v8_ver}}
140BuildRequires:  libpaper-devel
141BuildRequires:  libXScrnSaver-devel
142BuildRequires:  libXtst-devel
143BuildRequires:  libXdamage-devel
144BuildRequires:  libXt-devel
145#BuildRequires:  gle-devel
146#BuildRequires:  webkit-gtk-devel
147#BuildRequires:  scons
148%ifarch x86_64
149Requires:  nspluginwrapper
150%endif
151
152##!!Requires:       alsa
153Requires:       alsa-lib
154Requires:       xdg-utils
155# shouldn't be required to name all dependencies
156# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
157
158BuildRoot:      %{_tmppath}/%{name}-%{version}-root
159
160%description
161Chromium is the open-source project behind Google Chrome.
162We invite you to join us in our effort to help build a safer, faster,
163and more stable way for all Internet users to experience the web,
164and to create a powerful platform for developing a new generation of
165web applications.
166
167%description -l ja
168Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
169ウェブを体験しているすべてのインターネットユーザに対して
170より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
171そして、ウェブアプリケーションの新しい世代を発展させ、
172強力なプラットホームを作成するために、
173私たちの取り組みにぜひ参加してください。
174
175
176%prep
177#%setup -q
178[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
179xz -dc %{SOURCE0} | %__tar -xf - || exit 1
180%setup -D -T -n %{pkgname}-%{version}
181
182%patch62 -p1
183%{?with_system_v8:%patch63 -p1}
184%patch100 -p1 -b .vine
185%patch4 -p1
186%patch8 -p1
187%patch12 -p1
188%patch13 -p1
189%patch14 -p1
190%patch17 -p1
191%patch18 -p1
192%patch19 -p1
193%patch20 -p1
194%patch21 -p1
195%patch25 -p1
196%patch26 -p1
197%patch28 -p1
198%patch29 -p1
199%{?with_system_vpx:%patch32 -p1}
200%{?with_system_v8:%patch34 -p1}
201
202pushd src/third_party/ffmpeg/
203%__tar xf %{SOURCE8} || exit 1
204## built header file: avconfig.h
205[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
206cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
207/* Generated by ffconf */
208#ifndef AVUTIL_AVCONFIG_H
209#define AVUTIL_AVCONFIG_H
210#define AV_HAVE_BIGENDIAN 0
211#endif /* AVUTIL_AVCONFIG_H */
212EOF
213popd
214
215#%__rm -rf src/third_party/libvpx/
216%__rm -rf src/third_party/speex/
217%__rm -rf src/third_party/nss src/third_party/nspr
218
219# apply vendor patch after substitution
220%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
221
222%build
223
224## create make files
225
226PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
227for i in src/build/common.gypi; do
228        %__sed -i "s|'-march=pentium4',||g" $i
229        %__sed -i "s|'-mfpmath=sse',||g" $i
230        %__sed -i "s|'-O<(debug_optimize)',||g" $i
231        %__sed -i "s|'-m32',||g" $i
232        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
233        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
234done
235# '
236
237pushd src
238
239./build/gyp_chromium -f make build/all.gyp \
240    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
241    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
242    -Duse_openssl=0 \
243    -Duse_system_ffmpeg=1 \
244    -Duse_system_zlib=1 \
245    -Duse_system_libpng=1 \
246    -Duse_system_bzip2=1 \
247    -Duse_system_libbz2=1 \
248    -Duse_system_libjpeg=1 \
249    -Duse_system_libxml=1 \
250    -Duse_system_libxslt=1 \
251    -Duse_system_libevent=1 \
252    %{?with_system_vpx:-Duse_system_vpx=1} \
253    %{!?with_system_vpx:-Duse_system_vpx=0} \
254    -Dproprietary_codecs=1 \
255    -Dlibrary=shared_library \
256    -Djavascript_engine=v8 \
257    -Dlinux_fpic=1 \
258    %{?with_system_v8:-Duse_system_v8=1} \
259    %{!?with_system_v8:-Duse_system_v8=0} \
260    %{?with_system_icu:-Duse_system_icu=1} \
261    %{!?with_system_icu:-Duse_system_icu=0} \
262    %ifarch %{ix86}
263        -Dtarget_arch=ia32 \
264         -Ddisable_sse2=1 \
265    %endif
266    %ifarch x86_64
267        -Dtarget_arch=x64 \
268    %endif
269    %if %{?_dist_release} == "vl6"
270        -Dno_strict_aliasing=1 -Dgcc_version=44 \
271    %endif
272    -Drelease_extra_cflags=-fPIC \
273    ;
274
275#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
276#%__make -r -j5 chrome BUILDTYPE=Release
277%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
278
279popd
280
281%install
282%{__rm} -rf %{buildroot}
283
284%__mkdir -p %{buildroot}%{_bindir}
285%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
286# x86_64 capable systems need this
287%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
288%__mkdir -p %{buildroot}%{_libdir}/chromium/
289%__mkdir -p %{buildroot}%{_mandir}/man1/
290pushd src/out/Release
291%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
292%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
293%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
294%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
295%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
296%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
297%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
298fdupes %{buildroot}%{_mandir}/man1/
299popd
300
301%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
302%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
303for i in 16 22 24 32 48 64 128 256; do
304    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
305    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
306done
307
308%__mkdir_p %{buildroot}%{_datadir}/applications/
309desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
310
311%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
312%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
313
314# # link to browser plugin path.  Plugin patch doesn't work. Why?
315# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
316# pushd %{buildroot}%{_libdir}/%{pkgname}
317# %{__ln_s} %{_libdir}/browser-plugins plugins
318# popd
319pushd %{buildroot}%{_libdir}/%{pkgname}
320%ifarch x86_64
321%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
322%else
323%{__ln_s} %{_libdir}/mozilla/plugins plugins
324%endif
325
326## support ffmpeg libs
327touch %{buildroot}%{_libdir}/libavcodec.so.52
328%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
329touch %{buildroot}%{_libdir}/libavformat.so.52
330%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
331touch %{buildroot}%{_libdir}/libavutil.so.50
332%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
333popd
334
335# Install the master_preferences file
336%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
337#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
338%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
339#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
340
341%clean
342%{__rm} -rf %{buildroot}
343
344%post
345touch --no-create %{_datadir}/icons/hicolor
346if [ -x %{_bindir}/gtk-update-icon-cache ]; then
347  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
348fi
349%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
350
351%postun
352%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
353touch --no-create %{_datadir}/icons/hicolor
354if [ -x %{_bindir}/gtk-update-icon-cache ]; then
355  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
356fi || :
357
358
359%files
360%defattr(-,root,root,-)
361%config %{_sysconfdir}/%{pkgname}
362%dir %{_datadir}/gnome-control-center
363%dir %{_datadir}/gnome-control-center/default-apps
364%{_bindir}/chromium
365%{_libdir}/chromium/chromium
366%{_libdir}/chromium/plugins/
367%{_libdir}/chromium/resources/
368%{_libdir}/chromium/xdg-settings
369%{_mandir}/man1/chrom*
370%{_datadir}/pixmaps/chromium-browser.png
371%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
372%{_datadir}/applications/*.desktop
373%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
374%{_libdir}/chromium/libavcodec.so.52
375%{_libdir}/chromium/libavutil.so.50
376%{_libdir}/chromium/libavformat.so.52
377%exclude %{_libdir}/libavcodec.so.52
378%exclude %{_libdir}/libavutil.so.50
379%exclude %{_libdir}/libavformat.so.52
380## libs
381%dir %{_libdir}/chromium/
382%{_libdir}/chromium/chrome.pak
383%{_libdir}/chromium/resources.pak
384%{_libdir}/chromium/locales/
385%{_libdir}/chromium/lib*.so
386
387%changelog
388* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
389- fix user-agent string (chromium-vendor-vine.patch.in)
390  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
391
392* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
393- updated to 12.0.742.93
394- fixed icon field of chromium-browser-vine.desktop
395
396* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
397- updated to 12.0.742.91
398
399* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
400- updated to 12.0.742.77
401
402* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
403- updated to 12.0.742.63
404
405* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
406- updated to 12.0.742.42
407
408* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
409- updated to 12.0.742.6
410- dropped/upstreamed patches
411- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
412
413* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
414- updated to 11.0.696.50
415- dropped some Patches for MeeGo Netbook
416
417* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
418- updated to 11.0.696.35
419
420* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
421- updated to 11.0.696.29
422- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
423
424* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
425- updated to 11.0.696.22
426- improved chromium-browser-vine.sh
427  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
428
429* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
430- updated to 11.0.696.20
431- improved chromium-browser-vine.desktop
432
433* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
434- updated to 11.0.696.17
435
436* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
437- updated to 11.0.696.15
438  - ready for Vine Linux 6 release
439- dropped BuildRequires: v8-devel, libicu-devel
440
441* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
442- updated to 11.0.696.5 with v8 3.2.0
443- added BuildRequires: pam-devel
444
445* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
446- rebuilt with libevent-2.0.10
447
448* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
449- updated to 10.0.651.0 with v8 3.0.12
450- added BuildRequires:
451  - libpaper-devel
452  - python-devel
453- added built header file: libavutil/avconfig.h %%prep
454- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
455
456* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
457- updated to 10.0.622.0
458- added BuildRequires: libXt-devel
459
460* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
461- updated to 10.0.605.0
462- added BuildRequires:
463  - libXdamage-devel
464  - hunspell-devel
465
466* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
467- updated to 9.0.598
468
469* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
470- updated to 9.0.593
471
472* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
473- updated to 9.0.582
474- added Requires: xdg-utils
475
476* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
477- updated to 9.0.578
478
479* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
480- updated to 9.0.569
481
482  * Mon Oct 25 2010 tittiatcoke@gmail.com
483  - Update to 9.0.564 build
484    * Added specific patches for MeeGo.
485    * We are now using shared libraries for Chromium
486    * Spec-file cleanup (Thanks to prusnak)
487
488* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
489- updated to snapshot 8.0.556
490
491* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
492- updated to snapshot 8.0.551
493
494* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
495- updated to snapshot 7.0.527
496
497* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
498- updated to snapshot 7.0.519
499
500* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
501- updated to snapshot 7.0.513
502  - updated chromium-vendor-vine.patch.in
503
504* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
505- updated to snapshot 7.0.507
506
507* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
508- updated to snapshot 7.0.498
509
510* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
511- updated to snapshot 6.0.493
512- used with_system_icu (for vl6)
513  - added BuildRequires: libicu-devel
514
515* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
516- build for Vine Linux 5.x
517  - add BuildRequires: gnome-keyring-devel
518
519* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
520- updated to snapshot 6.0.454
521- added BuildRequires:
522  - sqlite3-devel
523  - gnutls-devel
524  - libgnome-keyring-devel
525
526* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
527- updated to snapshot 6.0.431.0 r49253
528- added BuildRequires: cups-devel
529
530* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
531- updated to snapshot 6.0.405.0 r47263
532
533* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
534- unused with_system_icu (for vl6)
535  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
536
537* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
538- updated to snapshot 5.0.378.0 r44472
539  - used with_system_icu (for vl6)
540  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
541
542* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
543- updated to snapshot 5.0.372.0 r43947
544- added BuildRequires: glew-devel
545- changed Group tag to Applications/Internet
546- added Summary(ja) and %%description -l ja
547
548* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
549- updated to snapshot 5.0.365.0 r42966
550- merged 5.0.353.0-4vl5
551 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
552 - build on Vine Linux 5.1
553   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
554
555* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
556- updated to snapshot 5.0.364.0 r42779
557
558* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
559- updated to snapshot 5.0.359.0 r42116
560- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
561
562* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
563- fixed master_preferences.vine, little
564
565* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
566- fixed to install master_preferences
567- dropped chromium-5.0.353-no-ffmpeg-vine.patch
568
569* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
570- applied chromium-5.0.353-no-ffmpeg-vine.patch
571
572* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
573- updated to snapshot 5.0.353.0 r41449
574  * Wed Mar 10 2010 bgmerrell@novell.com
575  - Add master_preferences source file and install it to /etc/chromium.
576  - Create a new patch (chromium-master-prefs-path.patch) which tells
577    chromium to look in /etc/chromium for the master_preferences file
578    (instead of looking in the default directory, which is the same
579    directory as the 'chrome' binary).
580
581* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
582- updated to snapshot 5.0.335.0 r39556
583
584* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
585- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
586
587* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
588- updated to snapshot 5.0.330.0 r39074
589
590* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
591- use_system_ffmpeg
592
593* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
594- added Requires:  nspluginwrapper
595- fixed a symbolic link of plugins directory with nspluginwrapper
596
597* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
598- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
599
600* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
601- added BuildRequires: mesa-libGLU-devel
602- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
603
604* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
605- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
606
607  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
608  - Update to 4.0.260
609  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
610  - Update to 4.0.259
611  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
612  - Update to 4.0.258
613  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
614  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
615    changed to having an built-in v8
616  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
617  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
618  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
619  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
620  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
621  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
622  - update to newer svn snapshot
623    + Obsoletes fwrite patch (included upstream)
624  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
625  - update to newer svn snapshot
626    + Requires newer version of v8
627  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
628  - do not force SSE on x86 (drop-sse.patch)
629  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
630  - Update to newer svn snapshot
631  - Fixed spec file in order to build
632  - Included patch to build with system zlib
633  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
634  - package renamed to chromium
635  - cleaned up spec file
636  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
637  - v8 is now built as a separate package, and is required
638  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
639  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
640  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
641  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
642  - initial build
643
644#% changelog
645* Sun Jan 24 2010 prusnak@suse.cz
646- added vendor to user agent (chromium-vendor.patch.in)
647* Sun Nov 29 2009 prusnak@suse.cz
648- added --enable-sync to wrapper to enable bookmark sync
649* Sun Nov 29 2009 tittiatcoke@gmail.com 
650- Update to 4.0.260
651* Fri Nov 27 2009 tittiatcoke@gmail.com 
652- Update to 4.0.259
653* Thu Nov 26 2009 tittiatcoke@gmail.com 
654- Update to 4.0.258
655* Tue Nov 24 2009 tittatcoke@gmai.com 
656- In order to complete prevent the wrong v8 version to be used,
657  the Chromium build has been changed to having an built-in v8
658* Tue Nov 24 2009 dbuck@example.com 
659- Re-base patches.
660- Fixed a few patch errors.
661- Rename some patches to better correspond with function.
662- Removed some patches.
663- Minor SPEC changes.
664- I changed the v8 requirement to be exact, instead of greater than a specific version.
665* Fri Nov 13 2009 tittiatcoke@gmail.com
666- update to 247.0 svn 31928
667* Fri Oct 30 2009 tittiatcoke@gmail.com
668- update to 229.0 svn 30454
669  + Fix regression where popups and app frames lost their titlebars.
670  + Makes it so that when a folder is open on the bookmark bar
671    and the mouse moves over another folder, the menu for that
672    folder is shown.
673  + Lazily create the find bar.
674  + Polish to the gmail checker sample.
675  * New, crisper icons that are exactly 19x19
676  * Add a loading animation at the beginning before Gmail
677    responds.
678  * Fix a bug where we sometimes don't update the UI after a
679    logout/login cycle.
680  + Refactor widget methods to support desktop notifications,
681    including GTK stubs.
682  + Find-in-page should not ding while deleting characters.
683  + Add SSL wrapper for linux and mac.  This allows notifier to
684    use chrome's SSL layer instead of OpenSSL.
685  + Add three of the six extensions to PAC that Internet Explorer supports.
686  + WebSocket support in chromium. (Run with --enable-web-sockets
687    enables WebSocket features.)
688  + Do not allow GTK File Chooser dialogs to return directories.
689  + Fix the notifier SSL layer to make notifications work for
690    Linux Bookmark sync.
691  + linux: don't override mouse selection behavior in omnibox
692* Sun Oct 25 2009 tittiatcoke@gmail.com
693- Update to 224.4 svn 30027
694  + First cut at new page and browser action docs based
695    on new API. Deleted old stuff.
696  + Add suppression for new memory leak caused by WebKit merge 49830:49844
697  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
698  + Minimize dependency of user scripts
699  + Fixup the flip_framer eof-handling semantics now that we have
700    the FIN bit in place
701  + app depends on x11 because of active_window_watcher_x
702  + Adding two images for the new Extension managment UI
703  + Removing hard-coded Chrome Frame output path
704  + Rearrange clipboard code
705  + Fix crash bug when attempting to download a url with unsupported scheme,
706    e.g. 'data:', by 'Alt + Click'
707  + GTK: Change text for extension download UI
708  + Ignore invalid urls on command line
709  + Make dropped tabs animate from where they were dropped.
710  + Make room for the full width of the tab placeholder.
711  + Make tab dragging as smooth as glass.
712  + Remove an annoying NOTIMPLEMNETED
713  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
714  + If we're in the middle of a drag, don't allow the user to middle
715    click to close or right click for the context menu
716  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
717  + Remove +x bit from files that shouldn't have it
718  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
719  + Adding new image needed for the managment UI
720  + Fix a race bug where content scripts would not apply to the first page load
721  + Make escape remove a bookmark if it's just been added (but not if it already existed)
722  + Fix bubbles deactivating the opaque frame
723  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
724  + ake all pepper plugins default to windowless and transparent
725  + Add styles for printing
726  + Implement the new extension management UI
727  + Add support for to automation interface load install and load extensions
728  + GTK: theme the info bar border
729  + Update V8 to version 1.3.16.1
730  + Introduce WebSecurityPolicy for security related methods
731  + New button scheme...borders are separate from the inner contents so
732    that they can be highlighted / depressed independently
733  + When opening Chrome maximized with an application window already
734    running, the Chrome window was not activated
735  + Fix compatibility problems with FileZilla FTP Server
736  + Remove the extension shelf on Linux
737  + Fix the proxy host and port string to start with http:// if it does not already
738  + Enable HTML5 databases for all extension renderer processes
739* Sat Oct 24 2009 prusnak@opensuse.org 
740- don't create desktop files in wrapper
741- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
742* Tue Oct 20 2009 tittiatcoke@gmail.com 
743- update to newer svn snapshot
744  + Obsoletes fwrite patch (included upstream)
745* Fri Oct 16 2009 tittiatcoke@gmail.com 
746- update to newer svn snapshot
747  + Requires newer version of v8
748* Thu Oct 15 2009 prusnak@suse.cz 
749- do not force SSE on x86 (drop-sse.patch)
750* Tue Oct 13 2009 tittiatcoke@gmail.com 
751- Update to newer svn snapshot
752- Fixed spec file in order to build
753- Included patch to build with system zlib
754* Mon Oct 12 2009 prusnak@suse.cz 
755- package renamed to chromium
756- cleaned up spec file
757* Tue Oct  6 2009 dbuck@example.com 
758- v8 is now built as a separate package, and is required
759- included many patches to use system libraries:
760    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
761* Thu Oct  1 2009 dbuck@example.com 
762- included a newer DEP than is in svn, native_client@823
763- things should compile cleanly now
764* Mon Aug 31 2009 dbuck@example.com 
765- initial build
Note: See TracBrowser for help on using the repository browser.