source: projects/specs/trunk/c/chromium/chromium12-vl.spec @ 4107

Revision 4107, 28.1 KB checked in by munepi, 13 years ago (diff)

updated chromium

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_icu 1
8#% define with_system_v8 1
9
10#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
11#     libvpx doesn't currently supply a pkg-config file, so we assume that
12#     -lvpx is sufficient.
13%define with_system_vpx 1
14
15#Name:           chromium12
16Name:           chromium
17Summary:        Google's opens source browser project
18Summary(ja):    Googleのオープンソースウェブブラウザ
19#'
20Version:        12.0.742.93
21Release:        1%{?_dist_release}
22License:        BSD
23Group:          Applications/Internet
24Source0:        %{pkgname}-%{version}.tar.xz
25# Script used to create the %{pkgname}-%{version}.tar.xz archive from
26# a official tarball:
27# http://build.chromium.org/official/chromium-12.0.742.XXX.tar.bz2
28Source3:        pack_chromium12_source-vine.sh
29# Official ffmpeg headers
30Source8:        ffmpeg-0.6-headers.tar.xz
31#Source10:       chromium.desktop
32#Source10:       chromium-vine.desktop
33# Patch template which adds vendor to user agent
34##!!Source20:       chromium-vendor.patch.in
35Source20:       chromium-vendor-vine.patch.in
36# Set default prefs
37##!!Source30:       master_preferences
38Source30:       master_preferences.vine
39##!!Source31:       default_bookmarks.html
40#Source31:       default_bookmarks.html.vine
41Source99:       chrome-wrapper
42##!!Source100:      chromium-browser.sh
43Source100:      chromium-browser-vine.sh
44##!!Source101:      chromium-browser.desktop
45Source101:      chromium-browser-vine.desktop
46Source102:      chromium-browser.xml
47Source103:      chromium-browser-rpmlintrc
48##!!Source104:      chromium-icons.tar.bz2
49
50%{?nosrc:NoSource: 0}
51
52Provides:       chromium-browser = %{version}
53##Provides:     chromium-based-browser = %{version}
54##Obsoletes:      chromium-browser < %{version}
55##Conflicts:      chromium
56
57## Start Patches
58# Many changes to the gyp systems so we can use system libraries
59Patch4:         chromium-no-sqlite-debug.patch
60Patch8:         chromium-codechanges-zlib.patch
61Patch12:        chromium-no-test-sources.patch
62Patch13:        chromium-no-courgette.patch
63Patch14:        chromium-master-prefs-path.patch
64Patch17:        chromium-system-glew.patch
65Patch18:        chromium-system-expat.patch
66Patch19:        chromium-system-zlib.patch
67Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
68Patch21:        chromium-7.0.542.0-media-probe.patch
69Patch25:        tcmalloc-factory.patch
70Patch26:        chromium-remoting-build-fix.diff
71Patch28:        chromium-7.0.500.0-system-speex.patch
72Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
73Patch32:        chromium-7.0.542.0-system-libvpx.patch
74Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
75Patch62:        chromium-norpath.patch
76Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
77
78# Vine
79Patch100:       chromium-12.0.742.6-no-tests.patch
80
81
82BuildRequires:  gcc gcc-c++
83BuildRequires:  libstdc++ libstdc++-devel
84BuildRequires:  libevent
85##!!BuildRequires:  pkg-config
86BuildRequires:  python
87##!!BuildRequires:  python-xml
88BuildRequires:  python-pyxml
89BuildRequires:  perl bison flex gperf
90##!!BuildRequires:  wdiff
91##!!BuildRequires:  update-desktop-files
92#BuildRequires:  lzma
93BuildRequires:  xz
94##!!BuildRequires:  mozilla-nss-devel
95BuildRequires:  nss-devel
96##!!BuildRequires:  alsa-devel
97BuildRequires:  alsa-lib-devel
98BuildRequires:  gtk2-devel
99BuildRequires:  glib2-devel
100BuildRequires:  cairo-devel >= 1.6
101##!!BuildRequires:  mozilla-nspr-devel
102BuildRequires:  nspr-devel
103##!!BuildRequires:  gconf2-devel
104BuildRequires:  GConf2-devel
105BuildRequires:  freetype2-devel
106##!!BuildRequires:  dbus-1-devel
107BuildRequires:  dbus-devel
108BuildRequires:  libxslt-devel
109BuildRequires:  libxml2-devel
110BuildRequires:  libjpeg-devel
111BuildRequires:  zlib-devel
112##!!BuildRequires:  libbz2-devel
113BuildRequires:  bzip2-devel
114BuildRequires:  cups-devel
115BuildRequires:  fdupes
116##!!BuildRequires:  libexpat-devel
117BuildRequires:  expat-devel
118BuildRequires:  libpng-devel
119BuildRequires:  sqlite3-devel
120BuildRequires:  gnutls-devel
121BuildRequires:  desktop-file-utils
122%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
123%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
124BuildRequires:  pam-devel
125BuildRequires:  libgnome-keyring-devel
126BuildRequires:  python-devel
127BuildRequires:  glew-devel
128##!!BuildRequires:  Mesa-devel
129BuildRequires:  mesa-libGLU-devel
130BuildRequires:  hunspell-devel
131
132%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
133BuildRequires:  libevent-devel
134#BuildRequires:  libjingle-devel >= 0.4.0-7
135#BuildRequires:  srtp-devel
136BuildRequires:  speex-devel
137
138##Vine Linux
139%{?with_system_v8:Requires:       v8 = %{v8_ver}}
140BuildRequires:  libpaper-devel
141BuildRequires:  libXScrnSaver-devel
142BuildRequires:  libXtst-devel
143BuildRequires:  libXdamage-devel
144BuildRequires:  libXt-devel
145#BuildRequires:  gle-devel
146#BuildRequires:  webkit-gtk-devel
147#BuildRequires:  scons
148%ifarch x86_64
149Requires:  nspluginwrapper
150%endif
151
152##!!Requires:       alsa
153Requires:       alsa-lib
154Requires:       xdg-utils
155# shouldn't be required to name all dependencies
156# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
157
158BuildRoot:      %{_tmppath}/%{name}-%{version}-root
159
160%description
161Chromium is the open-source project behind Google Chrome.
162We invite you to join us in our effort to help build a safer, faster,
163and more stable way for all Internet users to experience the web,
164and to create a powerful platform for developing a new generation of
165web applications.
166
167%description -l ja
168Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
169ウェブを体験しているすべてのインターネットユーザに対して
170より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
171そして、ウェブアプリケーションの新しい世代を発展させ、
172強力なプラットホームを作成するために、
173私たちの取り組みにぜひ参加してください。
174
175
176%prep
177#%setup -q
178[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
179xz -dc %{SOURCE0} | %__tar -xf - || exit 1
180%setup -D -T -n %{pkgname}-%{version}
181
182%patch62 -p1
183%{?with_system_v8:%patch63 -p1}
184%patch100 -p1 -b .vine
185%patch4 -p1
186%patch8 -p1
187%patch12 -p1
188%patch13 -p1
189%patch14 -p1
190%patch17 -p1
191%patch18 -p1
192%patch19 -p1
193%patch20 -p1
194%patch21 -p1
195%patch25 -p1
196%patch26 -p1
197%patch28 -p1
198%patch29 -p1
199%{?with_system_vpx:%patch32 -p1}
200%{?with_system_v8:%patch34 -p1}
201
202pushd src/third_party/ffmpeg/
203%__tar xf %{SOURCE8} || exit 1
204## built header file: avconfig.h
205[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
206cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
207/* Generated by ffconf */
208#ifndef AVUTIL_AVCONFIG_H
209#define AVUTIL_AVCONFIG_H
210#define AV_HAVE_BIGENDIAN 0
211#endif /* AVUTIL_AVCONFIG_H */
212EOF
213popd
214
215#%__rm -rf src/third_party/libvpx/
216%__rm -rf src/third_party/speex/
217%__rm -rf src/third_party/nss src/third_party/nspr
218
219# apply vendor patch after substitution
220%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
221
222%build
223
224## create make files
225
226PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
227for i in src/build/common.gypi; do
228        %__sed -i "s|'-march=pentium4',||g" $i
229        %__sed -i "s|'-mfpmath=sse',||g" $i
230        %__sed -i "s|'-O<(debug_optimize)',||g" $i
231        %__sed -i "s|'-m32',||g" $i
232        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
233        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
234done
235# '
236
237pushd src
238
239./build/gyp_chromium -f make build/all.gyp \
240    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
241    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
242    -Duse_openssl=0 \
243    -Duse_system_ffmpeg=1 \
244    -Duse_system_zlib=1 \
245    -Duse_system_libpng=1 \
246    -Duse_system_bzip2=1 \
247    -Duse_system_libbz2=1 \
248    -Duse_system_libjpeg=1 \
249    -Duse_system_libxml=1 \
250    -Duse_system_libxslt=1 \
251    -Duse_system_libevent=1 \
252    %{?with_system_vpx:-Duse_system_vpx=1} \
253    %{!?with_system_vpx:-Duse_system_vpx=0} \
254    -Dproprietary_codecs=1 \
255    -Dlibrary=shared_library \
256    -Djavascript_engine=v8 \
257    -Dlinux_fpic=1 \
258    %{?with_system_v8:-Duse_system_v8=1} \
259    %{!?with_system_v8:-Duse_system_v8=0} \
260    %{?with_system_icu:-Duse_system_icu=1} \
261    %{!?with_system_icu:-Duse_system_icu=0} \
262    %ifarch %{ix86}
263        -Dtarget_arch=ia32 \
264         -Ddisable_sse2=1 \
265    %endif
266    %ifarch x86_64
267        -Dtarget_arch=x64 \
268    %endif
269    %if %{?_dist_release} == "vl6"
270        -Dno_strict_aliasing=1 -Dgcc_version=44 \
271    %endif
272    -Drelease_extra_cflags=-fPIC \
273    ;
274
275#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
276#%__make -r -j5 chrome BUILDTYPE=Release
277%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
278
279popd
280
281%install
282%{__rm} -rf %{buildroot}
283
284%__mkdir -p %{buildroot}%{_bindir}
285%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
286# x86_64 capable systems need this
287%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
288%__mkdir -p %{buildroot}%{_libdir}/chromium/
289%__mkdir -p %{buildroot}%{_mandir}/man1/
290pushd src/out/Release
291%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
292%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
293%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
294%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
295%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
296%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
297%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
298fdupes %{buildroot}%{_mandir}/man1/
299popd
300
301%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
302%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
303for i in 16 22 24 32 48 64 128 256; do
304    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
305    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
306done
307
308%__mkdir_p %{buildroot}%{_datadir}/applications/
309desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
310
311%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
312%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
313
314# # link to browser plugin path.  Plugin patch doesn't work. Why?
315# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
316# pushd %{buildroot}%{_libdir}/%{pkgname}
317# %{__ln_s} %{_libdir}/browser-plugins plugins
318# popd
319pushd %{buildroot}%{_libdir}/%{pkgname}
320%ifarch x86_64
321%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
322%else
323%{__ln_s} %{_libdir}/mozilla/plugins plugins
324%endif
325
326## support ffmpeg libs
327touch %{buildroot}%{_libdir}/libavcodec.so.52
328%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
329touch %{buildroot}%{_libdir}/libavformat.so.52
330%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
331touch %{buildroot}%{_libdir}/libavutil.so.50
332%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
333popd
334
335# Install the master_preferences file
336%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
337#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
338%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
339#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
340
341%clean
342%{__rm} -rf %{buildroot}
343
344%post
345touch --no-create %{_datadir}/icons/hicolor
346if [ -x %{_bindir}/gtk-update-icon-cache ]; then
347  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
348fi
349%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
350
351%postun
352%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
353touch --no-create %{_datadir}/icons/hicolor
354if [ -x %{_bindir}/gtk-update-icon-cache ]; then
355  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
356fi || :
357
358
359%files
360%defattr(-,root,root,-)
361%config %{_sysconfdir}/%{pkgname}
362%dir %{_datadir}/gnome-control-center
363%dir %{_datadir}/gnome-control-center/default-apps
364%{_bindir}/chromium
365%{_libdir}/chromium/chromium
366%{_libdir}/chromium/plugins/
367%{_libdir}/chromium/resources/
368%{_libdir}/chromium/xdg-settings
369%{_mandir}/man1/chrom*
370%{_datadir}/pixmaps/chromium-browser.png
371%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
372%{_datadir}/applications/*.desktop
373%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
374%{_libdir}/chromium/libavcodec.so.52
375%{_libdir}/chromium/libavutil.so.50
376%{_libdir}/chromium/libavformat.so.52
377%exclude %{_libdir}/libavcodec.so.52
378%exclude %{_libdir}/libavutil.so.50
379%exclude %{_libdir}/libavformat.so.52
380## libs
381%dir %{_libdir}/chromium/
382%{_libdir}/chromium/chrome.pak
383%{_libdir}/chromium/resources.pak
384%{_libdir}/chromium/locales/
385%{_libdir}/chromium/lib*.so
386
387%changelog
388* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
389- updated to 12.0.742.93
390- fixed icon field of chromium-browser-vine.desktop
391
392* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
393- updated to 12.0.742.91
394
395* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
396- updated to 12.0.742.77
397
398* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
399- updated to 12.0.742.63
400
401* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
402- updated to 12.0.742.42
403
404* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
405- updated to 12.0.742.6
406- dropped/upstreamed patches
407- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
408
409* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
410- updated to 11.0.696.50
411- dropped some Patches for MeeGo Netbook
412
413* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
414- updated to 11.0.696.35
415
416* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
417- updated to 11.0.696.29
418- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
419
420* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
421- updated to 11.0.696.22
422- improved chromium-browser-vine.sh
423  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
424
425* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
426- updated to 11.0.696.20
427- improved chromium-browser-vine.desktop
428
429* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
430- updated to 11.0.696.17
431
432* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
433- updated to 11.0.696.15
434  - ready for Vine Linux 6 release
435- dropped BuildRequires: v8-devel, libicu-devel
436
437* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
438- updated to 11.0.696.5 with v8 3.2.0
439- added BuildRequires: pam-devel
440
441* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
442- rebuilt with libevent-2.0.10
443
444* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
445- updated to 10.0.651.0 with v8 3.0.12
446- added BuildRequires:
447  - libpaper-devel
448  - python-devel
449- added built header file: libavutil/avconfig.h %%prep
450- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
451
452* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
453- updated to 10.0.622.0
454- added BuildRequires: libXt-devel
455
456* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
457- updated to 10.0.605.0
458- added BuildRequires:
459  - libXdamage-devel
460  - hunspell-devel
461
462* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
463- updated to 9.0.598
464
465* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
466- updated to 9.0.593
467
468* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
469- updated to 9.0.582
470- added Requires: xdg-utils
471
472* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
473- updated to 9.0.578
474
475* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
476- updated to 9.0.569
477
478  * Mon Oct 25 2010 tittiatcoke@gmail.com
479  - Update to 9.0.564 build
480    * Added specific patches for MeeGo.
481    * We are now using shared libraries for Chromium
482    * Spec-file cleanup (Thanks to prusnak)
483
484* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
485- updated to snapshot 8.0.556
486
487* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
488- updated to snapshot 8.0.551
489
490* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
491- updated to snapshot 7.0.527
492
493* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
494- updated to snapshot 7.0.519
495
496* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
497- updated to snapshot 7.0.513
498  - updated chromium-vendor-vine.patch.in
499
500* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
501- updated to snapshot 7.0.507
502
503* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
504- updated to snapshot 7.0.498
505
506* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
507- updated to snapshot 6.0.493
508- used with_system_icu (for vl6)
509  - added BuildRequires: libicu-devel
510
511* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
512- build for Vine Linux 5.x
513  - add BuildRequires: gnome-keyring-devel
514
515* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
516- updated to snapshot 6.0.454
517- added BuildRequires:
518  - sqlite3-devel
519  - gnutls-devel
520  - libgnome-keyring-devel
521
522* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
523- updated to snapshot 6.0.431.0 r49253
524- added BuildRequires: cups-devel
525
526* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
527- updated to snapshot 6.0.405.0 r47263
528
529* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
530- unused with_system_icu (for vl6)
531  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
532
533* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
534- updated to snapshot 5.0.378.0 r44472
535  - used with_system_icu (for vl6)
536  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
537
538* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
539- updated to snapshot 5.0.372.0 r43947
540- added BuildRequires: glew-devel
541- changed Group tag to Applications/Internet
542- added Summary(ja) and %%description -l ja
543
544* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
545- updated to snapshot 5.0.365.0 r42966
546- merged 5.0.353.0-4vl5
547 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
548 - build on Vine Linux 5.1
549   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
550
551* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
552- updated to snapshot 5.0.364.0 r42779
553
554* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
555- updated to snapshot 5.0.359.0 r42116
556- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
557
558* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
559- fixed master_preferences.vine, little
560
561* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
562- fixed to install master_preferences
563- dropped chromium-5.0.353-no-ffmpeg-vine.patch
564
565* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
566- applied chromium-5.0.353-no-ffmpeg-vine.patch
567
568* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
569- updated to snapshot 5.0.353.0 r41449
570  * Wed Mar 10 2010 bgmerrell@novell.com
571  - Add master_preferences source file and install it to /etc/chromium.
572  - Create a new patch (chromium-master-prefs-path.patch) which tells
573    chromium to look in /etc/chromium for the master_preferences file
574    (instead of looking in the default directory, which is the same
575    directory as the 'chrome' binary).
576
577* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
578- updated to snapshot 5.0.335.0 r39556
579
580* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
581- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
582
583* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
584- updated to snapshot 5.0.330.0 r39074
585
586* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
587- use_system_ffmpeg
588
589* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
590- added Requires:  nspluginwrapper
591- fixed a symbolic link of plugins directory with nspluginwrapper
592
593* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
594- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
595
596* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
597- added BuildRequires: mesa-libGLU-devel
598- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
599
600* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
601- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
602
603  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
604  - Update to 4.0.260
605  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
606  - Update to 4.0.259
607  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
608  - Update to 4.0.258
609  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
610  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
611    changed to having an built-in v8
612  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
613  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
614  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
615  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
616  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
617  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
618  - update to newer svn snapshot
619    + Obsoletes fwrite patch (included upstream)
620  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
621  - update to newer svn snapshot
622    + Requires newer version of v8
623  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
624  - do not force SSE on x86 (drop-sse.patch)
625  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
626  - Update to newer svn snapshot
627  - Fixed spec file in order to build
628  - Included patch to build with system zlib
629  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
630  - package renamed to chromium
631  - cleaned up spec file
632  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
633  - v8 is now built as a separate package, and is required
634  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
635  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
636  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
637  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
638  - initial build
639
640#% changelog
641* Sun Jan 24 2010 prusnak@suse.cz
642- added vendor to user agent (chromium-vendor.patch.in)
643* Sun Nov 29 2009 prusnak@suse.cz
644- added --enable-sync to wrapper to enable bookmark sync
645* Sun Nov 29 2009 tittiatcoke@gmail.com 
646- Update to 4.0.260
647* Fri Nov 27 2009 tittiatcoke@gmail.com 
648- Update to 4.0.259
649* Thu Nov 26 2009 tittiatcoke@gmail.com 
650- Update to 4.0.258
651* Tue Nov 24 2009 tittatcoke@gmai.com 
652- In order to complete prevent the wrong v8 version to be used,
653  the Chromium build has been changed to having an built-in v8
654* Tue Nov 24 2009 dbuck@example.com 
655- Re-base patches.
656- Fixed a few patch errors.
657- Rename some patches to better correspond with function.
658- Removed some patches.
659- Minor SPEC changes.
660- I changed the v8 requirement to be exact, instead of greater than a specific version.
661* Fri Nov 13 2009 tittiatcoke@gmail.com
662- update to 247.0 svn 31928
663* Fri Oct 30 2009 tittiatcoke@gmail.com
664- update to 229.0 svn 30454
665  + Fix regression where popups and app frames lost their titlebars.
666  + Makes it so that when a folder is open on the bookmark bar
667    and the mouse moves over another folder, the menu for that
668    folder is shown.
669  + Lazily create the find bar.
670  + Polish to the gmail checker sample.
671  * New, crisper icons that are exactly 19x19
672  * Add a loading animation at the beginning before Gmail
673    responds.
674  * Fix a bug where we sometimes don't update the UI after a
675    logout/login cycle.
676  + Refactor widget methods to support desktop notifications,
677    including GTK stubs.
678  + Find-in-page should not ding while deleting characters.
679  + Add SSL wrapper for linux and mac.  This allows notifier to
680    use chrome's SSL layer instead of OpenSSL.
681  + Add three of the six extensions to PAC that Internet Explorer supports.
682  + WebSocket support in chromium. (Run with --enable-web-sockets
683    enables WebSocket features.)
684  + Do not allow GTK File Chooser dialogs to return directories.
685  + Fix the notifier SSL layer to make notifications work for
686    Linux Bookmark sync.
687  + linux: don't override mouse selection behavior in omnibox
688* Sun Oct 25 2009 tittiatcoke@gmail.com
689- Update to 224.4 svn 30027
690  + First cut at new page and browser action docs based
691    on new API. Deleted old stuff.
692  + Add suppression for new memory leak caused by WebKit merge 49830:49844
693  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
694  + Minimize dependency of user scripts
695  + Fixup the flip_framer eof-handling semantics now that we have
696    the FIN bit in place
697  + app depends on x11 because of active_window_watcher_x
698  + Adding two images for the new Extension managment UI
699  + Removing hard-coded Chrome Frame output path
700  + Rearrange clipboard code
701  + Fix crash bug when attempting to download a url with unsupported scheme,
702    e.g. 'data:', by 'Alt + Click'
703  + GTK: Change text for extension download UI
704  + Ignore invalid urls on command line
705  + Make dropped tabs animate from where they were dropped.
706  + Make room for the full width of the tab placeholder.
707  + Make tab dragging as smooth as glass.
708  + Remove an annoying NOTIMPLEMNETED
709  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
710  + If we're in the middle of a drag, don't allow the user to middle
711    click to close or right click for the context menu
712  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
713  + Remove +x bit from files that shouldn't have it
714  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
715  + Adding new image needed for the managment UI
716  + Fix a race bug where content scripts would not apply to the first page load
717  + Make escape remove a bookmark if it's just been added (but not if it already existed)
718  + Fix bubbles deactivating the opaque frame
719  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
720  + ake all pepper plugins default to windowless and transparent
721  + Add styles for printing
722  + Implement the new extension management UI
723  + Add support for to automation interface load install and load extensions
724  + GTK: theme the info bar border
725  + Update V8 to version 1.3.16.1
726  + Introduce WebSecurityPolicy for security related methods
727  + New button scheme...borders are separate from the inner contents so
728    that they can be highlighted / depressed independently
729  + When opening Chrome maximized with an application window already
730    running, the Chrome window was not activated
731  + Fix compatibility problems with FileZilla FTP Server
732  + Remove the extension shelf on Linux
733  + Fix the proxy host and port string to start with http:// if it does not already
734  + Enable HTML5 databases for all extension renderer processes
735* Sat Oct 24 2009 prusnak@opensuse.org 
736- don't create desktop files in wrapper
737- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
738* Tue Oct 20 2009 tittiatcoke@gmail.com 
739- update to newer svn snapshot
740  + Obsoletes fwrite patch (included upstream)
741* Fri Oct 16 2009 tittiatcoke@gmail.com 
742- update to newer svn snapshot
743  + Requires newer version of v8
744* Thu Oct 15 2009 prusnak@suse.cz 
745- do not force SSE on x86 (drop-sse.patch)
746* Tue Oct 13 2009 tittiatcoke@gmail.com 
747- Update to newer svn snapshot
748- Fixed spec file in order to build
749- Included patch to build with system zlib
750* Mon Oct 12 2009 prusnak@suse.cz 
751- package renamed to chromium
752- cleaned up spec file
753* Tue Oct  6 2009 dbuck@example.com 
754- v8 is now built as a separate package, and is required
755- included many patches to use system libraries:
756    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
757* Thu Oct  1 2009 dbuck@example.com 
758- included a newer DEP than is in svn, native_client@823
759- things should compile cleanly now
760* Mon Aug 31 2009 dbuck@example.com 
761- initial build
Note: See TracBrowser for help on using the repository browser.