source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 2277

Revision 2277, 27.3 KB checked in by munepi, 14 years ago (diff)

updated chromium-vl.spec, v8-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8%define with_system_icu 1
9%endif
10
11%define svn_rev 67715
12%define v8_ver 2.5.9
13
14Name:           chromium
15Summary:        Google's opens source browser project
16Summary(ja):    Googleのオープンソースウェブブラウザ
17#'
18Version:        9.0.598.0
19Release:        1%{?_dist_release}
20License:        BSD
21Group:          Applications/Internet
22Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
23## The following are included for source reasons only
24# Custom build tools for chromium, hammer is a fancy front-end for scons
25Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
26# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
27Source2:        repack_chromium_archive.sh
28# Script used to create the tar.lzma archive from a checked out source
29Source3:        pack_chromium_source.sh
30# Official ffmpeg headers
31Source8:        ffmpeg-0.6-headers.tar.bz2
32#Source10:       chromium.desktop
33#Source10:       chromium-vine.desktop
34# Patch template which adds vendor to user agent
35##!!Source20:       chromium-vendor.patch.in
36Source20:       chromium-vendor-vine.patch.in
37# Set default prefs
38##!!Source30:       master_preferences
39Source30:       master_preferences.vine
40#Source31:       default_bookmarks.html
41#Source31:       default_bookmarks.html.vine
42# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
43Source50:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
44Source99:       chrome-wrapper
45##!!Source100:      chromium-browser.sh
46Source100:      chromium-browser-vine.sh
47##!!Source101:      chromium-browser.desktop
48Source101:      chromium-browser-vine.desktop
49Source102:      chromium-browser.xml
50Source103:      chromium-browser-rpmlintrc
51
52%{?nosrc:NoSource: 0}
53%{?nosrc:NoSource: 1}
54%{?nosrc:NoSource: 50}
55
56Provides:       chromium-browser = %{version}
57##Provides:     chromium-based-browser
58##Obsoletes:      chromium-browser < %{version}
59
60## Start Patches
61# Many changes to the gyp systems so we can use system libraries
62# My first ever patch set.  I hope I did well.
63Patch3:         chromium-gyp-system-icu.patch
64Patch4:         chromium-no-sqlite-debug.patch
65Patch5:         chromium-gyp-system-04-nss-nspr.patch
66Patch7:         chromium-codechanges-nss-nspr.patch
67Patch8:         chromium-codechanges-zlib.patch
68Patch12:        chromium-no-test-sources.patch
69Patch13:        chromium-no-courgette.patch
70Patch14:        chromium-master-prefs-path.patch
71Patch17:        chromium-system-glew.patch
72Patch18:        chromium-system-expat.patch
73Patch19:        chromium-system-zlib.patch
74Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
75Patch21:        chromium-7.0.542.0-media-probe.patch
76Patch23:        chromium-disable-mmx.patch
77Patch25:        tcmalloc-factory.patch
78Patch26:        chromium-remoting-build-fix.diff
79#Patch27:        chromium-7.0.542.0-system-libjingle.patch
80Patch28:        chromium-7.0.500.0-system-speex.patch
81Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
82Patch30:        chromium-7.0.510.0-fstat.patch
83#Patch31:        chromium-7.0.542.0-system-srtp.patch
84Patch32:        chromium-7.0.542.0-system-libvpx.patch
85#Patch33:        chromium-20090807-gyp-system-minizip.patch
86Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
87# Shared Library patches
88Patch60:        chromium-sharedlibfixes.patch
89Patch61:        chromium-shared-chromiumthreading.patch
90Patch62:        chromium-norpath.patch
91Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
92# Patches for MeeGo Netbook
93Patch80:        chromium-browser-window-focus.patch
94Patch81:        chromium-20100319-default-browser-setting.patch
95Patch82:        chromium-20100506-expose-chromium-browser-api.patch
96Patch83:        chromium-fix-toolbar-icon-size.patch
97
98# Vine
99
100
101BuildRequires:  gcc gcc-c++
102%if %{?_dist_release} == "vl5"
103BuildRequires:  libstdc++34 libstdc++34-devel
104%elseif %{?_dist_release} == "vl6"
105BuildRequires:  libstdc++ libstdc++-devel
106%endif
107BuildRequires:  libevent
108##!!BuildRequires:  pkg-config
109BuildRequires:  python
110##!!BuildRequires:  python-xml
111BuildRequires:  python-pyxml
112BuildRequires:  perl bison flex gperf
113##!!BuildRequires:  wdiff
114##!!BuildRequires:  update-desktop-files
115BuildRequires:  lzma
116##!!BuildRequires:  mozilla-nss-devel
117BuildRequires:  nss-devel
118##!!BuildRequires:  alsa-devel
119BuildRequires:  alsa-lib-devel
120BuildRequires:  gtk2-devel
121BuildRequires:  glib2-devel
122BuildRequires:  cairo-devel >= 1.6
123##!!BuildRequires:  mozilla-nspr-devel
124BuildRequires:  nspr-devel
125##!!BuildRequires:  gconf2-devel
126BuildRequires:  GConf2-devel
127BuildRequires:  freetype2-devel
128##!!BuildRequires:  dbus-1-devel
129BuildRequires:  dbus-devel
130BuildRequires:  libxslt-devel
131BuildRequires:  libxml2-devel
132BuildRequires:  libjpeg-devel
133BuildRequires:  zlib-devel
134##!!BuildRequires:  libbz2-devel
135BuildRequires:  bzip2-devel
136BuildRequires:  cups-devel
137%if %{?_dist_release} == "vl6"
138BuildRequires:  fdupes
139%endif
140##!!BuildRequires:  libexpat-devel
141BuildRequires:  expat-devel
142BuildRequires:  libpng-devel
143BuildRequires:  sqlite3-devel
144BuildRequires:  gnutls-devel
145BuildRequires:  desktop-file-utils
146BuildRequires:  v8-devel = %{v8_ver}
147BuildRequires:  libvpx-devel
148%if %{?_dist_release} == "vl5"
149BuildRequires:  gnome-keyring-devel
150%elseif %{?_dist_release} == "vl6"
151BuildRequires:  libgnome-keyring-devel
152%endif
153BuildRequires:  glew-devel
154##!!BuildRequires:  Mesa-devel
155BuildRequires:  mesa-libGLU-devel
156
157%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
158BuildRequires:  libevent-devel
159#BuildRequires:  libjingle-devel >= 0.4.0-7
160#BuildRequires:  srtp-devel
161BuildRequires:  speex-devel
162
163##Vine Linux
164Requires:       v8 = %{v8_ver}
165BuildRequires:  libXScrnSaver-devel
166BuildRequires:  libXtst-devel
167#BuildRequires:  gle-devel
168#BuildRequires:  webkit-gtk-devel
169#BuildRequires:  scons
170%ifarch x86_64
171Requires:  nspluginwrapper
172%endif
173
174##!!Requires:       alsa
175Requires:       alsa-lib
176Requires:       xdg-utils
177# shouldn't be required to name all dependencies
178# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
179
180BuildRoot:      %{_tmppath}/%{name}-%{version}-root
181
182%description
183Chromium is the open-source project behind Google Chrome.
184We invite you to join us in our effort to help build a safer, faster,
185and more stable way for all Internet users to experience the web,
186and to create a powerful platform for developing a new generation of
187web applications.
188
189%description -l ja
190Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
191私たちは、ウェブを体験しているすべてのインターネットユーザに対して
192より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
193そして、ウェブアプリケーションの新しい世代を発展させるように
194強力なプラットホームを作成するために、
195私たちの取り組みで私たちに加わるようにあなたを誘います。
196
197%package devel
198Summary:        Header file for chromium browser
199Group:          Development/Libraries
200Requires:       chromium = %{version}-%{release}
201
202%description devel
203This package contains the header files and pc file of chromium browser for
204applications which will use chromium browser APIs.
205
206
207%prep
208[ -d %{name} ] && %__rm -rf %{name}
209lzma -cd %{SOURCE0} | tar xf -
210%setup -D -T -n %{name}
211
212# use static libicu
213%if %{?_dist_release} == "vl5"
214cd src/third_party || exit 1
215    %__rm -rf icu || exit 1
216    tar jxvf %{SOURCE50} || exit 1
217    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
218cd - || exit 1
219%endif
220
221%patch60 -p1
222%patch61 -p1
223%patch62 -p1
224%patch63 -p1
225%patch80 -p1
226%patch81 -p1
227%patch82 -p1
228%patch83 -p1
229
230# use system libicu only if >= 4.0
231%{?with_system_icu:%patch3 -p1}
232
233%patch4 -p1
234%patch5 -p1
235%patch7 -p1
236%patch8 -p1
237%patch12 -p1
238%patch13 -p1
239%patch14 -p1
240%patch17 -p1
241%patch18 -p1
242%patch19 -p1
243%patch20 -p1
244%patch21 -p1
245%patch25 -p1
246%ifarch %ix86
247%patch23 -p1
248%endif
249%patch26 -p1
250#%patch27 -p1
251%patch28 -p1
252%patch29 -p1
253%patch30 -p1
254#%patch31 -p1
255%patch32 -p1
256#%patch33 -p1
257%patch34 -p1
258
259pushd src/third_party/ffmpeg/
260tar xf %{SOURCE8}
261popd
262
263%__rm -rf src/third_party/libvpx/ src/third_party/speex/
264
265# apply vendor patch after substitution
266%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
267
268%build
269## create make files
270
271PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
272for i in src/build/common.gypi; do
273        %__sed -i "s|'-march=pentium4',||g" $i
274        %__sed -i "s|'-msse2',||g" $i
275        %__sed -i "s|'-mfpmath=sse',||g" $i
276        %__sed -i "s|'-O<(debug_optimize)',||g" $i
277        %__sed -i "s|'-m32',||g" $i
278        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
279        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
280done
281# '
282
283pushd src
284
285./build/gyp_chromium -f make build/all.gyp \
286    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
287    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
288    -Duse_system_ffmpeg=1 \
289    -Duse_system_zlib=1 \
290    -Duse_system_libpng=1 \
291    -Duse_system_bzip2=1 \
292    -Duse_system_libbz2=1 \
293    -Duse_system_libjpeg=1 \
294    -Duse_system_libxml=1 \
295    -Duse_system_libxslt=1 \
296    -Duse_system_libevent=1 \
297    -Duse_system_vpx=1 \
298    -Dproprietary_codecs=1 \
299    -Dlibrary=shared_library \
300    -Djavascript_engine=v8 \
301    -Dlinux_fpic=1 \
302    %{?with_system_icu:-Duse_system_icu=1} \
303    %{!?with_system_icu:-Duse_system_icu=0} \
304    %ifarch %{ix86}
305        -Dtarget_arch=ia32 \
306         -Ddisable_sse2=1 \
307    %endif
308    %ifarch x86_64
309        -Dtarget_arch=x64 \
310    %endif
311    %if %{?_dist_release} == "vl6"
312        -Dno_strict_aliasing=1 -Dgcc_version=44 \
313    %endif
314    -Drelease_extra_cflags=-fPIC \
315    ;
316
317#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
318#%__make -r -j5 chrome BUILDTYPE=Release
319%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
320
321popd
322
323%install
324%{__rm} -rf %{buildroot}
325
326%__mkdir -p %{buildroot}%{_bindir}
327%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
328# x86_64 capable systems need this
329%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
330%__mkdir -p %{buildroot}%{_libdir}/chromium/
331%__mkdir -p %{buildroot}%{_mandir}/man1/
332pushd src/out/Release
333%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
334%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
335%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
336%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
337%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
338#%__cp -a chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
339%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
340%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
341%if %{?_dist_release} == "vl6"
342fdupes %{buildroot}%{_mandir}/man1/
343%endif
344popd
345
346# devel package install
347mkdir -p %{buildroot}%{_libdir}/chromium/include
348pushd src
349find base -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
350find app -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
351find chrome -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
352find skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
353find build -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
354find googleurl -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
355find ipc -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
356find testing -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
357find net -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
358find third_party/skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
359find third_party/WebKit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
360find webkit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
361find gfx -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
362popd
363find %{buildroot}%{_libdir}/chromium/include -name "*.h" -exec chmod 644 {} \;
364%if %{?_dist_release} == "vl6"
365fdupes %{buildroot}%{_libdir}/chromium/include
366%endif
367
368%__mkdir_p %{buildroot}/%{_libdir}/pkgconfig
369cat <<EOF > %{buildroot}/%{_libdir}/pkgconfig/chromium-browser.pc
370Name: Chromium browser
371Description: Chromium browser development package
372Version: 1.0.1
373Libs: -L%{_libdir}/chromium -lapp_base -lappcache -lbase_i18n -lbase -lblob -lbrowser -lcacheinvalidation -lchrome_gpu -lchromoting_base -lchromoting_client -lchromoting_host -lchromoting_jingle_glue -lchromoting_protocol -lchromotocol_proto_lib -lcld -lcommon_constants -lcommon_net -lcommon -ldatabase -ldebugger -ldefault_plugin -ldynamic_annotations -lffmpeg -lfileapi -lgfx -lglue -lgoogleurl -lgtest -lharfbuzz_interface -lharfbuzz -lhttp_listen_socket -lhunspell -liccjpeg -lil -linstaller_util -lipc -ljingle_p2p -ljingle -lmedia -lmodp_b64 -lnet_base -lnet -lnotifier -lomx_wrapper -lots -lpcre -lppapi_plugin -lplugin -lprinting -lprofile_import -lprotobuf_lite -lrenderer -lsandbox -lsdch -lservice -lskia_opts -lskia -lsqlite3 -lsrtp -lssl_host_info -lssl -lsymbolize -lsyncapi -lsync_notifier -lsync -ltrace_proto_lib -lundoview -lutility -lwebcore_bindings -lwebcore_html -lwebcore_platform -lwebcore_remaining -lwebcore_svg -lwebkit -lwebkit_user_agent -lwebp -lworker -lwtf -lxdg_mime -lzlib
374Cflags: -I%{_libdir}/chromium/include -I%{_libdir}/chromium/include/skia/config
375EOF
376
377%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
378%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
379
380%__mkdir_p %{buildroot}%{_datadir}/applications/
381desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
382
383%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
384%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
385
386# # link to browser plugin path.  Plugin patch doesn't work. Why?
387# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
388# pushd %{buildroot}%{_libdir}/%{name}
389# %{__ln_s} %{_libdir}/browser-plugins plugins
390# popd
391pushd %{buildroot}%{_libdir}/%{name}
392%ifarch x86_64
393%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
394%else
395%{__ln_s} %{_libdir}/mozilla/plugins plugins
396%endif
397
398## support ffmpeg libs
399touch %{buildroot}%{_libdir}/libavcodec.so.52
400%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
401touch %{buildroot}%{_libdir}/libavformat.so.52
402%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
403touch %{buildroot}%{_libdir}/libavutil.so.50
404%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
405popd
406
407# Install the master_preferences file
408%__mkdir_p %{buildroot}%{_sysconfdir}/%{name}
409#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
410%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
411#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{name}
412
413%clean
414%{__rm} -rf %{buildroot}
415
416
417%files
418%defattr(-,root,root,-)
419%config %{_sysconfdir}/%{name}
420%dir %{_datadir}/gnome-control-center
421%dir %{_datadir}/gnome-control-center/default-apps
422%{_bindir}/chromium
423%{_libdir}/chromium/chromium
424# These unique permissions are intentional and necessary for the sandboxing
425#%attr(4555, root, root) %{_libdir}/chromium/chrome-sandbox
426%{_libdir}/chromium/plugins/
427%{_libdir}/chromium/resources/
428%{_libdir}/chromium/xdg-settings
429%{_mandir}/man1/chrom*
430%{_datadir}/pixmaps/chromium-browser.png
431%{_datadir}/applications/*.desktop
432%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
433%{_libdir}/chromium/libavcodec.so.52
434%{_libdir}/chromium/libavutil.so.50
435%{_libdir}/chromium/libavformat.so.52
436%exclude %{_libdir}/libavcodec.so.52
437%exclude %{_libdir}/libavutil.so.50
438%exclude %{_libdir}/libavformat.so.52
439## libs
440%dir %{_libdir}/chromium/
441%{_libdir}/chromium/chrome.pak
442%{_libdir}/chromium/resources.pak
443%{_libdir}/chromium/locales/
444%{_libdir}/chromium/lib*.so
445
446%files devel
447%defattr(-,root,root,-)
448%{_libdir}/chromium/include/
449%{_libdir}/pkgconfig/chromium-browser.pc
450
451%changelog
452* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
453- updated to 9.0.598
454
455* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
456- updated to 9.0.593
457
458* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
459- updated to 9.0.582
460- added Requires: xdg-utils
461
462* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
463- updated to 9.0.578
464
465* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
466- updated to 9.0.569
467
468  * Mon Oct 25 2010 tittiatcoke@gmail.com
469  - Update to 9.0.564 build
470    * Added specific patches for MeeGo.
471    * We are now using shared libraries for Chromium
472    * Spec-file cleanup (Thanks to prusnak)
473
474* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
475- updated to snapshot 8.0.556
476
477* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
478- updated to snapshot 8.0.551
479
480* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
481- updated to snapshot 7.0.527
482
483* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
484- updated to snapshot 7.0.519
485
486* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
487- updated to snapshot 7.0.513
488  - updated chromium-vendor-vine.patch.in
489
490* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
491- updated to snapshot 7.0.507
492
493* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
494- updated to snapshot 7.0.498
495
496* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
497- updated to snapshot 6.0.493
498- used with_system_icu (for vl6)
499  - added BuildRequires: libicu-devel
500
501* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
502- build for Vine Linux 5.x
503  - add BuildRequires: gnome-keyring-devel
504
505* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
506- updated to snapshot 6.0.454
507- added BuildRequires:
508  - sqlite3-devel
509  - gnutls-devel
510  - libgnome-keyring-devel
511
512* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
513- updated to snapshot 6.0.431.0 r49253
514- added BuildRequires: cups-devel
515
516* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
517- updated to snapshot 6.0.405.0 r47263
518
519* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
520- unused with_system_icu (for vl6)
521  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
522
523* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
524- updated to snapshot 5.0.378.0 r44472
525  - used with_system_icu (for vl6)
526  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
527
528* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
529- updated to snapshot 5.0.372.0 r43947
530- added BuildRequires: glew-devel
531- changed Group tag to Applications/Internet
532- added Summary(ja) and %%description -l ja
533
534* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
535- updated to snapshot 5.0.365.0 r42966
536- merged 5.0.353.0-4vl5
537 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
538 - build on Vine Linux 5.1
539   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
540
541* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
542- updated to snapshot 5.0.364.0 r42779
543
544* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
545- updated to snapshot 5.0.359.0 r42116
546- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
547
548* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
549- fixed master_preferences.vine, little
550
551* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
552- fixed to install master_preferences
553- dropped chromium-5.0.353-no-ffmpeg-vine.patch
554
555* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
556- applied chromium-5.0.353-no-ffmpeg-vine.patch
557
558* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
559- updated to snapshot 5.0.353.0 r41449
560  * Wed Mar 10 2010 bgmerrell@novell.com
561  - Add master_preferences source file and install it to /etc/chromium.
562  - Create a new patch (chromium-master-prefs-path.patch) which tells
563    chromium to look in /etc/chromium for the master_preferences file
564    (instead of looking in the default directory, which is the same
565    directory as the 'chrome' binary).
566
567* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
568- updated to snapshot 5.0.335.0 r39556
569
570* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
571- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
572
573* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
574- updated to snapshot 5.0.330.0 r39074
575
576* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
577- use_system_ffmpeg
578
579* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
580- added Requires:  nspluginwrapper
581- fixed a symbolic link of plugins directory with nspluginwrapper
582
583* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
584- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
585
586* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
587- added BuildRequires: mesa-libGLU-devel
588- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
589
590* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
591- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
592
593  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
594  - Update to 4.0.260
595  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
596  - Update to 4.0.259
597  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
598  - Update to 4.0.258
599  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
600  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
601    changed to having an built-in v8
602  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
603  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
604  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
605  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
606  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
607  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
608  - update to newer svn snapshot
609    + Obsoletes fwrite patch (included upstream)
610  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
611  - update to newer svn snapshot
612    + Requires newer version of v8
613  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
614  - do not force SSE on x86 (drop-sse.patch)
615  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
616  - Update to newer svn snapshot
617  - Fixed spec file in order to build
618  - Included patch to build with system zlib
619  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
620  - package renamed to chromium
621  - cleaned up spec file
622  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
623  - v8 is now built as a separate package, and is required
624  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
625  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
626  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
627  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
628  - initial build
629
630#% changelog
631* Sun Jan 24 2010 prusnak@suse.cz
632- added vendor to user agent (chromium-vendor.patch.in)
633* Sun Nov 29 2009 prusnak@suse.cz
634- added --enable-sync to wrapper to enable bookmark sync
635* Fri Nov 13 2009 tittiatcoke@gmail.com
636- update to 247.0 svn 31928
637* Fri Oct 30 2009 tittiatcoke@gmail.com
638- update to 229.0 svn 30454
639  + Fix regression where popups and app frames lost their titlebars.
640  + Makes it so that when a folder is open on the bookmark bar
641    and the mouse moves over another folder, the menu for that
642    folder is shown.
643  + Lazily create the find bar.
644  + Polish to the gmail checker sample.
645  * New, crisper icons that are exactly 19x19
646  * Add a loading animation at the beginning before Gmail
647    responds.
648  * Fix a bug where we sometimes don't update the UI after a
649    logout/login cycle.
650  + Refactor widget methods to support desktop notifications,
651    including GTK stubs.
652  + Find-in-page should not ding while deleting characters.
653  + Add SSL wrapper for linux and mac.  This allows notifier to
654    use chrome's SSL layer instead of OpenSSL.
655  + Add three of the six extensions to PAC that Internet Explorer supports.
656  + WebSocket support in chromium. (Run with --enable-web-sockets
657    enables WebSocket features.)
658  + Do not allow GTK File Chooser dialogs to return directories.
659  + Fix the notifier SSL layer to make notifications work for
660    Linux Bookmark sync.
661  + linux: don't override mouse selection behavior in omnibox
662* Sun Oct 25 2009 tittiatcoke@gmail.com
663- Update to 224.4 svn 30027
664  + First cut at new page and browser action docs based
665    on new API. Deleted old stuff.
666  + Add suppression for new memory leak caused by WebKit merge 49830:49844
667  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
668  + Minimize dependency of user scripts
669  + Fixup the flip_framer eof-handling semantics now that we have
670    the FIN bit in place
671  + app depends on x11 because of active_window_watcher_x
672  + Adding two images for the new Extension managment UI
673  + Removing hard-coded Chrome Frame output path
674  + Rearrange clipboard code
675  + Fix crash bug when attempting to download a url with unsupported scheme,
676    e.g. 'data:', by 'Alt + Click'
677  + GTK: Change text for extension download UI
678  + Ignore invalid urls on command line
679  + Make dropped tabs animate from where they were dropped.
680  + Make room for the full width of the tab placeholder.
681  + Make tab dragging as smooth as glass.
682  + Remove an annoying NOTIMPLEMNETED
683  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
684  + If we're in the middle of a drag, don't allow the user to middle
685    click to close or right click for the context menu
686  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
687  + Remove +x bit from files that shouldn't have it
688  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
689  + Adding new image needed for the managment UI
690  + Fix a race bug where content scripts would not apply to the first page load
691  + Make escape remove a bookmark if it's just been added (but not if it already existed)
692  + Fix bubbles deactivating the opaque frame
693  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
694  + ake all pepper plugins default to windowless and transparent
695  + Add styles for printing
696  + Implement the new extension management UI
697  + Add support for to automation interface load install and load extensions
698  + GTK: theme the info bar border
699  + Update V8 to version 1.3.16.1
700  + Introduce WebSecurityPolicy for security related methods
701  + New button scheme...borders are separate from the inner contents so
702    that they can be highlighted / depressed independently
703  + When opening Chrome maximized with an application window already
704    running, the Chrome window was not activated
705  + Fix compatibility problems with FileZilla FTP Server
706  + Remove the extension shelf on Linux
707  + Fix the proxy host and port string to start with http:// if it does not already
708  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.