source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 2223

Revision 2223, 25.8 KB checked in by munepi, 14 years ago (diff)

updated chromium-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8%define with_system_icu 1
9%endif
10
11%define svn_rev 62756
12%define v8_ver 2.4.9
13
14Name:           chromium
15Summary:        Google's opens source browser project
16Summary(ja):    Googleのオープンソースウェブブラウザ
17#'
18Version:        8.0.556.0
19Release:        2%{?_dist_release}
20License:        BSD
21Group:          Applications/Internet
22Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
23## The following are included for source reasons only
24# Custom build tools for chromium, hammer is a fancy front-end for scons
25Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
26# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
27Source2:        repack_chromium_archive.sh
28# Script used to create the tar.lzma archive from a checked out source
29Source3:        pack_chromium_source.sh
30#Source10:       chromium.desktop
31#Source10:       chromium-vine.desktop
32# Patch template which adds vendor to user agent
33##!!Source20:       chromium-vendor.patch.in
34Source20:       chromium-vendor-vine.patch.in
35##!!Source30:       master_preferences
36Source30:       master_preferences.vine
37#Source31:       default_bookmarks.html
38#Source31:       default_bookmarks.html.vine
39# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
40Source50:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
41Source99:       chrome-wrapper
42##!!Source100:      chromium-browser.sh
43Source100:      chromium-browser-vine.sh
44##!!Source101:      chromium-browser.desktop
45Source101:      chromium-browser-vine.desktop
46Source102:      chromium-browser.xml
47Source103:      chromium-browser-rpmlintrc
48
49%{?nosrc:NoSource: 0}
50%{?nosrc:NoSource: 1}
51%{?nosrc:NoSource: 50}
52
53Provides:       chromium-browser = %{version}
54##Provides:     chromium-based-browser
55##Obsoletes:      chromium-browser < %{version}
56
57## Start Patches
58# Many changes to the gyp system so we can use system libraries
59# My first ever patch set.  I hope I did well.
60Patch3:         chromium-gyp-system-icu.patch
61Patch4:         chromium-no-sqlite-debug.patch
62Patch5:         chromium-gyp-system-04-nss-nspr.patch
63Patch7:         chromium-codechanges-nss-nspr.patch
64Patch8:         chromium-codechanges-zlib.patch
65Patch12:        chromium-no-test-sources.patch
66Patch13:        chromium-no-courgette.patch
67Patch14:        chromium-master-prefs-path.patch
68Patch17:        chromium-system-glew.patch
69Patch18:        chromium-system-expat.patch
70Patch19:        chromium-system-zlib.patch
71Patch20:        chromium-noffmpeg.patch
72Patch21:        chromium-system-old-ffmpeg-way.patch
73Patch23:        chromium-disable-mmx.patch
74Patch25:        tcmalloc-factory.patch
75Patch26:        chromium-remoting-build-fix.diff
76# Shared Library patches
77Patch60:        chromium-sharedlibfixes.patch
78Patch61:        chromium-shared-chromiumthreading.patch
79Patch62:        chromium-norpath.patch
80Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
81# Patches for MeeGo Netbook
82Patch80:        chromium-browser-window-focus.patch
83Patch81:        chromium-20100319-default-browser-setting.patch
84Patch82:        chromium-20100506-expose-chromium-browser-api.patch
85Patch83:        chromium-fix-toolbar-icon-size.patch
86
87# Vine
88
89
90BuildRequires:  gcc gcc-c++
91%if %{?_dist_release} == "vl5"
92BuildRequires:  libstdc++34 libstdc++34-devel
93%elseif %{?_dist_release} == "vl6"
94BuildRequires:  libstdc++ libstdc++-devel
95%endif
96BuildRequires:  libevent
97##!!BuildRequires:  pkg-config
98BuildRequires:  python
99##!!BuildRequires:  python-xml
100BuildRequires:  python-pyxml
101BuildRequires:  perl bison flex gperf
102##!!BuildRequires:  wdiff
103##!!BuildRequires:  update-desktop-files
104BuildRequires:  lzma
105##!!BuildRequires:  mozilla-nss-devel
106BuildRequires:  nss-devel
107##!!BuildRequires:  alsa-devel
108BuildRequires:  alsa-lib-devel
109BuildRequires:  gtk2-devel
110BuildRequires:  glib2-devel
111BuildRequires:  cairo-devel >= 1.6
112##!!BuildRequires:  mozilla-nspr-devel
113BuildRequires:  nspr-devel
114##!!BuildRequires:  gconf2-devel
115BuildRequires:  GConf2-devel
116BuildRequires:  freetype2-devel
117##!!BuildRequires:  dbus-1-devel
118BuildRequires:  dbus-devel
119BuildRequires:  libxslt-devel
120BuildRequires:  libxml2-devel
121BuildRequires:  libjpeg-devel
122BuildRequires:  zlib-devel
123##!!BuildRequires:  libbz2-devel
124BuildRequires:  bzip2-devel
125BuildRequires:  cups-devel
126%if %{?_dist_release} == "vl6"
127BuildRequires:  fdupes
128%endif
129##!!BuildRequires:  libexpat-devel
130BuildRequires:  expat-devel
131BuildRequires:  libpng-devel
132BuildRequires:  sqlite3-devel
133BuildRequires:  gnutls-devel
134BuildRequires:  desktop-file-utils
135BuildRequires:  v8-devel = %{v8_ver}
136BuildRequires:  libvpx-devel
137%if %{?_dist_release} == "vl5"
138BuildRequires:  gnome-keyring-devel
139%elseif %{?_dist_release} == "vl6"
140BuildRequires:  libgnome-keyring-devel
141%endif
142BuildRequires:  glew-devel
143##!!BuildRequires:  Mesa-devel
144BuildRequires:  mesa-libGLU-devel
145
146%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
147BuildRequires:  libevent-devel
148
149##Vine Linux
150Requires:       v8 = %{v8_ver}
151BuildRequires:  libXScrnSaver-devel
152#BuildRequires:  gle-devel
153#BuildRequires:  webkit-gtk-devel
154#BuildRequires:  scons
155%ifarch x86_64
156Requires:  nspluginwrapper
157%endif
158
159##!!Requires:       alsa
160Requires:       alsa-lib
161# shouldn't be required to name all dependencies
162# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
163## Recommends the ffmpeg libraries (available from packman)
164#Recommends:     libavcodec52 libavformat52 libavutil50
165
166BuildRoot:      %{_tmppath}/%{name}-%{version}-root
167ExclusiveArch:  %{ix86} x86_64
168
169%description
170Chromium is the open-source project behind Google Chrome.
171We invite you to join us in our effort to help build a safer, faster,
172and more stable way for all Internet users to experience the web,
173and to create a powerful platform for developing a new generation of
174web applications.
175
176%description -l ja
177Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
178私たちは、ウェブを体験しているすべてのインターネットユーザに対して
179より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
180ウェブアプリケーションの新しい世代を発展させるように
181強力なプラットホームを作成するために、
182私たちの取り組みで私たちに加わるようにあなたを誘います。
183
184%package devel
185Summary:        Header file for chromium browser
186Group:          Development/Libraries
187Requires:       chromium = %{version}-%{release}
188
189%description devel
190This package contains the header files and pc file of chromium browser for
191applications which will use chromium browser APIs.
192
193
194%prep
195[ -d %{name} ] && %__rm -rf %{name}
196lzma -cd %{SOURCE0} | tar xf -
197%setup -D -T -n %{name}
198
199# use static libicu
200%if %{?_dist_release} == "vl5"
201cd src/third_party || exit 1
202    %__rm -rf icu || exit 1
203    tar jxvf %{SOURCE50} || exit 1
204    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
205cd - || exit 1
206%endif
207
208%patch60 -p1
209%patch61 -p1
210%patch62 -p1
211%patch63 -p1
212%patch80 -p1
213%patch81 -p1
214%patch82 -p1
215%patch83 -p1
216
217# use system libicu only if >= 4.0
218%{?with_system_icu:%patch3 -p1}
219
220%patch4 -p1
221%patch5 -p1
222%patch7 -p1
223%patch8 -p1
224%patch12 -p1
225%patch13 -p1
226%patch14 -p1
227%patch17 -p1
228%patch18 -p1
229%patch19 -p1
230%patch20 -p1
231%patch21 -p1
232%patch25 -p1
233%ifarch %ix86
234%patch23 -p1
235%endif
236%patch26 -p1
237
238
239# apply vendor patch after substitution
240%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
241
242%build
243## create make files
244
245PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
246for i in src/build/common.gypi; do
247        %__sed -i "s|'-march=pentium4',||g" $i
248        %__sed -i "s|'-msse2',||g" $i
249        %__sed -i "s|'-mfpmath=sse',||g" $i
250        %__sed -i "s|'-O<(debug_optimize)',||g" $i
251        %__sed -i "s|'-m32',||g" $i
252        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
253        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
254done
255# '
256
257pushd src
258
259./build/gyp_chromium -f make build/all.gyp \
260    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
261    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
262    -Duse_system_ffmpeg=1 \
263    -Duse_system_zlib=1 \
264    -Duse_system_libpng=1 \
265    -Duse_system_bzip2=1 \
266    -Duse_system_libbz2=1 \
267    -Duse_system_libjpeg=1 \
268    -Duse_system_libxml=1 \
269    -Duse_system_libxslt=1 \
270    -Duse_system_libevent=1 \
271    -Duse_system_vpx=1 \
272    -Dproprietary_codecs=1 \
273    -Dlibrary=shared_library \
274    -Dlinux_fpic=1 \
275    %{?with_system_icu:-Duse_system_icu=1} \
276    %{!?with_system_icu:-Duse_system_icu=0} \
277    %ifarch %{ix86}
278        -Dtarget_arch=ia32 \
279         -Ddisable_sse2=1 \
280    %endif
281    %ifarch x86_64
282        -Dtarget_arch=x64 \
283    %endif
284    %if %{?_dist_release} == "vl6"
285        -Dno_strict_aliasing=1 -Dgcc_version=44 \
286    %endif
287    -Drelease_extra_cflags=-fPIC \
288    ;
289
290#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
291#%__make -r -j5 chrome BUILDTYPE=Release
292%__make %{?_smp_mflags} chrome BUILDTYPE=Release
293
294popd
295
296%install
297%{__rm} -rf %{buildroot}
298
299%__mkdir -p %{buildroot}%{_bindir}
300%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
301# x86_64 capable systems need this
302%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
303%__mkdir -p %{buildroot}%{_libdir}/chromium/
304%__mkdir -p %{buildroot}%{_mandir}/man1/
305pushd src/out/Release
306%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
307%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
308%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
309%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
310%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
311#%__cp -a chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
312%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
313%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
314%if %{?_dist_release} == "vl6"
315fdupes %{buildroot}%{_mandir}/man1/
316%endif
317popd
318
319# devel package install
320mkdir -p %{buildroot}%{_libdir}/chromium/include
321pushd src
322find base -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
323find app -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
324find chrome -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
325find skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
326find build -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
327find googleurl -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
328find ipc -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
329find testing -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
330find net -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
331find third_party/skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
332find third_party/WebKit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
333find webkit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
334find gfx -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
335popd
336find %{buildroot}%{_libdir}/chromium/include -name "*.h" -exec chmod 644 {} \;
337%if %{?_dist_release} == "vl6"
338fdupes %{buildroot}%{_libdir}/chromium/include
339%endif
340
341%__mkdir_p %{buildroot}/%{_libdir}/pkgconfig
342cat <<! > %{buildroot}/%{_libdir}/pkgconfig/chromium-browser.pc
343Name: Chromium browser
344Description: Chromium browser development package
345Version: 1.0.1
346Libs: -L%{_libdir}/chromium -lapp_base -lappcache -lbase_i18n -lbase -lblob -lbrowser -lcacheinvalidation -lchrome_gpu -lchromoting_base -lchromoting_client -lchromoting_host -lchromoting_jingle_glue -lchromotocol_proto_lib -lcld -lcommon_constants -lcommon_net -lcommon -ldatabase -ldebugger -ldefault_plugin -ldynamic_annotations -lffmpeg -lfileapi -lgfx -lglue -lgoogleurl -lgtest -lharfbuzz_interface -lharfbuzz -lhttp_listen_socket -lhunspell -lil -linstaller_util -lipc -ljingle_p2p -ljingle -lmedia -lmodp_b64 -lnet_base -lnet -lnotifier -lomx_wrapper -lots -lpcre -lplugin -lprinting -lprofile_import -lprotobuf_lite -lprotobuf -lrenderer -lsandbox -lsdch -lservice -lskia_opts -lskia -lspeex -lsqlite3 -lsrtp -lssl -lsymbolize -lsyncapi -lsync_notifier -lsync -ltrace_proto_lib -lutility -lwebcore_bindings -lwebcore_platform -lwebcore_remaining -lwebcore_svg -lwebkit_user_agent -lworker -lwtf -lxdg_mime -lzlib
347Cflags: -I%{_libdir}/chromium/include -I%{_libdir}/chromium/include/skia/config
348!
349
350%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
351%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
352
353%__mkdir_p %{buildroot}%{_datadir}/applications/
354desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
355
356%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
357%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
358
359# # link to browser plugin path.  Plugin patch doesn't work. Why?
360# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
361# pushd %{buildroot}%{_libdir}/%{name}
362# %{__ln_s} %{_libdir}/browser-plugins plugins
363# popd
364pushd %{buildroot}%{_libdir}/%{name}
365%ifarch x86_64
366%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
367%else
368%{__ln_s} %{_libdir}/mozilla/plugins plugins
369%endif
370
371## support ffmpeg libs
372touch %{buildroot}%{_libdir}/libavcodec.so.52
373%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
374touch %{buildroot}%{_libdir}/libavformat.so.52
375%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
376touch %{buildroot}%{_libdir}/libavutil.so.50
377%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
378popd
379
380# Install the master_preferences file
381%__mkdir_p %{buildroot}%{_sysconfdir}/%{name}
382#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
383%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
384#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{name}
385
386%clean
387%{__rm} -rf %{buildroot}
388
389
390%files
391%defattr(-,root,root,-)
392%config %{_sysconfdir}/%{name}
393%dir /usr/share/gnome-control-center
394%dir /usr/share/gnome-control-center/default-apps
395%{_bindir}/chromium
396%{_libdir}/chromium/chromium
397# These unique permissions are intentional and necessary for the sandboxing
398#%attr(4555, root, root) %{_libdir}/chromium/chrome-sandbox
399%{_libdir}/chromium/plugins/
400%{_libdir}/chromium/resources/
401%{_libdir}/chromium/xdg-settings
402%{_mandir}/man1/chrom*
403%{_datadir}/pixmaps/chromium-browser.png
404%{_datadir}/applications/*.desktop
405%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
406%{_libdir}/chromium/libavcodec.so.52
407%{_libdir}/chromium/libavutil.so.50
408%{_libdir}/chromium/libavformat.so.52
409%exclude %{_libdir}/libavcodec.so.52
410%exclude %{_libdir}/libavutil.so.50
411%exclude %{_libdir}/libavformat.so.52
412## libs
413%dir %{_libdir}/chromium/
414%{_libdir}/chromium/chrome.pak
415%{_libdir}/chromium/resources.pak
416%{_libdir}/chromium/locales/
417%{_libdir}/chromium/lib*.so
418
419%files devel
420%defattr(-,root,root,-)
421%{_libdir}/chromium/include/
422%_libdir/pkgconfig/chromium-browser.pc
423
424%changelog
425* Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-2
426- rebuilt
427- added ExclusiveArch: %%{ix86} x86_64
428
429* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
430- updated to snapshot 8.0.556
431
432* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
433- updated to snapshot 8.0.551
434
435* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
436- updated to snapshot 7.0.527
437
438* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
439- updated to snapshot 7.0.519
440
441* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
442- updated to snapshot 7.0.513
443  - updated chromium-vendor-vine.patch.in
444
445* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
446- updated to snapshot 7.0.507
447
448* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
449- updated to snapshot 7.0.498
450
451* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
452- updated to snapshot 6.0.493
453- used with_system_icu (for vl6)
454  - added BuildRequires: libicu-devel
455
456* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
457- build for Vine Linux 5.x
458  - add BuildRequires: gnome-keyring-devel
459
460* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
461- updated to snapshot 6.0.454
462- added BuildRequires:
463  - sqlite3-devel
464  - gnutls-devel
465  - libgnome-keyring-devel
466
467* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
468- updated to snapshot 6.0.431.0 r49253
469- added BuildRequires: cups-devel
470
471* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
472- updated to snapshot 6.0.405.0 r47263
473
474* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
475- unused with_system_icu (for vl6)
476  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
477
478* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
479- updated to snapshot 5.0.378.0 r44472
480  - used with_system_icu (for vl6)
481  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
482
483* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
484- updated to snapshot 5.0.372.0 r43947
485- added BuildRequires: glew-devel
486- changed Group tag to Applications/Internet
487- added Summary(ja) and %%description -l ja
488
489* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
490- updated to snapshot 5.0.365.0 r42966
491- merged 5.0.353.0-4vl5
492 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
493 - build on Vine Linux 5.1
494   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
495
496* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
497- updated to snapshot 5.0.364.0 r42779
498
499* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
500- updated to snapshot 5.0.359.0 r42116
501- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
502
503* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
504- fixed master_preferences.vine, little
505
506* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
507- fixed to install master_preferences
508- dropped chromium-5.0.353-no-ffmpeg-vine.patch
509
510* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
511- applied chromium-5.0.353-no-ffmpeg-vine.patch
512
513* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
514- updated to snapshot 5.0.353.0 r41449
515  * Wed Mar 10 2010 bgmerrell@novell.com
516  - Add master_preferences source file and install it to /etc/chromium.
517  - Create a new patch (chromium-master-prefs-path.patch) which tells
518    chromium to look in /etc/chromium for the master_preferences file
519    (instead of looking in the default directory, which is the same
520    directory as the 'chrome' binary).
521
522* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
523- updated to snapshot 5.0.335.0 r39556
524
525* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
526- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
527
528* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
529- updated to snapshot 5.0.330.0 r39074
530
531* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
532- use_system_ffmpeg
533
534* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
535- added Requires:  nspluginwrapper
536- fixed a symbolic link of plugins directory with nspluginwrapper
537
538* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
539- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
540
541* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
542- added BuildRequires: mesa-libGLU-devel
543- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
544
545* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
546- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
547
548  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
549  - Update to 4.0.260
550  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
551  - Update to 4.0.259
552  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
553  - Update to 4.0.258
554  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
555  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
556    changed to having an built-in v8
557  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
558  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
559  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
560  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
561  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
562  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
563  - update to newer svn snapshot
564    + Obsoletes fwrite patch (included upstream)
565  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
566  - update to newer svn snapshot
567    + Requires newer version of v8
568  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
569  - do not force SSE on x86 (drop-sse.patch)
570  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
571  - Update to newer svn snapshot
572  - Fixed spec file in order to build
573  - Included patch to build with system zlib
574  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
575  - package renamed to chromium
576  - cleaned up spec file
577  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
578  - v8 is now built as a separate package, and is required
579  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
580  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
581  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
582  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
583  - initial build
584
585#% changelog
586* Sun Jan 24 2010 prusnak@suse.cz
587- added vendor to user agent (chromium-vendor.patch.in)
588* Sun Nov 29 2009 prusnak@suse.cz
589- added --enable-sync to wrapper to enable bookmark sync
590* Fri Nov 13 2009 tittiatcoke@gmail.com
591- update to 247.0 svn 31928
592* Fri Oct 30 2009 tittiatcoke@gmail.com
593- update to 229.0 svn 30454
594  + Fix regression where popups and app frames lost their titlebars.
595  + Makes it so that when a folder is open on the bookmark bar
596    and the mouse moves over another folder, the menu for that
597    folder is shown.
598  + Lazily create the find bar.
599  + Polish to the gmail checker sample.
600  * New, crisper icons that are exactly 19x19
601  * Add a loading animation at the beginning before Gmail
602    responds.
603  * Fix a bug where we sometimes don't update the UI after a
604    logout/login cycle.
605  + Refactor widget methods to support desktop notifications,
606    including GTK stubs.
607  + Find-in-page should not ding while deleting characters.
608  + Add SSL wrapper for linux and mac.  This allows notifier to
609    use chrome's SSL layer instead of OpenSSL.
610  + Add three of the six extensions to PAC that Internet Explorer supports.
611  + WebSocket support in chromium. (Run with --enable-web-sockets
612    enables WebSocket features.)
613  + Do not allow GTK File Chooser dialogs to return directories.
614  + Fix the notifier SSL layer to make notifications work for
615    Linux Bookmark sync.
616  + linux: don't override mouse selection behavior in omnibox
617* Sun Oct 25 2009 tittiatcoke@gmail.com
618- Update to 224.4 svn 30027
619  + First cut at new page and browser action docs based
620    on new API. Deleted old stuff.
621  + Add suppression for new memory leak caused by WebKit merge 49830:49844
622  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
623  + Minimize dependency of user scripts
624  + Fixup the flip_framer eof-handling semantics now that we have
625    the FIN bit in place
626  + app depends on x11 because of active_window_watcher_x
627  + Adding two images for the new Extension managment UI
628  + Removing hard-coded Chrome Frame output path
629  + Rearrange clipboard code
630  + Fix crash bug when attempting to download a url with unsupported scheme,
631    e.g. 'data:', by 'Alt + Click'
632  + GTK: Change text for extension download UI
633  + Ignore invalid urls on command line
634  + Make dropped tabs animate from where they were dropped.
635  + Make room for the full width of the tab placeholder.
636  + Make tab dragging as smooth as glass.
637  + Remove an annoying NOTIMPLEMNETED
638  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
639  + If we're in the middle of a drag, don't allow the user to middle
640    click to close or right click for the context menu
641  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
642  + Remove +x bit from files that shouldn't have it
643  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
644  + Adding new image needed for the managment UI
645  + Fix a race bug where content scripts would not apply to the first page load
646  + Make escape remove a bookmark if it's just been added (but not if it already existed)
647  + Fix bubbles deactivating the opaque frame
648  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
649  + ake all pepper plugins default to windowless and transparent
650  + Add styles for printing
651  + Implement the new extension management UI
652  + Add support for to automation interface load install and load extensions
653  + GTK: theme the info bar border
654  + Update V8 to version 1.3.16.1
655  + Introduce WebSecurityPolicy for security related methods
656  + New button scheme...borders are separate from the inner contents so
657    that they can be highlighted / depressed independently
658  + When opening Chrome maximized with an application window already
659    running, the Chrome window was not activated
660  + Fix compatibility problems with FileZilla FTP Server
661  + Remove the extension shelf on Linux
662  + Fix the proxy host and port string to start with http:// if it does not already
663  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.