source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 2076

Revision 2076, 25.7 KB checked in by munepi, 14 years ago (diff)

updated chromium, v8

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8%define with_system_icu 1
9%endif
10
11%define svn_rev 62756
12%define v8_ver 2.4.9
13
14Name:           chromium
15Summary:        Google's opens source browser project
16Summary(ja):    Googleのオープンソースウェブブラウザ
17#'
18Version:        8.0.556.0
19Release:        1%{?_dist_release}
20License:        BSD
21Group:          Applications/Internet
22Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
23## The following are included for source reasons only
24# Custom build tools for chromium, hammer is a fancy front-end for scons
25Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
26# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
27Source2:        repack_chromium_archive.sh
28# Script used to create the tar.lzma archive from a checked out source
29Source3:        pack_chromium_source.sh
30#Source10:       chromium.desktop
31#Source10:       chromium-vine.desktop
32# Patch template which adds vendor to user agent
33##!!Source20:       chromium-vendor.patch.in
34Source20:       chromium-vendor-vine.patch.in
35##!!Source30:       master_preferences
36Source30:       master_preferences.vine
37#Source31:       default_bookmarks.html
38#Source31:       default_bookmarks.html.vine
39# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
40Source50:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
41Source99:       chrome-wrapper
42##!!Source100:      chromium-browser.sh
43Source100:      chromium-browser-vine.sh
44##!!Source101:      chromium-browser.desktop
45Source101:      chromium-browser-vine.desktop
46Source102:      chromium-browser.xml
47Source103:      chromium-browser-rpmlintrc
48
49%{?nosrc:NoSource: 0}
50%{?nosrc:NoSource: 1}
51%{?nosrc:NoSource: 50}
52
53Provides:       chromium-browser = %{version}
54##Provides:     chromium-based-browser
55##Obsoletes:      chromium-browser < %{version}
56
57## Start Patches
58# Many changes to the gyp system so we can use system libraries
59# My first ever patch set.  I hope I did well.
60Patch3:         chromium-gyp-system-icu.patch
61Patch4:         chromium-no-sqlite-debug.patch
62Patch5:         chromium-gyp-system-04-nss-nspr.patch
63Patch7:         chromium-codechanges-nss-nspr.patch
64Patch8:         chromium-codechanges-zlib.patch
65Patch12:        chromium-no-test-sources.patch
66Patch13:        chromium-no-courgette.patch
67Patch14:        chromium-master-prefs-path.patch
68Patch17:        chromium-system-glew.patch
69Patch18:        chromium-system-expat.patch
70Patch19:        chromium-system-zlib.patch
71Patch20:        chromium-noffmpeg.patch
72Patch21:        chromium-system-old-ffmpeg-way.patch
73Patch23:        chromium-disable-mmx.patch
74Patch25:        tcmalloc-factory.patch
75Patch26:        chromium-remoting-build-fix.diff
76# Shared Library patches
77Patch60:        chromium-sharedlibfixes.patch
78Patch61:        chromium-shared-chromiumthreading.patch
79Patch62:        chromium-norpath.patch
80Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
81# Patches for MeeGo Netbook
82Patch80:        chromium-browser-window-focus.patch
83Patch81:        chromium-20100319-default-browser-setting.patch
84Patch82:        chromium-20100506-expose-chromium-browser-api.patch
85Patch83:        chromium-fix-toolbar-icon-size.patch
86
87# Vine
88
89
90BuildRequires:  gcc gcc-c++
91%if %{?_dist_release} == "vl5"
92BuildRequires:  libstdc++34 libstdc++34-devel
93%elseif %{?_dist_release} == "vl6"
94BuildRequires:  libstdc++ libstdc++-devel
95%endif
96BuildRequires:  libevent
97##!!BuildRequires:  pkg-config
98BuildRequires:  python
99##!!BuildRequires:  python-xml
100BuildRequires:  python-pyxml
101BuildRequires:  perl bison flex gperf
102##!!BuildRequires:  wdiff
103##!!BuildRequires:  update-desktop-files
104BuildRequires:  lzma
105##!!BuildRequires:  mozilla-nss-devel
106BuildRequires:  nss-devel
107##!!BuildRequires:  alsa-devel
108BuildRequires:  alsa-lib-devel
109BuildRequires:  gtk2-devel
110BuildRequires:  glib2-devel
111BuildRequires:  cairo-devel >= 1.6
112##!!BuildRequires:  mozilla-nspr-devel
113BuildRequires:  nspr-devel
114##!!BuildRequires:  gconf2-devel
115BuildRequires:  GConf2-devel
116BuildRequires:  freetype2-devel
117##!!BuildRequires:  dbus-1-devel
118BuildRequires:  dbus-devel
119BuildRequires:  libxslt-devel
120BuildRequires:  libxml2-devel
121BuildRequires:  libjpeg-devel
122BuildRequires:  zlib-devel
123##!!BuildRequires:  libbz2-devel
124BuildRequires:  bzip2-devel
125BuildRequires:  cups-devel
126%if %{?_dist_release} == "vl6"
127BuildRequires:  fdupes
128%endif
129##!!BuildRequires:  libexpat-devel
130BuildRequires:  expat-devel
131BuildRequires:  libpng-devel
132BuildRequires:  sqlite3-devel
133BuildRequires:  gnutls-devel
134BuildRequires:  desktop-file-utils
135BuildRequires:  v8-devel = %{v8_ver}
136BuildRequires:  libvpx-devel
137%if %{?_dist_release} == "vl5"
138BuildRequires:  gnome-keyring-devel
139%elseif %{?_dist_release} == "vl6"
140BuildRequires:  libgnome-keyring-devel
141%endif
142BuildRequires:  glew-devel
143##!!BuildRequires:  Mesa-devel
144BuildRequires:  mesa-libGLU-devel
145
146%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
147BuildRequires:  libevent-devel
148
149##Vine Linux
150Requires:       v8 = %{v8_ver}
151BuildRequires:  libXScrnSaver-devel
152#BuildRequires:  gle-devel
153#BuildRequires:  webkit-gtk-devel
154#BuildRequires:  scons
155%ifarch x86_64
156Requires:  nspluginwrapper
157%endif
158
159##!!Requires:       alsa
160Requires:       alsa-lib
161# shouldn't be required to name all dependencies
162# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
163## Recommends the ffmpeg libraries (available from packman)
164#Recommends:     libavcodec52 libavformat52 libavutil50
165
166BuildRoot:      %{_tmppath}/%{name}-%{version}-root
167
168%description
169Chromium is the open-source project behind Google Chrome.
170We invite you to join us in our effort to help build a safer, faster,
171and more stable way for all Internet users to experience the web,
172and to create a powerful platform for developing a new generation of
173web applications.
174
175%description -l ja
176Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
177私たちは、ウェブを体験しているすべてのインターネットユーザに対して
178より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
179ウェブアプリケーションの新しい世代を発展させるように
180強力なプラットホームを作成するために、
181私たちの取り組みで私たちに加わるようにあなたを誘います。
182
183%package devel
184Summary:        Header file for chromium browser
185Group:          Development/Libraries
186Requires:       chromium = %{version}-%{release}
187
188%description devel
189This package contains the header files and pc file of chromium browser for
190applications which will use chromium browser APIs.
191
192
193%prep
194[ -d %{name} ] && %__rm -rf %{name}
195lzma -cd %{SOURCE0} | tar xf -
196%setup -D -T -n %{name}
197
198# use static libicu
199%if %{?_dist_release} == "vl5"
200cd src/third_party || exit 1
201    %__rm -rf icu || exit 1
202    tar jxvf %{SOURCE50} || exit 1
203    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
204cd - || exit 1
205%endif
206
207%patch60 -p1
208%patch61 -p1
209%patch62 -p1
210%patch63 -p1
211%patch80 -p1
212%patch81 -p1
213%patch82 -p1
214%patch83 -p1
215
216# use system libicu only if >= 4.0
217%{?with_system_icu:%patch3 -p1}
218
219%patch4 -p1
220%patch5 -p1
221%patch7 -p1
222%patch8 -p1
223%patch12 -p1
224%patch13 -p1
225%patch14 -p1
226%patch17 -p1
227%patch18 -p1
228%patch19 -p1
229%patch20 -p1
230%patch21 -p1
231%patch25 -p1
232%ifarch %ix86
233%patch23 -p1
234%endif
235%patch26 -p1
236
237
238# apply vendor patch after substitution
239%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
240
241%build
242## create make files
243
244PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
245for i in src/build/common.gypi; do
246        %__sed -i "s|'-march=pentium4',||g" $i
247        %__sed -i "s|'-msse2',||g" $i
248        %__sed -i "s|'-mfpmath=sse',||g" $i
249        %__sed -i "s|'-O<(debug_optimize)',||g" $i
250        %__sed -i "s|'-m32',||g" $i
251        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
252        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
253done
254# '
255
256pushd src
257
258./build/gyp_chromium -f make build/all.gyp \
259    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
260    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
261    -Duse_system_ffmpeg=1 \
262    -Duse_system_zlib=1 \
263    -Duse_system_libpng=1 \
264    -Duse_system_bzip2=1 \
265    -Duse_system_libbz2=1 \
266    -Duse_system_libjpeg=1 \
267    -Duse_system_libxml=1 \
268    -Duse_system_libxslt=1 \
269    -Duse_system_libevent=1 \
270    -Duse_system_vpx=1 \
271    -Dproprietary_codecs=1 \
272    -Dlibrary=shared_library \
273    -Dlinux_fpic=1 \
274    %{?with_system_icu:-Duse_system_icu=1} \
275    %{!?with_system_icu:-Duse_system_icu=0} \
276    %ifarch %{ix86}
277        -Dtarget_arch=ia32 \
278         -Ddisable_sse2=1 \
279    %endif
280    %ifarch x86_64
281        -Dtarget_arch=x64 \
282    %endif
283    %if %{?_dist_release} == "vl6"
284        -Dno_strict_aliasing=1 -Dgcc_version=44 \
285    %endif
286    -Drelease_extra_cflags=-fPIC \
287    ;
288
289#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
290#%__make -r -j5 chrome BUILDTYPE=Release
291%__make %{?_smp_mflags} chrome BUILDTYPE=Release
292
293popd
294
295%install
296%{__rm} -rf %{buildroot}
297
298%__mkdir -p %{buildroot}%{_bindir}
299%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
300# x86_64 capable systems need this
301%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
302%__mkdir -p %{buildroot}%{_libdir}/chromium/
303%__mkdir -p %{buildroot}%{_mandir}/man1/
304pushd src/out/Release
305%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
306%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
307%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
308%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
309%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
310#%__cp -a chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
311%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
312%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
313%if %{?_dist_release} == "vl6"
314fdupes %{buildroot}%{_mandir}/man1/
315%endif
316popd
317
318# devel package install
319mkdir -p %{buildroot}%{_libdir}/chromium/include
320pushd src
321find base -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
322find app -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
323find chrome -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
324find skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
325find build -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
326find googleurl -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
327find ipc -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
328find testing -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
329find net -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
330find third_party/skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
331find third_party/WebKit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
332find webkit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
333find gfx -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
334popd
335find %{buildroot}%{_libdir}/chromium/include -name "*.h" -exec chmod 644 {} \;
336%if %{?_dist_release} == "vl6"
337fdupes %{buildroot}%{_libdir}/chromium/include
338%endif
339
340%__mkdir_p %{buildroot}/%{_libdir}/pkgconfig
341cat <<! > %{buildroot}/%{_libdir}/pkgconfig/chromium-browser.pc
342Name: Chromium browser
343Description: Chromium browser development package
344Version: 1.0.1
345Libs: -L%{_libdir}/chromium -lapp_base -lappcache -lbase_i18n -lbase -lblob -lbrowser -lcacheinvalidation -lchrome_gpu -lchromoting_base -lchromoting_client -lchromoting_host -lchromoting_jingle_glue -lchromotocol_proto_lib -lcld -lcommon_constants -lcommon_net -lcommon -ldatabase -ldebugger -ldefault_plugin -ldynamic_annotations -lffmpeg -lfileapi -lgfx -lglue -lgoogleurl -lgtest -lharfbuzz_interface -lharfbuzz -lhttp_listen_socket -lhunspell -lil -linstaller_util -lipc -ljingle_p2p -ljingle -lmedia -lmodp_b64 -lnet_base -lnet -lnotifier -lomx_wrapper -lots -lpcre -lplugin -lprinting -lprofile_import -lprotobuf_lite -lprotobuf -lrenderer -lsandbox -lsdch -lservice -lskia_opts -lskia -lspeex -lsqlite3 -lsrtp -lssl -lsymbolize -lsyncapi -lsync_notifier -lsync -ltrace_proto_lib -lutility -lwebcore_bindings -lwebcore_platform -lwebcore_remaining -lwebcore_svg -lwebkit_user_agent -lworker -lwtf -lxdg_mime -lzlib
346Cflags: -I%{_libdir}/chromium/include -I%{_libdir}/chromium/include/skia/config
347!
348
349%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
350%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
351
352%__mkdir_p %{buildroot}%{_datadir}/applications/
353desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
354
355%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
356%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
357
358# # link to browser plugin path.  Plugin patch doesn't work. Why?
359# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
360# pushd %{buildroot}%{_libdir}/%{name}
361# %{__ln_s} %{_libdir}/browser-plugins plugins
362# popd
363pushd %{buildroot}%{_libdir}/%{name}
364%ifarch x86_64
365%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
366%else
367%{__ln_s} %{_libdir}/mozilla/plugins plugins
368%endif
369
370## support ffmpeg libs
371touch %{buildroot}%{_libdir}/libavcodec.so.52
372%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
373touch %{buildroot}%{_libdir}/libavformat.so.52
374%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
375touch %{buildroot}%{_libdir}/libavutil.so.50
376%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
377popd
378
379# Install the master_preferences file
380%__mkdir_p %{buildroot}%{_sysconfdir}/%{name}
381#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
382%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
383#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{name}
384
385%clean
386%{__rm} -rf %{buildroot}
387
388
389%files
390%defattr(-,root,root,-)
391%config %{_sysconfdir}/%{name}
392%dir /usr/share/gnome-control-center
393%dir /usr/share/gnome-control-center/default-apps
394%{_bindir}/chromium
395%{_libdir}/chromium/chromium
396# These unique permissions are intentional and necessary for the sandboxing
397#%attr(4555, root, root) %{_libdir}/chromium/chrome-sandbox
398%{_libdir}/chromium/plugins/
399%{_libdir}/chromium/resources/
400%{_libdir}/chromium/xdg-settings
401%{_mandir}/man1/chrom*
402%{_datadir}/pixmaps/chromium-browser.png
403%{_datadir}/applications/*.desktop
404%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
405%{_libdir}/chromium/libavcodec.so.52
406%{_libdir}/chromium/libavutil.so.50
407%{_libdir}/chromium/libavformat.so.52
408%exclude %{_libdir}/libavcodec.so.52
409%exclude %{_libdir}/libavutil.so.50
410%exclude %{_libdir}/libavformat.so.52
411## libs
412%dir %{_libdir}/chromium/
413%{_libdir}/chromium/chrome.pak
414%{_libdir}/chromium/resources.pak
415%{_libdir}/chromium/locales/
416%{_libdir}/chromium/lib*.so
417
418%files devel
419%defattr(-,root,root,-)
420%{_libdir}/chromium/include/
421%_libdir/pkgconfig/chromium-browser.pc
422
423%changelog
424* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
425- updated to snapshot 8.0.556
426
427* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
428- updated to snapshot 8.0.551
429
430* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
431- updated to snapshot 7.0.527
432
433* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
434- updated to snapshot 7.0.519
435
436* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
437- updated to snapshot 7.0.513
438  - updated chromium-vendor-vine.patch.in
439
440* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
441- updated to snapshot 7.0.507
442
443* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
444- updated to snapshot 7.0.498
445
446* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
447- updated to snapshot 6.0.493
448- used with_system_icu (for vl6)
449  - added BuildRequires: libicu-devel
450
451* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
452- build for Vine Linux 5.x
453  - add BuildRequires: gnome-keyring-devel
454
455* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
456- updated to snapshot 6.0.454
457- added BuildRequires:
458  - sqlite3-devel
459  - gnutls-devel
460  - libgnome-keyring-devel
461
462* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
463- updated to snapshot 6.0.431.0 r49253
464- added BuildRequires: cups-devel
465
466* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
467- updated to snapshot 6.0.405.0 r47263
468
469* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
470- unused with_system_icu (for vl6)
471  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
472
473* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
474- updated to snapshot 5.0.378.0 r44472
475  - used with_system_icu (for vl6)
476  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
477
478* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
479- updated to snapshot 5.0.372.0 r43947
480- added BuildRequires: glew-devel
481- changed Group tag to Applications/Internet
482- added Summary(ja) and %%description -l ja
483
484* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
485- updated to snapshot 5.0.365.0 r42966
486- merged 5.0.353.0-4vl5
487 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
488 - build on Vine Linux 5.1
489   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
490
491* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
492- updated to snapshot 5.0.364.0 r42779
493
494* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
495- updated to snapshot 5.0.359.0 r42116
496- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
497
498* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
499- fixed master_preferences.vine, little
500
501* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
502- fixed to install master_preferences
503- dropped chromium-5.0.353-no-ffmpeg-vine.patch
504
505* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
506- applied chromium-5.0.353-no-ffmpeg-vine.patch
507
508* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
509- updated to snapshot 5.0.353.0 r41449
510  * Wed Mar 10 2010 bgmerrell@novell.com
511  - Add master_preferences source file and install it to /etc/chromium.
512  - Create a new patch (chromium-master-prefs-path.patch) which tells
513    chromium to look in /etc/chromium for the master_preferences file
514    (instead of looking in the default directory, which is the same
515    directory as the 'chrome' binary).
516
517* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
518- updated to snapshot 5.0.335.0 r39556
519
520* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
521- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
522
523* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
524- updated to snapshot 5.0.330.0 r39074
525
526* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
527- use_system_ffmpeg
528
529* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
530- added Requires:  nspluginwrapper
531- fixed a symbolic link of plugins directory with nspluginwrapper
532
533* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
534- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
535
536* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
537- added BuildRequires: mesa-libGLU-devel
538- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
539
540* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
541- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
542
543  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
544  - Update to 4.0.260
545  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
546  - Update to 4.0.259
547  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
548  - Update to 4.0.258
549  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
550  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
551    changed to having an built-in v8
552  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
553  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
554  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
555  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
556  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
557  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
558  - update to newer svn snapshot
559    + Obsoletes fwrite patch (included upstream)
560  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
561  - update to newer svn snapshot
562    + Requires newer version of v8
563  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
564  - do not force SSE on x86 (drop-sse.patch)
565  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
566  - Update to newer svn snapshot
567  - Fixed spec file in order to build
568  - Included patch to build with system zlib
569  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
570  - package renamed to chromium
571  - cleaned up spec file
572  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
573  - v8 is now built as a separate package, and is required
574  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
575  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
576  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
577  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
578  - initial build
579
580#% changelog
581* Sun Jan 24 2010 prusnak@suse.cz
582- added vendor to user agent (chromium-vendor.patch.in)
583* Sun Nov 29 2009 prusnak@suse.cz
584- added --enable-sync to wrapper to enable bookmark sync
585* Fri Nov 13 2009 tittiatcoke@gmail.com
586- update to 247.0 svn 31928
587* Fri Oct 30 2009 tittiatcoke@gmail.com
588- update to 229.0 svn 30454
589  + Fix regression where popups and app frames lost their titlebars.
590  + Makes it so that when a folder is open on the bookmark bar
591    and the mouse moves over another folder, the menu for that
592    folder is shown.
593  + Lazily create the find bar.
594  + Polish to the gmail checker sample.
595  * New, crisper icons that are exactly 19x19
596  * Add a loading animation at the beginning before Gmail
597    responds.
598  * Fix a bug where we sometimes don't update the UI after a
599    logout/login cycle.
600  + Refactor widget methods to support desktop notifications,
601    including GTK stubs.
602  + Find-in-page should not ding while deleting characters.
603  + Add SSL wrapper for linux and mac.  This allows notifier to
604    use chrome's SSL layer instead of OpenSSL.
605  + Add three of the six extensions to PAC that Internet Explorer supports.
606  + WebSocket support in chromium. (Run with --enable-web-sockets
607    enables WebSocket features.)
608  + Do not allow GTK File Chooser dialogs to return directories.
609  + Fix the notifier SSL layer to make notifications work for
610    Linux Bookmark sync.
611  + linux: don't override mouse selection behavior in omnibox
612* Sun Oct 25 2009 tittiatcoke@gmail.com
613- Update to 224.4 svn 30027
614  + First cut at new page and browser action docs based
615    on new API. Deleted old stuff.
616  + Add suppression for new memory leak caused by WebKit merge 49830:49844
617  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
618  + Minimize dependency of user scripts
619  + Fixup the flip_framer eof-handling semantics now that we have
620    the FIN bit in place
621  + app depends on x11 because of active_window_watcher_x
622  + Adding two images for the new Extension managment UI
623  + Removing hard-coded Chrome Frame output path
624  + Rearrange clipboard code
625  + Fix crash bug when attempting to download a url with unsupported scheme,
626    e.g. 'data:', by 'Alt + Click'
627  + GTK: Change text for extension download UI
628  + Ignore invalid urls on command line
629  + Make dropped tabs animate from where they were dropped.
630  + Make room for the full width of the tab placeholder.
631  + Make tab dragging as smooth as glass.
632  + Remove an annoying NOTIMPLEMNETED
633  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
634  + If we're in the middle of a drag, don't allow the user to middle
635    click to close or right click for the context menu
636  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
637  + Remove +x bit from files that shouldn't have it
638  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
639  + Adding new image needed for the managment UI
640  + Fix a race bug where content scripts would not apply to the first page load
641  + Make escape remove a bookmark if it's just been added (but not if it already existed)
642  + Fix bubbles deactivating the opaque frame
643  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
644  + ake all pepper plugins default to windowless and transparent
645  + Add styles for printing
646  + Implement the new extension management UI
647  + Add support for to automation interface load install and load extensions
648  + GTK: theme the info bar border
649  + Update V8 to version 1.3.16.1
650  + Introduce WebSecurityPolicy for security related methods
651  + New button scheme...borders are separate from the inner contents so
652    that they can be highlighted / depressed independently
653  + When opening Chrome maximized with an application window already
654    running, the Chrome window was not activated
655  + Fix compatibility problems with FileZilla FTP Server
656  + Remove the extension shelf on Linux
657  + Fix the proxy host and port string to start with http:// if it does not already
658  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.