source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 1394

Revision 1394, 20.6 KB checked in by munepi, 14 years ago (diff)

updated chromium-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8#% define with_system_icu 1
9%endif
10
11%define svn_rev 51404
12
13Name:           chromium
14Summary:        Google's opens source browser project
15Summary(ja):    Googleのオープンソースウェブブラウザ
16#'
17Version:        6.0.454.0
18Release:        1%{?_dist_release}
19License:        BSD
20Group:          Applications/Internet
21Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
22## The following are included for source reasons only
23# Custom build tools for chromium, hammer is a fancy front-end for scons
24Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
25%{?nosrc:NoSource: 0}
26%{?nosrc:NoSource: 1}
27# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
28Source2:        repack_chromium_archive.sh
29# Script used to create the tar.lzma archive from a checked out source
30#Source3:        pack_chromium_source.sh
31Source3:        pack_chromium_source-vine.sh
32#Source10:       chromium.desktop
33Source10:       chromium-vine.desktop
34# Patch template which adds vendor to user agent
35##!!Source20:       chromium-vendor.patch.in
36Source20:       chromium-vendor-vine.patch.in
37##!!Source30:       master_preferences
38Source30:       master_preferences.vine
39#Source31:       default_bookmarks.html
40#Source31:       default_bookmarks.html.vine
41# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
42Source100:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
43Provides:       chromium-browser = %{version}
44#Obsoletes:      chromium-browser < %{version}
45
46## Start Patches
47# Many changes to the gyp system so we can use system libraries
48# My first ever patch set.  I hope I did well.
49Patch3:         chromium-gyp-system-icu.patch
50Patch4:         chromium-no-sqlite-debug.patch
51Patch5:         chromium-gyp-system-04-nss-nspr.patch
52Patch7:         chromium-codechanges-nss-nspr.patch
53Patch8:         chromium-codechanges-zlib.patch
54#Patch9:         chromium-drop-sse.patch
55Patch10:        chromium-fix-wrapper.patch
56Patch12:        chromium-no-test-sources.patch
57Patch13:        chromium-no-courgette.patch
58Patch14:        chromium-master-prefs-path.patch
59#Patch15:        chromium-media-probe.patch
60Patch16:        chromium-icu-code-changes.patch
61Patch17:        chromium-system-glew.patch
62Patch18:        chromium-system-expat.patch
63Patch19:        chromium-system-zlib.patch
64Patch20:        chromium-noffmpeg.patch
65Patch21:        chromium-system-old-ffmpeg-way.patch
66Patch23:        chromium-disable-mmx.patch
67Patch24:        chromium-fix-yuv_row_posix-shared.patch
68Patch25:        tcmalloc-factory.patch
69
70# Vine
71#Patch40:       chromium-5.0.353-no-ffmpeg-vine.patch
72
73## Gentoo patches
74# Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
75#Patch50: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
76
77BuildRequires:  gcc gcc-c++
78%if %{?_dist_release} == "vl5"
79BuildRequires:  libstdc++34 libstdc++34-devel
80%elseif %{?_dist_release} == "vl6"
81BuildRequires:  libstdc++ libstdc++-devel
82%endif
83BuildRequires:  libevent
84##!!BuildRequires:  pkg-config
85BuildRequires:  python
86##!!BuildRequires:  python-xml
87BuildRequires:  python-pyxml
88BuildRequires:  perl bison flex gperf
89##!!BuildRequires:  wdiff
90##!!BuildRequires:  update-desktop-files
91BuildRequires:  desktop-file-utils
92BuildRequires:  lzma
93##!!BuildRequires:  mozilla-nss-devel
94BuildRequires:  nss-devel
95##!!BuildRequires:  alsa-devel
96BuildRequires:  alsa-lib-devel
97BuildRequires:  gtk2-devel
98BuildRequires:  glib2-devel
99BuildRequires:  cairo-devel >= 1.6
100##!!BuildRequires:  mozilla-nspr-devel
101BuildRequires:  nspr-devel
102##!!BuildRequires:  gconf2-devel
103BuildRequires:  GConf2-devel
104BuildRequires:  freetype2-devel
105##!!BuildRequires:  dbus-1-devel
106BuildRequires:  dbus-devel
107BuildRequires:  libxslt-devel
108BuildRequires:  libxml2-devel
109BuildRequires:  libjpeg-devel
110BuildRequires:  zlib-devel
111##!!BuildRequires:  libbz2-devel
112BuildRequires:  bzip2-devel
113BuildRequires:  cups-devel
114%if %{?_dist_release} == "vl6"
115BuildRequires:  fdupes
116%endif
117##!!BuildRequires:  libexpat-devel
118BuildRequires:  expat-devel
119BuildRequires:  libpng-devel
120BuildRequires:  sqlite3-devel
121BuildRequires:  gnutls-devel
122BuildRequires:  libgnome-keyring-devel
123BuildRequires:  glew-devel
124##!!BuildRequires:  Mesa-devel
125BuildRequires:  mesa-libGLU-devel
126
127%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
128BuildRequires:  libevent-devel
129
130##Vine Linux
131BuildRequires:  libXScrnSaver-devel
132#BuildRequires:  gle-devel
133#BuildRequires:  webkit-gtk-devel
134#BuildRequires:  scons
135%ifarch x86_64
136Requires:  nspluginwrapper
137%endif
138
139##!!Requires:       alsa
140Requires:       alsa-lib
141# shouldn't be required to name all dependencies
142# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
143## Recommends the ffmpeg libraries (available from packman)
144#Recommends:     libavcodec52 libavformat52 libavutil50
145
146BuildRoot:      %{_tmppath}/%{name}-%{version}-root
147
148%description
149Chromium is the open-source project behind Google Chrome.
150We invite you to join us in our effort to help build a safer, faster,
151and more stable way for all Internet users to experience the web,
152and to create a powerful platform for developing a new generation of
153web applications.
154
155%description -l ja
156Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
157私たちは、ウェブを体験しているすべてのインターネットユーザに対して
158より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
159ウェブアプリケーションの新しい世代を発展させるように
160強力なプラットホームを作成するために、
161私たちの取り組みで私たちに加わるようにあなたを誘います。
162
163
164%prep
165[ -d %{name} ] && %__rm -rf %{name}
166lzma -cd %{SOURCE0} | tar xf -
167%setup -D -T -n %{name}
168
169# use static libicu
170#%if %{?_dist_release} == "vl5"
171cd src/third_party || exit 1
172    %__rm -rf icu || exit 1
173    tar jxvf %{SOURCE100} || exit 1
174    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
175cd - || exit 1
176#%endif
177
178# use system libicu only if >= 4.0
179%{?with_system_icu:%patch3 -p1}
180
181%patch4 -p1
182%patch5 -p1
183%patch7 -p1
184%patch8 -p1
185#%patch9 -p1
186%patch10 -p1
187#%patch11 -p1
188%patch12 -p1
189%patch13 -p1
190%patch14 -p1
191#%patch15 -p0
192%{?with_system_icu:%patch16 -p1}
193%patch17 -p1
194%patch18 -p1
195%patch19 -p1
196%patch20 -p1
197%patch21 -p1
198#%patch22 -p1
199%patch25 -p1
200%ifarch %ix86
201%patch23 -p1
202%endif
203%patch24 -p1
204
205
206# apply vendor patch after substitution
207%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
208
209%build
210## create make files
211
212PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
213for i in src/build/common.gypi; do
214        %__sed -i "s|'-march=pentium4',||g" $i
215        %__sed -i "s|'-msse2',||g" $i
216        %__sed -i "s|'-mfpmath=sse',||g" $i
217        %__sed -i "s|'-O<(debug_optimize)',||g" $i
218        %__sed -i "s|'-m32',||g" $i
219        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
220        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
221done
222# '
223
224pushd src
225
226./build/gyp_chromium -f make build/all.gyp \
227    -Duse_system_ffmpeg=1 \
228    -Duse_system_zlib=1 \
229    -Duse_system_libpng=1 \
230    -Duse_system_bzip2=1 \
231    -Duse_system_libbz2=1 \
232    -Duse_system_libjpeg=1 \
233    -Duse_system_libxml=1 \
234    -Duse_system_libxslt=1 \
235    -Duse_system_libevent=1 \
236    -Dproprietary_codecs=1 \
237    -Dlinux_fpic=1 \
238    %{?with_system_icu:-Duse_system_icu=1} \
239    %{!?with_system_icu:-Duse_system_icu=0} \
240    %ifarch %{ix86}
241        -Dtarget_arch=ia32 \
242         -Ddisable_sse2=1 \
243    %endif
244    %ifarch x86_64
245        -Dtarget_arch=x64 \
246    %endif
247    %if %{?_dist_release} == "vl6"
248        -Dno_strict_aliasing=1 -Dgcc_version=44 \
249    %endif
250    -Drelease_extra_cflags=-fPIC \
251    ;
252
253#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
254#%__make -r -j5 chrome BUILDTYPE=Release
255%__make %{?_smp_mflags} chrome BUILDTYPE=Release
256
257popd
258
259%install
260%{__rm} -rf %{buildroot}
261
262## Create install directories
263%{__mkdir_p} %{buildroot}%{_libdir}/%{name}
264%{__mkdir_p} %{buildroot}%{_bindir}
265%{__mkdir_p} %{buildroot}%{_datadir}/applications
266%{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
267%{__mkdir_p} %{buildroot}%{_mandir}/man1
268%{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
269
270# chromium 'make' deposits us back at the top level build directory
271pushd src/out/Release
272ls -l
273
274# clean somechromium-codechanges-zlib.patch
275# clean debug junk
276%{__rm} -rf obj/ mksnapshot obj.target obj.host
277find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
278# clean NaCl stuff...  maybe NaCl will be in its own package in the future.
279%{__rm} -f ncdecode_table ncdecode_tablegen
280# clean other temporary binaries used in the compilation of chromium
281%{__rm} -f protoc xdg-settings
282
283%{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
284
285# Man page
286[ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
287%__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
288
289# Add startup file with plugins enabled
290%{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
291#!/bin/bash
292%{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
293EOF
294
295# # link to browser plugin path.  Plugin patch doesn't work. Why?
296# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
297# pushd %{buildroot}%{_libdir}/%{name}
298# %{__ln_s} %{_libdir}/browser-plugins plugins
299# popd
300pushd %{buildroot}%{_libdir}/%{name}
301%ifarch x86_64
302%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
303%else
304%{__ln_s} %{_libdir}/mozilla/plugins plugins
305%endif
306
307#touch %{buildroot}%{_libdir}/libavcodec.so.52
308#%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
309#touch %{buildroot}%{_libdir}/libavformat.so.52
310#%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
311#touch %{buildroot}%{_libdir}/libavutil.so.50
312#%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
313popd
314
315# Install desktop-related files
316%__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
317%__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
318desktop-file-install --vendor Vine                      \
319        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
320        --delete-original                               \
321        --mode 644                                      \
322        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
323
324# Install the master_preferences file
325#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
326%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
327
328## install o3d plugin
329#pushd src/o3d/build/out/Release
330#%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
331
332%clean
333%{__rm} -rf %{buildroot}
334
335
336%files
337%defattr(-,root,root)
338%doc src/AUTHORS src/LICENSE
339%dir %{_libdir}/%{name}
340%attr(0755,root,root) %{_bindir}/%{name}
341%{_mandir}/man1/*
342%{_datadir}/applications/*%{name}.desktop
343%{_datadir}/pixmaps/%{name}.png
344%{_libdir}/%{name}/*
345%config %{_sysconfdir}/%{name}
346#%{_libdir}/browser-plugins/*
347#%exclude %{_libdir}/libavcodec.so.52
348#%exclude %{_libdir}/libavutil.so.50
349#%exclude %{_libdir}/libavformat.so.52
350
351%changelog
352* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
353- updated to snapshot 6.0.454
354- added BuildRequires:
355  - sqlite3-devel
356  - gnutls-devel
357  - libgnome-keyring-devel
358
359* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
360- updated to snapshot 6.0.431.0 r49253
361- added BuildRequires: cups-devel
362
363* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
364- updated to snapshot 6.0.405.0 r47263
365
366* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
367- unused with_system_icu (for vl6)
368  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
369
370* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
371- updated to snapshot 5.0.378.0 r44472
372  - used with_system_icu (for vl6)
373  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
374
375* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
376- updated to snapshot 5.0.372.0 r43947
377- added BuildRequires: glew-devel
378- changed Group tag to Applications/Internet
379- added Summary(ja) and %%description -l ja
380
381* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
382- updated to snapshot 5.0.365.0 r42966
383- merged 5.0.353.0-4vl5
384 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
385 - build on Vine Linux 5.1
386   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
387
388* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
389- updated to snapshot 5.0.364.0 r42779
390
391* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
392- updated to snapshot 5.0.359.0 r42116
393- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
394
395* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
396- fixed master_preferences.vine, little
397
398* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
399- fixed to install master_preferences
400- dropped chromium-5.0.353-no-ffmpeg-vine.patch
401
402* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
403- applied chromium-5.0.353-no-ffmpeg-vine.patch
404
405* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
406- updated to snapshot 5.0.353.0 r41449
407  * Wed Mar 10 2010 bgmerrell@novell.com
408  - Add master_preferences source file and install it to /etc/chromium.
409  - Create a new patch (chromium-master-prefs-path.patch) which tells
410    chromium to look in /etc/chromium for the master_preferences file
411    (instead of looking in the default directory, which is the same
412    directory as the 'chrome' binary).
413
414* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
415- updated to snapshot 5.0.335.0 r39556
416
417* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
418- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
419
420* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
421- updated to snapshot 5.0.330.0 r39074
422
423* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
424- use_system_ffmpeg
425
426* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
427- added Requires:  nspluginwrapper
428- fixed a symbolic link of plugins directory with nspluginwrapper
429
430* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
431- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
432
433* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
434- added BuildRequires: mesa-libGLU-devel
435- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
436
437* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
438- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
439
440  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
441  - Update to 4.0.260
442  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
443  - Update to 4.0.259
444  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
445  - Update to 4.0.258
446  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
447  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
448    changed to having an built-in v8
449  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
450  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
451  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
452  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
453  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
454  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
455  - update to newer svn snapshot
456    + Obsoletes fwrite patch (included upstream)
457  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
458  - update to newer svn snapshot
459    + Requires newer version of v8
460  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
461  - do not force SSE on x86 (drop-sse.patch)
462  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
463  - Update to newer svn snapshot
464  - Fixed spec file in order to build
465  - Included patch to build with system zlib
466  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
467  - package renamed to chromium
468  - cleaned up spec file
469  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
470  - v8 is now built as a separate package, and is required
471  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
472  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
473  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
474  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
475  - initial build
476
477#% changelog
478* Sun Jan 24 2010 prusnak@suse.cz
479- added vendor to user agent (chromium-vendor.patch.in)
480* Sun Nov 29 2009 prusnak@suse.cz
481- added --enable-sync to wrapper to enable bookmark sync
482* Fri Nov 13 2009 tittiatcoke@gmail.com
483- update to 247.0 svn 31928
484* Fri Oct 30 2009 tittiatcoke@gmail.com
485- update to 229.0 svn 30454
486  + Fix regression where popups and app frames lost their titlebars.
487  + Makes it so that when a folder is open on the bookmark bar
488    and the mouse moves over another folder, the menu for that
489    folder is shown.
490  + Lazily create the find bar.
491  + Polish to the gmail checker sample.
492  * New, crisper icons that are exactly 19x19
493  * Add a loading animation at the beginning before Gmail
494    responds.
495  * Fix a bug where we sometimes don't update the UI after a
496    logout/login cycle.
497  + Refactor widget methods to support desktop notifications,
498    including GTK stubs.
499  + Find-in-page should not ding while deleting characters.
500  + Add SSL wrapper for linux and mac.  This allows notifier to
501    use chrome's SSL layer instead of OpenSSL.
502  + Add three of the six extensions to PAC that Internet Explorer supports.
503  + WebSocket support in chromium. (Run with --enable-web-sockets
504    enables WebSocket features.)
505  + Do not allow GTK File Chooser dialogs to return directories.
506  + Fix the notifier SSL layer to make notifications work for
507    Linux Bookmark sync.
508  + linux: don't override mouse selection behavior in omnibox
509* Sun Oct 25 2009 tittiatcoke@gmail.com
510- Update to 224.4 svn 30027
511  + First cut at new page and browser action docs based
512    on new API. Deleted old stuff.
513  + Add suppression for new memory leak caused by WebKit merge 49830:49844
514  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
515  + Minimize dependency of user scripts
516  + Fixup the flip_framer eof-handling semantics now that we have
517    the FIN bit in place
518  + app depends on x11 because of active_window_watcher_x
519  + Adding two images for the new Extension managment UI
520  + Removing hard-coded Chrome Frame output path
521  + Rearrange clipboard code
522  + Fix crash bug when attempting to download a url with unsupported scheme,
523    e.g. 'data:', by 'Alt + Click'
524  + GTK: Change text for extension download UI
525  + Ignore invalid urls on command line
526  + Make dropped tabs animate from where they were dropped.
527  + Make room for the full width of the tab placeholder.
528  + Make tab dragging as smooth as glass.
529  + Remove an annoying NOTIMPLEMNETED
530  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
531  + If we're in the middle of a drag, don't allow the user to middle
532    click to close or right click for the context menu
533  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
534  + Remove +x bit from files that shouldn't have it
535  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
536  + Adding new image needed for the managment UI
537  + Fix a race bug where content scripts would not apply to the first page load
538  + Make escape remove a bookmark if it's just been added (but not if it already existed)
539  + Fix bubbles deactivating the opaque frame
540  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
541  + ake all pepper plugins default to windowless and transparent
542  + Add styles for printing
543  + Implement the new extension management UI
544  + Add support for to automation interface load install and load extensions
545  + GTK: theme the info bar border
546  + Update V8 to version 1.3.16.1
547  + Introduce WebSecurityPolicy for security related methods
548  + New button scheme...borders are separate from the inner contents so
549    that they can be highlighted / depressed independently
550  + When opening Chrome maximized with an application window already
551    running, the Chrome window was not activated
552  + Fix compatibility problems with FileZilla FTP Server
553  + Remove the extension shelf on Linux
554  + Fix the proxy host and port string to start with http:// if it does not already
555  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.