source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 1196

Revision 1196, 20.3 KB checked in by munepi, 14 years ago (diff)

updated chromium-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8#% define with_system_icu 1
9%endif
10
11%define svn_rev 49253
12
13Name:           chromium
14Summary:        Google's opens source browser project
15Summary(ja):    Googleのオープンソースウェブブラウザ
16#'
17Version:        6.0.431.0
18Release:        1%{?_dist_release}
19License:        BSD
20Group:          Applications/Internet
21Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
22## The following are included for source reasons only
23# Custom build tools for chromium, hammer is a fancy front-end for scons
24Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
25%{?nosrc:NoSource: 0}
26%{?nosrc:NoSource: 1}
27# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
28Source2:        repack_chromium_archive.sh
29# Script used to create the tar.lzma archive from a checked out source
30#Source3:        pack_chromium_source.sh
31Source3:        pack_chromium_source-vine.sh
32#Source10:       chromium.desktop
33Source10:       chromium-vine.desktop
34# Patch template which adds vendor to user agent
35##!!Source20:       chromium-vendor.patch.in
36Source20:       chromium-vendor-vine.patch.in
37##!!Source30:       master_preferences
38Source30:       master_preferences.vine
39#Source31:       default_bookmarks.html
40#Source31:       default_bookmarks.html.vine
41# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
42Source100:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
43Provides:       chromium-browser = %{version}
44#Obsoletes:      chromium-browser < %{version}
45
46## Start Patches
47# Many changes to the gyp system so we can use system libraries
48# My first ever patch set.  I hope I did well.
49Patch3:         chromium-gyp-system-icu.patch
50Patch4:         chromium-no-sqlite-debug.patch
51Patch5:         chromium-gyp-system-04-nss-nspr.patch
52Patch7:         chromium-codechanges-nss-nspr.patch
53Patch8:         chromium-codechanges-zlib.patch
54#Patch9:         chromium-drop-sse.patch
55Patch10:        chromium-fix-wrapper.patch
56Patch12:        chromium-no-test-sources.patch
57Patch13:        chromium-no-courgette.patch
58Patch14:        chromium-master-prefs-path.patch
59#Patch15:        chromium-media-probe.patch
60Patch16:        chromium-icu-code-changes.patch
61Patch17:        chromium-system-glew.patch
62Patch18:        chromium-system-expat.patch
63Patch19:        chromium-system-zlib.patch
64Patch20:        chromium-noffmpeg.patch
65Patch21:        chromium-system-old-ffmpeg-way.patch
66Patch23:        chromium-disable-mmx.patch
67Patch24:        chromium-fix-yuv_row_posix-shared.patch
68Patch25:        tcmalloc-factory.patch
69
70# Vine
71#Patch40:       chromium-5.0.353-no-ffmpeg-vine.patch
72
73## Gentoo patches
74# Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
75#Patch50: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
76
77BuildRequires:  gcc gcc-c++
78%if %{?_dist_release} == "vl5"
79BuildRequires:  libstdc++34 libstdc++34-devel
80%elseif %{?_dist_release} == "vl6"
81BuildRequires:  libstdc++ libstdc++-devel
82%endif
83BuildRequires:  libevent
84##!!BuildRequires:  pkg-config
85BuildRequires:  python
86##!!BuildRequires:  python-xml
87BuildRequires:  python-pyxml
88BuildRequires:  perl bison flex gperf
89##!!BuildRequires:  wdiff
90##!!BuildRequires:  update-desktop-files
91BuildRequires:  desktop-file-utils
92BuildRequires:  lzma
93##!!BuildRequires:  mozilla-nss-devel
94BuildRequires:  nss-devel
95##!!BuildRequires:  alsa-devel
96BuildRequires:  alsa-lib-devel
97BuildRequires:  gtk2-devel
98BuildRequires:  glib2-devel
99BuildRequires:  cairo-devel >= 1.6
100##!!BuildRequires:  mozilla-nspr-devel
101BuildRequires:  nspr-devel
102##!!BuildRequires:  gconf2-devel
103BuildRequires:  GConf2-devel
104BuildRequires:  freetype2-devel
105##!!BuildRequires:  dbus-1-devel
106BuildRequires:  dbus-devel
107BuildRequires:  libxslt-devel
108BuildRequires:  libxml2-devel
109BuildRequires:  libjpeg-devel
110BuildRequires:  zlib-devel
111BuildRequires:  libpng-devel
112##!!BuildRequires:  libbz2-devel
113BuildRequires:  bzip2-devel
114BuildRequires:  cups-devel
115%if %{?_dist_release} == "vl6"
116BuildRequires:  fdupes
117%endif
118##!!BuildRequires:  libexpat-devel
119BuildRequires:  expat-devel
120BuildRequires:  glew-devel
121##!!BuildRequires:  Mesa-devel
122BuildRequires:  mesa-libGLU-devel
123
124%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
125BuildRequires:  libevent-devel
126
127##Vine Linux
128BuildRequires:  libXScrnSaver-devel
129#BuildRequires:  gle-devel
130#BuildRequires:  webkit-gtk-devel
131#BuildRequires:  scons
132%ifarch x86_64
133Requires:  nspluginwrapper
134%endif
135
136##!!Requires:       alsa
137Requires:       alsa-lib
138# shouldn't be required to name all dependencies
139# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
140## Recommends the ffmpeg libraries (available from packman)
141#Recommends:     libavcodec52 libavformat52 libavutil50
142
143BuildRoot:      %{_tmppath}/%{name}-%{version}-root
144
145%description
146Chromium is the open-source project behind Google Chrome.
147We invite you to join us in our effort to help build a safer, faster,
148and more stable way for all Internet users to experience the web,
149and to create a powerful platform for developing a new generation of
150web applications.
151
152%description -l ja
153Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
154私たちは、ウェブを体験しているすべてのインターネットユーザに対して
155より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
156ウェブアプリケーションの新しい世代を発展させるように
157強力なプラットホームを作成するために、
158私たちの取り組みで私たちに加わるようにあなたを誘います。
159
160
161%prep
162[ -d %{name} ] && %__rm -rf %{name}
163lzma -cd %{SOURCE0} | tar xf -
164%setup -D -T -n %{name}
165
166# use static libicu
167#%if %{?_dist_release} == "vl5"
168cd src/third_party || exit 1
169    %__rm -rf icu || exit 1
170    tar jxvf %{SOURCE100} || exit 1
171    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
172cd - || exit 1
173#%endif
174
175# use system libicu only if >= 4.0
176%{?with_system_icu:%patch3 -p1}
177
178%patch4 -p1
179%patch5 -p1
180%patch7 -p1
181%patch8 -p1
182#%patch9 -p1
183%patch10 -p1
184#%patch11 -p1
185%patch12 -p1
186%patch13 -p1
187%patch14 -p1
188#%patch15 -p0
189%{?with_system_icu:%patch16 -p1}
190%patch17 -p1
191%patch18 -p1
192%patch19 -p1
193%patch20 -p1
194%patch21 -p1
195#%patch22 -p1
196%patch25 -p1
197%ifarch %ix86
198%patch23 -p1
199%endif
200%patch24 -p1
201
202
203# apply vendor patch after substitution
204%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
205
206%build
207## create make files
208
209PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
210for i in src/build/common.gypi; do
211        %__sed -i "s|'-march=pentium4',||g" $i
212        %__sed -i "s|'-msse2',||g" $i
213        %__sed -i "s|'-mfpmath=sse',||g" $i
214        %__sed -i "s|'-O<(debug_optimize)',||g" $i
215        %__sed -i "s|'-m32',||g" $i
216        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
217        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
218done
219# '
220
221pushd src
222
223./build/gyp_chromium -f make build/all.gyp \
224    -Duse_system_ffmpeg=1 \
225    -Duse_system_zlib=1 \
226    -Duse_system_libpng=1 \
227    -Duse_system_bzip2=1 \
228    -Duse_system_libjpeg=1 \
229    -Duse_system_libxml=1 \
230    -Duse_system_libxslt=1 \
231    -Duse_system_libevent=1 \
232    -Dproprietary_codecs=1 \
233    -Dlinux_fpic=1 \
234    %{?with_system_icu:-Duse_system_icu=1} \
235    %{!?with_system_icu:-Duse_system_icu=0} \
236    %ifarch %{ix86}
237        -Dtarget_arch=ia32 \
238         -Ddisable_sse2=1 \
239    %endif
240    %ifarch x86_64
241        -Dtarget_arch=x64 \
242    %endif
243    %if %{?_dist_release} == "vl6"
244        -Dno_strict_aliasing=1 -Dgcc_version=44 \
245    %endif
246    -Drelease_extra_cflags=-fPIC \
247    ;
248
249#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
250#%__make -r -j5 chrome BUILDTYPE=Release
251%__make %{?_smp_mflags} chrome BUILDTYPE=Release
252
253popd
254
255%install
256%{__rm} -rf %{buildroot}
257
258## Create install directories
259%{__mkdir_p} %{buildroot}%{_libdir}/%{name}
260%{__mkdir_p} %{buildroot}%{_bindir}
261%{__mkdir_p} %{buildroot}%{_datadir}/applications
262%{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
263%{__mkdir_p} %{buildroot}%{_mandir}/man1
264%{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
265
266# chromium 'make' deposits us back at the top level build directory
267pushd src/out/Release
268ls -l
269
270# clean somechromium-codechanges-zlib.patch
271# clean debug junk
272%{__rm} -rf obj/ mksnapshot obj.target obj.host
273find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
274# clean NaCl stuff...  maybe NaCl will be in its own package in the future.
275%{__rm} -f ncdecode_table ncdecode_tablegen
276# clean other temporary binaries used in the compilation of chromium
277%{__rm} -f protoc xdg-settings
278
279%{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
280
281# Man page
282[ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
283%__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
284
285# Add startup file with plugins enabled
286%{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
287#!/bin/bash
288%{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
289EOF
290
291# # link to browser plugin path.  Plugin patch doesn't work. Why?
292# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
293# pushd %{buildroot}%{_libdir}/%{name}
294# %{__ln_s} %{_libdir}/browser-plugins plugins
295# popd
296pushd %{buildroot}%{_libdir}/%{name}
297%ifarch x86_64
298%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
299%else
300%{__ln_s} %{_libdir}/mozilla/plugins plugins
301%endif
302
303#touch %{buildroot}%{_libdir}/libavcodec.so.52
304#%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
305#touch %{buildroot}%{_libdir}/libavformat.so.52
306#%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
307#touch %{buildroot}%{_libdir}/libavutil.so.50
308#%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
309popd
310
311# Install desktop-related files
312%__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
313%__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
314desktop-file-install --vendor Vine                      \
315        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
316        --delete-original                               \
317        --mode 644                                      \
318        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
319
320# Install the master_preferences file
321#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
322%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
323
324## install o3d plugin
325#pushd src/o3d/build/out/Release
326#%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
327
328%clean
329%{__rm} -rf %{buildroot}
330
331
332%files
333%defattr(-,root,root)
334%doc src/AUTHORS src/LICENSE
335%dir %{_libdir}/%{name}
336%attr(0755,root,root) %{_bindir}/%{name}
337%{_mandir}/man1/*
338%{_datadir}/applications/*%{name}.desktop
339%{_datadir}/pixmaps/%{name}.png
340%{_libdir}/%{name}/*
341%config %{_sysconfdir}/%{name}
342#%{_libdir}/browser-plugins/*
343#%exclude %{_libdir}/libavcodec.so.52
344#%exclude %{_libdir}/libavutil.so.50
345#%exclude %{_libdir}/libavformat.so.52
346
347%changelog
348* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
349- updated to snapshot 6.0.431.0 r49253
350- added BuildRequires: cups-devel
351
352* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
353- updated to snapshot 6.0.405.0 r47263
354
355* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
356- unused with_system_icu (for vl6)
357  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
358
359* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
360- updated to snapshot 5.0.378.0 r44472
361  - used with_system_icu (for vl6)
362  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
363
364* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
365- updated to snapshot 5.0.372.0 r43947
366- added BuildRequires: glew-devel
367- changed Group tag to Applications/Internet
368- added Summary(ja) and %%description -l ja
369
370* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
371- updated to snapshot 5.0.365.0 r42966
372- merged 5.0.353.0-4vl5
373 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
374 - build on Vine Linux 5.1
375   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
376
377* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
378- updated to snapshot 5.0.364.0 r42779
379
380* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
381- updated to snapshot 5.0.359.0 r42116
382- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
383
384* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
385- fixed master_preferences.vine, little
386
387* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
388- fixed to install master_preferences
389- dropped chromium-5.0.353-no-ffmpeg-vine.patch
390
391* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
392- applied chromium-5.0.353-no-ffmpeg-vine.patch
393
394* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
395- updated to snapshot 5.0.353.0 r41449
396  * Wed Mar 10 2010 bgmerrell@novell.com
397  - Add master_preferences source file and install it to /etc/chromium.
398  - Create a new patch (chromium-master-prefs-path.patch) which tells
399    chromium to look in /etc/chromium for the master_preferences file
400    (instead of looking in the default directory, which is the same
401    directory as the 'chrome' binary).
402
403* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
404- updated to snapshot 5.0.335.0 r39556
405
406* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
407- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
408
409* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
410- updated to snapshot 5.0.330.0 r39074
411
412* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
413- use_system_ffmpeg
414
415* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
416- added Requires:  nspluginwrapper
417- fixed a symbolic link of plugins directory with nspluginwrapper
418
419* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
420- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
421
422* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
423- added BuildRequires: mesa-libGLU-devel
424- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
425
426* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
427- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
428
429  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
430  - Update to 4.0.260
431  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
432  - Update to 4.0.259
433  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
434  - Update to 4.0.258
435  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
436  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
437    changed to having an built-in v8
438  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
439  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
440  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
441  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
442  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
443  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
444  - update to newer svn snapshot
445    + Obsoletes fwrite patch (included upstream)
446  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
447  - update to newer svn snapshot
448    + Requires newer version of v8
449  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
450  - do not force SSE on x86 (drop-sse.patch)
451  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
452  - Update to newer svn snapshot
453  - Fixed spec file in order to build
454  - Included patch to build with system zlib
455  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
456  - package renamed to chromium
457  - cleaned up spec file
458  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
459  - v8 is now built as a separate package, and is required
460  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
461  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
462  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
463  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
464  - initial build
465
466#% changelog
467* Sun Jan 24 2010 prusnak@suse.cz
468- added vendor to user agent (chromium-vendor.patch.in)
469* Sun Nov 29 2009 prusnak@suse.cz
470- added --enable-sync to wrapper to enable bookmark sync
471* Fri Nov 13 2009 tittiatcoke@gmail.com
472- update to 247.0 svn 31928
473* Fri Oct 30 2009 tittiatcoke@gmail.com
474- update to 229.0 svn 30454
475  + Fix regression where popups and app frames lost their titlebars.
476  + Makes it so that when a folder is open on the bookmark bar
477    and the mouse moves over another folder, the menu for that
478    folder is shown.
479  + Lazily create the find bar.
480  + Polish to the gmail checker sample.
481  * New, crisper icons that are exactly 19x19
482  * Add a loading animation at the beginning before Gmail
483    responds.
484  * Fix a bug where we sometimes don't update the UI after a
485    logout/login cycle.
486  + Refactor widget methods to support desktop notifications,
487    including GTK stubs.
488  + Find-in-page should not ding while deleting characters.
489  + Add SSL wrapper for linux and mac.  This allows notifier to
490    use chrome's SSL layer instead of OpenSSL.
491  + Add three of the six extensions to PAC that Internet Explorer supports.
492  + WebSocket support in chromium. (Run with --enable-web-sockets
493    enables WebSocket features.)
494  + Do not allow GTK File Chooser dialogs to return directories.
495  + Fix the notifier SSL layer to make notifications work for
496    Linux Bookmark sync.
497  + linux: don't override mouse selection behavior in omnibox
498* Sun Oct 25 2009 tittiatcoke@gmail.com
499- Update to 224.4 svn 30027
500  + First cut at new page and browser action docs based
501    on new API. Deleted old stuff.
502  + Add suppression for new memory leak caused by WebKit merge 49830:49844
503  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
504  + Minimize dependency of user scripts
505  + Fixup the flip_framer eof-handling semantics now that we have
506    the FIN bit in place
507  + app depends on x11 because of active_window_watcher_x
508  + Adding two images for the new Extension managment UI
509  + Removing hard-coded Chrome Frame output path
510  + Rearrange clipboard code
511  + Fix crash bug when attempting to download a url with unsupported scheme,
512    e.g. 'data:', by 'Alt + Click'
513  + GTK: Change text for extension download UI
514  + Ignore invalid urls on command line
515  + Make dropped tabs animate from where they were dropped.
516  + Make room for the full width of the tab placeholder.
517  + Make tab dragging as smooth as glass.
518  + Remove an annoying NOTIMPLEMNETED
519  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
520  + If we're in the middle of a drag, don't allow the user to middle
521    click to close or right click for the context menu
522  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
523  + Remove +x bit from files that shouldn't have it
524  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
525  + Adding new image needed for the managment UI
526  + Fix a race bug where content scripts would not apply to the first page load
527  + Make escape remove a bookmark if it's just been added (but not if it already existed)
528  + Fix bubbles deactivating the opaque frame
529  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
530  + ake all pepper plugins default to windowless and transparent
531  + Add styles for printing
532  + Implement the new extension management UI
533  + Add support for to automation interface load install and load extensions
534  + GTK: theme the info bar border
535  + Update V8 to version 1.3.16.1
536  + Introduce WebSecurityPolicy for security related methods
537  + New button scheme...borders are separate from the inner contents so
538    that they can be highlighted / depressed independently
539  + When opening Chrome maximized with an application window already
540    running, the Chrome window was not activated
541  + Fix compatibility problems with FileZilla FTP Server
542  + Remove the extension shelf on Linux
543  + Fix the proxy host and port string to start with http:// if it does not already
544  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.