source: projects/specs/trunk/c/choqok/choqok-vl.spec @ 1065

Revision 1065, 4.2 KB checked in by inagaki, 14 years ago (diff)

NEW: choqok

Line 
1Summary: Choqok KDE Micro-Blogging Client
2Summary(ja): KDE マイクロブログクライアント
3Name: choqok
4Version: 0.9.55
5Release: 15%{?_dist_release}
6License: GPLv3
7Group: Applications/Internet
8URL: http://choqok.gnufolks.org/
9Source: http://tejas.fedorapeople.org/choqok-0.9.55.tar.bz2
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: cmake >= 2.6
13BuildRequires: desktop-file-utils
14BuildRequires: kdelibs4-devel
15BuildRequires: gettext
16
17Requires: %{name}-libs = %{version}-%{release}
18
19%description
20A Free/Open Source micro-blogging client for K Desktop Environment.
21The name comes from an ancient Persian word, which means Sparrow!
22Choqok currently supports Twitter.com and Identi.ca services.
23
24%package libs
25Summary: Runtime libraries for %{name}
26Group:   System Environment/Libraries
27# Requires: %{name} = %{version}-%{release}
28# for kwallet, among other goodies
29Requires: kdebase-runtime
30
31%description libs
32%{summary}
33
34%package devel
35Group:    Development/Libraries
36Summary:  Development files for %{name}
37Requires: %{name}-libs = %{version}-%{release}
38Requires: kdelibs4-devel
39
40%description devel
41%{summary}
42
43
44%prep
45%setup -q
46
47%build
48mkdir -p %{_target_platform}
49pushd %{_target_platform}
50unset QTDIR || : ; . /etc/profile.d/qt4.sh
51PATH=$PATH:%{_prefix}/kerberos/bin \
52%cmake \
53    -DCMAKE_BUILD_TYPE=release \
54    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
55    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
56    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
57    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
58    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
59    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
60    ..
61popd
62
63make %{?_smp_mflags} -C %{_target_platform}
64
65%install
66rm -rf %{buildroot}
67
68make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
69
70%find_lang %{name}
71
72%check
73desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/choqok.desktop
74
75%clean
76rm -rf %{buildroot}
77
78%post
79touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
80
81%postun
82if [ $1 -eq 0 ] ; then
83touch --no-create %{_datadir}/icons/hicolor &> /dev/null
84gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
85fi
86
87%posttrans
88gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
89
90
91%files -f %{name}.lang
92%defattr(-,root,root,-)
93%doc COPYING README AUTHORS changelog TODO
94%{_bindir}/choqok
95%{_libdir}/kde4/choqok_*.so
96%{_libdir}/kde4/kcm_choqok_*.so
97%{_datadir}/icons/hicolor/*/actions/retweet.png
98%{_datadir}/icons/hicolor/*/apps/*.png
99%{_datadir}/applications/kde4/choqok.desktop
100%{_datadir}/config.kcfg/*.kcfg
101%{_datadir}/kde4/services/choqok_*.desktop
102%{_datadir}/kde4/apps/choqok
103%{_datadir}/kde4/apps/choqok_*/*.rc
104%{_datadir}/kde4/servicetypes/choqok*.desktop
105
106%files libs
107%defattr(-,root,root,-)
108%{_libdir}/lib*.so.*
109
110%files devel
111%defattr(-,root,root,-)
112%{_includedir}/kde4/choqok
113%{_libdir}/lib*.so
114
115
116%changelog
117* Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.55-15
118- initial build for Vine Linux
119
120* Tue Mar 09 2010 Tejas Dinkar <tejas@gja.in> - 0.9.55-14
121- Add dependency from -libs to choqok
122
123* Tue Mar 09 2010 Rex Dieter <rdieter@fedoraprojecdt.org> - 0.9.55-13
124- Requires: kdebase-runtime (not kdeutils)
125
126* Tue Mar 09 2010 Tejas Dinkar <tejas@gja.in> - 0.9.55-12
127- choqok 1.0-beta
128
129* Wed Sep 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.6.6-9
130- add icon/desktop-file scriptlets
131
132* Sun Aug 16 2009 Tejas Dinkar <tejas@gja.in> - 0.6.6-8
133- Added Dependency on kdeutils
134- Choqok 0.6.6 is out
135
136* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-8
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
138
139* Sun Jun 14 2009 Tejas Dinkar <tejas@gja.in> - 0.6.1-7
140- Choqok 0.6.1 is out with the below two patches
141
142* Sat Jun 13 2009 Tejas Dinkar <tejas@gja.in> - 0.6-6
143- Fixed the inreplyto (via patch)
144
145* Sat Jun 13 2009 Tejas Dinkar <tejas@gja.in> - 0.6-5
146- Fixed the twitpocalypse (via patch)
147
148* Wed May 27 2009 Tejas Dinkar <tejas@gja.in> - 0.6-4
149- Changed to 0.6
150
151* Fri Apr 10 2009 Tejas Dinkar <tejas@gja.in> - 0.5-3
152- Added the TweetAll patch, remove this by 0.6
153
154* Fri Mar 27 2009 Tejas Dinkar <tejas@gja.in> - 0.5-2
155- Added AUTHORS changelog and TODO to doc
156
157* Fri Mar 27 2009 Tejas Dinkar <tejas@gja.in> - 0.5-1
158- Initial Version for Fedora
Note: See TracBrowser for help on using the repository browser.