source: projects/specs/trunk/c/choqok/choqok-vl.spec @ 10757

Revision 10757, 5.2 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%if %{?_dist_release} != "vl5"
2%define kde KDE
3%else
4%define kde KDE4
5%endif
6
7Summary: Choqok %{kde} Micro-Blogging Client
8Summary(ja): %{kde} マイクロブログクライアント
9Name: choqok
10Version: 1.3
11Release: 2%{?_dist_release}
12
13License: GPLv3
14Group: Applications/Internet
15URL: http://choqok.gnufolks.org/
16
17Source0: http://choqok.gnufolks.org/pkgs/%{name}-%{version}.tar.bz2
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: cmake >= 2.6
21BuildRequires: desktop-file-utils
22BuildRequires: kdelibs4-devel
23BuildRequires: gettext
24BuildRequires: qjson-devel
25BuildRequires: qoauth-devel
26BuildRequires: attica-devel
27BuildRequires: soprano-devel
28%if %{?_dist_release} != "vl5"
29BuildRequires: libindicate-qt-devel
30%endif
31
32Requires: %{name}-libs = %{version}-%{release}
33
34%description
35A Free/Open Source micro-blogging client for %{kde}.
36The name comes from an ancient Persian word, which means Sparrow!
37Choqok currently supports Twitter.com and Identi.ca services.
38
39%package libs
40Summary: Runtime libraries for %{name}
41Summary(ja): %{name} のランタイムライブラリ
42Group:   System Environment/Libraries
43# Requires: %{name} = %{version}-%{release}
44# for kwallet, among other goodies
45Requires: kdebase-runtime
46
47%description libs
48%{summary}
49
50%package devel
51Summary:  Development files for %{name}
52Summary(ja): %{name} の開発用ファイル
53Group:    Development/Libraries
54Requires: %{name}-libs = %{version}-%{release}
55Requires: kdelibs4-devel
56
57%description devel
58%{summary}
59
60
61%prep
62%setup -q
63
64%build
65mkdir -p %{_target_platform}
66pushd %{_target_platform}
67PATH=$PATH:%{_prefix}/kerberos/bin \
68%cmake \
69    -DCMAKE_BUILD_TYPE=release \
70    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
71    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
72    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
73    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
74    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
75    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
76    ..
77popd
78
79make %{?_smp_mflags} -C %{_target_platform}
80
81%install
82rm -rf %{buildroot}
83
84make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
85
86%find_lang %{name}
87
88%check
89desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/choqok.desktop
90
91%clean
92rm -rf %{buildroot}
93
94%post
95touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
96
97%postun
98if [ $1 -eq 0 ] ; then
99touch --no-create %{_datadir}/icons/hicolor &> /dev/null
100gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
101fi
102
103%posttrans
104gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
105
106
107%files -f %{name}.lang
108%defattr(-,root,root,-)
109%doc COPYING README AUTHORS changelog TODO
110%{_bindir}/choqok
111%{_libdir}/kde4/choqok_*.so
112%{_libdir}/kde4/kcm_choqok_*.so
113%{_libdir}/kde4/konqchoqokplugin.so
114%{_datadir}/icons/hicolor/*/actions/retweet.png
115%{_datadir}/icons/hicolor/*/apps/*.png
116%{_datadir}/applications/kde4/choqok.desktop
117%{_datadir}/config.kcfg/*.kcfg
118%{_datadir}/kde4/services/choqok_*.desktop
119%{_datadir}/kde4/apps/choqok
120%{_datadir}/kde4/apps/choqok_*/*.rc
121%{_datadir}/kde4/apps/dbus-1/services/*
122%{_datadir}/kde4/apps/khtml/kpartplugins/*
123%{_datadir}/kde4/services/ServiceMenus/*.desktop
124%{_datadir}/kde4/servicetypes/choqok*.desktop
125%doc %{_docdir}/HTML/*
126
127%files libs
128%defattr(-,root,root,-)
129%{_libdir}/lib*.so.*
130
131%files devel
132%defattr(-,root,root,-)
133%{_includedir}/kde4/choqok
134%{_libdir}/lib*.so
135%{_datadir}/kde4/apps/cmake/*
136
137
138%changelog
139* Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> - 1.3-2
140- rebuild with gcc-5.4.0
141
142* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3-1
143- new upstream release
144
145* Fri Feb 03 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 1.2-1
146- new upstream release
147- added BR: soprano-devel
148
149* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0-1
150- new upstream release
151
152* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.98-1
153- new upstream release
154- added BR: qjson-devel, qoauth-devel
155
156* Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.55-15
157- initial build for Vine Linux
158
159* Tue Mar 09 2010 Tejas Dinkar <tejas@gja.in> - 0.9.55-14
160- Add dependency from -libs to choqok
161
162* Tue Mar 09 2010 Rex Dieter <rdieter@fedoraprojecdt.org> - 0.9.55-13
163- Requires: kdebase-runtime (not kdeutils)
164
165* Tue Mar 09 2010 Tejas Dinkar <tejas@gja.in> - 0.9.55-12
166- choqok 1.0-beta
167
168* Wed Sep 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.6.6-9
169- add icon/desktop-file scriptlets
170
171* Sun Aug 16 2009 Tejas Dinkar <tejas@gja.in> - 0.6.6-8
172- Added Dependency on kdeutils
173- Choqok 0.6.6 is out
174
175* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-8
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
177
178* Sun Jun 14 2009 Tejas Dinkar <tejas@gja.in> - 0.6.1-7
179- Choqok 0.6.1 is out with the below two patches
180
181* Sat Jun 13 2009 Tejas Dinkar <tejas@gja.in> - 0.6-6
182- Fixed the inreplyto (via patch)
183
184* Sat Jun 13 2009 Tejas Dinkar <tejas@gja.in> - 0.6-5
185- Fixed the twitpocalypse (via patch)
186
187* Wed May 27 2009 Tejas Dinkar <tejas@gja.in> - 0.6-4
188- Changed to 0.6
189
190* Fri Apr 10 2009 Tejas Dinkar <tejas@gja.in> - 0.5-3
191- Added the TweetAll patch, remove this by 0.6
192
193* Fri Mar 27 2009 Tejas Dinkar <tejas@gja.in> - 0.5-2
194- Added AUTHORS changelog and TODO to doc
195
196* Fri Mar 27 2009 Tejas Dinkar <tejas@gja.in> - 0.5-1
197- Initial Version for Fedora
Note: See TracBrowser for help on using the repository browser.