source: projects/specs/trunk/c/chkconfig/chkconfig-vl.spec @ 7990

Revision 7990, 11.2 KB checked in by daisuke, 11 years ago (diff)

chkconfig: update to 1.3.61, add /usr/sbin/*alternatives symlink

Line 
1Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
2Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
3Name: chkconfig
4Version: 1.3.61
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8Source: %{name}-%{version}.tar.bz2
9Source2: chkconfig.8
10Source3: ntsysv.8
11Source4: update-alternatives.ja.8
12Patch1: chkconfig-1.3.51-vine.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: newt-devel
15BuildRequires: popt-devel
16Conflicts: initscripts <= 5.30-1
17
18%description
19Chkconfig is a basic system utility.  It updates and queries runlevel
20information for system services.  Chkconfig manipulates the numerous
21symbolic links in /etc/rc.d, to relieve system administrators of some
22of the drudgery of manually editing the symbolic links.
23
24%description -l ja
25chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
26runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
27多数のシンボリックリンクを操作しますので、システム管理者は手動で
28シンボリックリンクをたびたびエディットしなくてもよい。
29
30%package -n ntsysv
31Summary: A tool to set the stop/start of system services in a runlevel.
32Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
33Group: System Environment/Base
34
35%description -n ntsysv
36Ntsysv provides a simple interface for setting which system services
37are started or stopped in various runlevels (instead of directly
38manipulating the numerous symbolic links in /etc/rc.d). Unless you
39specify a runlevel or runlevels on the command line (see the man
40page), ntsysv configures the current runlevel (5 if you're using X).
41
42%description -n ntsysv -l ja
43ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
44ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
45操作することから解放する。
46
47%package -n alternatives
48Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
49Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
50Group: System Environment/Base
51
52%description -n alternatives
53maintain symbolic links determining default commands (from Debian dpkg utilities)
54
55%description -n alternatives -l ja
56コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
57
58
59%prep
60%setup -q
61%patch1 -p1
62
63%build
64
65%ifarch sparc
66LIBMHACK=-lm
67%endif
68
69%__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
70
71%install
72rm -rf $RPM_BUILD_ROOT
73%__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
74
75mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
76ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
77for n in 0 1 2 3 4 5 6; do
78    mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
79    ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
80done
81
82mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
83cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
84
85# alternatives
86mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
87mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
88mkdir -p $RPM_BUILD_ROOT/var/lib/rpm/alternatives
89install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
90ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
91
92# create compat symlinks
93mkdir -p $RPM_BUILD_ROOT/%{_sbindir}
94for i in alternatives update-alternatives chkconfig
95do
96  ln -sf /sbin/$i $RPM_BUILD_ROOT/%{_sbindir}/$i
97done
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%files
103%defattr(-,root,root)
104/sbin/chkconfig
105%{_sbindir}/chkconfig
106/etc/init.d
107/etc/rc.d/init.d
108/etc/rc[0-6].d
109/etc/rc.d/rc[0-6].d
110%{_mandir}/*/chkconfig*
111%{_mandir}/ja/*/chkconfig*
112%{_localedir}/*/LC_MESSAGES/chkconfig.mo
113
114%files -n ntsysv
115%defattr(-,root,root)
116%{_sbindir}/ntsysv
117%{_mandir}/*/ntsysv.8*
118%{_mandir}/ja/*/ntsysv.8*
119
120%files -n alternatives
121%defattr (-, root, root)
122/sbin/alternatives
123/sbin/update-alternatives
124%{_sbindir}/alternatives
125%{_sbindir}/update-alternatives
126%{_sysconfdir}/alternatives
127%{_mandir}/man8/*
128%{_mandir}/ja/man8/*
129/var/lib/rpm/alternatives
130
131
132%changelog
133* Wed Nov 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.61-1
134- update to 1.3.61
135- create compat symlinks in %%{_sbindir}
136
137* Thu Jun 06 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.60-1
138- update to 1.3.60
139
140* Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.51-2
141- change BuildRequires: popt-devel intead of popt
142
143* Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
144- new upstream release
145- enable fedora version of alternatives
146  - add alternatives subpackage, replace debian's alternatives
147
148* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
149- new upstream release
150
151* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
152- applied new versioning policy and spec in utf-8
153
154* Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
155- dropped obsoleted Makefile.x86_64.patch
156
157* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
158- new upstream release
159
160* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
161- add Makefile.x86_64.patch
162
163* Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
164- add Patch10 to skip xinetd parsing if not exist.
165
166* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
167- rebuild
168
169* Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
170- Requires -> Conflicts.
171  apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
172  Conflicts/Pre-Depends-loop does not happen.
173
174* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
175- Oops not PreReq but Requires. Fixed.
176
177* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
178- change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
179  to avoid Conflicts/Pre-Depends loop on apt
180
181* Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
182- 1.2.17-1vl3
183- change checkbox color
184
185* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
186- 1.2.17-1vl2
187- rebuilt for VineSeed
188
189* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
190- 1.2.17-1vl1
191
192* Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
193- ignore .rpmnew files (#18915)
194- fix typo in error message (#17575)
195
196* Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
197- make xinetd config files mode 0644, not 644
198
199* Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
200- updated it and es translations
201
202* Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
203- get man pages in proper packages
204
205* Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
206- new translations
207
208* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
209- don't worry about extra whitespace on chkconfig: lines (#16150)
210
211* Thu Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
212- i18n merge
213
214* Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
215- new translations for de fr it es
216
217* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
218- change prereqs
219
220* Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
221- fix ntsysv's handling of xinetd/init files with the same name
222
223* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
224- fix segv when reading malformed files
225
226* Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
227- put links, rc[0-6].d dirs back, those are necessary
228
229* Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
230- add quick hack support for reading descriptions from xinetd files
231
232* Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
233- don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
234
235* Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
236- move back to old file layout
237
238* Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
239- bump copyright date
240
241* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
242- no %pre today. Maybe tomorrow.
243
244* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
245- put initscripts %pre here too
246
247* Mon Jul  3 2000 Bill Nottingham <notting@redhat.com>
248- oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
249
250* Sun Jul  2 2000 Bill Nottingham <notting@redhat.com>
251- add xinetd support
252
253* Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
254- changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
255- fixed sumary and description where a global string replace nuked them
256
257* Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
258- what Bill said, but actually build this version
259
260* Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
261- don't own /etc/rc.*
262
263* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
264- typo in man page
265
266* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
267- fix description
268
269* Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
270- link chkconfig statically against popt
271
272* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
273- fix querying alternate levels
274
275* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
276- don't use strchr to skip unwanted files, look at extension instead (#4166).
277
278* Thu Aug  5 1999 Bill Nottingham <notting@redhat.com>
279- fix --help, --verson
280
281* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
282- rebuilt ntsysv against newt 0.50
283
284* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
285- fix i18n problem in usage message (#4233).
286- add --help and --version.
287
288* Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
289- release for Red Hat 6.0
290
291* Thu Apr  8 1999 Matt Wilson <msw@redhat.com>
292- added support for a "hide: true" tag in initscripts that will make
293  services not appear in ntsysv when run with the "--hide" flag
294
295* Thu Apr  1 1999 Matt Wilson <msw@redhat.com>
296- added --hide flag for ntsysv that allows you to hide a service from the
297  user.
298
299* Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
300- fix glob, once and for all. Really. We mean it.
301
302* Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
303- revert fix for services@levels, it's broken
304- change default to only edit the current runlevel
305
306* Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
307- don't remove scripts that don't support chkconfig
308
309* Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
310- made glob a bit more specific so xinetd and inetd don't cause improper matches
311
312* Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
313- removed debugging output when starting ntsysv
314
315* Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
316- fixed globbing error
317- fixed ntsysv running services not at their specified levels.
318
319* Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
320- print the value of errno on glob failures.
321
322* Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
323- rebuilt for newt 0.40 (ntsysv)
324
325* Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
326- add ru.po.
327
328* Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
329- build for Raw Hide (slang-1.2.2)
330
331* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
332- translation updates
333
334* Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
335- updated czech translation (and use cs instead of cz)
336
337* Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
338- added pt_BR translations
339- added more translatable strings
340- support for i18n init.d scripts description
341
342* Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
343- built against newt 0.30
344- split ntsysv into a separate package
345
346* Thu May 07 1998 Erik Troan <ewt@redhat.com>
347- added numerous translations
348
349* Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
350- added i18n support
351
352* Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
353- added --back
Note: See TracBrowser for help on using the repository browser.