source: projects/specs/trunk/c/chkconfig/chkconfig-vl.spec @ 12545

Revision 12545, 11.7 KB checked in by tomop, 3 years ago (diff)

rpm-4.16.1.2-1 and requirements

Line 
1Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
2Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
3Name: chkconfig
4Version: 1.3.61
5Release: 4%{?_dist_release}
6Group: system,admin-tools
7Vendor: Project Vine
8Distribution: Vine Linux
9
10License: GPL
11Source: %{name}-%{version}.tar.bz2
12Source2: chkconfig.8
13Source3: ntsysv.8
14Source4: update-alternatives.ja.8
15Patch1: chkconfig-1.3.51-vine.patch
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: newt-devel
18BuildRequires: popt-devel
19Conflicts: initscripts <= 5.30-1
20
21%description
22Chkconfig is a basic system utility.  It updates and queries runlevel
23information for system services.  Chkconfig manipulates the numerous
24symbolic links in /etc/rc.d, to relieve system administrators of some
25of the drudgery of manually editing the symbolic links.
26
27%description -l ja
28chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
29runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
30多数のシンボリックリンクを操作しますので、システム管理者は手動で
31シンボリックリンクをたびたびエディットしなくてもよい。
32
33
34%package -n ntsysv
35Summary: A tool to set the stop/start of system services in a runlevel.
36Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
37Group: system,admin-tools
38
39%description -n ntsysv
40Ntsysv provides a simple interface for setting which system services
41are started or stopped in various runlevels (instead of directly
42manipulating the numerous symbolic links in /etc/rc.d). Unless you
43specify a runlevel or runlevels on the command line (see the man
44page), ntsysv configures the current runlevel (5 if you're using X).
45
46%description -n ntsysv -l ja
47ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
48ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
49操作することから解放する。
50
51
52%package -n alternatives
53Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
54Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
55Group: system,admin-tools
56
57%description -n alternatives
58maintain symbolic links determining default commands (from Debian dpkg utilities)
59
60%description -n alternatives -l ja
61コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
62
63
64%debug_package
65
66
67%prep
68%setup -q
69#%patch1 -p1
70
71
72%build
73%__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
74
75%install
76rm -rf $RPM_BUILD_ROOT
77%__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
78
79mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
80ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
81for n in 0 1 2 3 4 5 6; do
82    mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
83    ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
84done
85
86mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
87cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
88
89# alternatives
90mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
91mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
92mkdir -p $RPM_BUILD_ROOT/var/lib/alternatives
93install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
94ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
95
96# create compat symlinks
97mkdir -p $RPM_BUILD_ROOT/%{_sbindir}
98for i in alternatives update-alternatives chkconfig
99do
100  ln -sf /sbin/$i $RPM_BUILD_ROOT/%{_sbindir}/$i
101done
102
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107
108%post -n alternatives
109if [ "$1" -gt "1" ]; then
110  if [ -d /var/lib/rpm/alternatives -a $(ls /var/lib/rpm/alternatives | wc --lines) -gt 0 ]; then
111    mv -f /var/lib/rpm/alternatives/* /var/lib/alternatives/
112  fi
113fi
114
115
116%files
117%defattr(-,root,root)
118/sbin/chkconfig
119%{_sbindir}/chkconfig
120/etc/init.d
121/etc/rc.d/init.d
122/etc/rc[0-6].d
123/etc/rc.d/rc[0-6].d
124%{_mandir}/*/chkconfig*
125%{_mandir}/ja/*/chkconfig*
126%{_localedir}/*/LC_MESSAGES/chkconfig.mo
127
128%files -n ntsysv
129%defattr(-,root,root)
130%{_sbindir}/ntsysv
131%{_mandir}/*/ntsysv.8*
132%{_mandir}/ja/*/ntsysv.8*
133
134%files -n alternatives
135%defattr (-, root, root)
136/sbin/alternatives
137/sbin/update-alternatives
138%{_sbindir}/alternatives
139%{_sbindir}/update-alternatives
140%{_sysconfdir}/alternatives
141%{_mandir}/man8/*
142%{_mandir}/ja/man8/*
143/var/lib/alternatives
144
145
146%changelog
147* Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.61-4
148- moved /var/lib/rpm/alternatives to /var/lib/alternatives.
149
150* Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.61-3
151- rebuilt with current environment.
152
153* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.61-2
154- rebuild with VineSeed environment
155
156* Wed Nov 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.61-1
157- update to 1.3.61
158- create compat symlinks in %%{_sbindir}
159
160* Thu Jun 06 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.60-1
161- update to 1.3.60
162
163* Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.51-2
164- change BuildRequires: popt-devel intead of popt
165
166* Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
167- new upstream release
168- enable fedora version of alternatives
169  - add alternatives subpackage, replace debian's alternatives
170
171* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
172- new upstream release
173
174* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
175- applied new versioning policy and spec in utf-8
176
177* Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
178- dropped obsoleted Makefile.x86_64.patch
179
180* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
181- new upstream release
182
183* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
184- add Makefile.x86_64.patch
185
186* Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
187- add Patch10 to skip xinetd parsing if not exist.
188
189* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
190- rebuild
191
192* Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
193- Requires -> Conflicts.
194  apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
195  Conflicts/Pre-Depends-loop does not happen.
196
197* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
198- Oops not PreReq but Requires. Fixed.
199
200* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
201- change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
202  to avoid Conflicts/Pre-Depends loop on apt
203
204* Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
205- 1.2.17-1vl3
206- change checkbox color
207
208* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
209- 1.2.17-1vl2
210- rebuilt for VineSeed
211
212* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
213- 1.2.17-1vl1
214
215* Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
216- ignore .rpmnew files (#18915)
217- fix typo in error message (#17575)
218
219* Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
220- make xinetd config files mode 0644, not 644
221
222* Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
223- updated it and es translations
224
225* Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
226- get man pages in proper packages
227
228* Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
229- new translations
230
231* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
232- don't worry about extra whitespace on chkconfig: lines (#16150)
233
234* Thu Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
235- i18n merge
236
237* Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
238- new translations for de fr it es
239
240* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
241- change prereqs
242
243* Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
244- fix ntsysv's handling of xinetd/init files with the same name
245
246* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
247- fix segv when reading malformed files
248
249* Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
250- put links, rc[0-6].d dirs back, those are necessary
251
252* Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
253- add quick hack support for reading descriptions from xinetd files
254
255* Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
256- don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
257
258* Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
259- move back to old file layout
260
261* Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
262- bump copyright date
263
264* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
265- no %pre today. Maybe tomorrow.
266
267* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
268- put initscripts %pre here too
269
270* Mon Jul  3 2000 Bill Nottingham <notting@redhat.com>
271- oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
272
273* Sun Jul  2 2000 Bill Nottingham <notting@redhat.com>
274- add xinetd support
275
276* Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
277- changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
278- fixed sumary and description where a global string replace nuked them
279
280* Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
281- what Bill said, but actually build this version
282
283* Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
284- don't own /etc/rc.*
285
286* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
287- typo in man page
288
289* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
290- fix description
291
292* Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
293- link chkconfig statically against popt
294
295* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
296- fix querying alternate levels
297
298* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
299- don't use strchr to skip unwanted files, look at extension instead (#4166).
300
301* Thu Aug  5 1999 Bill Nottingham <notting@redhat.com>
302- fix --help, --verson
303
304* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
305- rebuilt ntsysv against newt 0.50
306
307* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
308- fix i18n problem in usage message (#4233).
309- add --help and --version.
310
311* Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
312- release for Red Hat 6.0
313
314* Thu Apr  8 1999 Matt Wilson <msw@redhat.com>
315- added support for a "hide: true" tag in initscripts that will make
316  services not appear in ntsysv when run with the "--hide" flag
317
318* Thu Apr  1 1999 Matt Wilson <msw@redhat.com>
319- added --hide flag for ntsysv that allows you to hide a service from the
320  user.
321
322* Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
323- fix glob, once and for all. Really. We mean it.
324
325* Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
326- revert fix for services@levels, it's broken
327- change default to only edit the current runlevel
328
329* Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
330- don't remove scripts that don't support chkconfig
331
332* Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
333- made glob a bit more specific so xinetd and inetd don't cause improper matches
334
335* Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
336- removed debugging output when starting ntsysv
337
338* Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
339- fixed globbing error
340- fixed ntsysv running services not at their specified levels.
341
342* Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
343- print the value of errno on glob failures.
344
345* Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
346- rebuilt for newt 0.40 (ntsysv)
347
348* Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
349- add ru.po.
350
351* Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
352- build for Raw Hide (slang-1.2.2)
353
354* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
355- translation updates
356
357* Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
358- updated czech translation (and use cs instead of cz)
359
360* Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
361- added pt_BR translations
362- added more translatable strings
363- support for i18n init.d scripts description
364
365* Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
366- built against newt 0.30
367- split ntsysv into a separate package
368
369* Thu May 07 1998 Erik Troan <ewt@redhat.com>
370- added numerous translations
371
372* Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
373- added i18n support
374
375* Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
376- added --back
Note: See TracBrowser for help on using the repository browser.