source: projects/specs/trunk/c/chkconfig/chkconfig-vl.spec @ 4082

Revision 4082, 10.7 KB checked in by Takemikaduchi, 13 years ago (diff)

chkconfig,libcap: fix BR, libxml2: fix debian security announce DSA-2255, wireshark: new upstream release

Line 
1Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
2Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
3Name: chkconfig
4Version: 1.3.51
5Release: 2%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8Source: %{name}-%{version}.tar.bz2
9Source2: chkconfig.8
10Source3: ntsysv.8
11Source4: update-alternatives.ja.8
12Patch1: chkconfig-1.3.51-vine.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: newt-devel
15BuildRequires: popt-devel
16Conflicts: initscripts <= 5.30-1
17
18%description
19Chkconfig is a basic system utility.  It updates and queries runlevel
20information for system services.  Chkconfig manipulates the numerous
21symbolic links in /etc/rc.d, to relieve system administrators of some
22of the drudgery of manually editing the symbolic links.
23
24%description -l ja
25chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
26runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
27多数のシンボリックリンクを操作しますので、システム管理者は手動で
28シンボリックリンクをたびたびエディットしなくてもよい。
29
30%package -n ntsysv
31Summary: A tool to set the stop/start of system services in a runlevel.
32Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
33Group: System Environment/Base
34
35%description -n ntsysv
36Ntsysv provides a simple interface for setting which system services
37are started or stopped in various runlevels (instead of directly
38manipulating the numerous symbolic links in /etc/rc.d). Unless you
39specify a runlevel or runlevels on the command line (see the man
40page), ntsysv configures the current runlevel (5 if you're using X).
41
42%description -n ntsysv -l ja
43ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
44ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
45操作することから解放する。
46
47%package -n alternatives
48Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
49Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
50Group: System Environment/Base
51
52%description -n alternatives
53maintain symbolic links determining default commands (from Debian dpkg utilities)
54
55%description -n alternatives -l ja
56コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
57
58
59%prep
60%setup -q
61%patch1 -p1
62
63%build
64
65%ifarch sparc
66LIBMHACK=-lm
67%endif
68
69%__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
70
71%install
72rm -rf $RPM_BUILD_ROOT
73%__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
74
75mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
76ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
77for n in 0 1 2 3 4 5 6; do
78    mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
79    ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
80done
81
82mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
83cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
84
85# alternatives
86mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
87mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
88mkdir -p $RPM_BUILD_ROOT/var/lib/rpm/alternatives
89install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
90ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%files
96%defattr(-,root,root)
97/sbin/chkconfig
98/etc/init.d
99/etc/rc.d/init.d
100/etc/rc[0-6].d
101/etc/rc.d/rc[0-6].d
102%{_mandir}/*/chkconfig*
103%{_mandir}/ja/*/chkconfig*
104%{_localedir}/*/LC_MESSAGES/chkconfig.mo
105
106%files -n ntsysv
107%defattr(-,root,root)
108/usr/sbin/ntsysv
109%{_mandir}/*/ntsysv.8*
110%{_mandir}/ja/*/ntsysv.8*
111
112%files -n alternatives
113%defattr (-, root, root)
114/sbin/alternatives
115/sbin/update-alternatives
116%{_sysconfdir}/alternatives
117%{_mandir}/man8/*
118%{_mandir}/ja/man8/*
119/var/lib/rpm/alternatives
120
121
122%changelog
123* Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.51-2
124- change BuildRequires: popt-devel intead of popt
125
126* Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
127- new upstream release
128- enable fedora version of alternatives
129  - add alternatives subpackage, replace debian's alternatives
130
131* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
132- new upstream release
133
134* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
135- applied new versioning policy and spec in utf-8
136
137* Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
138- dropped obsoleted Makefile.x86_64.patch
139
140* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
141- new upstream release
142
143* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
144- add Makefile.x86_64.patch
145
146* Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
147- add Patch10 to skip xinetd parsing if not exist.
148
149* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
150- rebuild
151
152* Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
153- Requires -> Conflicts.
154  apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
155  Conflicts/Pre-Depends-loop does not happen.
156
157* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
158- Oops not PreReq but Requires. Fixed.
159
160* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
161- change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
162  to avoid Conflicts/Pre-Depends loop on apt
163
164* Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
165- 1.2.17-1vl3
166- change checkbox color
167
168* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
169- 1.2.17-1vl2
170- rebuilt for VineSeed
171
172* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
173- 1.2.17-1vl1
174
175* Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
176- ignore .rpmnew files (#18915)
177- fix typo in error message (#17575)
178
179* Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
180- make xinetd config files mode 0644, not 644
181
182* Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
183- updated it and es translations
184
185* Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
186- get man pages in proper packages
187
188* Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
189- new translations
190
191* Tue Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
192- don't worry about extra whitespace on chkconfig: lines (#16150)
193
194* Wed Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
195- i18n merge
196
197* Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
198- new translations for de fr it es
199
200* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
201- change prereqs
202
203* Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
204- fix ntsysv's handling of xinetd/init files with the same name
205
206* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
207- fix segv when reading malformed files
208
209* Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
210- put links, rc[0-6].d dirs back, those are necessary
211
212* Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
213- add quick hack support for reading descriptions from xinetd files
214
215* Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
216- don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
217
218* Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
219- move back to old file layout
220
221* Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
222- bump copyright date
223
224* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
225- no %pre today. Maybe tomorrow.
226
227* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
228- put initscripts %pre here too
229
230* Mon Jul  3 2000 Bill Nottingham <notting@redhat.com>
231- oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
232
233* Sun Jul  2 2000 Bill Nottingham <notting@redhat.com>
234- add xinetd support
235
236* Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
237- changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
238- fixed sumary and description where a global string replace nuked them
239
240* Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
241- what Bill said, but actually build this version
242
243* Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
244- don't own /etc/rc.*
245
246* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
247- typo in man page
248
249* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
250- fix description
251
252* Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
253- link chkconfig statically against popt
254
255* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
256- fix querying alternate levels
257
258* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
259- don't use strchr to skip unwanted files, look at extension instead (#4166).
260
261* Thu Aug  5 1999 Bill Nottingham <notting@redhat.com>
262- fix --help, --verson
263
264* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
265- rebuilt ntsysv against newt 0.50
266
267* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
268- fix i18n problem in usage message (#4233).
269- add --help and --version.
270
271* Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
272- release for Red Hat 6.0
273
274* Thu Apr  8 1999 Matt Wilson <msw@redhat.com>
275- added support for a "hide: true" tag in initscripts that will make
276  services not appear in ntsysv when run with the "--hide" flag
277
278* Thu Apr  1 1999 Matt Wilson <msw@redhat.com>
279- added --hide flag for ntsysv that allows you to hide a service from the
280  user.
281
282* Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
283- fix glob, once and for all. Really. We mean it.
284
285* Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
286- revert fix for services@levels, it's broken
287- change default to only edit the current runlevel
288
289* Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
290- don't remove scripts that don't support chkconfig
291
292* Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
293- made glob a bit more specific so xinetd and inetd don't cause improper matches
294
295* Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
296- removed debugging output when starting ntsysv
297
298* Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
299- fixed globbing error
300- fixed ntsysv running services not at their specified levels.
301
302* Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
303- print the value of errno on glob failures.
304
305* Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
306- rebuilt for newt 0.40 (ntsysv)
307
308* Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
309- add ru.po.
310
311* Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
312- build for Raw Hide (slang-1.2.2)
313
314* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
315- translation updates
316
317* Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
318- updated czech translation (and use cs instead of cz)
319
320* Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
321- added pt_BR translations
322- added more translatable strings
323- support for i18n init.d scripts description
324
325* Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
326- built against newt 0.30
327- split ntsysv into a separate package
328
329* Thu May 07 1998 Erik Troan <ewt@redhat.com>
330- added numerous translations
331
332* Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
333- added i18n support
334
335* Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
336- added --back
Note: See TracBrowser for help on using the repository browser.