source: projects/specs/trunk/c/chkconfig/chkconfig-vl.spec @ 3349

Revision 3349, 10.6 KB checked in by daisuke, 13 years ago (diff)

chkconfig:

  • new upstream release
  • enable fedora version of alternatives
    • add alternatives subpackage, replace debian's alternatives


Line 
1Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
2Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
3Name: chkconfig
4Version: 1.3.51
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8Source: %{name}-%{version}.tar.bz2
9Source2: chkconfig.8
10Source3: ntsysv.8
11Source4: update-alternatives.ja.8
12Patch1: chkconfig-1.3.51-vine.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildPrereq: newt-devel popt
15Conflicts: initscripts <= 5.30-1
16
17%description
18Chkconfig is a basic system utility.  It updates and queries runlevel
19information for system services.  Chkconfig manipulates the numerous
20symbolic links in /etc/rc.d, to relieve system administrators of some
21of the drudgery of manually editing the symbolic links.
22
23%description -l ja
24chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
25runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
26多数のシンボリックリンクを操作しますので、システム管理者は手動で
27シンボリックリンクをたびたびエディットしなくてもよい。
28
29%package -n ntsysv
30Summary: A tool to set the stop/start of system services in a runlevel.
31Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
32Group: System Environment/Base
33
34%description -n ntsysv
35Ntsysv provides a simple interface for setting which system services
36are started or stopped in various runlevels (instead of directly
37manipulating the numerous symbolic links in /etc/rc.d). Unless you
38specify a runlevel or runlevels on the command line (see the man
39page), ntsysv configures the current runlevel (5 if you're using X).
40
41%description -n ntsysv -l ja
42ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
43ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
44操作することから解放する。
45
46%package -n alternatives
47Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
48Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
49Group: System Environment/Base
50
51%description -n alternatives
52maintain symbolic links determining default commands (from Debian dpkg utilities)
53
54%description -n alternatives -l ja
55コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
56
57
58%prep
59%setup -q
60%patch1 -p1
61
62%build
63
64%ifarch sparc
65LIBMHACK=-lm
66%endif
67
68%__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
69
70%install
71rm -rf $RPM_BUILD_ROOT
72%__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
73
74mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
75ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
76for n in 0 1 2 3 4 5 6; do
77    mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
78    ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
79done
80
81mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
82cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
83
84# alternatives
85mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
86mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
87mkdir -p $RPM_BUILD_ROOT/var/lib/rpm/alternatives
88install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
89ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(-,root,root)
96/sbin/chkconfig
97/etc/init.d
98/etc/rc.d/init.d
99/etc/rc[0-6].d
100/etc/rc.d/rc[0-6].d
101%{_mandir}/*/chkconfig*
102%{_mandir}/ja/*/chkconfig*
103%{_localedir}/*/LC_MESSAGES/chkconfig.mo
104
105%files -n ntsysv
106%defattr(-,root,root)
107/usr/sbin/ntsysv
108%{_mandir}/*/ntsysv.8*
109%{_mandir}/ja/*/ntsysv.8*
110
111%files -n alternatives
112%defattr (-, root, root)
113/sbin/alternatives
114/sbin/update-alternatives
115%{_sysconfdir}/alternatives
116%{_mandir}/man8/*
117%{_mandir}/ja/man8/*
118/var/lib/rpm/alternatives
119
120
121%changelog
122* Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
123- new upstream release
124- enable fedora version of alternatives
125  - add alternatives subpackage, replace debian's alternatives
126
127* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
128- new upstream release
129
130* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
131- applied new versioning policy and spec in utf-8
132
133* Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
134- dropped obsoleted Makefile.x86_64.patch
135
136* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
137- new upstream release
138
139* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
140- add Makefile.x86_64.patch
141
142* Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
143- add Patch10 to skip xinetd parsing if not exist.
144
145* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
146- rebuild
147
148* Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
149- Requires -> Conflicts.
150  apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
151  Conflicts/Pre-Depends-loop does not happen.
152
153* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
154- Oops not PreReq but Requires. Fixed.
155
156* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
157- change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
158  to avoid Conflicts/Pre-Depends loop on apt
159
160* Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
161- 1.2.17-1vl3
162- change checkbox color
163
164* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
165- 1.2.17-1vl2
166- rebuilt for VineSeed
167
168* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
169- 1.2.17-1vl1
170
171* Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
172- ignore .rpmnew files (#18915)
173- fix typo in error message (#17575)
174
175* Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
176- make xinetd config files mode 0644, not 644
177
178* Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
179- updated it and es translations
180
181* Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
182- get man pages in proper packages
183
184* Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
185- new translations
186
187* Tue Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
188- don't worry about extra whitespace on chkconfig: lines (#16150)
189
190* Wed Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
191- i18n merge
192
193* Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
194- new translations for de fr it es
195
196* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
197- change prereqs
198
199* Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
200- fix ntsysv's handling of xinetd/init files with the same name
201
202* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
203- fix segv when reading malformed files
204
205* Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
206- put links, rc[0-6].d dirs back, those are necessary
207
208* Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
209- add quick hack support for reading descriptions from xinetd files
210
211* Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
212- don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
213
214* Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
215- move back to old file layout
216
217* Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
218- bump copyright date
219
220* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
221- no %pre today. Maybe tomorrow.
222
223* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
224- put initscripts %pre here too
225
226* Mon Jul  3 2000 Bill Nottingham <notting@redhat.com>
227- oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
228
229* Sun Jul  2 2000 Bill Nottingham <notting@redhat.com>
230- add xinetd support
231
232* Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
233- changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
234- fixed sumary and description where a global string replace nuked them
235
236* Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
237- what Bill said, but actually build this version
238
239* Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
240- don't own /etc/rc.*
241
242* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
243- typo in man page
244
245* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
246- fix description
247
248* Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
249- link chkconfig statically against popt
250
251* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
252- fix querying alternate levels
253
254* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
255- don't use strchr to skip unwanted files, look at extension instead (#4166).
256
257* Thu Aug  5 1999 Bill Nottingham <notting@redhat.com>
258- fix --help, --verson
259
260* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
261- rebuilt ntsysv against newt 0.50
262
263* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
264- fix i18n problem in usage message (#4233).
265- add --help and --version.
266
267* Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
268- release for Red Hat 6.0
269
270* Thu Apr  8 1999 Matt Wilson <msw@redhat.com>
271- added support for a "hide: true" tag in initscripts that will make
272  services not appear in ntsysv when run with the "--hide" flag
273
274* Thu Apr  1 1999 Matt Wilson <msw@redhat.com>
275- added --hide flag for ntsysv that allows you to hide a service from the
276  user.
277
278* Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
279- fix glob, once and for all. Really. We mean it.
280
281* Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
282- revert fix for services@levels, it's broken
283- change default to only edit the current runlevel
284
285* Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
286- don't remove scripts that don't support chkconfig
287
288* Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
289- made glob a bit more specific so xinetd and inetd don't cause improper matches
290
291* Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
292- removed debugging output when starting ntsysv
293
294* Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
295- fixed globbing error
296- fixed ntsysv running services not at their specified levels.
297
298* Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
299- print the value of errno on glob failures.
300
301* Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
302- rebuilt for newt 0.40 (ntsysv)
303
304* Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
305- add ru.po.
306
307* Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
308- build for Raw Hide (slang-1.2.2)
309
310* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
311- translation updates
312
313* Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
314- updated czech translation (and use cs instead of cz)
315
316* Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
317- added pt_BR translations
318- added more translatable strings
319- support for i18n init.d scripts description
320
321* Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
322- built against newt 0.30
323- split ntsysv into a separate package
324
325* Thu May 07 1998 Erik Troan <ewt@redhat.com>
326- added numerous translations
327
328* Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
329- added i18n support
330
331* Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
332- added --back
Note: See TracBrowser for help on using the repository browser.