source: projects/specs/trunk/c/chkconfig/chkconfig-vl.spec @ 521

Revision 521, 9.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
2Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
3Name: chkconfig
4Version: 1.3.37
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8Source: %{name}-%{version}.tar.gz
9Source1: chkconfig-1.2.17.ja.po
10Source2: chkconfig.8
11Source3: ntsysv.8
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildPrereq: newt-devel popt
14Conflicts: initscripts <= 5.30-1
15
16%description
17Chkconfig is a basic system utility.  It updates and queries runlevel
18information for system services.  Chkconfig manipulates the numerous
19symbolic links in /etc/rc.d, to relieve system administrators of some
20of the drudgery of manually editing the symbolic links.
21
22%description -l ja
23chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
24runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
25多数のシンボリックリンクを操作しますので、システム管理者は手動で
26シンボリックリンクをたびたびエディットしなくてもよい。
27
28%package -n ntsysv
29Summary: A tool to set the stop/start of system services in a runlevel.
30Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
31Group: System Environment/Base
32
33%description -n ntsysv
34Ntsysv provides a simple interface for setting which system services
35are started or stopped in various runlevels (instead of directly
36manipulating the numerous symbolic links in /etc/rc.d). Unless you
37specify a runlevel or runlevels on the command line (see the man
38page), ntsysv configures the current runlevel (5 if you're using X).
39
40%description -n ntsysv -l ja
41ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
42ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
43操作することから解放する。
44
45%prep
46%setup -q
47#cp %SOURCE1 po/ja.po
48
49%build
50
51%ifarch sparc
52LIBMHACK=-lm
53%endif
54
55%__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
56
57%install
58rm -rf $RPM_BUILD_ROOT
59%__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
60
61mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
62ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
63for n in 0 1 2 3 4 5 6; do
64    mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
65    ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
66done
67
68mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
69cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
70
71# remove unpackaged files
72# we have own alternatives system.
73rm -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives
74rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/*alternatives*
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(-,root,root)
81/sbin/chkconfig
82/etc/init.d
83/etc/rc.d/init.d
84/etc/rc[0-6].d
85/etc/rc.d/rc[0-6].d
86%{_mandir}/*/chkconfig*
87%{_mandir}/ja/*/chkconfig*
88%{_localedir}/*/LC_MESSAGES/chkconfig.mo
89
90%files -n ntsysv
91%defattr(-,root,root)
92/usr/sbin/ntsysv
93%{_mandir}/*/ntsysv.8*
94%{_mandir}/ja/*/ntsysv.8*
95
96%define date    %(echo `LC_ALL="C" date +"%a %b %d %Y"`)
97
98%changelog
99* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
100- new upstream release
101
102* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
103- applied new versioning policy and spec in utf-8
104
105* Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
106- dropped obsoleted Makefile.x86_64.patch
107
108* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
109- new upstream release
110
111* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
112- add Makefile.x86_64.patch
113
114* Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
115- add Patch10 to skip xinetd parsing if not exist.
116
117* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
118- rebuild
119
120* Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
121- Requires -> Conflicts.
122  apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
123  Conflicts/Pre-Depends-loop does not happen.
124
125* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
126- Oops not PreReq but Requires. Fixed.
127
128* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
129- change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
130  to avoid Conflicts/Pre-Depends loop on apt
131
132* Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
133- 1.2.17-1vl3
134- change checkbox color
135
136* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
137- 1.2.17-1vl2
138- rebuilt for VineSeed
139
140* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
141- 1.2.17-1vl1
142
143* Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
144- ignore .rpmnew files (#18915)
145- fix typo in error message (#17575)
146
147* Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
148- make xinetd config files mode 0644, not 644
149
150* Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
151- updated it and es translations
152
153* Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
154- get man pages in proper packages
155
156* Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
157- new translations
158
159* Tue Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
160- don't worry about extra whitespace on chkconfig: lines (#16150)
161
162* Wed Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
163- i18n merge
164
165* Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
166- new translations for de fr it es
167
168* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
169- change prereqs
170
171* Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
172- fix ntsysv's handling of xinetd/init files with the same name
173
174* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
175- fix segv when reading malformed files
176
177* Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
178- put links, rc[0-6].d dirs back, those are necessary
179
180* Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
181- add quick hack support for reading descriptions from xinetd files
182
183* Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
184- don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
185
186* Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
187- move back to old file layout
188
189* Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
190- bump copyright date
191
192* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
193- no %pre today. Maybe tomorrow.
194
195* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
196- put initscripts %pre here too
197
198* Mon Jul  3 2000 Bill Nottingham <notting@redhat.com>
199- oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
200
201* Sun Jul  2 2000 Bill Nottingham <notting@redhat.com>
202- add xinetd support
203
204* Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
205- changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
206- fixed sumary and description where a global string replace nuked them
207
208* Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
209- what Bill said, but actually build this version
210
211* Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
212- don't own /etc/rc.*
213
214* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
215- typo in man page
216
217* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
218- fix description
219
220* Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
221- link chkconfig statically against popt
222
223* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
224- fix querying alternate levels
225
226* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
227- don't use strchr to skip unwanted files, look at extension instead (#4166).
228
229* Thu Aug  5 1999 Bill Nottingham <notting@redhat.com>
230- fix --help, --verson
231
232* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
233- rebuilt ntsysv against newt 0.50
234
235* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
236- fix i18n problem in usage message (#4233).
237- add --help and --version.
238
239* Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
240- release for Red Hat 6.0
241
242* Thu Apr  8 1999 Matt Wilson <msw@redhat.com>
243- added support for a "hide: true" tag in initscripts that will make
244  services not appear in ntsysv when run with the "--hide" flag
245
246* Thu Apr  1 1999 Matt Wilson <msw@redhat.com>
247- added --hide flag for ntsysv that allows you to hide a service from the
248  user.
249
250* Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
251- fix glob, once and for all. Really. We mean it.
252
253* Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
254- revert fix for services@levels, it's broken
255- change default to only edit the current runlevel
256
257* Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
258- don't remove scripts that don't support chkconfig
259
260* Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
261- made glob a bit more specific so xinetd and inetd don't cause improper matches
262
263* Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
264- removed debugging output when starting ntsysv
265
266* Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
267- fixed globbing error
268- fixed ntsysv running services not at their specified levels.
269
270* Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
271- print the value of errno on glob failures.
272
273* Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
274- rebuilt for newt 0.40 (ntsysv)
275
276* Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
277- add ru.po.
278
279* Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
280- build for Raw Hide (slang-1.2.2)
281
282* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
283- translation updates
284
285* Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
286- updated czech translation (and use cs instead of cz)
287
288* Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
289- added pt_BR translations
290- added more translatable strings
291- support for i18n init.d scripts description
292
293* Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
294- built against newt 0.30
295- split ntsysv into a separate package
296
297* Thu May 07 1998 Erik Troan <ewt@redhat.com>
298- added numerous translations
299
300* Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
301- added i18n support
302
303* Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
304- added --back
Note: See TracBrowser for help on using the repository browser.