source: projects/specs/trunk/c/chicken/chicken-vl.spec @ 10804

Revision 10804, 1.6 KB checked in by ara_t, 7 years ago (diff)

change Group

Line 
1%define pkg_name    chicken
2%define pkg_version 4.11.0
3%define pkg_release 2%{?_dist_release}
4
5Summary: Practical and portable Scheme system - compiler
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD-style
11Group:   Development/Languages
12URL:     https://www.call-cc.org/
13Source:  http://code.call-cc.org/releases/%{version}/%{name}-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: ara_t
20
21%description
22CHICKEN is a compiler for the Scheme programming language.
23It produces portable and efficient C and supports the R5RS
24and R7RS (work in progress) standards, and many extensions.
25
26
27%prep
28%{__rm} -rf ${RPM_BUILD_ROOT}
29%setup -q
30
31%build
32%{__make} \
33 PLATFORM=linux \
34 PREFIX=%{_prefix} \
35 IDOCDIR=%{_docdir}/%{name}-%{version}
36
37%install
38%{__make} install \
39 PLATFORM=linux \
40 PREFIX=%{_prefix} \
41 IDOCDIR=%{_docdir}/%{name}-%{version} \
42 DESTDIR=${RPM_BUILD_ROOT}
43
44%check
45%{__make} check PLATFORM=linux
46
47%clean
48%{__rm} -rf ${RPM_BUILD_ROOT}
49
50%post -p %{_syssbindir}/ldconfig
51%postun -p %{_syssbindir}/ldconfig
52
53
54%files
55%defattr(-, root, root)
56%{_bindir}/
57%{_includedir}/
58/usr/lib/libchicken.so*
59/usr/lib//libchicken.a
60/usr/lib/chicken
61%{_datadir}/chicken
62%{_mandir}/man1/
63%{_docdir}/%{name}-%{version}
64
65
66%changelog
67* Sun Nov 06 2016 Toshiaki Ara <ara_t@384.jp> 4.11.0-2
68- change Group to Development/Languages
69
70* Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 4.11.0-1
71- update to 4.11.0
72- add %{__make} check for VineSeed
73
74* Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 4.10.0-1
75- new package
Note: See TracBrowser for help on using the repository browser.