source: projects/specs/trunk/c/chicken/chicken-vl.spec @ 11813

Revision 11813, 1.6 KB checked in by ara_t, 5 years ago (diff)

chicken: update to 4.13.0

Line 
1%define pkg_name    chicken
2%define pkg_version 4.13.0
3%define pkg_release 1%{?_dist_release}
4
5Summary: Practical and portable Scheme system - compiler
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD-style
11Group:   Development/Languages
12URL:     https://www.call-cc.org/
13Source:  http://code.call-cc.org/releases/%{version}/%{name}-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: ara_t
20
21%description
22CHICKEN is a compiler for the Scheme programming language.
23It produces portable and efficient C and supports the R5RS
24and R7RS (work in progress) standards, and many extensions.
25
26
27%prep
28%{__rm} -rf ${RPM_BUILD_ROOT}
29%setup -q
30
31%build
32%{__make} \
33 PLATFORM=linux \
34 PREFIX=%{_prefix} \
35 LIBDIR=%{_libdir} \
36 IDOCDIR=%{_docdir}/%{name}-%{version}
37
38%install
39%{__make} install \
40 PLATFORM=linux \
41 PREFIX=%{_prefix} \
42 LIBDIR=%{_libdir} \
43 IDOCDIR=%{_docdir}/%{name}-%{version} \
44 DESTDIR=${RPM_BUILD_ROOT}
45
46%check
47%{__make} check PLATFORM=linux
48
49%clean
50%{__rm} -rf ${RPM_BUILD_ROOT}
51
52%post -p %{_syssbindir}/ldconfig
53%postun -p %{_syssbindir}/ldconfig
54
55
56%files
57%defattr(-, root, root)
58%{_bindir}/
59%{_includedir}/
60%{_libdir}/chicken
61%{_libdir}/libchicken.so*
62%{_libdir}/libchicken.a
63%{_datadir}/chicken
64%{_mandir}/man1/
65%{_docdir}/%{name}-%{version}
66
67
68%changelog
69* Sun Nov 06 2016 Toshiaki Ara <ara_t@384.jp> 4.11.0-2
70- change Group to Development/Languages
71
72* Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 4.11.0-1
73- update to 4.11.0
74- add %{__make} check for VineSeed
75
76* Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 4.10.0-1
77- new package
Note: See TracBrowser for help on using the repository browser.