source: projects/specs/trunk/c/check/check-vl.spec @ 9086

Revision 9086, 3.7 KB checked in by inagaki, 9 years ago (diff)

2014-11-14 Ryoichi INAGAKI <ryo1@…>

  • check, libpipeline: updated
  • liblinebreak, preload: change Group


RevLine 
[521]1Summary:        A unit test framework for C
2Summary(ja):    C 言語用単体テストフレームワーク
3Name:           check
[9086]4Version:        0.9.14
[7064]5Release:        1%{?_dist_release}
[521]6License:        LGPL
[9086]7Group:          System Environment/Libraries
[521]8URL:            http://check.sourceforge.net/
[9086]9Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
[521]10Patch0:         %{name}-examples-bootstrap.patch
[9086]11
[521]12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  docbook-utils
[9086]14BuildRequires:  texinfo
[521]15Requires(post,preun): /sbin/install-info
16
[890]17Vendor:         Project Vine
18Distribution:   Vine Linux
19Packager:       USAMI Kosuke <usami-k@yc5.so-net.ne.jp>
[521]20
21%description
22Check is a unit test framework for C. It features a simple interface
23for defining unit tests, putting little in the way of the developer.
24Tests are run in a separate address space, so Check can catch both
25assertion failures and code errors that cause segmentation faults or
26other signals. The output from unit tests can be used within source
27code editors and IDEs.
28
29
30%package devel
31Summary:        Libraries and headers for developing programs with check
32Summary(ja):    Check を使ったプログラム開発用ライブラリとヘッダファイル
33Group:          Development/Libraries
34Requires:       pkgconfig
35Requires:       %{name} = %{version}-%{release}
36
37%description devel
38Libraries and headers for developing programs with check
39
40
[7064]41%package tools
42Summary:        The tools for %{name}
43Summary(ja):    Check 用のツール
[9086]44Group:          Development/Tools
[7064]45Requires:       %{name} = %{version}-%{release}
46
47%description tools
48This package contains check tool "chkckmk".
49checkmk, a tool for reducing "boilerplate coding" when writing unit tests with check.
50
51
[521]52%prep
53%setup -q
54%patch0 -p1
55
56%build
[890]57%configure --disable-static
58make %{?_smp_mflags}
[521]59
60
61%install
62rm -rf $RPM_BUILD_ROOT
63%makeinstall
64rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
65rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
66
67rm -rf example
68cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/check/example .
69rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/check
70
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%post
77/sbin/ldconfig
78/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
79
80
81%postun -p /sbin/ldconfig
82
83%preun
84if [ $1 = 0 ]; then
85    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
86fi
87
88
89%files
90%defattr(-,root,root)
91%doc AUTHORS COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
92%{_libdir}/libcheck.so.*
93%{_infodir}/check.info*
94
95%files devel
96%defattr(-,root,root)
97%doc example
98%{_includedir}/check.h
[8369]99%{_includedir}/check_stdint.h
[521]100%{_libdir}/libcheck.so
101%{_libdir}/pkgconfig/check.pc
102%{_datadir}/aclocal/check.m4
103
[7064]104%files tools
105%defattr(-,root,root)
106%{_bindir}/checkmk
107%{_mandir}/man1/checkmk.1.gz
108
109
[521]110%changelog
[9086]111* Thu Nov 13 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.14-1
112- new upstream release
113
[8369]114* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.12-1
115- new upstream release
116
[7064]117* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-1
118- new upstream release
119- create %{name}-tools sub package
120
[1958]121* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
122- rebuilt with rpm-4.8.1 for pkg-config
123
[890]124* Sat Apr 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.8-1
125- new upstream release
126- dropt Patch1
127
[521]128* Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.5-2
129- spec in UTF-8
130- split devel subpackage
131
132* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-1vl5
133- new upstream release
134- updated Patch1
135
136* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl2
137- enable -fPIC to build gstreamer on x86_64
138
139* Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl1
140- upstream release
141- add BuildRequires: docbook-utils instead of lyx
142
143* Fri Aug  1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.8.4-0vl2
144- Rebuild for new Vine.
145
146* Wed Jun 18 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 0.8.4-0vl1
147- Initial build.
148
Note: See TracBrowser for help on using the repository browser.