source: projects/specs/trunk/c/check/check-vl.spec @ 8369

Revision 8369, 3.6 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.1

Line 
1Summary:        A unit test framework for C
2Summary(ja):    C 言語用単体テストフレームワーク
3Name:           check
4Version:        0.9.12
5Release:        1%{?_dist_release}
6License:        LGPL
7Group:          Development/Tools
8URL:            http://check.sourceforge.net/
9Source0:        http://prdownloads.sourceforge.net/check/%{name}-%{version}.tar.gz
10Patch0:         %{name}-examples-bootstrap.patch
11Patch1:         check-0.9.5-fPIC.patch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  docbook-utils
14Requires(post,preun): /sbin/install-info
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18Packager:       USAMI Kosuke <usami-k@yc5.so-net.ne.jp>
19
20%description
21Check is a unit test framework for C. It features a simple interface
22for defining unit tests, putting little in the way of the developer.
23Tests are run in a separate address space, so Check can catch both
24assertion failures and code errors that cause segmentation faults or
25other signals. The output from unit tests can be used within source
26code editors and IDEs.
27
28
29%package devel
30Summary:        Libraries and headers for developing programs with check
31Summary(ja):    Check を使ったプログラム開発用ライブラリとヘッダファイル
32Group:          Development/Libraries
33Requires:       pkgconfig
34Requires:       %{name} = %{version}-%{release}
35
36%description devel
37Libraries and headers for developing programs with check
38
39
40%package tools
41Summary:        The tools for %{name}
42Summary(ja):    Check 用のツール
43Group:          Development/Languages
44Requires:       %{name} = %{version}-%{release}
45
46%description tools
47This package contains check tool "chkckmk".
48checkmk, a tool for reducing "boilerplate coding" when writing unit tests with check.
49
50
51%prep
52%setup -q
53%patch0 -p1
54#patch1 -p1 -b .fPIC
55
56
57%build
58%configure --disable-static
59make %{?_smp_mflags}
60
61
62%install
63rm -rf $RPM_BUILD_ROOT
64%makeinstall
65rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
66rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
67
68rm -rf example
69cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/check/example .
70rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/check
71
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76
77%post
78/sbin/ldconfig
79/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
80
81
82%postun -p /sbin/ldconfig
83
84%preun
85if [ $1 = 0 ]; then
86    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
87fi
88
89
90%files
91%defattr(-,root,root)
92%doc AUTHORS COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
93%{_libdir}/libcheck.so.*
94%{_infodir}/check.info*
95
96
97%files devel
98%defattr(-,root,root)
99%doc example
100%{_includedir}/check.h
101%{_includedir}/check_stdint.h
102%{_libdir}/libcheck.so
103%{_libdir}/pkgconfig/check.pc
104%{_datadir}/aclocal/check.m4
105
106
107%files tools
108%defattr(-,root,root)
109%{_bindir}/checkmk
110%{_mandir}/man1/checkmk.1.gz
111
112
113%changelog
114* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.12-1
115- new upstream release
116
117* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-1
118- new upstream release
119- create %{name}-tools sub package
120
121* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
122- rebuilt with rpm-4.8.1 for pkg-config
123
124* Sat Apr 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.8-1
125- new upstream release
126- dropt Patch1
127
128* Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.5-2
129- spec in UTF-8
130- split devel subpackage
131
132* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-1vl5
133- new upstream release
134- updated Patch1
135
136* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl2
137- enable -fPIC to build gstreamer on x86_64
138
139* Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl1
140- upstream release
141- add BuildRequires: docbook-utils instead of lyx
142
143* Fri Aug  1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.8.4-0vl2
144- Rebuild for new Vine.
145
146* Wed Jun 18 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 0.8.4-0vl1
147- Initial build.
148
Note: See TracBrowser for help on using the repository browser.