source: projects/specs/trunk/c/cfitsio/cfitsio-vl.spec @ 4722

Revision 4722, 8.3 KB checked in by inagaki, 13 years ago (diff)

update: libindi, libnova, cfitsio

RevLine 
[521]1Name:           cfitsio
2Summary:        Library for manipulating FITS data files
[4722]3Summary(ja):    FITS データファイルを処理するためのライブラリ
4Version:        3.280
5Release:        1%{?_dist_release}
[521]6
7Group:          System Environment/Libraries
[4722]8License:        MIT
[521]9URL:            http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
[4722]10
11Source0:        ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/cfitsio3280.tar.gz
12Patch0:         cfitsio.patch
13Patch1:         cfitsio-pkgconfig.patch
14
[521]15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
[4722]16BuildRequires:  gcc-gfortran
[521]17
[4722]18Requires(post): /sbin/ldconfig
19Requires(postun): /sbin/ldconfig
[521]20
21%description
22CFITSIO is a library of C and FORTRAN subroutines for reading and writing
23data files in FITS (Flexible Image Transport System) data format. CFITSIO
24simplifies the task of writing software that deals with FITS files by
25providing an easy to use set of high-level routines that insulate the
26programmer from the internal complexities of the FITS file format. At the
27same time, CFITSIO provides many advanced features that have made it the
28most widely used FITS file programming interface in the astronomical
29community.
30
31%package devel
[4722]32Summary: Headers required when building programs against cfitsio
[521]33Group:  Development/Libraries
34Requires: %{name} = %{version}-%{release}
35Requires: pkgconfig
36
37%description devel
38Headers required when building a program against the cfitsio library.
39
40%package static
[4722]41Summary: Static cfitsio library
[521]42Group: Development/Libraries
[4722]43Requires: %{name}-devel = %{version}-%{release}
[521]44
45%description static
46Static cfitsio library; avoid use if possible.
47
48%package docs
49Summary: Documentation for cfitsio
50Group:  Development/Libraries
[4722]51BuildArch: noarch
[521]52
53%description docs
54Stand-alone documentation for cfitsio.
55
56%prep
57%setup -q -n cfitsio
[4722]58%patch0 -p1
59%patch1 -p1
[521]60
61%build
62FC=f95
63export FC
64export CC=gcc # fixes -O*, -g
65%configure
66make shared %{?_smp_mflags}
[4722]67ln -s libcfitsio.so.0 libcfitsio.so
68make fpack %{?_smp_mflags}
69make funpack %{?_smp_mflags}
[521]70unset FC
[4722]71# Manually fix pkgconfig .pc file (BZ 436539, BZ 618291)
72sed 's|/usr/include|/usr/include/%{name}|' cfitsio.pc >cfitsio.pc.new
[521]73mv cfitsio.pc.new cfitsio.pc
74
75%check
76make testprog
77LD_LIBRARY_PATH=. ./testprog > testprog.lis
78cmp -s testprog.lis testprog.out
79cmp -s testprog.fit testprog.std
80
81%install
82rm -rf %{buildroot}
83mkdir -p %{buildroot}
84mkdir -p %{buildroot}%{_libdir}
85mkdir -p %{buildroot}%{_includedir}/%{name}
86make LIBDIR=%{_lib} INCLUDEDIR=include/%{name} CFITSIO_LIB=%{buildroot}%{_libdir} \
87     CFITSIO_INCLUDE=%{buildroot}%{_includedir}/%{name} install
88pushd %{buildroot}%{_libdir}
89ln -s libcfitsio.so.0 libcfitsio.so
90popd
91
92%clean
93rm -rf %{buildroot}
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99%files
100%defattr(-,root,root,-)
101%doc README License.txt changes.txt
102%{_libdir}/libcfitsio.so.*
103
104%files devel
105%defattr(-,root,root,-)
106%{_includedir}/%{name}
107%{_libdir}/libcfitsio.so
108%{_libdir}/pkgconfig/cfitsio.pc
109
110%files static
111%defattr(-,root,root,-)
112%{_libdir}/libcfitsio.a
113
114%files docs
115%defattr(-,root,root,-)
116%doc fitsio.doc fitsio.ps cfitsio.doc cfitsio.ps
117
118%changelog
[4722]119* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.280-1
120- new upstream release
121- added Patch1
122
[1928]123* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 3.240-2
124- rebuilt with rpm-4.8.1 for pkg-config
125
[846]126* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.240-1
127- new upstream release
128
[521]129* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.140-3
130- Initial build for Vine Linux
131
132* Fri Jul 24 2009 Matthew Truch <matt at truch.net> - 3.140-2
133- Bump to include proper tarball.
134
135* Tue Jul 21 2009 Matthew Truch <matt at truch.net> - 3.140-1
136- Update to upstream 3.140 release.
137- Bump for mass rebuild.
138
139* Wed Jun 17 2009 Matthew Truch <matt at truch.net> - 3.130-5
140- Separate -docs noarch subpackage as per BZ 492438.
141- Explicitly set file attributes correctly. 
142
143* Tue Mar 10 2009 Matthew Truch <matt at truch.net> - 3.130-4
144- Set correct version in pkgconfig .pc file. 
145
146* Sun Feb 22 2009 Matthew Truch <matt at truch.net> - 3.130-3
147- Re-check testprogram output.
148- Build for koji, rpm, gcc upgrade. 
149
150* Thu Feb 5 2009 Matthew Truch <matt at truch.net> - 3.130-2
151- Fix source file naming typo.
152
153* Wed Feb 4 2009 Matthew Truch <matt at truch.net> - 3.130-1
154- Update to 3.130 upstream.
155
156* Sat Sep 20 2008 Matthew Truch <matt at truch.net> - 3.100-2
157- Test library with included test-suite. 
158
159* Fri Sep 19 2008 Matthew Truch <matt at truch.net> - 3.100-1
160- Update to 3.100 upstream.
161  Includes bugfixes and new compression scheme.
162
163* Fri Mar 7 2008 Matthew Truch <matt at truch.net> - 3.060-3
164- Properly indicated include and lib directories in .pc file
165  (BZ 436539)
166- Fix typo in -static descrition.
167
168* Mon Feb 11 2008 Matthew Truch <matt at truch.net> - 3.060-2
169- Bump release for rebuild.
170
171* Fri Nov 9 2007 Matthew Truch <matt at truch.net> - 3.060-1
172- Update to 3.060 bugfix release.
173- Add static package (BZ 372801)
174
175* Tue Aug 21 2007 Matthew Truch <matt at truch.net> - 3.040-3
176- Bump release for rebuild (build-id etc.)
177
178* Thu Aug 2 2007 Matthew Truch <matt at truch.net> - 3.040-2
179- Update License tag
180
181* Mon Jul 9 2007 Matthew Truch <matt at truch.net> - 3.040-1
182- Upgrade to version 3.040 of cfitsio.
183
184* Fri Feb 16 2007 Matthew Truch <matt at truch.net> - 3.030-2
185- Require pkgconfig for -devel.
186- export CC=gcc so we don't clobber $RPM_OPT_FLAGS, thereby
187  ruining any -debuginfo packages. 
188  See RedHat Bugzilla 229041.
189
190* Fri Jan 5 2007 Matthew Truch <matt at truch.net> - 3.030-1
191- Upgrade to version 3.020 of cfitsio.
192
193* Fri Dec 8 2006 Matthew Truch <matt at truch.net> - 3.020-3
194- Commit correct patch to configure and Makefiles.
195
196* Fri Dec 8 2006 Matthew Truch <matt at truch.net> - 3.020-2
197- Modify spec file to install to correct directories.
198- Package cfitsio.pc file in -devel package.
199
200* Wed Dec 6 2006 Matthew Truch <matt at truch.net> - 3.020-1
201- Upgrade to revision 3.020 of cfitsio.
202
203* Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 3.006-6
204- Bump release for rebuild in prep. for FC6.
205
206* Thu Mar 30 2006 Matthew Truch <matt at truch.net> - 3.006-5
207- Include defattr() for devel package as well - bug 187366
208
209* Sun Mar 19 2006 Matthew Truch <matt at truch.net> - 3.006-4
210- Don't use macro {buildroot} in build, only in install as per
211  appended comments to Bugzilla bug 172042
212 
213* Fri Mar 10 2006 Matthew Truch <matt at truch.net> - 3.006-3
214- Point to f95 instead of g95 as per bugzilla bug 185107
215
216* Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.006-2
217- Fix spelling typo in name of License.txt file.
218
219* Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.006-1
220- Use new 3.006 fully official stable (non-beta) upstream package.
221
222* Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.005-0.2.beta
223- Bump release for FC5 extras rebuild.
224
225* Fri Dec 23 2005 Matthew Truch <matt at truch.net> - 3.005-0.1.beta
226- Update to 3.005beta release.
227
228* Mon Nov 14 2005 Matthew Truch <matt at truch.net> - 3.004-0.12.b
229- Put in proper URL and Source addresses.
230- Sync up spec files.
231
232* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.11.b
233- Clean up unused code in spec file.
234
235* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.10.b
236- Set environment variables correctly.
237- Include patch so Makefile will put things where they belong.
238
239* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.9.b
240- Set libdir and includedir correctly for build process.
241
242* Sat Nov 12 2005 Matthew Truch <matt at truch.net> - 3.004-0.8.b
243- unset FC once we are done with the build
244
245* Sat Nov 12 2005 Ed Hill <ed@eh3.com> - 3.004-0.7.b
246- shared libs and small cleanups
247
248* Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.6.b
249- Own include directory created by the devel package.
250
251* Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.5.b
252- Shorten summary.
253- Improve specfile post and postun syntax.
254- Install headers in cfitsio include subdir.
255- Include more documentation provided in tarball.
256
257* Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.4.b
258- Require cfitsio for cfitsio-devel
259
260* Sat Nov 05 2005 Matthew Truch <matt at truch.net> - 3.004-0.3.b
261- Use proper virgin tarball from upstream.
262
263* Sun Oct 30 2005 Matthew Truch <matt at truch.net> - 3.004-0.2.b
264- Include gcc-gfortran build requirment and make sure it gets used.
265- Use macros instead of hard coded paths.
266- Include home page in description
267
268* Sat Oct 29 2005 Matthew Truch <matt at truch.net> - 3.004-0.1.b
269- Initial spec file for Fedora Extras.
270
Note: See TracBrowser for help on using the repository browser.