source: projects/specs/trunk/c/cfitsio/cfitsio-vl.spec @ 9382

Revision 9382, 10.1 KB checked in by inagaki, 9 years ago (diff)

2015-02-25 Ryoichi INAGAKI <ryo1@…>

  • cfitsio, libnova: updated
  • kstars, libfli, libindi, ufraw: rebuilt


Line 
1Name:           cfitsio
2Version:        3.370
3Release:        1%{?_dist_release}
4Summary:        Library for manipulating FITS data files
5Summary(ja):    FITS データファイルを処理するためのライブラリ
6
7Group:          System Environment/Libraries
8License:        MIT
9URL:            http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
10
11Source0:        ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/cfitsio3370.tar.gz
12# Unbundles zlib
13Patch0:         cfitsio-zlib.patch
14# Remove soname version check
15Patch1:         cfitsio-noversioncheck.patch
16# Some rearrangements in pkg-config file
17Patch2:         cfitsio-pkgconfig.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildRequires:  gcc-gfortran
21BuildRequires:  bzip2-devel
22BuildRequires:  zlib-devel
23
24Requires(post): /sbin/ldconfig
25Requires(postun): /sbin/ldconfig
26
27%description
28CFITSIO is a library of C and FORTRAN subroutines for reading and writing
29data files in FITS (Flexible Image Transport System) data format. CFITSIO
30simplifies the task of writing software that deals with FITS files by
31providing an easy to use set of high-level routines that insulate the
32programmer from the internal complexities of the FITS file format. At the
33same time, CFITSIO provides many advanced features that have made it the
34most widely used FITS file programming interface in the astronomical
35community.
36
37%package devel
38Summary: Headers required when building programs against cfitsio
39Summary(ja): cfitsio を用いるプログラムのビルドに必要なヘッダファイル
40Group:  Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Requires: pkgconfig
43
44%description devel
45Headers required when building a program against the cfitsio library.
46
47%package static
48Summary: Static cfitsio library
49Summary(ja): cfitsio の静的ライブラリ
50Group: Development/Libraries
51Requires: %{name}-devel = %{version}-%{release}
52
53%description static
54Static cfitsio library; avoid use if possible.
55
56%package docs
57Summary: Documentation for cfitsio
58Summary(ja): cfitsio のドキュメント
59Group:  Documentation
60BuildArch: noarch
61
62%description docs
63Stand-alone documentation for cfitsio.
64
65%package -n fpack
66Summary: FITS image compression and decompression utilities
67Group: Applications/Engineering
68Requires: %{name} = %{version}-%{release}
69
70%description -n fpack
71fpack optimally compresses FITS format images and funpack restores them
72to the original state.
73
74* Integer format images are losslessly compressed using the Rice
75compression algorithm.
76    * typically 30% better compression than GZIP
77    * about 3 times faster compression speed than GZIP
78    * about the same uncompression speed as GUNZIP
79
80* Floating-point format images are compressed with a lossy algorithm
81    * truncates the image pixel noise by a user-specified amount to
82      produce much higher compression than by lossless techniques
83    * the precision of scientific measurements in the compressed image
84      (relative to those in the original image) depends on the selected
85       amount of compression
86
87%prep
88%setup -q -n cfitsio
89%patch0 -p1
90%patch1 -p1
91%patch2 -p1
92
93# remove bundled zlib
94# not all the files inside zlib belong to zlib
95pushd zlib
96rm adler32.c crc32.c deflate.c infback.c inffast.c inflate.c inflate.h \
97inftrees.c inftrees.h zlib.h deflate.h trees.c trees.h uncompr.c zconf.h \
98zutil.c zutil.h crc32.h  inffast.h  inffixed.h
99popd
100
101%build
102%configure \
103    --enable-reentrant \
104%ifarch x86_64
105    --enable-sse2 \
106%endif
107    --with-bzip2
108make shared %{?_smp_mflags}
109make fpack %{?_smp_mflags}
110make funpack %{?_smp_mflags}
111
112%check
113make testprog
114LD_LIBRARY_PATH=. ./testprog > testprog.lis
115cmp -s testprog.lis testprog.out
116cmp -s testprog.fit testprog.std
117
118%install
119rm -rf %{buildroot}
120mkdir -p %{buildroot}
121mkdir -p %{buildroot}%{_bindir}
122mkdir -p %{buildroot}%{_libdir}
123mkdir -p %{buildroot}%{_includedir}/%{name}
124make LIBDIR=%{_lib} INCLUDEDIR=include/%{name} \
125     CFITSIO_LIB=%{buildroot}%{_libdir} \
126     CFITSIO_INCLUDE=%{buildroot}%{_includedir}/%{name} install
127cp -p f{,un}pack %{buildroot}%{_bindir}
128
129chmod 755 %{buildroot}%{_libdir}/libcfitsio.so.*
130chmod 755 %{buildroot}%{_bindir}/f{,un}pack
131
132
133%clean
134rm -rf %{buildroot}
135
136%post -p /sbin/ldconfig
137
138%postun -p /sbin/ldconfig
139
140%files
141%defattr(-,root,root,-)
142%doc README License.txt docs/changes.txt
143%{_libdir}/libcfitsio.so.*
144
145%files devel
146%defattr(-,root,root,-)
147%{_includedir}/%{name}
148%{_libdir}/libcfitsio.so
149%{_libdir}/pkgconfig/cfitsio.pc
150
151%files static
152%defattr(-,root,root,-)
153%{_libdir}/libcfitsio.a
154
155%files docs
156%defattr(-,root,root,-)
157%doc docs/fitsio.doc docs/fitsio.pdf docs/cfitsio.doc docs/cfitsio.pdf License.txt
158
159%files -n fpack
160%defattr(-,root,root,-)
161%doc docs/fpackguide.pdf License.txt
162%{_bindir}/fpack
163%{_bindir}/funpack
164
165%changelog
166* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 3.370-1
167- new upstream release
168- moved docs subpackages to Documentation Group
169
170* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.280-1
171- new upstream release
172- added Patch1
173
174* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 3.240-2
175- rebuilt with rpm-4.8.1 for pkg-config
176
177* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.240-1
178- new upstream release
179
180* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.140-3
181- Initial build for Vine Linux
182
183* Fri Jul 24 2009 Matthew Truch <matt at truch.net> - 3.140-2
184- Bump to include proper tarball.
185
186* Tue Jul 21 2009 Matthew Truch <matt at truch.net> - 3.140-1
187- Update to upstream 3.140 release.
188- Bump for mass rebuild.
189
190* Wed Jun 17 2009 Matthew Truch <matt at truch.net> - 3.130-5
191- Separate -docs noarch subpackage as per BZ 492438.
192- Explicitly set file attributes correctly. 
193
194* Tue Mar 10 2009 Matthew Truch <matt at truch.net> - 3.130-4
195- Set correct version in pkgconfig .pc file. 
196
197* Sun Feb 22 2009 Matthew Truch <matt at truch.net> - 3.130-3
198- Re-check testprogram output.
199- Build for koji, rpm, gcc upgrade. 
200
201* Thu Feb 5 2009 Matthew Truch <matt at truch.net> - 3.130-2
202- Fix source file naming typo.
203
204* Wed Feb 4 2009 Matthew Truch <matt at truch.net> - 3.130-1
205- Update to 3.130 upstream.
206
207* Sat Sep 20 2008 Matthew Truch <matt at truch.net> - 3.100-2
208- Test library with included test-suite. 
209
210* Fri Sep 19 2008 Matthew Truch <matt at truch.net> - 3.100-1
211- Update to 3.100 upstream.
212  Includes bugfixes and new compression scheme.
213
214* Fri Mar 7 2008 Matthew Truch <matt at truch.net> - 3.060-3
215- Properly indicated include and lib directories in .pc file
216  (BZ 436539)
217- Fix typo in -static descrition.
218
219* Mon Feb 11 2008 Matthew Truch <matt at truch.net> - 3.060-2
220- Bump release for rebuild.
221
222* Fri Nov 9 2007 Matthew Truch <matt at truch.net> - 3.060-1
223- Update to 3.060 bugfix release.
224- Add static package (BZ 372801)
225
226* Tue Aug 21 2007 Matthew Truch <matt at truch.net> - 3.040-3
227- Bump release for rebuild (build-id etc.)
228
229* Thu Aug 2 2007 Matthew Truch <matt at truch.net> - 3.040-2
230- Update License tag
231
232* Mon Jul 9 2007 Matthew Truch <matt at truch.net> - 3.040-1
233- Upgrade to version 3.040 of cfitsio.
234
235* Fri Feb 16 2007 Matthew Truch <matt at truch.net> - 3.030-2
236- Require pkgconfig for -devel.
237- export CC=gcc so we don't clobber $RPM_OPT_FLAGS, thereby
238  ruining any -debuginfo packages. 
239  See RedHat Bugzilla 229041.
240
241* Fri Jan 5 2007 Matthew Truch <matt at truch.net> - 3.030-1
242- Upgrade to version 3.020 of cfitsio.
243
244* Fri Dec 8 2006 Matthew Truch <matt at truch.net> - 3.020-3
245- Commit correct patch to configure and Makefiles.
246
247* Fri Dec 8 2006 Matthew Truch <matt at truch.net> - 3.020-2
248- Modify spec file to install to correct directories.
249- Package cfitsio.pc file in -devel package.
250
251* Wed Dec 6 2006 Matthew Truch <matt at truch.net> - 3.020-1
252- Upgrade to revision 3.020 of cfitsio.
253
254* Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 3.006-6
255- Bump release for rebuild in prep. for FC6.
256
257* Thu Mar 30 2006 Matthew Truch <matt at truch.net> - 3.006-5
258- Include defattr() for devel package as well - bug 187366
259
260* Sun Mar 19 2006 Matthew Truch <matt at truch.net> - 3.006-4
261- Don't use macro {buildroot} in build, only in install as per
262  appended comments to Bugzilla bug 172042
263 
264* Fri Mar 10 2006 Matthew Truch <matt at truch.net> - 3.006-3
265- Point to f95 instead of g95 as per bugzilla bug 185107
266
267* Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.006-2
268- Fix spelling typo in name of License.txt file.
269
270* Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.006-1
271- Use new 3.006 fully official stable (non-beta) upstream package.
272
273* Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.005-0.2.beta
274- Bump release for FC5 extras rebuild.
275
276* Fri Dec 23 2005 Matthew Truch <matt at truch.net> - 3.005-0.1.beta
277- Update to 3.005beta release.
278
279* Mon Nov 14 2005 Matthew Truch <matt at truch.net> - 3.004-0.12.b
280- Put in proper URL and Source addresses.
281- Sync up spec files.
282
283* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.11.b
284- Clean up unused code in spec file.
285
286* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.10.b
287- Set environment variables correctly.
288- Include patch so Makefile will put things where they belong.
289
290* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.9.b
291- Set libdir and includedir correctly for build process.
292
293* Sat Nov 12 2005 Matthew Truch <matt at truch.net> - 3.004-0.8.b
294- unset FC once we are done with the build
295
296* Sat Nov 12 2005 Ed Hill <ed@eh3.com> - 3.004-0.7.b
297- shared libs and small cleanups
298
299* Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.6.b
300- Own include directory created by the devel package.
301
302* Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.5.b
303- Shorten summary.
304- Improve specfile post and postun syntax.
305- Install headers in cfitsio include subdir.
306- Include more documentation provided in tarball.
307
308* Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.4.b
309- Require cfitsio for cfitsio-devel
310
311* Sat Nov 05 2005 Matthew Truch <matt at truch.net> - 3.004-0.3.b
312- Use proper virgin tarball from upstream.
313
314* Sun Oct 30 2005 Matthew Truch <matt at truch.net> - 3.004-0.2.b
315- Include gcc-gfortran build requirment and make sure it gets used.
316- Use macros instead of hard coded paths.
317- Include home page in description
318
319* Sat Oct 29 2005 Matthew Truch <matt at truch.net> - 3.004-0.1.b
320- Initial spec file for Fedora Extras.
321
Note: See TracBrowser for help on using the repository browser.