source: projects/specs/trunk/c/cdparanoia/cdparanoia-vl.spec @ 521

Revision 521, 5.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
2Name: cdparanoia
3Version: 10.2
4Release: 1%{?_dist_release}
5License: GPLv2 and LGPLv2
6Group: Applications/Multimedia
7Source: http://www.xiph.org/paranoia/download/%{name}-III-%{version}.src.tgz
8Patch0: cdparanoia-fPIC.patch
9# Patch from upstream to fix cdda_interface.h C++ incompatibility ("private")
10# https://trac.xiph.org/changeset/15338
11# https://bugzilla.redhat.com/show_bug.cgi?id=463009
12Patch1: cdparanoia-10.2-#463009.patch
13#Patch1: cdparanoia-gcc4-build.patch
14URL: http://www.xiph.org/paranoia/index.html
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17%description
18Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
19writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
20PCM format.  Cdparanoia doesn't contain any extra features (like the ones
21included in the cdda2wav sampling utility).  Instead, cdparanoia's strength
22lies in its ability to handle a variety of hardware, including inexpensive
23drives prone to misalignment, frame jitter and loss of streaming during
24atomic reads.  Cdparanoia is also good at reading and repairing data from
25damaged CDs.
26
27%package devel
28Summary: Development tools for libcdda_paranoia (Paranoia III).
29Group: Development/Libraries
30Requires: %{name} = %{version}
31License: LGPLv2
32
33%description devel
34The cdparanoia-devel package contains the static libraries and header
35files needed for developing applications to read CD Digital Audio disks.
36
37%prep
38%setup -q -n %{name}-III-%{version}
39%patch1 -p3 -b .#463009
40#patch0 -p1 -b .fPIC
41#patch1 -p1
42
43%build
44export OPT="${CFLAGS:-%optflags} -O0 -Wno-pointer-sign -Wno-unused -Werror-implicit-function-declaration"
45%configure --includedir=%{_includedir}/cdda
46make OPT="$OPT"
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51install -d $RPM_BUILD_ROOT%{_bindir}
52install -d $RPM_BUILD_ROOT%{_includedir}/cdda
53install -d $RPM_BUILD_ROOT%{_libdir}
54install -d $RPM_BUILD_ROOT%{_mandir}/man1
55install -m 0755 cdparanoia $RPM_BUILD_ROOT%{_bindir}
56install -m 0644 cdparanoia.1 $RPM_BUILD_ROOT%{_mandir}/man1/
57install -m 0644 utils.h paranoia/cdda_paranoia.h interface/cdda_interface.h \
58        $RPM_BUILD_ROOT%{_includedir}/cdda
59install -m 0755 paranoia/libcdda_paranoia.so.0.10.? \
60        interface/libcdda_interface.so.0.10.? \
61        $RPM_BUILD_ROOT%{_libdir}
62install -m 0755 paranoia/libcdda_paranoia.a interface/libcdda_interface.a \
63        $RPM_BUILD_ROOT%{_libdir}
64install -d $RPM_BUILD_ROOT%{_mandir}/ja/man1
65install -m 0644 cdparanoia.1.jp $RPM_BUILD_ROOT%{_mandir}/ja/man1/cdparanoia.1
66
67/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_libdir}
68
69pushd $RPM_BUILD_ROOT%{_libdir}
70ln -s libcdda_paranoia.so.0.10.? libcdda_paranoia.so
71ln -s libcdda_interface.so.0.10.? libcdda_interface.so
72popd
73
74%post -p /sbin/ldconfig
75
76%postun -p /sbin/ldconfig
77
78%clean
79[ "$RPM_BUILD_ROOT" != "/" -a -d "$RPM_BUILD_ROOT" ] && rm -rf "$RPM_BUILD_ROOT"
80
81%files
82%defattr(-,root,root)
83%doc README COPYING-GPL COPYING-LGPL
84%{_bindir}/*
85%{_mandir}/man1/*
86%{_mandir}/ja/man1/*
87%{_libdir}/lib*.so*
88
89%files devel
90%defattr(-,root,root)
91%{_includedir}/cdda
92%{_libdir}/*.a
93
94%changelog
95* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-1
96- new upstream release
97- added Requires: cdparanoia to devel package
98
99* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> alpha9.8-9vl5
100- applied new versioning policy
101
102* Tue Jul  3 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> alpha9.8-8vl6
103- add Patch1
104
105* Tue Oct 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> alpha9.8-8vl5
106- added fPIC.patch fix a problem on x86_64 archtecture
107
108* Fri Dec 26 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> alpha9.8-8vl4
109- rebuild with new toolchain
110
111* Sun Mar 16 2003 IWAI Masaharu <iwai@alib.jp> alpha9.8-8vl3
112- rebuild with new toolchain
113
114* Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
115- alpha9.8-8vl2
116- rebuild on VineSeed
117
118* Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
119- alpha9.8-8vl1
120- included japanese manual
121
122* Tue Feb 27 2001 Karsten Hopp <karsten@redhat.de>
123- fix spelling error in description
124
125* Thu Dec  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
126- rebuild for new tree
127
128* Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
129- use %%{_tmppath}
130
131* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
132- automatic rebuild
133
134* Wed Jun 06 2000 Preston Brown <pbrown@redhat.com>
135- revert name change
136- use new rpm macro paths
137
138* Wed Apr 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
139- Switched spec file from the one used in Red Hat Linux 6.2, which
140  also changes the name
141- gzip man page
142
143* Thu Dec 23 1999 Peter Jones <pjones@redhat.com>
144- update package to provide cdparanoia-alpha9.7-2.*.rpm and
145  cdparanoia-devel-alpha9.7-2.*.rpm.  Also, URLs point at xiph.org
146  like they should.
147
148* Wed Dec 22 1999 Peter Jones <pjones@redhat.com>
149- updated package for alpha9.7, based on input from:
150  Monty <xiphmont@xiph.org>
151  David Philippi <david@torangan.saar.de>
152
153* Mon Apr 12 1999 Michael Maher <mike@redhat.com>
154- updated pacakge
155
156* Tue Oct 06 1998 Michael Maher <mike@redhat.com>
157- updated package
158
159* Mon Jun 29 1998 Michael Maher <mike@redhat.com>
160- built package
Note: See TracBrowser for help on using the repository browser.