source: projects/specs/trunk/c/cdparanoia/cdparanoia-vl.spec @ 11507

Revision 11507, 6.5 KB checked in by tomop, 6 years ago (diff)

cdparanoia-10.2-4

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: cdparanoia
4Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
5Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
6Version: 10.2
7Release: 4%{?_dist_release}
8
9Group: Applications/Multimedia
10License: GPLv2 and LGPLv2
11URL: http://www.xiph.org/paranoia/index.html
12
13Source: http://www.xiph.org/paranoia/download/%{name}-III-%{version}.src.tgz
14# Patch from upstream to fix cdda_interface.h C++ incompatibility ("private")
15# https://trac.xiph.org/changeset/15338
16# https://bugzilla.redhat.com/show_bug.cgi?id=463009
17Patch0: cdparanoia-10.2-#463009.patch
18# #466659
19Patch1: cdparanoia-10.2-endian.patch
20Patch2: cdparanoia-10.2-install.patch
21Patch3: cdparanoia-10.2-format-security.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25%description
26Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
27writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
28PCM format.  Cdparanoia doesn't contain any extra features (like the ones
29included in the cdda2wav sampling utility).  Instead, cdparanoia's strength
30lies in its ability to handle a variety of hardware, including inexpensive
31drives prone to misalignment, frame jitter and loss of streaming during
32atomic reads.  Cdparanoia is also good at reading and repairing data from
33damaged CDs.
34
35%package devel
36Summary: Development tools for libcdda_paranoia (Paranoia III).
37Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
38Group: Development/Libraries
39License: LGPLv2
40Requires: %{name} = %{version}-%{release}
41
42%description devel
43The cdparanoia-devel package contains the static libraries and header
44files needed for developing applications to read CD Digital Audio disks.
45
46# compat32
47%package -n compat32-%{name}
48Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
49Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
50Group: Applications/Multimedia
51Requires: %{name} = %{version}-%{release}
52
53%description -n compat32-%{name}
54Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
55writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
56PCM format.  Cdparanoia doesn't contain any extra features (like the ones
57included in the cdda2wav sampling utility).  Instead, cdparanoia's strength
58lies in its ability to handle a variety of hardware, including inexpensive
59drives prone to misalignment, frame jitter and loss of streaming during
60atomic reads.  Cdparanoia is also good at reading and repairing data from
61damaged CDs.
62
63%package -n compat32-%{name}-devel
64Summary: Development tools for libcdda_paranoia (Paranoia III).
65Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
66Group: Development/Libraries
67Requires: compat32-%{name} = %{version}-%{release}
68Requires: %{name}-devel = %{version}-%{release}
69
70%description -n compat32-%{name}-devel
71The cdparanoia-devel package contains the static libraries and header
72files needed for developing applications to read CD Digital Audio disks.
73
74
75%prep
76%setup -q -n %{name}-III-%{version}
77%patch0 -p3 -b .#463009
78%patch1 -p1 -b .endian
79%patch2 -p1 -b .install
80%patch3 -p1 -b .fmt-sec
81
82%build
83%configure --includedir=%{_includedir}/cdda
84# Using -O0 is mandatory, the build fails otherwise...
85# Also remove many warnings which we are aware of
86# Lastly, don't use _smp_mflags since it also makes the build fail
87make OPT="$RPM_OPT_FLAGS -O0 -Wno-pointer-sign -Wno-unused"
88
89%install
90rm -rf $RPM_BUILD_ROOT
91make install DESTDIR=$RPM_BUILD_ROOT
92mkdir -p %{buildroot}%{_mandir}/ja/man1
93install -m644 cdparanoia.1.jp %{buildroot}%{_mandir}/ja/man1/cdparanoia.1
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99%post -n compat32-%{name} -p /sbin/ldconfig
100
101%postun -n compat32-%{name} -p /sbin/ldconfig
102
103%clean
104[ "$RPM_BUILD_ROOT" != "/" -a -d "$RPM_BUILD_ROOT" ] && rm -rf "$RPM_BUILD_ROOT"
105
106%files
107%defattr(-,root,root)
108%doc README COPYING-GPL COPYING-LGPL
109%{_bindir}/*
110%{_libdir}/lib*.so.*
111%{_mandir}/man1/*
112%{_mandir}/ja/man1/*
113
114%files devel
115%defattr(-,root,root)
116%{_includedir}/cdda
117%{_libdir}/lib*.so
118%{_libdir}/*.a
119
120# compat32
121%if %{build_compat32}
122%files -n compat32-%{name}
123%defattr(-, root, root)
124%{_libdir}/*.so.*
125
126%files -n compat32-%{name}-devel
127%defattr(-, root, root)
128%{_libdir}/*.so
129%endif
130
131%changelog
132* Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.2-4
133- imported Patch1-3 from rawhide.
134
135* Wed Jan 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.2-3
136- create compat32 sub packages
137
138* Sun Apr 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-2
139- rebuilt with new toolchain
140- added Japanese summary
141
142* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-1
143- new upstream release
144- added Requires: cdparanoia to devel package
145
146* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> alpha9.8-9vl5
147- applied new versioning policy
148
149* Tue Jul  3 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> alpha9.8-8vl6
150- add Patch1
151
152* Tue Oct 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> alpha9.8-8vl5
153- added fPIC.patch fix a problem on x86_64 archtecture
154
155* Fri Dec 26 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> alpha9.8-8vl4
156- rebuild with new toolchain
157
158* Sun Mar 16 2003 IWAI Masaharu <iwai@alib.jp> alpha9.8-8vl3
159- rebuild with new toolchain
160
161* Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
162- alpha9.8-8vl2
163- rebuild on VineSeed
164
165* Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
166- alpha9.8-8vl1
167- included japanese manual
168
169* Tue Feb 27 2001 Karsten Hopp <karsten@redhat.de>
170- fix spelling error in description
171
172* Thu Dec  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
173- rebuild for new tree
174
175* Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
176- use %%{_tmppath}
177
178* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
179- automatic rebuild
180
181* Tue Jun 06 2000 Preston Brown <pbrown@redhat.com>
182- revert name change
183- use new rpm macro paths
184
185* Wed Apr 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
186- Switched spec file from the one used in Red Hat Linux 6.2, which
187  also changes the name
188- gzip man page
189
190* Thu Dec 23 1999 Peter Jones <pjones@redhat.com>
191- update package to provide cdparanoia-alpha9.7-2.*.rpm and
192  cdparanoia-devel-alpha9.7-2.*.rpm.  Also, URLs point at xiph.org
193  like they should.
194
195* Wed Dec 22 1999 Peter Jones <pjones@redhat.com>
196- updated package for alpha9.7, based on input from:
197  Monty <xiphmont@xiph.org>
198  David Philippi <david@torangan.saar.de>
199
200* Mon Apr 12 1999 Michael Maher <mike@redhat.com>
201- updated pacakge
202
203* Tue Oct 06 1998 Michael Maher <mike@redhat.com>
204- updated package
205
206* Mon Jun 29 1998 Michael Maher <mike@redhat.com>
207- built package
Note: See TracBrowser for help on using the repository browser.