source: projects/specs/trunk/c/cdparanoia/cdparanoia-vl.spec @ 5394

Revision 5394, 6.9 KB checked in by Takemikaduchi, 12 years ago (diff)

slocate: fix BTS:1176
qt4: fix compat32-qt4-devel
others: create compat32 sub packages

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: cdparanoia
4Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
5Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
6Version: 10.2
7Release: 3%{?_dist_release}
8
9Group: Applications/Multimedia
10License: GPLv2 and LGPLv2
11URL: http://www.xiph.org/paranoia/index.html
12
13Source: http://www.xiph.org/paranoia/download/%{name}-III-%{version}.src.tgz
14Patch0: cdparanoia-fPIC.patch
15# Patch from upstream to fix cdda_interface.h C++ incompatibility ("private")
16# https://trac.xiph.org/changeset/15338
17# https://bugzilla.redhat.com/show_bug.cgi?id=463009
18Patch1: cdparanoia-10.2-#463009.patch
19#Patch1: cdparanoia-gcc4-build.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23%description
24Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
25writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
26PCM format.  Cdparanoia doesn't contain any extra features (like the ones
27included in the cdda2wav sampling utility).  Instead, cdparanoia's strength
28lies in its ability to handle a variety of hardware, including inexpensive
29drives prone to misalignment, frame jitter and loss of streaming during
30atomic reads.  Cdparanoia is also good at reading and repairing data from
31damaged CDs.
32
33%package devel
34Summary: Development tools for libcdda_paranoia (Paranoia III).
35Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
36Group: Development/Libraries
37License: LGPLv2
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41The cdparanoia-devel package contains the static libraries and header
42files needed for developing applications to read CD Digital Audio disks.
43
44# compat32
45%package -n compat32-%{name}
46Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
47Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
48Group: Applications/Multimedia
49Requires: %{name} = %{version}-%{release}
50
51%description -n compat32-%{name}
52Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
53writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
54PCM format.  Cdparanoia doesn't contain any extra features (like the ones
55included in the cdda2wav sampling utility).  Instead, cdparanoia's strength
56lies in its ability to handle a variety of hardware, including inexpensive
57drives prone to misalignment, frame jitter and loss of streaming during
58atomic reads.  Cdparanoia is also good at reading and repairing data from
59damaged CDs.
60
61%package -n compat32-%{name}-devel
62Summary: Development tools for libcdda_paranoia (Paranoia III).
63Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
64Group: Development/Libraries
65Requires: compat32-%{name} = %{version}-%{release}
66Requires: %{name}-devel = %{version}-%{release}
67
68%description -n compat32-%{name}-devel
69The cdparanoia-devel package contains the static libraries and header
70files needed for developing applications to read CD Digital Audio disks.
71
72
73%prep
74%setup -q -n %{name}-III-%{version}
75%patch1 -p3 -b .#463009
76
77%build
78export OPT="${CFLAGS:-%optflags} -O0 -Wno-pointer-sign -Wno-unused -Werror-implicit-function-declaration"
79%configure --includedir=%{_includedir}/cdda
80make OPT="$OPT"
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85install -d $RPM_BUILD_ROOT%{_bindir}
86install -d $RPM_BUILD_ROOT%{_includedir}/cdda
87install -d $RPM_BUILD_ROOT%{_libdir}
88install -d $RPM_BUILD_ROOT%{_mandir}/man1
89install -m 0755 cdparanoia $RPM_BUILD_ROOT%{_bindir}
90install -m 0644 cdparanoia.1 $RPM_BUILD_ROOT%{_mandir}/man1/
91install -m 0644 utils.h paranoia/cdda_paranoia.h interface/cdda_interface.h \
92        $RPM_BUILD_ROOT%{_includedir}/cdda
93install -m 0755 paranoia/libcdda_paranoia.so.0.10.? \
94        interface/libcdda_interface.so.0.10.? \
95        $RPM_BUILD_ROOT%{_libdir}
96install -m 0755 paranoia/libcdda_paranoia.a interface/libcdda_interface.a \
97        $RPM_BUILD_ROOT%{_libdir}
98install -d $RPM_BUILD_ROOT%{_mandir}/ja/man1
99install -m 0644 cdparanoia.1.jp $RPM_BUILD_ROOT%{_mandir}/ja/man1/cdparanoia.1
100
101/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_libdir}
102
103pushd $RPM_BUILD_ROOT%{_libdir}
104ln -s libcdda_paranoia.so.0.10.? libcdda_paranoia.so
105ln -s libcdda_interface.so.0.10.? libcdda_interface.so
106popd
107
108%post -p /sbin/ldconfig
109
110%postun -p /sbin/ldconfig
111
112%post -n compat32-%{name} -p /sbin/ldconfig
113
114%postun -n compat32-%{name} -p /sbin/ldconfig
115
116%clean
117[ "$RPM_BUILD_ROOT" != "/" -a -d "$RPM_BUILD_ROOT" ] && rm -rf "$RPM_BUILD_ROOT"
118
119%files
120%defattr(-,root,root)
121%doc README COPYING-GPL COPYING-LGPL
122%{_bindir}/*
123%{_libdir}/lib*.so.*
124%{_mandir}/man1/*
125%{_mandir}/ja/man1/*
126
127%files devel
128%defattr(-,root,root)
129%{_includedir}/cdda
130%{_libdir}/lib*.so
131%{_libdir}/*.a
132
133# compat32
134%if %{build_compat32}
135%files -n compat32-%{name}
136%defattr(-, root, root)
137%{_libdir}/*.so.*
138
139%files -n compat32-%{name}-devel
140%defattr(-, root, root)
141%{_libdir}/*.so
142%endif
143
144%changelog
145* Wed Jan 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.2-3
146- create compat32 sub packages
147
148* Sun Apr 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-2
149- rebuilt with new toolchain
150- added Japanese summary
151
152* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-1
153- new upstream release
154- added Requires: cdparanoia to devel package
155
156* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> alpha9.8-9vl5
157- applied new versioning policy
158
159* Tue Jul  3 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> alpha9.8-8vl6
160- add Patch1
161
162* Tue Oct 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> alpha9.8-8vl5
163- added fPIC.patch fix a problem on x86_64 archtecture
164
165* Fri Dec 26 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> alpha9.8-8vl4
166- rebuild with new toolchain
167
168* Sun Mar 16 2003 IWAI Masaharu <iwai@alib.jp> alpha9.8-8vl3
169- rebuild with new toolchain
170
171* Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
172- alpha9.8-8vl2
173- rebuild on VineSeed
174
175* Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
176- alpha9.8-8vl1
177- included japanese manual
178
179* Tue Feb 27 2001 Karsten Hopp <karsten@redhat.de>
180- fix spelling error in description
181
182* Thu Dec  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
183- rebuild for new tree
184
185* Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
186- use %%{_tmppath}
187
188* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
189- automatic rebuild
190
191* Wed Jun 06 2000 Preston Brown <pbrown@redhat.com>
192- revert name change
193- use new rpm macro paths
194
195* Wed Apr 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
196- Switched spec file from the one used in Red Hat Linux 6.2, which
197  also changes the name
198- gzip man page
199
200* Thu Dec 23 1999 Peter Jones <pjones@redhat.com>
201- update package to provide cdparanoia-alpha9.7-2.*.rpm and
202  cdparanoia-devel-alpha9.7-2.*.rpm.  Also, URLs point at xiph.org
203  like they should.
204
205* Wed Dec 22 1999 Peter Jones <pjones@redhat.com>
206- updated package for alpha9.7, based on input from:
207  Monty <xiphmont@xiph.org>
208  David Philippi <david@torangan.saar.de>
209
210* Mon Apr 12 1999 Michael Maher <mike@redhat.com>
211- updated pacakge
212
213* Tue Oct 06 1998 Michael Maher <mike@redhat.com>
214- updated package
215
216* Mon Jun 29 1998 Michael Maher <mike@redhat.com>
217- built package
Note: See TracBrowser for help on using the repository browser.