source: projects/specs/trunk/c/ccid/ccid-vl.spec @ 521

Revision 521, 5.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define dropdir %(pkg-config libpcsclite --variable usbdropdir 2>/dev/null)
2%define libusb_ver 0.1.7
3%define pcsc_lite_ver 1.3.3
4
5Name:           ccid
6Version:        1.3.8
7Release: 1%{?_dist_release}
8Summary:        Generic USB CCID smart card reader driver
9Summary(ja):        Generic USB CCID smart card reader driver
10
11Group:          System Environment/Libraries
12License:        LGPLv2+
13URL:            http://pcsclite.alioth.debian.org/ccid.html
14Source0:        http://alioth.debian.org/download.php/1563/%{name}-%{version}.tar.bz2
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  libusb-devel >= %{libusb_ver}
18BuildRequires:  pcsc-lite-devel >= %{pcsc_lite_ver}
19Requires(post): initscripts
20Requires(postun): initscripts
21Requires:       libusb
22Requires:       pcsc-lite
23Provides:       pcsc-ifd-handler
24# 390 does not have libusb or smartCards
25ExcludeArch: s390 s390x
26
27
28%description
29Generic USB CCID (Chip/Smart Card Interface Devices) driver.
30
31
32%prep
33%setup -q
34for f in ChangeLog README ; do
35  iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
36done
37
38
39%build
40%configure --disable-dependency-tracking --disable-static --enable-twinserial --enable-udev
41make %{?_smp_mflags}
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46make install DESTDIR=$RPM_BUILD_ROOT
47#make install_ccidtwin -C src DESTDIR=$RPM_BUILD_ROOT
48mv $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf ./GemPCTwin.reader.conf
49mv $RPM_BUILD_ROOT/usr/share/doc/ccid/README_Kobil_mIDentity_switch.txt ./
50%{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d
51%{__install} -m 644 src/pcscd_ccid.rules $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d/85-pcscd_ccid.rules
52
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57
58%post
59[ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H > /dev/null 2>&1
60exit 0
61
62%postun
63[ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H  > /dev/null 2>&1
64exit 0
65
66
67%files
68%defattr(-,root,root,-)
69%doc AUTHORS ChangeLog COPYING README GemPCTwin.reader.conf README_Kobil_mIDentity_switch.txt
70%{dropdir}/ifd-ccid.bundle/
71%{dropdir}/serial/
72%config %{_sysconfdir}/udev/rules.d/85-pcscd_ccid.rules
73%{_bindir}/RSA_SecurID_getpasswd
74%{_mandir}/man1/RSA_SecurID_getpasswd.1.gz
75%{_mandir}/man8/Kobil_mIDentity_switch.8.gz
76%{_sbindir}/Kobil_mIDentity_switch
77#%doc /doc/ccid/
78
79
80%changelog
81* Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.8-1
82- initial build for Vine Linux
83
84* Tue Aug 26 2008 Bob Relyea <rrelyea@redhat.com> - 1.3.8-1
85- update to ccid 1.3.8
86
87* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.1-4
88- Autorebuild for GCC 4.3
89
90* Fri Aug 20 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-3
91- Update License description to the new Fedora standard
92
93* Mon Apr 30 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-2
94- Fix the missed use of the version macro
95
96* Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-1
97- Pick up ccid 1.2.1
98- use pcscd 'hotplug' feature instead of restarting the daemon
99- add enable_udev
100
101* Mon Nov 06 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-2
102- Fix version macro to remove '-'
103
104* Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-1
105- Pickup ccid 1.1.0
106
107* Sun Jul 20 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-5
108- require initscripts for post/postun
109
110* Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-4
111- fix excludearch line
112
113* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-3.1
114- rebuild
115
116* Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-3
117- remove s390 from the build
118
119* Mon Jun  5 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-2
120- Move to Fedora Core, removed %%{_dist}.
121
122* Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.1-1
123- 1.0.1.
124
125* Mon Mar  6 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.0-1
126- 1.0.0, license changed to LGPL.
127
128* Wed Feb 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-7
129- Rebuild.
130
131* Thu Nov  3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-6
132- Clean up build dependencies.
133- Convert docs to UTF-8.
134
135* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.4.1-5
136- rebuilt
137
138* Fri Feb 25 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-4
139- Drop Epoch: 0.
140- Improve summary.
141- Build with dependency tracking disabled.
142
143* Thu Jul  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.3
144- Restart pcscd in post(un)install phase if it's available and running.
145
146* Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.2
147- Provide pcsc-ifd-handler (idea from Debian).
148
149* Sat Feb 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.1
150- Update to 0.4.1.
151
152* Fri Feb 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.0-0.fdr.1
153- Update to 0.4.0.
154
155* Wed Nov  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.2-0.fdr.1
156- Update to 0.3.2.
157- Update URL.
158
159* Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.1-0.fdr.1
160- Update to 0.3.1.
161
162* Wed Sep 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.0-0.fdr.1
163- Update to 0.3.0.
164
165* Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.2.0-0.fdr.1
166- Update to 0.2.0.
167
168* Tue Aug 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.1.0-0.fdr.1
169- First build.
Note: See TracBrowser for help on using the repository browser.