source: projects/specs/trunk/c/ccid/ccid-vl.spec @ 6424

Revision 6424, 4.9 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define dropdir %(pkg-config libpcsclite --variable usbdropdir 2>/dev/null)
2%define libusb1_ver 1.0.9
3%define pcsc_lite_ver 1.8.3
4
5Name:           ccid
6Version:        1.4.7
7Release:        1%{?_dist_release}
8Summary:        Generic USB CCID smart card reader driver
9Summary(ja):        Generic USB CCID smart card reader driver
10
11Group:          System Environment/Libraries
12License:        LGPLv2+
13URL:            http://pcsclite.alioth.debian.org/ccid.html
14Source0:        http://alioth.debian.org/download.php/1563/%{name}-%{version}.tar.bz2
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  libusb1-devel >= %{libusb1_ver}
18BuildRequires:  pcsc-lite-devel >= %{pcsc_lite_ver}
19Requires(post): initscripts
20Requires(postun): initscripts
21Requires:       libusb1
22Requires:       pcsc-lite
23Provides:       pcsc-ifd-handler
24# 390 does not have libusb or smartCards
25ExcludeArch: s390 s390x
26
27
28%description
29Generic USB CCID (Chip/Smart Card Interface Devices) driver.
30
31
32%prep
33%setup -q
34for f in ChangeLog README ; do
35  iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
36done
37
38
39%build
40%configure --disable-dependency-tracking --disable-static --enable-twinserial
41make %{?_smp_mflags}
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46make install DESTDIR=$RPM_BUILD_ROOT
47%{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d
48%{__install} -m 644 src/92_pcscd_ccid.rules $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d/92-pcscd_ccid.rules
49
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54
55%post
56[ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H > /dev/null 2>&1
57exit 0
58
59%postun
60[ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H  > /dev/null 2>&1
61exit 0
62
63
64%files
65%defattr(-,root,root,-)
66%doc AUTHORS ChangeLog COPYING NEWS README SCARDGETATTRIB.txt
67%{dropdir}/ifd-ccid.bundle/
68%{dropdir}/serial/
69%config(noreplace) %{_sysconfdir}/reader.conf.d/libccidtwin
70%config %{_sysconfdir}/udev/rules.d/92-pcscd_ccid.rules
71
72
73%changelog
74* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
75- new upstream release
76- change BuildRequires: libusb1-devel instead of libusb-devel
77
78* Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.8-1
79- initial build for Vine Linux
80
81* Tue Aug 26 2008 Bob Relyea <rrelyea@redhat.com> - 1.3.8-1
82- update to ccid 1.3.8
83
84* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.1-4
85- Autorebuild for GCC 4.3
86
87* Fri Aug 20 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-3
88- Update License description to the new Fedora standard
89
90* Mon Apr 30 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-2
91- Fix the missed use of the version macro
92
93* Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-1
94- Pick up ccid 1.2.1
95- use pcscd 'hotplug' feature instead of restarting the daemon
96- add enable_udev
97
98* Mon Nov 06 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-2
99- Fix version macro to remove '-'
100
101* Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-1
102- Pickup ccid 1.1.0
103
104* Sun Jul 20 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-5
105- require initscripts for post/postun
106
107* Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-4
108- fix excludearch line
109
110* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-3.1
111- rebuild
112
113* Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-3
114- remove s390 from the build
115
116* Mon Jun  5 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-2
117- Move to Fedora Core, removed %%{_dist}.
118
119* Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.1-1
120- 1.0.1.
121
122* Mon Mar  6 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.0-1
123- 1.0.0, license changed to LGPL.
124
125* Wed Feb 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-7
126- Rebuild.
127
128* Thu Nov  3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-6
129- Clean up build dependencies.
130- Convert docs to UTF-8.
131
132* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.4.1-5
133- rebuilt
134
135* Fri Feb 25 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-4
136- Drop Epoch: 0.
137- Improve summary.
138- Build with dependency tracking disabled.
139
140* Thu Jul  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.3
141- Restart pcscd in post(un)install phase if it's available and running.
142
143* Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.2
144- Provide pcsc-ifd-handler (idea from Debian).
145
146* Sat Feb 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.1
147- Update to 0.4.1.
148
149* Fri Feb 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.0-0.fdr.1
150- Update to 0.4.0.
151
152* Wed Nov  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.2-0.fdr.1
153- Update to 0.3.2.
154- Update URL.
155
156* Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.1-0.fdr.1
157- Update to 0.3.1.
158
159* Wed Sep 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.0-0.fdr.1
160- Update to 0.3.0.
161
162* Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.2.0-0.fdr.1
163- Update to 0.2.0.
164
165* Tue Aug 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.1.0-0.fdr.1
166- First build.
Note: See TracBrowser for help on using the repository browser.