source: projects/specs/trunk/b/bzr/bzr-vl.spec @ 521

Revision 521, 9.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3# All package versioning is found here:
4# the actual version is composed from these below, including leading 0 for release candidates
5#   bzrmajor:  main bzr version
6#   Version: bzr version, add subrelease version here
7#   bzrrc: release candidate version, if any, line starts with % for rc, # for stable releas (no %).
8#   release: rpm subrelease (0.N for rc candidates, N for stable releases)
9%define bzrmajor 1.17
10#define bzrrc rc1
11%define release 1
12
13# Magics to get the dots in Release string correct per the above
14%define subrelease %{?bzrrc:.}%{?bzrrc}
15
16Name:           bzr
17Version:        %{bzrmajor}
18Release:        %{release}%{?subrelease}%{?_dist_release}
19Summary:        Friendly distributed version control system
20Summary(ja):    bzr - 分散型バージョン管理システム
21
22Group:          Development/Tools
23License:        GPLv2+
24URL:            http://www.bazaar-vcs.org/
25Source0:        https://launchpad.net/%{name}/%{bzrmajor}/%{version}%{?bzrrc}/+download/%{name}-%{version}%{?bzrrc}.tar.gz
26Source1:        https://launchpad.net/%{name}/%{bzrmajor}/%{version}%{?bzrrc}/+download/%{name}-%{version}%{?bzrrc}.tar.gz.sig
27BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
28
29BuildRequires:  python-devel zlib-devel
30# We're using an old version of Pyrex, use the pregenerated C files instead
31# of rebuilding
32#BuildRequires: Pyrex
33Requires:   python-paramiko
34# Workaround Bug #230223 otherwise this would be a soft dependency
35Requires:   python-pycurl
36
37# ElementTree is part of python2.5 on FC7+
38# This is also needed for EL-5
39#if 0%{?fedora} <= 6
40#BuildRequires:   python-elementtree
41#Requires:   python-elementtree
42#endif
43
44%description
45Bazaar is a distributed revision control system that is powerful, friendly,
46and scalable.  It is the successor of Baz-1.x which, in turn, was
47a user-friendly reimplementation of GNU Arch.
48
49
50%prep
51%setup -q -n %{name}-%{version}%{?bzrrc}
52
53sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/_patiencediff_py.py
54sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/weave.py
55
56%build
57CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
58
59chmod a-x contrib/bash/bzrbashprompt.sh
60
61%install
62rm -rf $RPM_BUILD_ROOT
63%{__python} setup.py install --skip-build --install-data %{_datadir} --root $RPM_BUILD_ROOT
64chmod 0644 contrib/bzr_access
65chmod 0644 contrib/bzr_ssh_path_limiter
66chmod 0755 $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/*.so
67
68install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
69install -m 0644 contrib/bash/bzr $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
70rm contrib/bash/bzr
71
72# This is included in %doc, remove redundancy here
73#rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/doc/
74
75# Use independently packaged python-elementtree instead
76rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/util/elementtree/
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81
82%files
83%defattr(-,root,root,-)
84%doc NEWS README TODO COPYING.txt doc/  contrib/
85%{_bindir}/bzr
86%{_mandir}/man1/*
87%{python_sitearch}/bzrlib/
88%{_sysconfdir}/bash_completion.d/
89
90#if 0%{?fedora} > 8
91%{python_sitearch}/*.egg-info
92#endif
93
94%changelog
95* Thu Aug  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
96- initial build for VineSeed
97
98* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-2
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
100
101* Mon Jul 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-1
102- Upgade to 1.17
103
104* Mon Jul 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-0.1
105- Update to 1.17rc1
106
107* Fri Jun 26 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16.1-1
108- Update to 1.16.1
109
110* Thu Jun 18 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16-1
111- Update to 1.16
112
113* Wed Jun 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15.1-1
114- Update to 1.15.1
115
116* Sat May 23 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-2
117- Update to 1.15final
118
119* Sat May 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-0.1
120- Update to 1.15rc1
121
122* Sat May 02 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14.1-1
123- Update to 1.14.1
124
125* Wed Apr 29 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-1
126- Update to 1.14
127
128* Mon Apr 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.3.rc2
129- Update to 1.14rc2
130
131* Sat Apr 11 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.2.rc1
132- Correct build dependencies
133
134* Thu Apr 09 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.1.rc1
135- Update to 1.14rc1
136
137* Tue Mar 24 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13.1-1
138- Update to 1.13.1
139
140* Mon Mar 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-1
141- Update to 1.13
142
143* Tue Mar 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-0.1.rc1
144- Update to 1.13rc1
145
146* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
148
149* Fri Feb 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-1
150- Update to 1.12
151
152* Tue Feb 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-0.1.rc1
153- Update to 1.12rc1
154
155* Mon Jan 19 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.11-1
156- Update to 1.11
157
158* Wed Dec 10 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.10-1
159- Update to 1.10
160
161* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.9-2
162- Rebuild for Python 2.6
163
164* Thu Nov 13 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.9-1
165- Update to 1.9
166
167* Thu Sep 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-1
168- 1.7 Final
169
170* Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-0.1.rc2
171- 1.7rc2
172- Remove executable permission from a %%doc file
173
174* Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.6.1-0.1.rc2
175- New upstream bugfix release.
176
177* Thu May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
178- Upload tarball.
179
180* Wed May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-1
181- Update to 1.5.
182
183* Thu May 15 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-2
184- Workaround upstream Bug# 230223 by Requiring python-pycurl.
185
186* Mon May 5 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-1
187- Update to 1.4.
188
189* Sun Apr 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-1
190- Paramiko/sftp backport from 1.4.0. bz#444325
191- Update to 1.3.1 final.
192
193* Sat Apr 4 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-0.1.rc1
194- Update to 1.3.1rc1 to fix a bug when you have a pack based remote repo and
195  knit based local branch.
196
197* Wed Mar 26 2008 Warren Togami <wtogami@redhat.com> - 1.3-1
198- Update to 1.3.
199
200* Mon Feb 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.2-1
201- Update to 1.2.
202
203* Fri Feb 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.1-2
204- Rebuild for new gcc.
205
206* Mon Jan 21 2008 Toshio Kuratomi <a.badger@gmail.com> - 1.1-1
207- Upstream 1.1 bugfix and performance enhancement release.
208- Enable bash completion script from the contrib directory.
209
210* Thu Dec 13 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-1
211- Update to 1.0 final.
212
213* Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc3
214- Update to 1.0rc3
215- The new rawhide python package generates egg-info files.
216
217* Fri Nov 30 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc2
218- Update to 1.0rc2
219
220* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.91-1
221- Update to 0.91.
222  + Fixes some issues with using tag-enabled branches.
223
224* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-1
225- Update to 0.90
226
227* Mon Aug 27 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-0.1.rc1
228- Update to 0.90rc1.
229- 0.90 contains some pyrex code to speed things up.  bzr is now arch specific.
230- Update license tag.
231
232* Wed Jul 25 2007 Warren Togami <wtogami@redhat.com> - 0.18-1
233- Update to 0.18.
234
235* Tue Jun 26 2007 Warren Togami <wtogami@redhat.com>  - 0.17-2
236- Update to 0.17.
237
238* Tue May 08 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.16-1
239- Update to 0.16.
240
241* Thu Mar 22 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.15-1
242- Update to 0.15.
243- Simplify the %%files list.
244
245* Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.14-1
246- Update to 0.14
247
248* Sun Dec 10 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-2
249- Conditionalize the python-elementtree requires as python2.5 in FC7 includes
250  elementtree
251
252* Wed Dec 6 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-1
253- Update to 0.13
254
255* Thu Oct 30 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.12-1
256- Update to 0.12
257
258* Thu Oct 08 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.11-1
259- Update to 0.11
260- New download location.
261
262* Sun Sep 17 2006 Warren Togami <wtogami@redhat.com> 0.10-1
263- 0.10
264
265* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.9-1
266- Update to new upstream
267
268* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.8.2-3
269- Include, don't ghost .pyo files per new guidelines
270
271* Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.8.2-2
272- Require python-paramiko for sftp support
273
274* Tue May 23 2006 Shahms E. King <shahms@shahms.com> 0.8.2-1
275- Update to new upstream version
276- Fix dist tag
277
278* Wed May 10 2006 Shahms E. King <shahms@shahms.com> 0.8-1
279- Update to new upstream version
280- Update bzr-sys-etree.patch for changes
281
282* Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-3
283- Add python-elementtree to BuildRequires
284
285* Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-2
286- Add dist tag
287
288* Fri Feb 10 2006 Shahms E. King <shahms@shahms.com> 0.7-1
289- Update to 0.7
290
291* Thu Jan 26 2006 Shahms E. King <shahms@shahms.com> 0.6.2-2
292- Fix system library patch
293
294* Wed Dec 07 2005 Shahms E. King <shahms@shahms.com> 0.6.2-1
295- Initial package
Note: See TracBrowser for help on using the repository browser.