source: projects/specs/trunk/b/brltty/brltty-vl.spec @ 5701

Revision 5701, 14.5 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define pkg_version 4.2
2%define api_version 0.5.5
3
4%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5%{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
6
7%define _exec_prefix %{nil}
8%define _libdir /%{_lib}
9
10# with speech dispatcher iff on Fedora:
11%define with_speech_dispatcher 0%{?fedora}
12
13Name: brltty
14Version: %{pkg_version}
15Release: 2%{?_dist_release}
16License: GPLv2+
17Group: System Environment/Daemons
18URL: http://mielke.cc/brltty/
19Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
20Patch0: brltty-cppflags.patch
21Patch1: brltty-autoconf-quote.patch
22Patch2: brltty-4.2-S_ISCHR.patch
23Patch3: brltty-parallel.patch
24BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
25Summary: Braille display driver for Linux/Unix
26BuildRequires: bison
27BuildRequires: flex
28BuildRequires: autoconf
29# work around a bug in the install process:
30Requires(post): coreutils
31
32%description
33BRLTTY is a background process (daemon) which provides
34access to the Linux/Unix console (when in text mode)
35for a blind person using a refreshable braille display.
36It drives the braille display and provides complete
37screen review functionality.
38%if %{with_speech_dispatcher}
39BRLTTY can also work with speech synthetizers; if you want to use it with
40Speech Dispatcher, please install also package %{name}-speech-dispatcher.
41
42%package speech-dispatcher
43Summary: Speech Dispatcher driver for BRLTTY
44Group: System Environment/Daemons
45License: GPLv2+
46BuildRequires: speech-dispatcher-devel
47Requires: %{name} = %{pkg_version}-%{release}
48%description speech-dispatcher
49This package provides the Speech Dispatcher driver for BRLTTY.
50%endif
51
52%package xw
53Summary: XWindow driver for BRLTTY
54Group: System Environment/Daemons
55License: GPLv2+
56BuildRequires: libSM-devel libICE-devel libX11-devel libXaw-devel libXext-devel libXt-devel libXtst-devel
57Requires: %{name} = %{pkg_version}-%{release}
58%description xw
59This package provides the XWindow driver for BRLTTY.
60
61%package at-spi
62Summary: AtSpi driver for BRLTTY
63Group: System Environment/Daemons
64# The data files are licensed under LGPLv2+, see the README file.
65License: GPLv2+ and LGPLv2+
66BuildRequires: at-spi-devel
67Requires: %{name} = %{pkg_version}-%{release}
68%description at-spi
69This package provides the AtSpi driver for BRLTTY.
70
71%package -n brlapi
72Version: %{api_version}
73Group: Applications/System
74License: LGPLv2+
75Summary: Appliation Programming Interface for BRLTTY
76Requires: %{name} = %{pkg_version}-%{release}
77%description -n brlapi
78This package provides the run-time support for the Application
79Programming Interface to BRLTTY.
80
81Install this package if you have an application which directly accesses
82a refreshable braille display.
83
84%package -n brlapi-devel
85Version: %{api_version}
86Group: Development/System
87License: LGPLv2+
88Requires: brlapi = %{api_version}-%{release}
89Summary: Headers, static archive, and documentation for BrlAPI
90
91%description -n brlapi-devel
92This package provides the header files, static archive, shared object
93linker reference, and reference documentation for BrlAPI (the
94Application Programming Interface to BRLTTY).  It enables the
95implementation of applications which take direct advantage of a
96refreshable braille display in order to present information in ways
97which are more appropriate for blind users and/or to provide user
98interfaces which are more specifically atuned to their needs.
99
100Install this package if you are developing or maintaining an application
101which directly accesses a refreshable braille display.
102
103%package -n tcl-brlapi
104Version: %{api_version}
105Group: Development/System
106License: LGPLv2+
107Requires: brlapi = %{api_version}-%{release}
108BuildRequires: tcl
109Summary: Tcl binding for BrlAPI
110%description -n tcl-brlapi
111This package provides the Tcl binding for BrlAPI.
112
113%package -n python-brlapi
114Version: %{api_version}
115Group: Development/System
116License: LGPLv2+
117Requires: brlapi = %{api_version}-%{release}
118BuildRequires: python-pyrex
119Summary: Python binding for BrlAPI
120%description -n python-brlapi
121This package provides the Python binding for BrlAPI.
122
123%package -n brlapi-java
124Version: %{api_version}
125Group: Development/System
126License: LGPLv2+
127Requires: brlapi = %{api_version}-%{release}
128## temporary work around, java-devel is not resolved consistently acrss archs
129BuildRequires: java-devel
130#BuildRequires: java-1.5.0-gcj-devel
131Summary: Java binding for BrlAPI
132%description -n brlapi-java
133This package provides the Java binding for BrlAPI.
134
135%define version %{pkg_version}
136
137%prep
138%setup -q
139%patch0 -p1 -b .cppflags
140%patch1 -p1 -b .quote
141%patch2 -p1 -b .S_ISCHR
142%patch3 -p1 -b .parallel
143
144%build
145# Patch6 changes aclocal.m4:
146autoconf
147for i in -I/usr/lib/jvm/java/include{,/linux}; do
148      java_inc="$java_inc $i"
149done
150# there is no curses packages in BuildRequires, so the package builds
151# without them in mock; let's express this decision explicitly
152%configure CPPFLAGS="$java_inc" --disable-stripping --without-curses \
153%if %{with_speech_dispatcher}
154  --with-speechd=%{_prefix} \
155%endif
156  --with-install-root="${RPM_BUILD_ROOT}"
157make %{?_smp_mflags}
158
159find . \( -path ./doc -o -path ./Documents \) -prune -o \
160  \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o \
161     -name '*.sgml' -o -name '*.patch' -o \
162     \( -path './Bootdisks/*' -type f -perm +ugo=x \) \) -print |
163while read file; do
164   mkdir -p doc/${file%/*} && cp -rp $file doc/$file || exit 1
165done
166
167%install
168rm -rf $RPM_BUILD_ROOT
169# does not seem to be parallel safe
170make install
171rm "$RPM_BUILD_ROOT%{_libdir}/libbrlapi.so"
172ln -s ../../%{_lib}/libbrlapi.so "$RPM_BUILD_ROOT%{_prefix}/%{_lib}/"
173install -d -m 755 "${RPM_BUILD_ROOT}%{_sysconfdir}" "$RPM_BUILD_ROOT%{_mandir}/man5"
174install -m 644 Documents/brltty.conf "${RPM_BUILD_ROOT}%{_sysconfdir}"
175echo ".so man1/brltty.1" > $RPM_BUILD_ROOT%{_mandir}/man5/brltty.conf.5
176
177# clean up the manuals:
178rm Documents/Manual-*/*/{*.mk,*.made,Makefile*}
179mv Documents/BrlAPIref/{html,BrlAPIref}
180
181# Don't want static lib
182rm -rf $RPM_BUILD_ROOT/%{_lib}/libbrlapi.a
183
184%clean
185rm -rf $RPM_BUILD_ROOT
186
187%post
188devices="/dev/vcsa /dev/vcsa0 /dev/vcc/a"
189install=true
190for device in ${devices}
191do
192   if [ -c "${device}" ]
193   then
194      install=false
195      break
196   fi
197done
198if $install
199then
200   device="$(set -- ${devices} && echo "${1}")"
201   mkdir -p "${device%/*}"
202   mknod -m o= "${device}" c 7 128
203   chmod 660 "${device}"
204   chown root.tty "${device}"
205fi
206exit 0
207
208%post   -n brlapi -p /sbin/ldconfig
209%postun -n brlapi -p /sbin/ldconfig
210
211%files
212%defattr(-,root,root)
213%config(noreplace) %{_sysconfdir}/brltty.conf
214%{_sysconfdir}/brltty/
215%{_bindir}/brltty
216%{_bindir}/brltty-*
217%{_libdir}/brltty/
218%exclude %{_libdir}/brltty/libbrlttybba.so
219%exclude %{_libdir}/brltty/libbrlttybxw.so
220%if %{with_speech_dispatcher}
221%exclude %{_libdir}/brltty/libbrlttyssd.so
222%endif
223%exclude %{_libdir}/brltty/libbrlttyxas.so
224%doc LICENSE-GPL LICENSE-LGPL
225%doc Documents/ChangeLog Documents/TODO
226%doc Documents/Manual-BRLTTY/
227%doc doc/*
228%doc %{_mandir}/man[15]/brltty.*
229
230%if %{with_speech_dispatcher}
231%files speech-dispatcher
232%doc Drivers/Speech/SpeechDispatcher/README
233%{_libdir}/brltty/libbrlttyssd.so
234%endif
235
236%files xw
237%doc Drivers/Braille/XWindow/README
238%{_libdir}/brltty/libbrlttybxw.so
239
240%files at-spi
241%{_libdir}/brltty/libbrlttyxas.so
242
243%files -n brlapi
244%defattr(-,root,root)
245%{_bindir}/vstp
246%{_bindir}/xbrlapi
247%{_libdir}/brltty/libbrlttybba.so
248%{_libdir}/libbrlapi.so.*
249%doc Drivers/Braille/XWindow/README
250%doc Documents/Manual-BrlAPI/
251%doc %{_mandir}/man1/xbrlapi.*
252%doc %{_mandir}/man1/vstp.*
253
254%files -n brlapi-devel
255%defattr(-,root,root)
256%{_prefix}/%{_lib}/libbrlapi.so
257%{_includedir}/brltty
258%{_includedir}/brlapi*.h
259%doc %{_mandir}/man3/brlapi_*.3*
260%doc Documents/BrlAPIref/BrlAPIref/
261
262%files -n tcl-brlapi
263%defattr(-,root,root)
264%{_prefix}/%{_lib}/brlapi-%{api_version}
265
266%files -n python-brlapi
267%defattr(-,root,root)
268%{python_sitearch}/brlapi.so
269%{python_sitearch}/Brlapi-%{api_version}-py%{pyver}.egg-info
270
271%files -n brlapi-java
272%defattr(-,root,root)
273%{_jnidir}/libbrlapi_java.so
274%{_javadir}/brlapi.jar
275
276
277%changelog
278* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2-2
279- rebuild with python-2.7.2
280
281* Sat Nov 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2-1
282- initial build for Vine Linux
283
284
285
286* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2-4
287- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
288
289* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 4.2-3
290- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
291
292* Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-2
293- rework parallel patch slightly and reapply
294
295* Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-1
296- update to 4.2
297- drop static lib (bz 556041)
298- fix undefined S_ISCHR call
299
300* Wed Jan 20 2010 Stepan Kasal <skasal@redhat.com> - 4.1-5
301- requires(post): coreutils to work around an installator bug
302- Resolves: #540437
303
304* Wed Jan 13 2010 Stepan Kasal <skasal@redhat.com> - 4.1-4
305- limit building against speech-dispatcher to Fedora
306- Resolves: rhbz#553795
307
308* Sun Nov  1 2009 Stepan Kasal <skasal@redhat.com> - 4.1-3
309- build the TTY driver (it was disabled since it first appered in 3.7.2-1)
310- build with speech-dispatcher, packed into a separate sub-package
311
312* Fri Oct 30 2009 Stepan Kasal <skasal@redhat.com> - 4.1-2
313- move data-directory back to default: /etc/brltty
314- move brltty to /bin and /lib, so that it can be used to repair the system
315  without /usr mounted (#276181)
316- move vstp and libbrlttybba.so to brlapi
317- brltty no longer requires brlapi
318- brlapi now requires brltty from the same build
319
320* Wed Oct 28 2009 Stepan Kasal <skasal@redhat.com> - 4.1-1
321- new upstream version
322- use --disable-stripping instead of make variable override
323- install the default brltty-pm.conf to docdir only (#526168)
324- remove the duplicate copies of rhmkboot and rhmkroot from docdir
325- patch configure so that the dirs in summary are not garbled:
326  brltty-autoconf-quote.patch
327- move data-directory to ${datadir}/brltty
328
329* Tue Oct 20 2009 Stepan Kasal <skasal@redhat.com> - 4.0-2
330- escape rpm macros in the rpm change log
331- add requires to bind subpackages from one build together
332
333* Wed Oct  7 2009 Stepan Kasal <skasal@redhat.com> - 4.0-1
334- new upstream version
335- drop upstreamed patches; ./autogen not needed anymore
336- pack the xbrlapi server; move its man page to brlapi package
337- add man-page for brltty.conf (#526168)
338
339* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-6
340- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
341
342* Tue May 12 2009 Stepan Kasal <skasal@redhat.com> - 3.10-5
343- rebuild after java-1.5.0-gcj rebuild
344
345* Thu Apr 30 2009 Stepan Kasal <skasal@redhat.com> - 3.10-4
346- own the tcl subdirectory (#474032)
347- set CPPFLAGS to java include dirs, so that the java bindings build with
348  any java implementation (#498964)
349- add --without-curses; there is no curses package BuildRequired anyway
350
351* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-3
352- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
353
354* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.10-2
355- Rebuild for Python 2.6
356
357* Sat Sep 13 2008 Stepan Kasal <skasal@redhat.com> - 3.10-1
358- new upstream release
359- drop brltty-3.9-java-svn.patch, brltty-3.9-tcl85path.patch,
360  and brltty-3.9-pyxfix.patch, they are upstream
361- fix BuildRoot
362- fix many sub-packages' Requires on brlapi
363
364* Wed Sep 10 2008 Stepan Kasal <skasal@redhat.com> - 3.9-3
365- add brltty-3.9-autoconf.patch to fix to build with Autoconf 2.62
366- add brltty-3.9-parallel.patch to fix race condition with parallel make
367- add brltty-3.9-pyxfix.patch to fix build with current pyrex
368- Summary lines shall not end with a dot
369
370* Thu Feb 28 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-2.2
371- glibc build fixes
372- applied java reorganisations from svn
373
374* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.9-2.1
375- Autorebuild for GCC 4.3
376
377* Wed Jan 09 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-1.1
378- specfile update to comply with tcl packaging guidelines
379
380* Mon Jan 07 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-1
381- update to latest upstream (3.9)
382
383* Tue Sep 18 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-2.svn3231
384- update to r3231 from svn
385- added java binding subpackage
386
387* Wed Aug 29 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-2.svn3231
388- update to r3231 from svn
389
390* Tue Aug 21 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-1
391- update to latest upstream
392- added the at-spi driver, tcl and python bindings
393- fixed the license tags
394
395* Mon Mar 05 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-3
396- added the XWindow driver
397- build fix for newer byacc
398
399* Tue Jan 30 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-2.1
400- quiet postinstall scriptlet, really fixes #224570
401
402* Tue Jan 30 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-2
403- failsafe postinstall script, fixes #224570
404- makefile fix - debuginfo extraction now works
405
406* Thu Jan 25 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-1.1
407- fix building with newer kernel-headers (#224149)
408
409* Wed Jul 12 2006 Petr Rockai <prockai@redhat.com> - 3.7.2-1
410- upgrade to latest upstream version
411- split off brlapi and brlapi-devel packages
412
413* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.2-12.1
414- rebuild
415
416* Sun Jul 02 2006 Florian La Roche <laroche@redhat.com>
417- for the post script require coreutils
418
419* Mon Jun 05 2006 Jesse Keating <jkeating@redhat.com> - 3.2-11
420- Added byacc BuildRequires, removed prereq, coreutils is always there
421
422* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.2-10.2.1
423- bump again for double-long bug on ppc(64)
424
425* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.2-10.2
426- rebuilt for new gcc4.1 snapshot and glibc changes
427
428* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
429- rebuilt
430
431* Wed Mar 16 2005 Bill Nottingham <notting@redhat.com> 3.2-10
432- rebuild
433
434* Fri Nov 26 2004 Florian La Roche <laroche@redhat.com>
435- add a %%clean into .spec
436
437* Thu Oct 14 2004 Adrian Havill <havill@redhat.com> 3.2-5
438- chmod a-x for conf file (#116244)
439
440* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
441- rebuilt
442
443* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
444- rebuilt
445
446* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
447- rebuilt
448
449* Tue Sep 30 2003 Florian La Roche <Florian.LaRoche@redhat.de>
450- prereq coreutils for mknod/chown/chmod
451
452* Mon Jul 07 2003 Adrian Havill <havill@redhat.com> 3.2-2
453- changed spec "Copyright" to "License"
454- use %%configure macro, %%{_libdir} for non-ia32 archs
455- removed unnecessary set and unset, assumed/default spec headers
456- fixed unpackaged man page, duplicate /bin and /lib entries
457- use plain install vs scripts for non-i386 buildsys
Note: See TracBrowser for help on using the repository browser.