source: projects/specs/trunk/b/brltty/brltty-vl.spec @ 10405

Revision 10405, 18.7 KB checked in by Takemikaduchi, 8 years ago (diff)

gcc-5.4.0 & python3-3.5.2

Line 
1%define pkg_version 5.2
2%define api_version 0.6.3
3
4
5%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6%{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
7
8%{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
9
10%{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
11
12#define _exec_prefix %{nil}
13#define _libdir /%{_lib}
14
15# with speech dispatcher iff on Fedora:
16%define with_speech_dispatcher 1
17%define with_ocaml 1
18
19Name: brltty
20Version: %{pkg_version}
21Release: 3%{?_dist_release}
22Summary: Braille display driver for Linux/Unix
23
24License: GPLv2+
25Group: System Environment/Daemons
26URL: http://mielke.cc/brltty/
27
28Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.xz
29Patch4: brltty-loadLibrary.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: bluez-libs-devel
33BuildRequires: byacc
34BuildRequires: gettext
35BuildRequires: glibc-kernheaders
36# work around a bug in the install process:
37Requires(post): coreutils
38
39%description
40BRLTTY is a background process (daemon) which provides
41access to the Linux/Unix console (when in text mode)
42for a blind person using a refreshable braille display.
43It drives the braille display and provides complete
44screen review functionality.
45%if %{with_speech_dispatcher}
46BRLTTY can also work with speech synthetizers; if you want to use it with
47Speech Dispatcher, please install also package %{name}-speech-dispatcher.
48
49%package speech-dispatcher
50Summary: Speech Dispatcher driver for BRLTTY
51Group: System Environment/Daemons
52License: GPLv2+
53BuildRequires: speech-dispatcher-devel
54Requires: %{name} = %{pkg_version}-%{release}
55
56%description speech-dispatcher
57This package provides the Speech Dispatcher driver for BRLTTY.
58%endif
59
60%package docs
61Summary: Documentation for BRLTTY
62Summary(ja): BRLTTY のドキュメント
63Group: Documentation
64License: GPLv2+
65Requires: %{name} = %{pkg_version}-%{release}
66BuildArch: noarch
67
68%description docs
69This package provides the documentation for BRLTTY.
70
71%package xw
72Summary: XWindow driver for BRLTTY
73Group: System Environment/Daemons
74License: GPLv2+
75BuildRequires: libSM-devel
76BuildRequires: libICE-devel
77BuildRequires: libX11-devel
78BuildRequires: libXaw-devel
79BuildRequires: libXext-devel
80BuildRequires: libXt-devel
81BuildRequires: libXtst-devel
82Requires: %{name} = %{pkg_version}-%{release}
83
84%description xw
85This package provides the XWindow driver for BRLTTY.
86
87%package at-spi
88Summary: AtSpi driver for BRLTTY
89Group: System Environment/Daemons
90# The data files are licensed under LGPLv2+, see the README file.
91License: GPLv2+ and LGPLv2+
92BuildRequires: at-spi-devel
93Requires: %{name} = %{pkg_version}-%{release}
94
95%description at-spi
96This package provides the AtSpi driver for BRLTTY.
97
98%package -n brlapi
99Summary: Appliation Programming Interface for BRLTTY
100Summary(ja): BRLTTY の API
101Version: %{api_version}
102Group: Applications/System
103License: LGPLv2+
104Requires: %{name} = %{pkg_version}-%{release}
105
106%description -n brlapi
107This package provides the run-time support for the Application
108Programming Interface to BRLTTY.
109
110Install this package if you have an application which directly accesses
111a refreshable braille display.
112
113%package -n brlapi-devel
114Summary: Headers, static archive, and documentation for BrlAPI
115Summary(ja): BrlAPI の開発用ファイル
116Version: %{api_version}
117Group: Development/Libraries
118License: LGPLv2+
119Requires: brlapi = %{api_version}-%{release}
120
121%description -n brlapi-devel
122This package provides the header files, static archive, shared object
123linker reference, and reference documentation for BrlAPI (the
124Application Programming Interface to BRLTTY).  It enables the
125implementation of applications which take direct advantage of a
126refreshable braille display in order to present information in ways
127which are more appropriate for blind users and/or to provide user
128interfaces which are more specifically atuned to their needs.
129
130Install this package if you are developing or maintaining an application
131which directly accesses a refreshable braille display.
132
133%package -n tcl-brlapi
134Summary: Tcl binding for BrlAPI
135Summary(ja): BrlAPI の Tcl バインディング
136Version: %{api_version}
137Group: Development/Libraries
138License: LGPLv2+
139BuildRequires: tcl-devel
140Requires: brlapi = %{api_version}-%{release}
141
142%description -n tcl-brlapi
143This package provides the Tcl binding for BrlAPI.
144
145%package -n python-brlapi
146Summary: Python binding for BrlAPI
147Summary(ja): BrlAPI の Python バインディング
148Version: %{api_version}
149Group: Development/Libraries
150License: LGPLv2+
151BuildRequires: Cython
152BuildRequires: python-devel
153BuildRequires: python-setuptools
154Requires: brlapi = %{api_version}-%{release}
155
156%description -n python-brlapi
157This package provides the Python binding for BrlAPI.
158
159%package -n python3-brlapi
160Summary: Python 3 binding for BrlAPI
161Summary(ja): BrlAPI の Python バインディング
162Version: %{api_version}
163Group: Development/Libraries
164License: LGPLv2+
165Requires: brlapi = %{api_version}-%{release}
166BuildRequires: Cython
167BuildRequires: python3-devel
168
169%description -n python3-brlapi
170This package provides the Python 3 binding for BrlAPI.
171
172
173%package -n brlapi-java
174Summary: Java binding for BrlAPI
175Summary(ja): BrlAPI の Java バインディング
176Version: %{api_version}
177Group: Development/Libraries
178License: LGPLv2+
179Requires: brlapi = %{api_version}-%{release}
180## temporary work around, java-devel is not resolved consistently acrss archs
181BuildRequires: java-devel
182#BuildRequires: java-1.5.0-gcj-devel
183
184%description -n brlapi-java
185This package provides the Java binding for BrlAPI.
186
187%if %{with_ocaml}
188%package -n ocaml-brlapi
189Summary: OCaml binding for BrlAPI
190Summary(ja): BrlAPI の OCaml バインディング
191Version: %{api_version}
192Group: Development/Libraries
193License: LGPLv2+
194Requires: brlapi = %{api_version}-%{release}
195BuildRequires: ocaml
196BuildRequires: ocaml-findlib
197
198%description -n ocaml-brlapi
199This package provides the OCaml binding for BrlAPI.
200%endif
201
202
203%define version %{pkg_version}
204
205%prep
206%setup -q
207%patch4 -p1 -b .loadLibrary
208#patch5 -p1
209
210# Make a copy of the source tree for building the Python 3 module
211rm -rf ../python3
212cp -a . ../python3
213
214
215%build
216# If MAKEFLAGS=-jN is set it would break local builds.
217unset MAKEFLAGS
218
219# Add the openjdk include directories to CPPFLAGS
220for i in -I/usr/lib/jvm/java/include{,/linux}; do
221      java_inc="$java_inc $i"
222done
223export CPPFLAGS="$java_inc"
224
225export CFLAGS="%{optflags} -I%{_includedir}/speech-dispatcher -fno-strict-aliasing"
226export CXXFLAGS="%{optflags} -I%{_includedir}/speech-dispatcher -fno-strict-aliasing"
227
228# there is no curses packages in BuildRequires, so the package builds
229# without them in mock; let's express this decision explicitly
230configure_opts=" \
231    --disable-stripping \
232    --without-curses \
233%if %{with_speech_dispatcher}
234  --with-speechd=%{_prefix} \
235%endif
236  --with-install-root=$RPM_BUILD_ROOT \
237  JAVA_JAR_DIR=%{_jnidir} \
238  JAVA_JNI_DIR=%{_libdir}/brltty \
239  JAVA_JNI=yes"
240
241# First build everything with Python 2 support
242%configure $configure_opts PYTHON=%{__python}
243# Parallel build seems broken, thus disabling it
244make
245
246# ... and then do it again for the Python 3 module
247pushd ../python3
248%configure $configure_opts PYTHON=%{_bindir}/python3
249# Parallel build seems broken, thus disabling it
250make
251popd
252
253find . \( -path ./doc -o -path ./Documents \) -prune -o \
254  \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o \
255     -name '*.sgml' -o -name '*.patch' -o \
256     \( -path './Bootdisks/*' -type f -perm /ugo=x \) \) -print |
257while read file; do
258   mkdir -p doc/${file%/*} && cp -rp $file doc/$file || exit 1
259done
260
261find . -name '*.sgml' |
262while read file; do
263   iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
264done
265find . -name '*.txt' |
266while read file; do
267   iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
268done
269find . -name 'README*' |
270while read file; do
271   iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
272done
273
274# backup Documents
275cp -a Documents Documents.buildsnap
276
277%install
278rm -rf $RPM_BUILD_ROOT
279rm -rf Documents
280cp -a Documents.buildsnap Documents
281
282%if %{with_ocaml}
283mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
284%endif
285
286make install JAVA_JAR_DIR=%{_jnidir} \
287             JAVA_JNI_DIR=%{_libdir}/brltty \
288             JAVA_JNI=yes
289
290pushd ../python3
291make install JAVA_JAR_DIR=%{_jnidir} \
292             JAVA_JNI_DIR=%{_libdir}/brltty \
293             JAVA_JNI=yes
294popd
295rm -rf ../python3
296
297install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT%{_mandir}/man5
298install -m 644 Documents/brltty.conf ${RPM_BUILD_ROOT}%{_sysconfdir}
299echo ".so man1/brltty.1" > $RPM_BUILD_ROOT%{_mandir}/man5/brltty.conf.5
300
301# clean up the manuals:
302rm Documents/Manual-*/*/{*.mk,*.made,Makefile*}
303mv Documents/BrlAPIref/{html,BrlAPIref}
304
305# Don't want static lib
306rm -rf $RPM_BUILD_ROOT%{_libdir}/libbrlapi.a
307
308# ghost brlapi.key
309touch $RPM_BUILD_ROOT%{_sysconfdir}/brlapi.key
310
311# disable xbrlapi gdm autostart, there is already orca
312rm -f $RPM_BUILD_ROOT%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
313
314# handle locales
315%find_lang %{name}
316
317%clean
318rm -rf $RPM_BUILD_ROOT
319
320%post
321devices="/dev/vcsa /dev/vcsa0 /dev/vcc/a"
322install=true
323for device in ${devices}
324do
325   if [ -c "${device}" ]
326   then
327      install=false
328      break
329   fi
330done
331if $install
332then
333    device="$(set -- ${devices} && echo "${1}")"
334    mkdir -p "${device%/*}"
335    mknod -m o= "${device}" c 7 128
336    chmod 660 "${device}"
337    chown root.tty "${device}"
338fi
339exit 0
340
341%pre -n brlapi
342getent group brlapi >/dev/null || groupadd -r brlapi >/dev/null
343
344%post -n brlapi
345if [ ! -e %{_sysconfdir}/brlapi.key ]; then
346    mcookie > %{_sysconfdir}/brlapi.key
347    chgrp brlapi %{_sysconfdir}/brlapi.key
348    chmod 0640 %{_sysconfdir}/brlapi.key
349fi
350/sbin/ldconfig
351
352%postun -n brlapi -p /sbin/ldconfig
353
354%files -f %{name}.lang
355%defattr(-,root,root)
356%doc LICENSE-GPL LICENSE-LGPL
357%config(noreplace) %{_sysconfdir}/brltty.conf
358%{_sysconfdir}/brltty/
359%{_bindir}/brltty
360%{_bindir}/brltty-*
361%{_libdir}/brltty/
362%exclude %{_libdir}/brltty/libbrlttybba.so
363%exclude %{_libdir}/brltty/libbrlttybxw.so
364%exclude %{_libdir}/brltty/libbrlapi_java.so
365%if %{with_speech_dispatcher}
366%exclude %{_libdir}/brltty/libbrlttyssd.so
367%endif
368%exclude %{_libdir}/brltty/libbrlttyxas.so
369%{_mandir}/man[15]/brltty.*
370
371%if %{with_speech_dispatcher}
372%files speech-dispatcher
373%defattr(-,root,root)
374%doc Drivers/Speech/SpeechDispatcher/README
375%{_libdir}/brltty/libbrlttyssd.so
376%endif
377
378%files docs
379%defattr(-,root,root)
380%doc Documents/ChangeLog Documents/TODO
381%doc Documents/Manual-BRLTTY/
382%doc doc/*
383
384%files xw
385%defattr(-,root,root)
386%doc Drivers/Braille/XWindow/README
387%{_libdir}/brltty/libbrlttybxw.so
388
389%files at-spi
390%defattr(-,root,root)
391%{_libdir}/brltty/libbrlttyxas.so
392
393%files -n brlapi
394%defattr(-,root,root)
395%doc Drivers/Braille/XWindow/README
396%doc Documents/Manual-BrlAPI/
397%ghost %{_sysconfdir}/brlapi.key
398%{_bindir}/vstp
399%{_bindir}/eutp
400%{_bindir}/xbrlapi
401%{_libdir}/brltty/libbrlttybba.so
402%{_libdir}/libbrlapi.so.*
403%{_mandir}/man1/xbrlapi.*
404%{_mandir}/man1/vstp.*
405%{_mandir}/man1/eutp.*
406
407%files -n brlapi-devel
408%defattr(-,root,root)
409%doc Documents/BrlAPIref/BrlAPIref/
410%{_libdir}/libbrlapi.so
411%{_includedir}/brltty
412%{_includedir}/brlapi*.h
413%{_mandir}/man3/brlapi_*.3*
414
415%files -n tcl-brlapi
416%defattr(-,root,root)
417%{_libdir}/tcl%{tcl_version}/brlapi-%{api_version}
418
419%files -n python-brlapi
420%defattr(-,root,root)
421%{python_sitearch}/brlapi.so
422%{python_sitearch}/Brlapi-%{api_version}-py%{pyver}.egg-info
423
424%files -n python3-brlapi
425%defattr(-,root,root)
426%{python3_sitearch}/brlapi.cpython-*.so
427%{python3_sitearch}/Brlapi-%{api_version}-*.egg-info
428
429%files -n brlapi-java
430%defattr(-,root,root)
431%{_libdir}/brltty/libbrlapi_java.so
432%{_jnidir}/brlapi.jar
433
434%if %{with_ocaml}
435%files -n ocaml-brlapi
436%defattr(-,root,root)
437%{_libdir}/ocaml/brlapi/
438%{_libdir}/ocaml/stublibs/
439%endif
440
441
442%changelog
443* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-3
444- rebuild with python3-3.5.2
445
446* Wed Apr 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-2
447- add BuildRequires: python3-devel
448- create python3-brlapi subpackage
449
450* Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.2-1
451- updated to 5.2
452- added speech-dispatcher, doc, and ocaml subpackages
453
454* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2-2
455- rebuild with python-2.7.2
456
457* Fri Nov 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2-1
458- initial build for Vine Linux
459
460* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2-4
461- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
462
463* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 4.2-3
464- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
465
466* Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-2
467- rework parallel patch slightly and reapply
468
469* Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-1
470- update to 4.2
471- drop static lib (bz 556041)
472- fix undefined S_ISCHR call
473
474* Wed Jan 20 2010 Stepan Kasal <skasal@redhat.com> - 4.1-5
475- requires(post): coreutils to work around an installator bug
476- Resolves: #540437
477
478* Wed Jan 13 2010 Stepan Kasal <skasal@redhat.com> - 4.1-4
479- limit building against speech-dispatcher to Fedora
480- Resolves: rhbz#553795
481
482* Sun Nov  1 2009 Stepan Kasal <skasal@redhat.com> - 4.1-3
483- build the TTY driver (it was disabled since it first appered in 3.7.2-1)
484- build with speech-dispatcher, packed into a separate sub-package
485
486* Fri Oct 30 2009 Stepan Kasal <skasal@redhat.com> - 4.1-2
487- move data-directory back to default: /etc/brltty
488- move brltty to /bin and /lib, so that it can be used to repair the system
489  without /usr mounted (#276181)
490- move vstp and libbrlttybba.so to brlapi
491- brltty no longer requires brlapi
492- brlapi now requires brltty from the same build
493
494* Wed Oct 28 2009 Stepan Kasal <skasal@redhat.com> - 4.1-1
495- new upstream version
496- use --disable-stripping instead of make variable override
497- install the default brltty-pm.conf to docdir only (#526168)
498- remove the duplicate copies of rhmkboot and rhmkroot from docdir
499- patch configure so that the dirs in summary are not garbled:
500  brltty-autoconf-quote.patch
501- move data-directory to ${datadir}/brltty
502
503* Tue Oct 20 2009 Stepan Kasal <skasal@redhat.com> - 4.0-2
504- escape rpm macros in the rpm change log
505- add requires to bind subpackages from one build together
506
507* Wed Oct  7 2009 Stepan Kasal <skasal@redhat.com> - 4.0-1
508- new upstream version
509- drop upstreamed patches; ./autogen not needed anymore
510- pack the xbrlapi server; move its man page to brlapi package
511- add man-page for brltty.conf (#526168)
512
513* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-6
514- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
515
516* Tue May 12 2009 Stepan Kasal <skasal@redhat.com> - 3.10-5
517- rebuild after java-1.5.0-gcj rebuild
518
519* Thu Apr 30 2009 Stepan Kasal <skasal@redhat.com> - 3.10-4
520- own the tcl subdirectory (#474032)
521- set CPPFLAGS to java include dirs, so that the java bindings build with
522  any java implementation (#498964)
523- add --without-curses; there is no curses package BuildRequired anyway
524
525* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-3
526- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
527
528* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.10-2
529- Rebuild for Python 2.6
530
531* Sat Sep 13 2008 Stepan Kasal <skasal@redhat.com> - 3.10-1
532- new upstream release
533- drop brltty-3.9-java-svn.patch, brltty-3.9-tcl85path.patch,
534  and brltty-3.9-pyxfix.patch, they are upstream
535- fix BuildRoot
536- fix many sub-packages' Requires on brlapi
537
538* Wed Sep 10 2008 Stepan Kasal <skasal@redhat.com> - 3.9-3
539- add brltty-3.9-autoconf.patch to fix to build with Autoconf 2.62
540- add brltty-3.9-parallel.patch to fix race condition with parallel make
541- add brltty-3.9-pyxfix.patch to fix build with current pyrex
542- Summary lines shall not end with a dot
543
544* Thu Feb 28 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-2.2
545- glibc build fixes
546- applied java reorganisations from svn
547
548* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.9-2.1
549- Autorebuild for GCC 4.3
550
551* Wed Jan 09 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-1.1
552- specfile update to comply with tcl packaging guidelines
553
554* Mon Jan 07 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-1
555- update to latest upstream (3.9)
556
557* Tue Sep 18 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-2.svn3231
558- update to r3231 from svn
559- added java binding subpackage
560
561* Wed Aug 29 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-2.svn3231
562- update to r3231 from svn
563
564* Tue Aug 21 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-1
565- update to latest upstream
566- added the at-spi driver, tcl and python bindings
567- fixed the license tags
568
569* Mon Mar 05 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-3
570- added the XWindow driver
571- build fix for newer byacc
572
573* Tue Jan 30 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-2.1
574- quiet postinstall scriptlet, really fixes #224570
575
576* Tue Jan 30 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-2
577- failsafe postinstall script, fixes #224570
578- makefile fix - debuginfo extraction now works
579
580* Thu Jan 25 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-1.1
581- fix building with newer kernel-headers (#224149)
582
583* Wed Jul 12 2006 Petr Rockai <prockai@redhat.com> - 3.7.2-1
584- upgrade to latest upstream version
585- split off brlapi and brlapi-devel packages
586
587* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.2-12.1
588- rebuild
589
590* Sun Jul 02 2006 Florian La Roche <laroche@redhat.com>
591- for the post script require coreutils
592
593* Mon Jun 05 2006 Jesse Keating <jkeating@redhat.com> - 3.2-11
594- Added byacc BuildRequires, removed prereq, coreutils is always there
595
596* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.2-10.2.1
597- bump again for double-long bug on ppc(64)
598
599* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.2-10.2
600- rebuilt for new gcc4.1 snapshot and glibc changes
601
602* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
603- rebuilt
604
605* Wed Mar 16 2005 Bill Nottingham <notting@redhat.com> 3.2-10
606- rebuild
607
608* Fri Nov 26 2004 Florian La Roche <laroche@redhat.com>
609- add a %%clean into .spec
610
611* Thu Oct 14 2004 Adrian Havill <havill@redhat.com> 3.2-5
612- chmod a-x for conf file (#116244)
613
614* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
615- rebuilt
616
617* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
618- rebuilt
619
620* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
621- rebuilt
622
623* Tue Sep 30 2003 Florian La Roche <Florian.LaRoche@redhat.de>
624- prereq coreutils for mknod/chown/chmod
625
626* Mon Jul 07 2003 Adrian Havill <havill@redhat.com> 3.2-2
627- changed spec "Copyright" to "License"
628- use %%configure macro, %%{_libdir} for non-ia32 archs
629- removed unnecessary set and unset, assumed/default spec headers
630- fixed unpackaged man page, duplicate /bin and /lib entries
631- use plain install vs scripts for non-i386 buildsys
Note: See TracBrowser for help on using the repository browser.