source: projects/specs/trunk/b/boo/boo-vl.spec @ 9477

Revision 9477, 8.9 KB checked in by inagaki, 9 years ago (diff)

2015-03-31 Ryoichi INAGAKI <ryo1@…>

  • boo: added patch and rebuilt
  • gnome-keyring-sharp, mono-tools, nofity-sharp: updated
  • tomboy: rebuilt


Line 
1%define debug_package %{nil}
2%define monodir %{_prefix}/lib
3
4Summary: An OO statically typed language for CLI
5Summary(ja): CLI 用のオブジェクト指向静的型付け言語
6Name: boo
7Version: 0.9.4.9
8Release: 3%{?_dist_release}
9License: MIT
10Group: Development/Languages
11
12URL: http://boo.codehaus.org
13Source0: http://dist.codehaus.org/boo/distributions/%{name}-%{version}-src.tar.bz2
14Patch0: boo-pkgconfig_path_fix.patch
15Patch1: boo-gtksourceview.patch
16Patch3: mono-2.0.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: mono-devel
20BuildRequires: gtksourceview2-devel
21BuildRequires: shared-mime-info
22BuildRequires: pkgconfig
23BuildRequires: nant
24BuildArch: noarch
25
26Requires(post): shared-mime-info
27Requires(postun): shared-mime-info
28
29%description
30Boo is a new object oriented statically typed programming language for the
31Common Language Infrastructure with a python inspired syntax and a special
32focus on language and compiler extensibility.
33
34%package devel
35Summary: Development files for boo
36Summary(ja): boo の開発用ファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41Development files for boo
42
43%prep
44%setup -q
45%patch0 -p1 -b .pc-original
46%patch1 -p1 -b .sourceview
47%patch3 -p1  -b .mono-2.0.patch
48
49# Get rid of prebuilt dll files
50rm -rf bin/*.dll bin/pt/*.dll
51
52# fix end-of-line encoding
53perl -pi -e 's/\r//' $(find examples/ -type f)
54
55%build
56nant -nologo -D:install.prefix=%{_prefix} -D:install.libdir=%{monodir}
57
58%install
59rm -rf %{buildroot}
60nant -f:default.build install -D:install.buildroot=%{buildroot} -D:install.prefix=%{buildroot}%{_prefix} -D:install.share=%{buildroot}%{_datadir} -D:install.libdir=%{buildroot}%{monodir} -D:install.bindir=%{buildroot}%{_bindir} -D:fakeroot.sharedmime=%{buildroot}%{_datadir}/.. -D:fakeroot.gsv=%{buildroot}%{_prefix}
61
62mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
63test "%{_libdir}" = "%{_prefix}/lib" || mv $RPM_BUILD_ROOT/%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
64
65%clean
66rm -rf %{buildroot}
67
68%post
69update-mime-database %{_datadir}/mime &> /dev/null || :
70
71%postun
72update-mime-database %{_datadir}/mime &> /dev/null || :
73
74%files
75%defattr(-,root,root,-)
76%doc license.txt notice.txt readme.txt docs/BooManifesto.sxw
77%{monodir}/boo*/
78%exclude %{monodir}/boo/Boo.NAnt.Tasks.dll
79%exclude %{monodir}/boo/Boo.Microsoft.Build.*
80%dir %{monodir}/mono/boo
81%{monodir}/mono/boo/*.dll
82%{monodir}/mono/gac/Boo*/
83%{_bindir}/boo*
84%exclude %{_datadir}/gtksourceview-1.0/language-specs/boo.lang
85%{_datadir}/mime/packages/boo*
86%{_datadir}/mime-info/boo*
87
88%files devel
89%defattr(-,root,root,-)
90%{_libdir}/pkgconfig/boo.pc
91%{monodir}/boo/Boo.Microsoft.Build.*
92%{monodir}/boo/Boo.NAnt.Tasks.dll
93
94%changelog
95* Tue Mar 31 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.4.9-3
96- added Patch3 to build with current VineSeed
97- built with nant 0.92+git20130131
98
99* Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.4.9-2
100- fix %%files
101
102* Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.4.9-1
103- initial build for Vine Linux
104
105
106* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4.9-4
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
108
109* Mon Nov 21 2011 Christian Krause <chkr@fedoraproject.org> - 0.9.4.9-3
110- Change paths for mono assemblies according to updated packaging
111  guidelines (http://fedoraproject.org/wiki/Packaging:Mono)
112
113* Tue Apr 19 2011 Dan Horák <dan[at]danny.cz> - 0.9.4.9-2
114- updated the supported arch list
115
116* Fri Feb 18 2011 Paul Lange <palango@gmx.de> - 0.9.4.9-1
117- update to 0.9.4
118
119* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.3.3457-2
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
121
122* Thu Oct 14 2010 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.9.3.3457-1
123- Update to newest version
124- Alter BR nant to BR nant-devel
125
126* Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.9.2.3383-3
127- ExcludeArch sparc64
128
129* Tue Oct 06 2009 Paul Lange <palango@gmx.de> - 0.9.2.3383-2
130- Move Boo.NAnt.Tasks.dll to boo-devel
131
132* Wed Sep 16 2009 Paul Lange <palango@gmx.de> - 0.9.2.3383-1
133- Update to boo 0.9.2
134- remove libdir patch
135
136* Fri Aug 28 2009 Paul Lange <palango@gmx.de> - 0.9.1.3287-3
137- Fix executable paths
138
139* Thu Aug 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.9.1.3287-2
140- Fix libdir in boo.pc to use %{_libdir}
141- Summary no longer repeats package name
142
143* Sun Aug 02 2009 Paul Lange <palango@gmx.de> - 0.9.1.3287-1
144- Update to boo 0.9.1
145
146* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1.2865-8
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
148
149* Mon Jun 15 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 0.8.1.2865-7
150- Include missing directory entries (#473630).
151
152* Mon Apr 20 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 0.8.1.2865-6
153- Fix FTBFS: added boo-mono.patch
154
155* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1.2865-5
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
157
158* Sat Apr 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.8.1.2865-4
159- get rid of prebuilt binary files
160
161* Tue Mar  4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.8.1.2865-3
162- Rebuild for new nant (causes broken deps)
163
164* Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.8.1-2865-2
165- Nope, ppc still broken (#434631)
166
167* Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.8.1-2865-1
168- Bump to 0.8.1
169- Exclude Visual Studio Environment buildtarget
170- Reenable ppc
171
172* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.8.0.2730-9
173- Autorebuild for GCC 4.3
174
175* Thu Jan 03 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-7
176- spec fix
177
178* Wed Dec 19 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-6
179- remove ppc build
180- fix libdir problem for pc file
181
182* Sun Dec 16 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-5
183- reenable ppc
184
185* Thu Nov 22 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-4
186- fixes to patches for corrected libdirs
187
188* Sat Nov 17 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-3
189- Added exclusivearch
190
191* Sun Nov 11 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-2
192- large bump
193- removed fc5 and fc6 bit6
194- removed MS update builds from default build
195- fixed problem with the boo.pc file
196
197* Sun Feb 18 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6-2237-13
198- fix for correct libdir in bin scripts
199
200* Wed Dec 20 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6-2237-11
201- fix for correct libdir
202
203* Thu Sep 14 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-9
204- rebuild
205
206* Mon Aug 07 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-8
207- adds conditional for boo.lang - not required in FC6
208
209* Wed Jul 26 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-7
210- claims ownership of monodir-boo now
211
212* Tue Jul 25 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-6
213- replaced monodir for libdir in devel
214- fixed tab-spaces problem
215- removed rm rf from the prep step
216- added update-mime-database
217
218* Sun Jul 23 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-5
219- removed nodebug
220- removed redefine of libdir
221- removed buildarch
222- added BR nant
223
224* Sat Jun 17 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-3
225- removed exclusivearch
226- changed BR
227- removed R
228- altered nant to /usr/bin/nant
229
230* Thu Jun 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-1
231- Spec file fixes
232- Fix for gtksourceview-1.0 langspecs
233- Added fixed libdir
234- rebuild for mono 1.1.15
235
236* Thu Jun 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-1
237- Bump to 0.7.6-2237
238- Added R nant
239- Multiple fixes to the install as it uses nant rather than make install
240- Removed some bits from the files section as they're no longer in boo
241
242* Wed May 31 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2013-7
243- Added devel files
244- Added doc to files section instead of adding the files manually
245- Added fix for x86_64
246
247* Mon May 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2013-6
248- Altered again for mock and x86_64
249
250* Fri Apr 28 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-5
251- added shared mime to satisfy mock
252
253* Sat Apr 22 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-4
254- Removal of the always usr-lib, but now use the system used in f-spot
255- include archs mono is available on
256- added requires: mono-core, gtksourceview
257- changed BR to include gtksourceview-sharp
258- removes the conflict in the language-specs with gtksourceview package
259
260* Tue Apr 18 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-3
261- Spec file tweaks
262- libdir is now usr-lib irrespective of hardware built on
263- Added docs to package
264
265* Mon Apr 17 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-2
266- Small fix to the spec file
267
268* Sat Apr 15 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-1
269- Initial import and debug for FE (spec file based on the mono project one)
Note: See TracBrowser for help on using the repository browser.