source: projects/specs/trunk/b/boo/boo-vl.spec @ 9480

Revision 9480, 9.2 KB checked in by inagaki, 9 years ago (diff)

2015-04-01 Ryoichi INAGAKI <ryo1@…>

  • banshee, gdata-sharp, gkeyfile-sharp, gudev-sharp: rebuilt
  • boo: fixed spec
  • taglib-sharp: updated


Line 
1%define debug_package %{nil}
2%define monodir %{_prefix}/lib
3
4Summary: An OO statically typed language for CLI
5Summary(ja): CLI 用のオブジェクト指向静的型付け言語
6Name: boo
7Version: 0.9.4.9
8Release: 4%{?_dist_release}
9License: MIT
10Group: Development/Languages
11
12URL: http://boo.codehaus.org
13Source0: http://dist.codehaus.org/boo/distributions/%{name}-%{version}-src.tar.bz2
14Patch0: boo-pkgconfig_path_fix.patch
15Patch1: boo-gtksourceview.patch
16Patch3: mono-2.0.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: mono-devel
20BuildRequires: gtksourceview2-devel
21BuildRequires: shared-mime-info
22BuildRequires: pkgconfig
23BuildRequires: nant
24BuildArch: noarch
25
26Requires(post): shared-mime-info
27Requires(postun): shared-mime-info
28
29%description
30Boo is a new object oriented statically typed programming language for the
31Common Language Infrastructure with a python inspired syntax and a special
32focus on language and compiler extensibility.
33
34%package devel
35Summary: Development files for boo
36Summary(ja): boo の開発用ファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41Development files for boo
42
43%prep
44%setup -q
45%patch0 -p1 -b .pc-original
46%patch1 -p1 -b .sourceview
47%patch3 -p1  -b .mono-2.0.patch
48
49# Get rid of prebuilt dll files
50rm -rf bin/*.dll bin/pt/*.dll
51
52# fix end-of-line encoding
53perl -pi -e 's/\r//' $(find examples/ -type f)
54
55%build
56nant -nologo -D:install.prefix=%{_prefix} -D:install.libdir=%{monodir}
57
58%install
59rm -rf %{buildroot}
60nant -f:default.build install -D:install.buildroot=%{buildroot} -D:install.prefix=%{buildroot}%{_prefix} -D:install.share=%{buildroot}%{_datadir} -D:install.libdir=%{buildroot}%{monodir} -D:install.bindir=%{buildroot}%{_bindir} -D:fakeroot.sharedmime=%{buildroot}%{_datadir}/.. -D:fakeroot.gsv=%{buildroot}%{_prefix}
61
62#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
63#test "%{_libdir}" = "%{_prefix}/lib" || mv $RPM_BUILD_ROOT/%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
64
65mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pkgconfig
66mv $RPM_BUILD_ROOT/%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT/%{_datadir}/pkgconfig
67
68%clean
69rm -rf %{buildroot}
70
71%post
72update-mime-database %{_datadir}/mime &> /dev/null || :
73
74%postun
75update-mime-database %{_datadir}/mime &> /dev/null || :
76
77%files
78%defattr(-,root,root,-)
79%doc license.txt notice.txt readme.txt docs/BooManifesto.sxw
80%{monodir}/boo*/
81%exclude %{monodir}/boo/Boo.NAnt.Tasks.dll
82%exclude %{monodir}/boo/Boo.Microsoft.Build.*
83%dir %{monodir}/mono/boo
84%{monodir}/mono/boo/*.dll
85%{monodir}/mono/gac/Boo*/
86%{_bindir}/boo*
87%exclude %{_datadir}/gtksourceview-1.0/language-specs/boo.lang
88%{_datadir}/mime/packages/boo*
89%{_datadir}/mime-info/boo*
90
91%files devel
92%defattr(-,root,root,-)
93%{monodir}/boo/Boo.Microsoft.Build.*
94%{monodir}/boo/Boo.NAnt.Tasks.dll
95%{_datadir}/pkgconfig/boo.pc
96
97%changelog
98* Wed Apr  1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.4.9-4
99- fixed pkgconfig location
100
101* Tue Mar 31 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.4.9-3
102- added Patch3 to build with current VineSeed
103- built with nant 0.92+git20130131
104
105* Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.4.9-2
106- fix %%files
107
108* Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.4.9-1
109- initial build for Vine Linux
110
111
112* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4.9-4
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
114
115* Mon Nov 21 2011 Christian Krause <chkr@fedoraproject.org> - 0.9.4.9-3
116- Change paths for mono assemblies according to updated packaging
117  guidelines (http://fedoraproject.org/wiki/Packaging:Mono)
118
119* Tue Apr 19 2011 Dan Horák <dan[at]danny.cz> - 0.9.4.9-2
120- updated the supported arch list
121
122* Fri Feb 18 2011 Paul Lange <palango@gmx.de> - 0.9.4.9-1
123- update to 0.9.4
124
125* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.3.3457-2
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
127
128* Thu Oct 14 2010 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.9.3.3457-1
129- Update to newest version
130- Alter BR nant to BR nant-devel
131
132* Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.9.2.3383-3
133- ExcludeArch sparc64
134
135* Tue Oct 06 2009 Paul Lange <palango@gmx.de> - 0.9.2.3383-2
136- Move Boo.NAnt.Tasks.dll to boo-devel
137
138* Wed Sep 16 2009 Paul Lange <palango@gmx.de> - 0.9.2.3383-1
139- Update to boo 0.9.2
140- remove libdir patch
141
142* Fri Aug 28 2009 Paul Lange <palango@gmx.de> - 0.9.1.3287-3
143- Fix executable paths
144
145* Thu Aug 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.9.1.3287-2
146- Fix libdir in boo.pc to use %{_libdir}
147- Summary no longer repeats package name
148
149* Sun Aug 02 2009 Paul Lange <palango@gmx.de> - 0.9.1.3287-1
150- Update to boo 0.9.1
151
152* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1.2865-8
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
154
155* Mon Jun 15 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 0.8.1.2865-7
156- Include missing directory entries (#473630).
157
158* Mon Apr 20 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 0.8.1.2865-6
159- Fix FTBFS: added boo-mono.patch
160
161* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1.2865-5
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
163
164* Sat Apr 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.8.1.2865-4
165- get rid of prebuilt binary files
166
167* Tue Mar  4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.8.1.2865-3
168- Rebuild for new nant (causes broken deps)
169
170* Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.8.1-2865-2
171- Nope, ppc still broken (#434631)
172
173* Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.8.1-2865-1
174- Bump to 0.8.1
175- Exclude Visual Studio Environment buildtarget
176- Reenable ppc
177
178* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.8.0.2730-9
179- Autorebuild for GCC 4.3
180
181* Thu Jan 03 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-7
182- spec fix
183
184* Wed Dec 19 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-6
185- remove ppc build
186- fix libdir problem for pc file
187
188* Sun Dec 16 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-5
189- reenable ppc
190
191* Thu Nov 22 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-4
192- fixes to patches for corrected libdirs
193
194* Sat Nov 17 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-3
195- Added exclusivearch
196
197* Sun Nov 11 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-2
198- large bump
199- removed fc5 and fc6 bit6
200- removed MS update builds from default build
201- fixed problem with the boo.pc file
202
203* Sun Feb 18 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6-2237-13
204- fix for correct libdir in bin scripts
205
206* Wed Dec 20 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6-2237-11
207- fix for correct libdir
208
209* Thu Sep 14 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-9
210- rebuild
211
212* Mon Aug 07 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-8
213- adds conditional for boo.lang - not required in FC6
214
215* Wed Jul 26 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-7
216- claims ownership of monodir-boo now
217
218* Tue Jul 25 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-6
219- replaced monodir for libdir in devel
220- fixed tab-spaces problem
221- removed rm rf from the prep step
222- added update-mime-database
223
224* Sun Jul 23 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-5
225- removed nodebug
226- removed redefine of libdir
227- removed buildarch
228- added BR nant
229
230* Sat Jun 17 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-3
231- removed exclusivearch
232- changed BR
233- removed R
234- altered nant to /usr/bin/nant
235
236* Thu Jun 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-1
237- Spec file fixes
238- Fix for gtksourceview-1.0 langspecs
239- Added fixed libdir
240- rebuild for mono 1.1.15
241
242* Thu Jun 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-1
243- Bump to 0.7.6-2237
244- Added R nant
245- Multiple fixes to the install as it uses nant rather than make install
246- Removed some bits from the files section as they're no longer in boo
247
248* Wed May 31 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2013-7
249- Added devel files
250- Added doc to files section instead of adding the files manually
251- Added fix for x86_64
252
253* Mon May 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2013-6
254- Altered again for mock and x86_64
255
256* Fri Apr 28 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-5
257- added shared mime to satisfy mock
258
259* Sat Apr 22 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-4
260- Removal of the always usr-lib, but now use the system used in f-spot
261- include archs mono is available on
262- added requires: mono-core, gtksourceview
263- changed BR to include gtksourceview-sharp
264- removes the conflict in the language-specs with gtksourceview package
265
266* Tue Apr 18 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-3
267- Spec file tweaks
268- libdir is now usr-lib irrespective of hardware built on
269- Added docs to package
270
271* Mon Apr 17 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-2
272- Small fix to the spec file
273
274* Sat Apr 15 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-1
275- Initial import and debug for FE (spec file based on the mono project one)
Note: See TracBrowser for help on using the repository browser.