source: projects/specs/trunk/b/boo/boo-vl.spec @ 6270

Revision 6270, 8.4 KB checked in by Takemikaduchi, 12 years ago (diff)

NEW: banshee and C# binding packages

Line 
1%define debug_package %{nil}
2%define monodir %{_prefix}/lib
3
4Summary: An OO statically typed language for CLI
5Name: boo
6Version: 0.9.4.9
7Release: 1%{?_dist_release}
8License: MIT
9Group: Development/Languages
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11URL: http://boo.codehaus.org
12Source0: http://dist.codehaus.org/boo/distributions/%{name}-%{version}-src.tar.bz2
13Patch0: boo-pkgconfig_path_fix.patch
14Patch1: boo-gtksourceview.patch
15BuildRequires: mono-devel, gtksourceview2-devel, shared-mime-info, pkgconfig, nant
16# Mono only available on these:
17ExclusiveArch: %ix86 x86_64 ppc ppc64 ia64 %{arm} sparcv9 alpha s390x
18
19%description
20Boo is a new object oriented statically typed programming language for the
21Common Language Infrastructure with a python inspired syntax and a special
22focus on language and compiler extensibility.
23
24%package devel
25Summary: Development files for boo
26Group: Development/Libraries
27Requires: %{name} = %{version}-%{release}
28
29%description devel
30Development files for boo
31
32%prep
33%setup -q
34%patch0 -p1 -b .pc-original
35%patch1 -p1 -b .sourceview
36
37# Get rid of prebuilt dll files
38rm -rf bin/*.dll bin/pt/*.dll
39
40%build
41nant -D:install.prefix=%{_prefix} -D:install.libdir=%{monodir}
42
43%install
44rm -rf %{buildroot}
45nant -f:default.build install -D:install.buildroot=%{buildroot} -D:install.prefix=%{buildroot}%{_prefix} -D:install.share=%{buildroot}%{_datadir} -D:install.libdir=%{buildroot}%{monodir} -D:install.bindir=%{buildroot}%{_bindir} -D:fakeroot.sharedmime=%{buildroot}%{_datadir}/.. -D:fakeroot.gsv=%{buildroot}%{_prefix}
46
47mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
48test "%{_libdir}" = "%{_prefix}/lib" || mv $RPM_BUILD_ROOT/%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
49
50%clean
51rm -rf %{buildroot}
52
53%post
54update-mime-database %{_datadir}/mime &> /dev/null || :
55
56%postun
57update-mime-database %{_datadir}/mime &> /dev/null || :
58
59%files
60%defattr(-,root,root,-)
61%doc license.txt notice.txt readme.txt docs/BooManifesto.sxw
62%{monodir}/boo*/
63%exclude %{monodir}/boo/Boo.NAnt.Tasks.dll
64%dir %{monodir}/mono/boo
65%{monodir}/mono/boo/*.dll
66%{monodir}/mono/gac/Boo*/
67%{_bindir}/boo*
68%exclude %{_datadir}/gtksourceview-1.0/language-specs/boo.lang
69%{_datadir}/mime/packages/boo*
70%{_datadir}/mime-info/boo*
71
72%files devel
73%defattr(-,root,root,-)
74%{_libdir}/pkgconfig/boo.pc
75%{monodir}/boo/Boo.NAnt.Tasks.dll
76
77%changelog
78* Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.4.9-1
79- initial build for Vine Linux
80
81
82* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4.9-4
83- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
84
85* Mon Nov 21 2011 Christian Krause <chkr@fedoraproject.org> - 0.9.4.9-3
86- Change paths for mono assemblies according to updated packaging
87  guidelines (http://fedoraproject.org/wiki/Packaging:Mono)
88
89* Tue Apr 19 2011 Dan Horák <dan[at]danny.cz> - 0.9.4.9-2
90- updated the supported arch list
91
92* Fri Feb 18 2011 Paul Lange <palango@gmx.de> - 0.9.4.9-1
93- update to 0.9.4
94
95* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.3.3457-2
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
97
98* Thu Oct 14 2010 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.9.3.3457-1
99- Update to newest version
100- Alter BR nant to BR nant-devel
101
102* Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.9.2.3383-3
103- ExcludeArch sparc64
104
105* Tue Oct 06 2009 Paul Lange <palango@gmx.de> - 0.9.2.3383-2
106- Move Boo.NAnt.Tasks.dll to boo-devel
107
108* Wed Sep 16 2009 Paul Lange <palango@gmx.de> - 0.9.2.3383-1
109- Update to boo 0.9.2
110- remove libdir patch
111
112* Fri Aug 28 2009 Paul Lange <palango@gmx.de> - 0.9.1.3287-3
113- Fix executable paths
114
115* Thu Aug 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.9.1.3287-2
116- Fix libdir in boo.pc to use %{_libdir}
117- Summary no longer repeats package name
118
119* Sun Aug 02 2009 Paul Lange <palango@gmx.de> - 0.9.1.3287-1
120- Update to boo 0.9.1
121
122* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1.2865-8
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
124
125* Mon Jun 15 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 0.8.1.2865-7
126- Include missing directory entries (#473630).
127
128* Mon Apr 20 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 0.8.1.2865-6
129- Fix FTBFS: added boo-mono.patch
130
131* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1.2865-5
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
133
134* Sat Apr 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.8.1.2865-4
135- get rid of prebuilt binary files
136
137* Tue Mar  4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.8.1.2865-3
138- Rebuild for new nant (causes broken deps)
139
140* Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.8.1-2865-2
141- Nope, ppc still broken (#434631)
142
143* Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.8.1-2865-1
144- Bump to 0.8.1
145- Exclude Visual Studio Environment buildtarget
146- Reenable ppc
147
148* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.8.0.2730-9
149- Autorebuild for GCC 4.3
150
151* Thu Jan 03 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-7
152- spec fix
153
154* Wed Dec 19 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-6
155- remove ppc build
156- fix libdir problem for pc file
157
158* Sun Dec 16 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-5
159- reenable ppc
160
161* Thu Nov 22 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-4
162- fixes to patches for corrected libdirs
163
164* Sat Nov 17 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-3
165- Added exclusivearch
166
167* Sun Nov 11 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-2
168- large bump
169- removed fc5 and fc6 bit6
170- removed MS update builds from default build
171- fixed problem with the boo.pc file
172
173* Sun Feb 18 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6-2237-13
174- fix for correct libdir in bin scripts
175
176* Wed Dec 20 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6-2237-11
177- fix for correct libdir
178
179* Thu Sep 14 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-9
180- rebuild
181
182* Mon Aug 07 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-8
183- adds conditional for boo.lang - not required in FC6
184
185* Wed Jul 26 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-7
186- claims ownership of monodir-boo now
187
188* Tue Jul 25 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-6
189- replaced monodir for libdir in devel
190- fixed tab-spaces problem
191- removed rm rf from the prep step
192- added update-mime-database
193
194* Sun Jul 23 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-5
195- removed nodebug
196- removed redefine of libdir
197- removed buildarch
198- added BR nant
199
200* Sat Jun 17 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-3
201- removed exclusivearch
202- changed BR
203- removed R
204- altered nant to /usr/bin/nant
205
206* Thu Jun 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-1
207- Spec file fixes
208- Fix for gtksourceview-1.0 langspecs
209- Added fixed libdir
210- rebuild for mono 1.1.15
211
212* Thu Jun 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-1
213- Bump to 0.7.6-2237
214- Added R nant
215- Multiple fixes to the install as it uses nant rather than make install
216- Removed some bits from the files section as they're no longer in boo
217
218* Wed May 31 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2013-7
219- Added devel files
220- Added doc to files section instead of adding the files manually
221- Added fix for x86_64
222
223* Mon May 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2013-6
224- Altered again for mock and x86_64
225
226* Fri Apr 28 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-5
227- added shared mime to satisfy mock
228
229* Sat Apr 22 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-4
230- Removal of the always usr-lib, but now use the system used in f-spot
231- include archs mono is available on
232- added requires: mono-core, gtksourceview
233- changed BR to include gtksourceview-sharp
234- removes the conflict in the language-specs with gtksourceview package
235
236* Tue Apr 18 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-3
237- Spec file tweaks
238- libdir is now usr-lib irrespective of hardware built on
239- Added docs to package
240
241* Mon Apr 17 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-2
242- Small fix to the spec file
243
244* Sat Apr 15 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-1
245- Initial import and debug for FE (spec file based on the mono project one)
Note: See TracBrowser for help on using the repository browser.