source: projects/specs/trunk/b/bogofilter/bogofilter-vl.spec @ 9332

Revision 9332, 5.6 KB checked in by inagaki, 9 years ago (diff)

2015-02-06 Ryoichi INAGAKI <ryo1@…>

  • bogofilter: updated
  • perl, python-bsbddb3: rebuilt with libdb


Line 
1Name:           bogofilter
2Summary:        fast anti-spam filtering by Bayesian statistical analysis
3Summary(ja):    ベイジアン解析による高速アンチスパムフィルタリング
4Version:        1.2.4
5Release:        1%{?_dist_release}
6License:        GPLv2
7Group:          Applications/Internet
8URL:            http://bogofilter.sourceforge.net/
9Source0:        http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
10Source999:      filter-requires-bogofilter.sh
11Patch10:        http://www.c-wind.com/bogofilter/bogofilter-%{version}+mecab-0.1.patch.gz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  libdb-devel
15BuildRequires:  mecab-devel
16BuildRequires:  gsl-devel
17BuildRequires:  flex
18BuildRequires:  xmlto
19
20%define __find_requires %{SOURCE999}
21
22%description
23Bogofilter is a Bayesian spam filter.  In its normal mode of
24operation, it takes an email message or other text on standard input,
25does a statistical check against lists of "good" and "bad" words, and
26returns a status code indicating whether or not the message is spam.
27Bogofilter is designed with fast algorithms (including Berkeley DB system),
28coded directly in C, and tuned for speed, so it can be used for production
29by sites that process a lot of mail.
30
31%prep
32[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
33
34%setup -q
35%patch10 -p1 -b .mecab
36
37%build
38export CFLAGS="$RPM_OPT_FLAGS -DWAKATI"
39export LIBS="`mecab-config --libs`"
40%configure --program-prefix=
41%__make
42
43%install
44[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
45make install DESTDIR=$RPM_BUILD_ROOT
46
47%__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
48        %{buildroot}%{_sysconfdir}/bogofilter.cf
49
50for n in xml html ; do
51        %__install -d -m755 .inst/$n
52        %__install -p -m644 doc/*.$n .inst/$n
53done
54
55#for d in contrib ; do
56#       %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
57#       for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
58#               case $f in
59#                       *.c|*.o|*.obj|*/Makefile*)
60#                               continue
61#                               ;;
62#                       *.1)
63#                               %__cp -p $f %{buildroot}%{_mandir}/man1
64#                               ;;
65#                       *)
66#                               %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
67#                               ;;
68#               esac
69#       done
70#done
71%{__chmod} -x contrib/*
72
73for README in contrib randomtrain ; do
74        %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
75done
76
77# drop executable bit from contrib/* to avoid unneeded dependencies
78#%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
79#       -exec %__chmod -x '{}' \;
80
81%clean
82[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
83
84%files
85%defattr(-,root,root)
86%doc AUTHORS COPYING INSTALL NEWS
87%doc README* RELEASE.NOTES* TODO GETTING.STARTED
88%doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
89%doc doc/programmer
90%doc .inst/html .inst/xml
91%doc contrib
92
93%{_sysconfdir}/bogofilter.cf.example
94%config(noreplace) %{_sysconfdir}/bogofilter.cf
95
96%{_bindir}/bogofilter
97%{_bindir}/bogolexer
98%{_bindir}/bogotune
99%{_bindir}/bogoutil
100%{_bindir}/bogoupgrade
101%{_bindir}/bf_compact
102%{_bindir}/bf_copy
103%{_bindir}/bf_tar
104%{_mandir}/man1/bogofilter.1*
105%{_mandir}/man1/bogolexer.1*
106%{_mandir}/man1/bogotune.1*
107%{_mandir}/man1/bogoutil.1*
108%{_mandir}/man1/bogoupgrade.1*
109%{_mandir}/man1/bf_compact.1*
110%{_mandir}/man1/bf_copy.1*
111%{_mandir}/man1/bf_tar.1*
112
113%changelog
114* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.4-1
115- update to 1.2.4
116- built with libdb 5.3.28
117- BR: xmlto
118
119* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
120- update to 1.2.3
121- use mecab instead of kakasi
122- BR: mecab-devel
123
124* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
125- rebuild with current VineSeed environment
126- fix perl requirements
127
128* Thu Dec 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.2.2-1
129- new upstream release
130- update Patch10
131- add Requires: kakasi (<BTS:VineLinux:852>)
132- updates Source999: add filtering string
133
134* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
135- applied new versioning policy, spec in utf-8
136
137* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
138- rebuild with gsl-1.9
139
140* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
141- rebuild with db4-4.3
142
143* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
144- add filter-requires-bogofilter.sh (source999)
145
146* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
147- rebuild
148
149* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
150- new upstream release
151- modified kakasi patch
152
153* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
154- rebuild
155
156* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
157- new upstream release
158- update kakasi patch
159- remove unneeded macro %%mydocdir
160- fix symlink
161- add Japanese summary
162- drop executable bit from contrib/*
163
164* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
165- rebuild
166
167* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
168- new upstream release
169- update and modify kakasi patch
170- fix dependencies
171  - add BuildRequires: kakasi-devel, gsl-devel, flex
172  - add Requires: gsl
173- update %%files
174  - update %%doc
175  - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
176
177* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
178- rebuilt with db4-4.2.52
179
180* Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
181- new upstream release.
182- update kakasi patch.
183
184* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
185- new upstream release
186- add kakasi patch (http://www.ono.org/software/bogofilter/)
187
188* Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
189- upstream release
190- using --program-prefix option with configure script
191- update %%files section
192
193* Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
194- first release for Vine Linux
195
Note: See TracBrowser for help on using the repository browser.