source: projects/specs/trunk/b/bogofilter/bogofilter-vl.spec @ 10570

Revision 10570, 5.7 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:           bogofilter
2Summary:        fast anti-spam filtering by Bayesian statistical analysis
3Summary(ja):    ベイジアン解析による高速アンチスパムフィルタリング
4Version:        1.2.4
5Release:        2%{?_dist_release}
6License:        GPLv2
7Group:          Applications/Internet
8URL:            http://bogofilter.sourceforge.net/
9Source0:        http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
10Source999:      filter-requires-bogofilter.sh
11Patch10:        http://www.c-wind.com/bogofilter/bogofilter-%{version}+mecab-0.1.patch.gz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  libdb-devel
15BuildRequires:  mecab-devel
16BuildRequires:  gsl-devel
17BuildRequires:  flex
18BuildRequires:  xmlto
19
20%define __find_requires %{SOURCE999}
21
22%description
23Bogofilter is a Bayesian spam filter.  In its normal mode of
24operation, it takes an email message or other text on standard input,
25does a statistical check against lists of "good" and "bad" words, and
26returns a status code indicating whether or not the message is spam.
27Bogofilter is designed with fast algorithms (including Berkeley DB system),
28coded directly in C, and tuned for speed, so it can be used for production
29by sites that process a lot of mail.
30
31%prep
32[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
33
34%setup -q
35%patch10 -p1 -b .mecab
36
37%build
38export CFLAGS="$RPM_OPT_FLAGS -DWAKATI"
39export LIBS="`mecab-config --libs`"
40%configure --program-prefix=
41%__make
42
43%install
44[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
45make install DESTDIR=$RPM_BUILD_ROOT
46
47%__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
48        %{buildroot}%{_sysconfdir}/bogofilter.cf
49
50for n in xml html ; do
51        %__install -d -m755 .inst/$n
52        %__install -p -m644 doc/*.$n .inst/$n
53done
54
55#for d in contrib ; do
56#       %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
57#       for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
58#               case $f in
59#                       *.c|*.o|*.obj|*/Makefile*)
60#                               continue
61#                               ;;
62#                       *.1)
63#                               %__cp -p $f %{buildroot}%{_mandir}/man1
64#                               ;;
65#                       *)
66#                               %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
67#                               ;;
68#               esac
69#       done
70#done
71%{__chmod} -x contrib/*
72
73for README in contrib randomtrain ; do
74        %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
75done
76
77# drop executable bit from contrib/* to avoid unneeded dependencies
78#%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
79#       -exec %__chmod -x '{}' \;
80
81%clean
82[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
83
84%files
85%defattr(-,root,root)
86%doc AUTHORS COPYING INSTALL NEWS
87%doc README* RELEASE.NOTES* TODO GETTING.STARTED
88%doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
89%doc doc/programmer
90%doc .inst/html .inst/xml
91%doc contrib
92
93%{_sysconfdir}/bogofilter.cf.example
94%config(noreplace) %{_sysconfdir}/bogofilter.cf
95
96%{_bindir}/bogofilter
97%{_bindir}/bogolexer
98%{_bindir}/bogotune
99%{_bindir}/bogoutil
100%{_bindir}/bogoupgrade
101%{_bindir}/bf_compact
102%{_bindir}/bf_copy
103%{_bindir}/bf_tar
104%{_mandir}/man1/bogofilter.1*
105%{_mandir}/man1/bogolexer.1*
106%{_mandir}/man1/bogotune.1*
107%{_mandir}/man1/bogoutil.1*
108%{_mandir}/man1/bogoupgrade.1*
109%{_mandir}/man1/bf_compact.1*
110%{_mandir}/man1/bf_copy.1*
111%{_mandir}/man1/bf_tar.1*
112
113%changelog
114* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-2
115- rebuild with gcc-5.4.0
116
117* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.4-1
118- update to 1.2.4
119- built with libdb 5.3.28
120- BR: xmlto
121
122* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
123- update to 1.2.3
124- use mecab instead of kakasi
125- BR: mecab-devel
126
127* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
128- rebuild with current VineSeed environment
129- fix perl requirements
130
131* Thu Dec 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.2.2-1
132- new upstream release
133- update Patch10
134- add Requires: kakasi (<BTS:VineLinux:852>)
135- updates Source999: add filtering string
136
137* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
138- applied new versioning policy, spec in utf-8
139
140* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
141- rebuild with gsl-1.9
142
143* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
144- rebuild with db4-4.3
145
146* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
147- add filter-requires-bogofilter.sh (source999)
148
149* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
150- rebuild
151
152* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
153- new upstream release
154- modified kakasi patch
155
156* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
157- rebuild
158
159* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
160- new upstream release
161- update kakasi patch
162- remove unneeded macro %%mydocdir
163- fix symlink
164- add Japanese summary
165- drop executable bit from contrib/*
166
167* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
168- rebuild
169
170* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
171- new upstream release
172- update and modify kakasi patch
173- fix dependencies
174  - add BuildRequires: kakasi-devel, gsl-devel, flex
175  - add Requires: gsl
176- update %%files
177  - update %%doc
178  - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
179
180* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
181- rebuilt with db4-4.2.52
182
183* Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
184- new upstream release.
185- update kakasi patch.
186
187* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
188- new upstream release
189- add kakasi patch (http://www.ono.org/software/bogofilter/)
190
191* Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
192- upstream release
193- using --program-prefix option with configure script
194- update %%files section
195
196* Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
197- first release for Vine Linux
198
Note: See TracBrowser for help on using the repository browser.