source: projects/specs/trunk/b/bogofilter/bogofilter-vl.spec @ 11697

Revision 11697, 5.8 KB checked in by ara_t, 6 years ago (diff)

bogofilter: rebuild with gsl-2.4

Line 
1Name:           bogofilter
2Summary:        fast anti-spam filtering by Bayesian statistical analysis
3Summary(ja):    ベイジアン解析による高速アンチスパムフィルタリング
4Version:        1.2.4
5Release:        4%{?_dist_release}
6License:        GPLv2
7Group:          Applications/Internet
8URL:            http://bogofilter.sourceforge.net/
9Source0:        http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
10Source999:      filter-requires-bogofilter.sh
11Patch10:        http://www.c-wind.com/bogofilter/bogofilter-%{version}+mecab-0.1.patch.gz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  libdb-devel
15BuildRequires:  mecab-devel
16BuildRequires:  gsl-devel
17BuildRequires:  flex
18BuildRequires:  xmlto
19
20%define __find_requires %{SOURCE999}
21
22%description
23Bogofilter is a Bayesian spam filter.  In its normal mode of
24operation, it takes an email message or other text on standard input,
25does a statistical check against lists of "good" and "bad" words, and
26returns a status code indicating whether or not the message is spam.
27Bogofilter is designed with fast algorithms (including Berkeley DB system),
28coded directly in C, and tuned for speed, so it can be used for production
29by sites that process a lot of mail.
30
31%prep
32[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
33
34%setup -q
35%patch10 -p1 -b .mecab
36
37%build
38export CFLAGS="$RPM_OPT_FLAGS -DWAKATI"
39export LIBS="`mecab-config --libs`"
40%configure --program-prefix=
41%__make
42
43%install
44[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
45make install DESTDIR=$RPM_BUILD_ROOT
46
47%__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
48        %{buildroot}%{_sysconfdir}/bogofilter.cf
49
50for n in xml html ; do
51        %__install -d -m755 .inst/$n
52        %__install -p -m644 doc/*.$n .inst/$n
53done
54
55#for d in contrib ; do
56#       %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
57#       for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
58#               case $f in
59#                       *.c|*.o|*.obj|*/Makefile*)
60#                               continue
61#                               ;;
62#                       *.1)
63#                               %__cp -p $f %{buildroot}%{_mandir}/man1
64#                               ;;
65#                       *)
66#                               %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
67#                               ;;
68#               esac
69#       done
70#done
71%{__chmod} -x contrib/*
72
73for README in contrib randomtrain ; do
74        %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
75done
76
77# drop executable bit from contrib/* to avoid unneeded dependencies
78#%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
79#       -exec %__chmod -x '{}' \;
80
81%clean
82[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
83
84%files
85%defattr(-,root,root)
86%doc AUTHORS COPYING INSTALL NEWS
87%doc README* RELEASE.NOTES* TODO GETTING.STARTED
88%doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
89%doc doc/programmer
90%doc .inst/html .inst/xml
91%doc contrib
92
93%{_sysconfdir}/bogofilter.cf.example
94%config(noreplace) %{_sysconfdir}/bogofilter.cf
95
96%{_bindir}/bogofilter
97%{_bindir}/bogolexer
98%{_bindir}/bogotune
99%{_bindir}/bogoutil
100%{_bindir}/bogoupgrade
101%{_bindir}/bf_compact
102%{_bindir}/bf_copy
103%{_bindir}/bf_tar
104%{_mandir}/man1/bogofilter.1*
105%{_mandir}/man1/bogolexer.1*
106%{_mandir}/man1/bogotune.1*
107%{_mandir}/man1/bogoutil.1*
108%{_mandir}/man1/bogoupgrade.1*
109%{_mandir}/man1/bf_compact.1*
110%{_mandir}/man1/bf_copy.1*
111%{_mandir}/man1/bf_tar.1*
112
113%changelog
114* Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 1.2.4-4
115- rebuild under gsl-2.4
116
117* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 1.2.4-3
118- rebuild under gsl-2.2.1
119
120* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-2
121- rebuild with gcc-5.4.0
122
123* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.4-1
124- update to 1.2.4
125- built with libdb 5.3.28
126- BR: xmlto
127
128* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
129- update to 1.2.3
130- use mecab instead of kakasi
131- BR: mecab-devel
132
133* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
134- rebuild with current VineSeed environment
135- fix perl requirements
136
137* Thu Dec 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.2.2-1
138- new upstream release
139- update Patch10
140- add Requires: kakasi (<BTS:VineLinux:852>)
141- updates Source999: add filtering string
142
143* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
144- applied new versioning policy, spec in utf-8
145
146* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
147- rebuild with gsl-1.9
148
149* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
150- rebuild with db4-4.3
151
152* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
153- add filter-requires-bogofilter.sh (source999)
154
155* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
156- rebuild
157
158* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
159- new upstream release
160- modified kakasi patch
161
162* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
163- rebuild
164
165* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
166- new upstream release
167- update kakasi patch
168- remove unneeded macro %%mydocdir
169- fix symlink
170- add Japanese summary
171- drop executable bit from contrib/*
172
173* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
174- rebuild
175
176* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
177- new upstream release
178- update and modify kakasi patch
179- fix dependencies
180  - add BuildRequires: kakasi-devel, gsl-devel, flex
181  - add Requires: gsl
182- update %%files
183  - update %%doc
184  - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
185
186* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
187- rebuilt with db4-4.2.52
188
189* Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
190- new upstream release.
191- update kakasi patch.
192
193* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
194- new upstream release
195- add kakasi patch (http://www.ono.org/software/bogofilter/)
196
197* Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
198- upstream release
199- using --program-prefix option with configure script
200- update %%files section
201
202* Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
203- first release for Vine Linux
204
Note: See TracBrowser for help on using the repository browser.