source: projects/specs/trunk/b/bluez/bluez-vl.spec @ 9791

Revision 9791, 12.0 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1Summary: Bluetooth utilities
2Summary(ja): Bluetooth ユーティリティ
3Name: bluez
4Version: 5.35
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: Applications/System
8
9URL: http://www.bluez.org/
10
11Vendor: Project Vine
12Distribution: Vine Linux
13Packager: daisuke, Takemikaduchi
14
15#----------------------------------------------------------------------------
16
17Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
18Source1: bluetooth.init.vine
19Source3: bluez-uinput.modules
20
21Source11: trusts.txt
22Source20: main.conf
23
24# from http://www.linuxfromscratch.org/patches/downloads/bluez/
25Patch0: bluez-5.35-obexd_without_systemd-1.patch
26
27# Patch for Vine
28Patch100: bluez-5.35-daemon.patch
29Patch101: bluez-5.35-config-vine.patch
30
31#----------------------------------------------------------------------------
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33
34BuildRequires:  flex
35BuildRequires:  bison
36BuildRequires:  dbus-devel
37BuildRequires:  glib2-devel
38BuildRequires:  eudev-libudev-devel
39BuildRequires:  readline-devel
40BuildRequires:  libical-devel
41
42ExcludeArch: s390 s390x
43
44Obsoletes: bluez-pan < 4.0, bluez-sdp < 4.0
45Requires: initscripts, bluez-libs = %{version}
46Requires: dbus >= 0.60
47# Requires: fuse
48## Requires: hwdata >= 0.215
49Requires: hwdata >= 0.146
50# virtual provides "dbus-bluez-pin-helper" ex. bluez-gnome
51Requires: dbus-bluez-pin-helper
52Requires(preun): /sbin/chkconfig, /sbin/service
53Requires(post): /sbin/chkconfig, /sbin/service
54#----------------------------------------------------------------------------
55
56Obsoletes: bluez-utils < 4.5-2
57Provides: bluez-utils = %{version}-%{release}
58Obsoletes: bluez-gstreamer < 5.0
59Obsoletes: bluez-alsa < 5.0
60
61#----------------------------------------------------------------------------
62%description
63Utilities for use in Bluetooth applications:
64        - hcitool
65        - hciattach
66        - hciconfig
67        - bluetoothd
68        - l2ping
69        - start scripts VineLinux (RedHat base)
70        - pcmcia configuration files
71
72 Please, read %{_defaultdocdir}/%{name}-%{version}/trusts.txt
73
74The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
75
76%description -l ja
77Bluetooth ユーティリティ (bluez-utils):
78        - hcitool
79        - hciattach
80        - hciconfig
81        - l2ping
82        - 起動スクリプト (Red Hat用をVineLinuxに合わせました)
83        - pcmcia コンフィグレーション ファイル
84※付属の%{_defaultdocdir}/%{name}-%{version}/trusts.txtもご覧下さい。
85
86(BLUETOOTH は Bluetooth SIG, Inc.(USA)のトレードマークです)
87
88#----------------------------------------------------------------------------
89%package libs
90Summary: Libraries for use in Bluetooth applications
91Summary(ja): BlueTooth アプリケーションの使用するライブラリ(BlueZ)
92Group: System Environment/Libraries
93
94%description libs
95Libraries for use in Bluetooth applications.
96
97%description libs -l ja
98Bluetooth アプリケーションのためのライブラリです。
99※BlueZ のユーティリティのためにも必要です
100
101#----------------------------------------------------------------------------
102%package libs-devel
103Summary: Development libraries for Bluetooth applications
104Summary(ja): Bluetooth アプリケーション開発のためのdevelパッケージ
105Group: Development/Libraries
106Requires: bluez-libs = %{version}
107Requires: pkgconfig
108Obsoletes: bluez-sdp-devel < 4.0
109
110%description libs-devel
111bluez-libs-devel contains development libraries and headers for
112use in Bluetooth applications.
113
114%description libs-devel -l ja
115bluez-libs-devel パッケージは Bluetooth アプリケーション開発のための
116ライブラリやヘッダーファイルを提供します。
117
118#----------------------------------------------------------------------------
119%package cups
120Summary: CUPS printer backend for Bluetooth printers
121Summary(ja): Bluetooth 経由の CUPS プリンタシステム用
122Group: System Environment/Daemons
123Obsoletes: bluez-utils-cups < 4.5-2
124Provides: bluez-utils-cups = %{version}-%{release}
125Requires: bluez-libs = %{version}
126Requires: cups
127
128%description cups
129This package contains the CUPS backend
130
131%description cups -l ja
132Bluetooth対応 プリンターを CUPS印刷システムから利用する
133ためのバックエンドです。
134
135#----------------------------------------------------------------------------
136
137%prep
138rm -rf $RPM_BUILD_ROOT
139
140%setup -q
141%patch0 -p1
142%patch100 -p1
143%patch101 -p1
144
145%build
146%configure \
147        --disable-systemd \
148        --enable-library \
149    --enable-cups \
150    --enable-tools \
151    --enable-sixaxis \
152        --disable-android
153
154# copy txt
155#cp %{SOURCE11} .
156
157make
158
159#----------------------------------------------------------------------------
160%install
161rm -rf $RPM_BUILD_ROOT
162make install DESTDIR=$RPM_BUILD_ROOT
163
164# Remove autocrap and libtool droppings
165find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
166
167mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/
168mkdir -p $RPM_BUILD_ROOT%{_libdir}/bluetooth/
169mkdir -p $RPM_BUILD_ROOT%{_sbindir}
170
171install -D -m0755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/bluetooth
172ln -s ../libexec/bluetooth/bluetoothd $RPM_BUILD_ROOT%{_sbindir}/bluetoothd
173
174#install -D -m0644 %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/
175install -D -m0644 src/main.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/
176# rename serial-api.txt
177#mv  doc/serial-api.txt doc/serial-api_doc.txt
178
179install -D -m0755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/modules/bluez-uinput.modules
180
181%clean
182rm -rf $RPM_BUILD_ROOT
183
184#----------------------------------------------------------------------------
185%post
186/sbin/chkconfig --add bluetooth
187if [ "$1" -ge "1" ]; then
188        /sbin/service bluetooth condrestart >/dev/null 2>&1 || :
189fi
190exit 0
191
192%preun
193if [ "$1" = "0" ]; then
194        /sbin/service bluetooth stop >/dev/null 2>&1 || :
195        /sbin/chkconfig --del bluetooth
196fi
197exit 0
198
199%post libs
200/sbin/ldconfig
201
202%postun libs
203/sbin/ldconfig
204
205#----------------------------------------------------------------------------
206%files
207%defattr(-, root, root)
208%doc AUTHORS COPYING INSTALL ChangeLog NEWS README
209%dir %{_sysconfdir}/bluetooth/
210%config(noreplace) %{_sysconfdir}/bluetooth/*
211%{_sysconfdir}/dbus-1/system.d/bluetooth.conf
212%{_sysconfdir}/rc.d/init.d/bluetooth
213%{_sysconfdir}/sysconfig/modules/bluez-uinput.modules
214%{_bindir}/*
215%{_sbindir}/bluetoothd
216%{_libexecdir}/bluetooth/bluetoothd
217%{_libexecdir}/bluetooth/obexd
218%dir %{_libdir}/bluetooth
219%dir %{_libdir}/bluetooth/plugins
220%{_libdir}/bluetooth/plugins/sixaxis.so
221%{_mandir}/man1/*
222%{_mandir}/man8/*
223/lib/udev/hid2hci
224/lib/udev/rules.d/97-hid2hci.rules
225
226%files libs
227%defattr(-, root, root)
228%{_libdir}/libbluetooth.so.*
229
230%files libs-devel
231%defattr(-, root, root)
232%{_libdir}/libbluetooth.so
233%dir %{_includedir}/bluetooth
234%{_includedir}/bluetooth/*
235%{_libdir}/pkgconfig/bluez.pc
236
237%files cups
238%defattr(-, root, root)
239%{_libdir}/cups/backend/bluetooth
240
241
242%changelog
243* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.35-1
244- update to 5.35
245- remove %%{name}-gstreamer, %%{name}-alsa subpackages
246- add Patch0 (bluez-5.35-obexd_without_systemd-1.patch)
247- add Patch100 (bluez-5.35-daemon.patch)
248- add Patch101 (bluez-5.35-config-vine.patch)
249
250* Sat Jul 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-5
251- rebuild with readline-6.3
252
253* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-4
254- change BuildRequires: eudev-libudev-devel instead of libudev-devel
255
256* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-3
257- rebuild with VineSeed environment
258
259* Thu Jul 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.101-2
260- build with sbc
261  - add BR: sbc-devel
262
263* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-1
264- new upstream release
265
266* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.99-1
267- new upstream release
268
269* Thu Feb 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.98-1
270- new upstream release
271
272* Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.97-1
273- new upstream release
274- add BuildRequires: check-devel, readline-devel
275
276* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.96-1
277- new upstream release
278- add BuildRequires: libudev-devel
279
280* Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.89-1
281- new upstream release
282
283* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.87-1
284- new upstream release
285
286* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.84-1
287- new upstream release
288
289* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.82-1
290- new upstream release
291
292* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.81-1
293- new upstream release
294
295* Tue Nov 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.79-1
296- new upstream release
297- drop Patch2
298
299* Wed Nov 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.77-1
300- new upstream release
301- fix %files (change path of alsa/bluetooth.conf)
302
303* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.69-2
304- rebuild with rpm-4.8.1 for pkg-config file
305
306* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.69-1
307- new upstream release
308
309* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.66-1
310- new upstream release
311
312* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.64-1
313- new upstream release
314- drop Patch1, Patch5, Patch6
315
316* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.42-2
317- add bluetooth.init again.
318  - on-demand startup on bootup process will fail, because
319    D-BUS service is not started yet.
320
321* Sun Jun 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.42-1
322- new upstream release
323
324* Mon Jun 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.41-2
325- remove bluetooth.init
326  - on-demand start/stop bluetoothd using udev
327  - run hid2hci using udev
328- add missing files to %%files
329
330* Fri Jun 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.41-1
331- new upstream release
332- add udev rule
333- add upstream Patch[2-6]
334
335* Tue May 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.37-1
336- new upstream release
337
338* Fri Oct 24 2008 Seiichirou Babasaki 4.15-1
339- Update to 4.15
340- added # Maintainers:  comments.
341- FedoraCore - LOGS
342-- 4.14-2
343-- Add script to autoload uinput on startup, so the PS3 remote
344   works out-of-the-box
345-- 4.14-1 - Update to 4.14
346-- 4.13-3
347-- Update udev rules (#246840)
348-- 4.13-2
349-- Fix PS3 BD remote input event generation
350-- 4.13-1 - Update to 4.13
351-- 4.12-1 - Update to 4.12
352-- 4.11-1 - Update to 4.11
353-- 4.10-1 - Update to 4.10
354-- 4.9-1 - Update to 4.9
355-- 4.8-1 - Update to 4.8
356-- 4.7-1 - Update to 4.7
357-- 4.6-4
358-- Fix patch application
359-- 4.6-3
360-- Add fuzz
361-- 4.6-2
362-- Fix possible crasher on resume from suspend
363-- 4.6-1 - Update to 4.6
364-- 4.5-4
365-- SDP browse fixes
366-- 4.5-3
367-- Bluez-alsa needs to provide/obsolete bluez-utils-alsa
368-- Use versioned Obsoletes:
369-- 4.5-2
370-- Change main utils package name to 'bluez'; likewise its subpackages
371-- Remove references to obsolete initscripts (hidd,pand,dund)
372-- 4.5-1
373-- Update to 4.5
374-- Fix initscript to actually start bluetoothd by hand
375-- Add chkconfig information to the initscript
376-- 4.4-2
377-- Fix rpmlint problems
378-- Fix input device handling
379-- 4.4-1
380-- Update to 4.4
381-- Update source address, and remove unneeded deps (thanks Marcel)
382-- 4.1-1
383-- Initial build
384- updated specfile
385- VineLinux-4.2 logfile
386-- *Thu Oct 2 2008 Seiichirou Babasaki 3.24-4
387-- update bleuz-gnome, rebuild bluez-utils
388-- Requires: fuse
389-- updated specfile
390-- *Tue Sep 30 2008 Seiichirou Babasaki 3.24-3
391-- trusts.txt update (added audio profile)
392-- updated specfile
393
394#----------------------------------------------------------------------------
395* Fri Sep 26 2008 Seiichirou Babasaki 3.32-2
396- *.conf update
397- updated specfile
398
399* Fri Jun 13 2008 Seiichirou Babasaki 3.32-1
400- Updated 3.32
401- Updated specfile
402- ** LOGS 3.31-2
403- ** Add a .service file, starting up hcid only when used (#446918)
404- ** Fix descriptions in the initscript headers (#433647)
405- ** LOGS 3.30-2
406- ** Add support for Dell HID/HCI switch
407- ** LOGS 3.27-1
408- ** Ship audio.conf (#278831)
409- ** Ship network service
410
411* Sat Jan 26 2008 Seiichirou Babasaki 3.24-2
412- Updated specfile
413-   marge bluez-utils-3.24-conf-vl.patch
414-      << bluez-utils-2.3-conf.patch
415- add trusts.txt(ja)
416- Updated specfile
417
418* Mon Jan 21 2008 Seiichirou Babasaki 3.24-1vl2
419- Updated specfile for (dbus-devel >= 0.90)
420
421* Wed Jan 16 2008 Seiichirou Babasaki 3.24-1vl1
422- Import bluez-utils - Packager: Babasaki
423- Updated specfile for (dbus-devel >= 0.60)
424- Update to 3.24
Note: See TracBrowser for help on using the repository browser.