source: projects/specs/trunk/b/bluez/bluez-vl.spec @ 11442

Revision 11442, 12.1 KB checked in by tomop, 6 years ago (diff)

bluez-5.48-1

Line 
1%define _unpackaged_files_terminate_build 1
2
3Summary: Bluetooth utilities
4Summary(ja): Bluetooth ユーティリティ
5Name: bluez
6Version: 5.48
7Release: 1%{?_dist_release}
8License: GPLv2+
9Group: Applications/System
10
11URL: http://www.bluez.org/
12
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: daisuke, Takemikaduchi
16
17#----------------------------------------------------------------------------
18
19Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
20Source1: bluetooth.init.vine
21Source3: bluez-uinput.modules
22
23Source11: trusts.txt
24Source20: main.conf
25
26# from http://www.linuxfromscratch.org/patches/downloads/bluez/
27Patch0: bluez-5.35-obexd_without_systemd-1.patch
28
29# Patch for Vine
30Patch100: bluez-5.35-daemon.patch
31Patch101: bluez-5.35-config-vine.patch
32
33#----------------------------------------------------------------------------
34BuildRoot:      %{_tmppath}/%{name}-%{version}-root
35
36BuildRequires:  flex
37BuildRequires:  bison
38BuildRequires:  dbus-devel
39BuildRequires:  glib2-devel
40BuildRequires:  eudev-libudev-devel
41BuildRequires:  readline-devel
42BuildRequires:  libical-devel
43
44ExcludeArch: s390 s390x
45
46Obsoletes: bluez-pan < 4.0, bluez-sdp < 4.0
47Requires: initscripts, bluez-libs = %{version}
48Requires: dbus >= 0.60
49# Requires: fuse
50## Requires: hwdata >= 0.215
51Requires: hwdata >= 0.146
52# virtual provides "dbus-bluez-pin-helper" ex. bluez-gnome
53Requires: dbus-bluez-pin-helper
54Requires(preun): /sbin/chkconfig, /sbin/service
55Requires(post): /sbin/chkconfig, /sbin/service
56#----------------------------------------------------------------------------
57
58Obsoletes: bluez-utils < 4.5-2
59Provides: bluez-utils = %{version}-%{release}
60Obsoletes: bluez-gstreamer < 5.0
61Obsoletes: bluez-alsa < 5.0
62
63#----------------------------------------------------------------------------
64%description
65Utilities for use in Bluetooth applications:
66        - hcitool
67        - hciattach
68        - hciconfig
69        - bluetoothd
70        - l2ping
71        - start scripts VineLinux (RedHat base)
72        - pcmcia configuration files
73
74 Please, read %{_defaultdocdir}/%{name}-%{version}/trusts.txt
75
76The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
77
78%description -l ja
79Bluetooth ユーティリティ (bluez-utils):
80        - hcitool
81        - hciattach
82        - hciconfig
83        - l2ping
84        - 起動スクリプト (Red Hat用をVineLinuxに合わせました)
85        - pcmcia コンフィグレーション ファイル
86※付属の%{_defaultdocdir}/%{name}-%{version}/trusts.txtもご覧下さい。
87
88(BLUETOOTH は Bluetooth SIG, Inc.(USA)のトレードマークです)
89
90#----------------------------------------------------------------------------
91%package libs
92Summary: Libraries for use in Bluetooth applications
93Summary(ja): BlueTooth アプリケーションの使用するライブラリ(BlueZ)
94Group: System Environment/Libraries
95
96%description libs
97Libraries for use in Bluetooth applications.
98
99%description libs -l ja
100Bluetooth アプリケーションのためのライブラリです。
101※BlueZ のユーティリティのためにも必要です
102
103#----------------------------------------------------------------------------
104%package libs-devel
105Summary: Development libraries for Bluetooth applications
106Summary(ja): Bluetooth アプリケーション開発のためのdevelパッケージ
107Group: Development/Libraries
108Requires: bluez-libs = %{version}
109Requires: pkgconfig
110Obsoletes: bluez-sdp-devel < 4.0
111
112%description libs-devel
113bluez-libs-devel contains development libraries and headers for
114use in Bluetooth applications.
115
116%description libs-devel -l ja
117bluez-libs-devel パッケージは Bluetooth アプリケーション開発のための
118ライブラリやヘッダーファイルを提供します。
119
120#----------------------------------------------------------------------------
121%package cups
122Summary: CUPS printer backend for Bluetooth printers
123Summary(ja): Bluetooth 経由の CUPS プリンタシステム用
124Group: System Environment/Daemons
125Obsoletes: bluez-utils-cups < 4.5-2
126Provides: bluez-utils-cups = %{version}-%{release}
127Requires: bluez-libs = %{version}
128Requires: cups
129
130%description cups
131This package contains the CUPS backend
132
133%description cups -l ja
134Bluetooth対応 プリンターを CUPS印刷システムから利用する
135ためのバックエンドです。
136
137#----------------------------------------------------------------------------
138
139%prep
140rm -rf $RPM_BUILD_ROOT
141
142%setup -q
143%patch0 -p1
144%patch100 -p1
145%patch101 -p1
146
147%build
148%configure \
149        --disable-systemd \
150        --enable-library \
151    --enable-cups \
152    --enable-tools \
153    --enable-sixaxis \
154    --enable-nfc \
155        --disable-android
156
157# copy txt
158#cp %{SOURCE11} .
159
160make
161
162#----------------------------------------------------------------------------
163%install
164rm -rf $RPM_BUILD_ROOT
165make install DESTDIR=$RPM_BUILD_ROOT
166
167# Remove autocrap and libtool droppings
168find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
169
170mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/
171mkdir -p $RPM_BUILD_ROOT%{_libdir}/bluetooth/
172mkdir -p $RPM_BUILD_ROOT%{_sbindir}
173
174install -D -m0755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/bluetooth
175ln -s ../libexec/bluetooth/bluetoothd $RPM_BUILD_ROOT%{_sbindir}/bluetoothd
176
177#install -D -m0644 %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/
178install -D -m0644 src/main.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/
179# rename serial-api.txt
180#mv  doc/serial-api.txt doc/serial-api_doc.txt
181
182install -D -m0755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/modules/bluez-uinput.modules
183
184%clean
185rm -rf $RPM_BUILD_ROOT
186
187#----------------------------------------------------------------------------
188%post
189/sbin/chkconfig --add bluetooth
190if [ "$1" -ge "1" ]; then
191        /sbin/service bluetooth condrestart >/dev/null 2>&1 || :
192fi
193exit 0
194
195%preun
196if [ "$1" = "0" ]; then
197        /sbin/service bluetooth stop >/dev/null 2>&1 || :
198        /sbin/chkconfig --del bluetooth
199fi
200exit 0
201
202%post libs
203/sbin/ldconfig
204
205%postun libs
206/sbin/ldconfig
207
208#----------------------------------------------------------------------------
209%files
210%defattr(-, root, root)
211%doc AUTHORS COPYING INSTALL ChangeLog NEWS README
212%dir %{_sysconfdir}/bluetooth/
213%config(noreplace) %{_sysconfdir}/bluetooth/*
214%{_sysconfdir}/dbus-1/system.d/bluetooth.conf
215%{_sysconfdir}/rc.d/init.d/bluetooth
216%{_sysconfdir}/sysconfig/modules/bluez-uinput.modules
217%{_bindir}/*
218%{_sbindir}/bluetoothd
219%{_libexecdir}/bluetooth/bluetoothd
220%{_libexecdir}/bluetooth/obexd
221%dir %{_libdir}/bluetooth
222%dir %{_libdir}/bluetooth/plugins
223%{_libdir}/bluetooth/plugins/sixaxis.so
224%{_mandir}/man1/*
225%{_mandir}/man8/*
226/lib/udev/hid2hci
227/lib/udev/rules.d/97-hid2hci.rules
228
229%files libs
230%defattr(-, root, root)
231%{_libdir}/libbluetooth.so.*
232
233%files libs-devel
234%defattr(-, root, root)
235%{_libdir}/libbluetooth.so
236%dir %{_includedir}/bluetooth
237%{_includedir}/bluetooth/*
238%{_libdir}/pkgconfig/bluez.pc
239
240%files cups
241%defattr(-, root, root)
242%{_libdir}/cups/backend/bluetooth
243
244
245%changelog
246* Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.48-1
247- updated to 5.48.
248
249* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.35-1
250- update to 5.35
251- remove %%{name}-gstreamer, %%{name}-alsa subpackages
252- add Patch0 (bluez-5.35-obexd_without_systemd-1.patch)
253- add Patch100 (bluez-5.35-daemon.patch)
254- add Patch101 (bluez-5.35-config-vine.patch)
255
256* Sat Jul 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-5
257- rebuild with readline-6.3
258
259* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-4
260- change BuildRequires: eudev-libudev-devel instead of libudev-devel
261
262* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-3
263- rebuild with VineSeed environment
264
265* Thu Jul 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.101-2
266- build with sbc
267  - add BR: sbc-devel
268
269* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-1
270- new upstream release
271
272* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.99-1
273- new upstream release
274
275* Thu Feb 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.98-1
276- new upstream release
277
278* Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.97-1
279- new upstream release
280- add BuildRequires: check-devel, readline-devel
281
282* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.96-1
283- new upstream release
284- add BuildRequires: libudev-devel
285
286* Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.89-1
287- new upstream release
288
289* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.87-1
290- new upstream release
291
292* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.84-1
293- new upstream release
294
295* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.82-1
296- new upstream release
297
298* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.81-1
299- new upstream release
300
301* Tue Nov 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.79-1
302- new upstream release
303- drop Patch2
304
305* Wed Nov 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.77-1
306- new upstream release
307- fix %files (change path of alsa/bluetooth.conf)
308
309* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.69-2
310- rebuild with rpm-4.8.1 for pkg-config file
311
312* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.69-1
313- new upstream release
314
315* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.66-1
316- new upstream release
317
318* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.64-1
319- new upstream release
320- drop Patch1, Patch5, Patch6
321
322* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.42-2
323- add bluetooth.init again.
324  - on-demand startup on bootup process will fail, because
325    D-BUS service is not started yet.
326
327* Sun Jun 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.42-1
328- new upstream release
329
330* Mon Jun 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.41-2
331- remove bluetooth.init
332  - on-demand start/stop bluetoothd using udev
333  - run hid2hci using udev
334- add missing files to %%files
335
336* Fri Jun 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.41-1
337- new upstream release
338- add udev rule
339- add upstream Patch[2-6]
340
341* Tue May 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.37-1
342- new upstream release
343
344* Fri Oct 24 2008 Seiichirou Babasaki 4.15-1
345- Update to 4.15
346- added # Maintainers:  comments.
347- FedoraCore - LOGS
348-- 4.14-2
349-- Add script to autoload uinput on startup, so the PS3 remote
350   works out-of-the-box
351-- 4.14-1 - Update to 4.14
352-- 4.13-3
353-- Update udev rules (#246840)
354-- 4.13-2
355-- Fix PS3 BD remote input event generation
356-- 4.13-1 - Update to 4.13
357-- 4.12-1 - Update to 4.12
358-- 4.11-1 - Update to 4.11
359-- 4.10-1 - Update to 4.10
360-- 4.9-1 - Update to 4.9
361-- 4.8-1 - Update to 4.8
362-- 4.7-1 - Update to 4.7
363-- 4.6-4
364-- Fix patch application
365-- 4.6-3
366-- Add fuzz
367-- 4.6-2
368-- Fix possible crasher on resume from suspend
369-- 4.6-1 - Update to 4.6
370-- 4.5-4
371-- SDP browse fixes
372-- 4.5-3
373-- Bluez-alsa needs to provide/obsolete bluez-utils-alsa
374-- Use versioned Obsoletes:
375-- 4.5-2
376-- Change main utils package name to 'bluez'; likewise its subpackages
377-- Remove references to obsolete initscripts (hidd,pand,dund)
378-- 4.5-1
379-- Update to 4.5
380-- Fix initscript to actually start bluetoothd by hand
381-- Add chkconfig information to the initscript
382-- 4.4-2
383-- Fix rpmlint problems
384-- Fix input device handling
385-- 4.4-1
386-- Update to 4.4
387-- Update source address, and remove unneeded deps (thanks Marcel)
388-- 4.1-1
389-- Initial build
390- updated specfile
391- VineLinux-4.2 logfile
392-- *Thu Oct 2 2008 Seiichirou Babasaki 3.24-4
393-- update bleuz-gnome, rebuild bluez-utils
394-- Requires: fuse
395-- updated specfile
396-- *Tue Sep 30 2008 Seiichirou Babasaki 3.24-3
397-- trusts.txt update (added audio profile)
398-- updated specfile
399
400#----------------------------------------------------------------------------
401* Fri Sep 26 2008 Seiichirou Babasaki 3.32-2
402- *.conf update
403- updated specfile
404
405* Fri Jun 13 2008 Seiichirou Babasaki 3.32-1
406- Updated 3.32
407- Updated specfile
408- ** LOGS 3.31-2
409- ** Add a .service file, starting up hcid only when used (#446918)
410- ** Fix descriptions in the initscript headers (#433647)
411- ** LOGS 3.30-2
412- ** Add support for Dell HID/HCI switch
413- ** LOGS 3.27-1
414- ** Ship audio.conf (#278831)
415- ** Ship network service
416
417* Sat Jan 26 2008 Seiichirou Babasaki 3.24-2
418- Updated specfile
419-   marge bluez-utils-3.24-conf-vl.patch
420-      << bluez-utils-2.3-conf.patch
421- add trusts.txt(ja)
422- Updated specfile
423
424* Mon Jan 21 2008 Seiichirou Babasaki 3.24-1vl2
425- Updated specfile for (dbus-devel >= 0.90)
426
427* Wed Jan 16 2008 Seiichirou Babasaki 3.24-1vl1
428- Import bluez-utils - Packager: Babasaki
429- Updated specfile for (dbus-devel >= 0.60)
430- Update to 3.24
Note: See TracBrowser for help on using the repository browser.