source: projects/specs/trunk/b/blueman/blueman-vl.spec @ 5701

Revision 5701, 5.4 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1Summary:        Full featured bluetooth manager for GNOME/GTK
2Summary(ja):    GNOME/GTK 用の高機能な Bluetooth マネージャ
3
4Name:           blueman
5Version:        1.23
6Release:        2%{?_dist_release}
7License:        GPLv2+
8Group:          Applications/System
9Url:            http://blueman-project.org/
10
11Source0:        %{name}-%{version}.tar.gz
12
13Buildroot:      %{_tmppath}/%{name}-%{version}
14BuildRequires:  desktop-file-utils
15BuildRequires:  perl(XML::Parser)
16BuildRequires:  glib2-devel
17BuildRequires:  gtk2-devel
18BuildRequires:  GConf2-devel
19BuildRequires:  pygtk2-devel
20BuildRequires:  intltool
21BuildRequires:  startup-notification-devel
22BuildRequires:  pygobject-devel
23BuildRequires:  notify-python
24BuildRequires:  bluez-libs-devel >= 4.37
25BuildRequires:  python-devel
26BuildRequires:  python-pyrex
27BuildRequires:  dbus-python
28Requires:       obex-data-server
29Requires:       notify-python
30Requires:       pygtk2
31Requires:       gnome-python
32Requires:       dbus-python
33Requires:       pygobject
34Requires:       PolicyKit-gnome
35Provides:       dbus-bluez-pin-helper
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: daisuke
40
41
42%description
43Blueman is designed to provide simple, yet effective means for
44controlling BlueZ API and simplifying bluetooth tasks such as:
45
46* Connecting to 3G/EDGE/GPRS via dial-up
47* Connecting to/Creating bluetooth networks
48* Connecting to input devices
49* Connecting to audio devices
50* Sending/Receiving/Browsing files via OBEX
51* Pairing
52
53Blueman also integrates with Network Manager 0.7, so any Dialup/Network
54 connections will be made available (via HAL) to Network Manager.
55
56%prep
57%setup -q
58
59%build
60%configure --disable-desktop-update --disable-icon-update --disable-schemas-install
61%__make %{?_smp_mflags}
62
63%install
64rm -rf %{buildroot}
65%__make install DESTDIR=${RPM_BUILD_ROOT}
66
67mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/devices
68cp $RPM_BUILD_ROOT%{_datadir}/blueman/icons/hicolor/scalable/devices/* \
69   $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/devices/
70
71desktop-file-install --vendor="" \
72  --add-category="GNOME;GTK" \
73  --add-category="Settings;HardwareSettings" \
74  --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/%{name}-manager.desktop
75
76find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
77find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
78
79%find_lang %{name}
80
81%clean
82rm -rf %{buildroot}
83
84%post
85export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
86gconftool-2 --makefile-install-rule \
87    %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
88update-desktop-database %{_datadir}/applications >& /dev/null || :
89touch --no-create %{_datadir}/icons/hicolor
90if [ -x /usr/bin/gtk-update-icon-cache ]; then
91  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
92fi
93 
94%pre
95if [ "$1" -gt 1 ]; then
96  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
97  gconftool-2 --makefile-uninstall-rule \
98      %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
99fi
100
101%preun
102if [ "$1" -eq 0 ]; then
103  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
104  gconftool-2 --makefile-uninstall-rule \
105      %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
106fi
107
108%postun
109update-desktop-database %{_datadir}/applications >& /dev/null || :
110touch --no-create %{_datadir}/icons/hicolor
111if [ -x /usr/bin/gtk-update-icon-cache ]; then
112  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
113fi
114
115
116%files -f %{name}.lang
117%defattr(-,root,root)
118%{_sysconfdir}/dbus-1/system.d/org.%{name}*.conf
119%{_sysconfdir}/xdg/autostart/%{name}.desktop
120%{_bindir}/%{name}-*
121%{_libdir}/nautilus-sendto/plugins/libnstblueman.so
122%{_datadir}/applications/%{name}-manager.desktop
123%{_datadir}/%{name}/ui/*.ui
124%{_datadir}/%{name}/icons/hicolor/*/*s/*.png
125%{_datadir}/%{name}/icons/hicolor/scalable/status/*.svg
126%{_datadir}/%{name}/icons/hicolor/scalable/actions/*.svg
127%{_datadir}/icons/hicolor/scalable/devices/*.svg
128%{_datadir}/icons/hicolor/*/apps/*.png
129%{_datadir}/icons/hicolor/scalable/apps/*.svg
130%{_datadir}/blueman/icons/hicolor/scalable/devices/blueman-device.svg
131%{_datadir}/blueman/icons/hicolor/scalable/devices/blueman-serial.svg
132%{_datadir}/dbus-1/services/%{name}-applet.service
133%{_datadir}/dbus-1/system-services/org.%{name}*.service
134%{_datadir}/polkit-1/actions/org.blueman.policy
135%{_mandir}/man1/%{name}*1.*
136%{python_sitelib}/*
137%if %_lib == lib64
138%{python_sitearch}/*
139%endif
140%{_libexecdir}/%{name}-*
141
142
143%changelog
144* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.23-2
145- rebuild with python-2.7.2
146
147* Tue Jan 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.23-1
148- new upstream release
149
150* Mon Apr 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-4
151- rebuild with rpm-4.8.1
152
153* Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-3
154- add BuildRequires: gtk2-devel
155
156* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.21-2
157- rebuilt with python-2.6.4
158
159* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-1
160- new upstream release
161
162* Mon Jan 04 2010 Shu KONNO <owa@bg.wakwak.com> 1.10-2
163- added _blueman to %%files (if lib64)
164
165* Tue May 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-1
166- initial build for Vine Linux
167
168* Fri Mar 27 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-4mdv2009.1
169+ Revision: 361574
170- don't explicitely requires notification-daemon
171
172* Mon Mar 02 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-3mdv2009.1
173+ Revision: 347587
174- requires python-blueman
175
176* Mon Mar 02 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-2mdv2009.1
177+ Revision: 347346
178- fix files
179- BR python-dbus
180- fix BR
181- BR python-devel
182- import blueman
183
184
Note: See TracBrowser for help on using the repository browser.