source: projects/specs/trunk/b/blueman/blueman-vl.spec @ 5348

Revision 5348, 5.4 KB checked in by Takemikaduchi, 12 years ago (diff)

NEW: gnme-packagekit
others: new upstream release

Line 
1Summary:        Full featured bluetooth manager for GNOME/GTK
2Summary(ja):    GNOME/GTK 用の高機能な Bluetooth マネージャ
3
4Name:           blueman
5Version:        1.23
6Release:        1%{?_dist_release}
7License:        GPLv2+
8Group:          Applications/System
9Url:            http://blueman-project.org/
10
11Source0:        %{name}-%{version}.tar.gz
12
13Buildroot:      %{_tmppath}/%{name}-%{version}
14BuildRequires:  desktop-file-utils
15BuildRequires:  perl(XML::Parser)
16BuildRequires:  glib2-devel
17BuildRequires:  gtk2-devel
18BuildRequires:  GConf2-devel
19BuildRequires:  pygtk2-devel
20BuildRequires:  intltool
21BuildRequires:  startup-notification-devel
22BuildRequires:  pygobject-devel
23BuildRequires:  notify-python
24BuildRequires:  bluez-libs-devel >= 4.37
25BuildRequires:  python-devel
26BuildRequires:  python-pyrex
27BuildRequires:  dbus-python
28Requires:       obex-data-server
29Requires:       notify-python
30Requires:       pygtk2
31Requires:       gnome-python
32Requires:       dbus-python
33Requires:       pygobject
34Requires:       PolicyKit-gnome
35Provides:       dbus-bluez-pin-helper
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: daisuke
40
41
42%description
43Blueman is designed to provide simple, yet effective means for
44controlling BlueZ API and simplifying bluetooth tasks such as:
45
46* Connecting to 3G/EDGE/GPRS via dial-up
47* Connecting to/Creating bluetooth networks
48* Connecting to input devices
49* Connecting to audio devices
50* Sending/Receiving/Browsing files via OBEX
51* Pairing
52
53Blueman also integrates with Network Manager 0.7, so any Dialup/Network
54 connections will be made available (via HAL) to Network Manager.
55
56%prep
57%setup -q
58
59%build
60sed -i 's|2.7|2.6|g' configure.ac
61autoreconf -if
62%configure --disable-desktop-update --disable-icon-update --disable-schemas-install
63%__make %{?_smp_mflags}
64
65%install
66rm -rf %{buildroot}
67%__make install DESTDIR=${RPM_BUILD_ROOT}
68
69mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/devices
70cp $RPM_BUILD_ROOT%{_datadir}/blueman/icons/hicolor/scalable/devices/* \
71   $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/devices/
72
73desktop-file-install --vendor="" \
74  --add-category="GNOME;GTK" \
75  --add-category="Settings;HardwareSettings" \
76  --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/%{name}-manager.desktop
77
78find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
79find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
80
81%find_lang %{name}
82
83%clean
84rm -rf %{buildroot}
85
86%post
87export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
88gconftool-2 --makefile-install-rule \
89    %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
90update-desktop-database %{_datadir}/applications >& /dev/null || :
91touch --no-create %{_datadir}/icons/hicolor
92if [ -x /usr/bin/gtk-update-icon-cache ]; then
93  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
94fi
95 
96%pre
97if [ "$1" -gt 1 ]; then
98  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
99  gconftool-2 --makefile-uninstall-rule \
100      %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
101fi
102
103%preun
104if [ "$1" -eq 0 ]; then
105  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
106  gconftool-2 --makefile-uninstall-rule \
107      %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
108fi
109
110%postun
111update-desktop-database %{_datadir}/applications >& /dev/null || :
112touch --no-create %{_datadir}/icons/hicolor
113if [ -x /usr/bin/gtk-update-icon-cache ]; then
114  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
115fi
116
117
118%files -f %{name}.lang
119%defattr(-,root,root)
120%{_sysconfdir}/dbus-1/system.d/org.%{name}*.conf
121%{_sysconfdir}/xdg/autostart/%{name}.desktop
122%{_bindir}/%{name}-*
123%{_libdir}/nautilus-sendto/plugins/libnstblueman.so
124%{_datadir}/applications/%{name}-manager.desktop
125%{_datadir}/%{name}/ui/*.ui
126%{_datadir}/%{name}/icons/hicolor/*/*s/*.png
127%{_datadir}/%{name}/icons/hicolor/scalable/status/*.svg
128%{_datadir}/%{name}/icons/hicolor/scalable/actions/*.svg
129%{_datadir}/icons/hicolor/scalable/devices/*.svg
130%{_datadir}/icons/hicolor/*/apps/*.png
131%{_datadir}/icons/hicolor/scalable/apps/*.svg
132%{_datadir}/blueman/icons/hicolor/scalable/devices/blueman-device.svg
133%{_datadir}/blueman/icons/hicolor/scalable/devices/blueman-serial.svg
134%{_datadir}/dbus-1/services/%{name}-applet.service
135%{_datadir}/dbus-1/system-services/org.%{name}*.service
136%{_datadir}/polkit-1/actions/org.blueman.policy
137%{_mandir}/man1/%{name}*1.*
138%{python_sitelib}/*
139%if %_lib == lib64
140%{python_sitearch}/*
141%endif
142%{_libexecdir}/%{name}-*
143
144
145%changelog
146* Tue Jan 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.23-1
147- new upstream release
148
149* Mon Apr 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-4
150- rebuild with rpm-4.8.1
151
152* Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-3
153- add BuildRequires: gtk2-devel
154
155* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.21-2
156- rebuilt with python-2.6.4
157
158* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-1
159- new upstream release
160
161* Mon Jan 04 2010 Shu KONNO <owa@bg.wakwak.com> 1.10-2
162- added _blueman to %%files (if lib64)
163
164* Tue May 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-1
165- initial build for Vine Linux
166
167* Fri Mar 27 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-4mdv2009.1
168+ Revision: 361574
169- don't explicitely requires notification-daemon
170
171* Mon Mar 02 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-3mdv2009.1
172+ Revision: 347587
173- requires python-blueman
174
175* Mon Mar 02 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-2mdv2009.1
176+ Revision: 347346
177- fix files
178- BR python-dbus
179- fix BR
180- BR python-devel
181- import blueman
182
183
Note: See TracBrowser for help on using the repository browser.