source: projects/specs/trunk/b/bison/bison-vl.spec @ 8067

Revision 8067, 6.3 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Summary: A GNU general-purpose parser generator.
2Summary(ja): GNU 汎用構文解析器生成プログラム
3Name: bison
4Version: 2.7.1
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Tools
8Source: http://ftp.gnu.org/gnu/bison/bison-%{version}.tar.xz
9URL: http://www.gnu.org/software/bison/
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12Requires: m4 >= 1.4
13Requires(post): install-info
14Requires(preun): install-info
15
16Vendor:        Project Vine
17Distribution:  Vine Linux
18
19%description
20Bison is a general purpose parser generator which converts a grammar
21description for an LALR(1) context-free grammar into a C program to parse
22that grammar.  Bison can be used to develop a wide range of language
23parsers, from ones used in simple desk calculators to complex programming
24languages.  Bison is upwardly compatible with Yacc, so any correctly
25written Yacc grammar should work with Bison without any changes.  If
26you know Yacc, you shouldn't have any trouble using Bison. You do need
27to be very proficient in C programming to be able to use Bison).  Bison
28is only needed on systems that are used for development.
29
30If your system will be used for C development, you should install Bison
31since it is used to build many C programs.
32
33#'
34%description -l ja
35bison は汎用構文解析器を生成するプログラムで,LALR(1) 文脈自由文法で
36書かれた文法記述を元に,その記述を解析する C プログラムを生成します.
37bison は簡単な電卓から複雑なプログラミング言語まで,幅広い種類の
38言語解析器を開発するのに使うことが出来ます.
39bison は yacc の上位互換ですので,yacc で書かれた文法を修正すること
40なしに解析することが出来ます.yacc を知っているのであれば,bison を
41使って困ることは何もないでしょう.bison を使うには C プログラミングの
42豊富な知識が必要となります.bison は開発を行うシステム以外では特に
43必要にならないでしょう.
44
45C 言語による開発を行う場合は,多くの C プログラムの作成に使われるので
46bison をインストールして下さい.
47
48
49%prep
50%setup -q
51
52
53%build
54%configure
55make
56make check
57
58
59%install
60rm -rf $RPM_BUILD_ROOT
61%makeinstall
62
63# Remove unpackaged files.
64rm -f $RPM_BUILD_ROOT/%{_bindir}/yacc
65rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
66rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/yacc*
67
68%find_lang %{name}
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74
75%post
76/sbin/install-info %{_infodir}/bison.info.gz %{_infodir}/dir \
77    --entry="* bison: (bison).                        The GNU parser generator."
78
79%preun
80if [ $1 = 0 ]; then
81  /sbin/install-info --delete %{_infodir}/bison.info.gz %{_infodir}/dir \
82      --entry="* bison: (bison).                        The GNU parser generator."
83fi
84
85
86%files -f %{name}.lang
87%defattr(-,root,root)
88%doc AUTHORS COPYING ChangeLog NEWS OChangeLog README THANKS TODO
89%{_bindir}/bison
90%{_libdir}/liby.a
91%{_datadir}/bison
92%{_datadir}/aclocal/*.m4
93%{_datadir}/locale/*/LC_MESSAGES/%{name}-runtime.mo
94%{_mandir}/*/bison*
95%{_infodir}/bison.info*
96
97
98%changelog
99* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-1
100- update to 2.7.1
101
102* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 2.5-1
103- new upstream release
104
105* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.3-1
106- new upstream release
107- delete Patch1
108
109* Wed Feb 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-2
110- rebuilt with new toolchain
111
112* Tue Feb  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.1-1
113- new upstream release
114- import Patch1 from Fedora
115
116* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
117- new upstream release
118- spec in UTF-8
119
120* Sun Apr 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.3-1
121- rebuild with new toolchain.
122- apply new versioning policy.
123
124* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl1
125- new upstream release
126
127* Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-0vl1
128- new upstream release
129
130* Wed Jun 09 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-6vl1
131- new upstream release
132- dropped Patch1
133- added %doc files
134- updated URL
135
136* Sun Feb 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.875-6vl1
137- add Patch1 from fedora
138- add Requires: m4
139  * Thu Oct 30 2003 Roland McGrath <roland@redhat.com> 1.875-6
140  - add dependency on m4 (bug #108655)
141  * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 1.875-5
142  - remove problematic __attribute__ use for label (bug #105034)
143
144* Sun Jul  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.875-3vl1
145- based on Rawhide 1.875-3
146- s/Copyright/License/
147
148* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.75-2vl1
149  - new upstream release
150  - merged with rawhide release
151    * Thu Nov 21 2002 Tim Waugh <twaugh@redhat.com> 1.75-2
152    - Run 'make check'.
153    - Apply patch from bison-patches to fix bash compilation.
154    * Thu Oct 17 2002 Florian La Roche <Florian.LaRoche@redhat.de>
155    - update to 1.75
156
157* Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
158- 1.35-2vl1: synced with rawhide
159
160* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
161- 1.28-5vl1
162- rebuilt with new %%{_mandir} definition
163- added Japanese summary and description
164
165* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.28-5vl1
166- build on Vine Linux with gcc-2.95.3
167
168* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
169- automatic rebuild
170
171* Sun Jun 18 2000 Than Ngo <than@redhat.de>
172- rebuilt in the new build environment
173- FHS packaging
174
175* Sat May 27 2000 Ngo Than <than@redhat.de>
176- rebuild for 7.0
177- put man pages and info files to correct place
178
179* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
180- rebuild to gzip man page.
181
182* Fri Jul 16 1999 Jeff Johnson <jbj@redhat.com>
183- update to 1.28.
184
185* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
186- auto rebuild in the new build environment (release 3)
187
188* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
189- configure with datadir=/usr/lib (#1386).
190
191* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
192- updated text in spec file.
193- update to 1.27
194
195* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
196- build for glibc 2.1
197
198* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
199- translations modified for de, fr, tr
200
201* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
202- built for Manhattan
203- added build root
204
205* Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
206- various spec file cleanups
207
208* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
209- built against glibc
210
Note: See TracBrowser for help on using the repository browser.