source: projects/specs/trunk/b/bison/bison-vl.spec @ 12546

Revision 12546, 7.1 KB checked in by tomop, 3 years ago (diff)

updated 28 packages

autoconf-2.71-1

automake-1.16.3-1

bison-3.7.5-1

e2fsprogs-1.46.1-1

findutils-4.8.0-1

galera-26.4.7-1

gawk-5.1.0-1

gdbm-1.19-1

gjs-1.66.2-1

gnome-initial-setup-3.36.4-2

grep-3.6-1

help2man-1.48.1-1

ipvsadm-1.31-1

less-563-1

libidn-1.36-1

make-4.3-1

mariadb-10.5.9-1

mozjs78-78.7.0-1

mpfr-4.1.0-1

nettle-3.7.1-1

parted-3.4-1

pcre2-10.36-1

polkit-0.118-1

strongswan-5.9.1-1

tar-1.34-1

trousers-0.3.15-1

wget-1.21-1

wireshark-3.4.3-1

Line 
1%bcond_without check
2
3Summary:        A GNU general-purpose parser generator.
4Summary(ja):    GNU 汎用構文解析器生成プログラム
5Name:           bison
6Version:        3.7.5
7Release:        1%{?_dist_release}
8Group:          programming
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        GPL
13Source:         https://ftp.gnu.org/gnu/bison/bison-%{version}.tar.xz
14URL:            https://www.gnu.org/software/bison/
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  flex
19
20Requires:       m4 >= 1.4
21Requires(post): install-info
22Requires(preun): install-info
23
24%description
25Bison is a general purpose parser generator which converts a grammar
26description for an LALR(1) context-free grammar into a C program to parse
27that grammar.  Bison can be used to develop a wide range of language
28parsers, from ones used in simple desk calculators to complex programming
29languages.  Bison is upwardly compatible with Yacc, so any correctly
30written Yacc grammar should work with Bison without any changes.  If
31you know Yacc, you shouldn't have any trouble using Bison. You do need
32to be very proficient in C programming to be able to use Bison).  Bison
33is only needed on systems that are used for development.
34
35If your system will be used for C development, you should install Bison
36since it is used to build many C programs.
37
38#'
39%description -l ja
40bison は汎用構文解析器を生成するプログラムで,LALR(1) 文脈自由文法で
41書かれた文法記述を元に,その記述を解析する C プログラムを生成します.
42bison は簡単な電卓から複雑なプログラミング言語まで,幅広い種類の
43言語解析器を開発するのに使うことが出来ます.
44bison は yacc の上位互換ですので,yacc で書かれた文法を修正すること
45なしに解析することが出来ます.yacc を知っているのであれば,bison を
46使って困ることは何もないでしょう.bison を使うには C プログラミングの
47豊富な知識が必要となります.bison は開発を行うシステム以外では特に
48必要にならないでしょう.
49
50C 言語による開発を行う場合は,多くの C プログラムの作成に使われるので
51bison をインストールして下さい.
52
53
54%debug_package
55
56
57%prep
58%setup -q
59
60
61%build
62%configure
63make %{_smp_mflags}
64
65
66%if %{with check}
67%check
68make check
69%endif
70
71
72%install
73rm -rf $RPM_BUILD_ROOT
74%makeinstall
75
76# Remove unpackaged files.
77rm -f $RPM_BUILD_ROOT/%{_bindir}/yacc
78rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
79rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/yacc*
80
81rm -f pkgdoc
82cp -af %{buildroot}%{_docdir}/%{name} ./pkgdoc
83rm -rf %{buildroot}%{_docdir}/%{name}
84rm -f pkgdoc/COPYING
85
86%find_lang %{name}
87%find_lang %{name}-gnulib
88
89cat %{name}-gnulib.lang >> %{name}.lang
90
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95
96%post
97/sbin/install-info %{_infodir}/bison.info.gz %{_infodir}/dir \
98    --entry="* bison: (bison).                        The GNU parser generator."
99
100%preun
101if [ $1 = 0 ]; then
102  /sbin/install-info --delete %{_infodir}/bison.info.gz %{_infodir}/dir \
103      --entry="* bison: (bison).                        The GNU parser generator."
104fi
105
106
107%files -f %{name}.lang
108%defattr(-,root,root)
109%license COPYING
110%doc pkgdoc/*
111%{_bindir}/bison
112%{_libdir}/liby.a
113%{_datadir}/bison
114%{_datadir}/aclocal/*.m4
115%{_datadir}/locale/*/LC_MESSAGES/%{name}-runtime.mo
116%{_mandir}/*/bison*
117%{_infodir}/bison.info*
118
119
120%changelog
121* Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7.5-1
122- new upstream release.
123
124* Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7.2-1
125- new upstream release.
126
127* Thu Sep 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7.1-1
128- new upstream release.
129
130* Thu Jun 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.4-1
131- new upstream release.
132
133* Tue Nov 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.2-1
134- new upstream release.
135
136* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-1
137- update to 2.7.1
138
139* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 2.5-1
140- new upstream release
141
142* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.3-1
143- new upstream release
144- delete Patch1
145
146* Wed Feb 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-2
147- rebuilt with new toolchain
148
149* Tue Feb  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.1-1
150- new upstream release
151- import Patch1 from Fedora
152
153* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
154- new upstream release
155- spec in UTF-8
156
157* Sun Apr 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.3-1
158- rebuild with new toolchain.
159- apply new versioning policy.
160
161* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl1
162- new upstream release
163
164* Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-0vl1
165- new upstream release
166
167* Wed Jun 09 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-6vl1
168- new upstream release
169- dropped Patch1
170- added %doc files
171- updated URL
172
173* Sun Feb 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.875-6vl1
174- add Patch1 from fedora
175- add Requires: m4
176  * Thu Oct 30 2003 Roland McGrath <roland@redhat.com> 1.875-6
177  - add dependency on m4 (bug #108655)
178  * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 1.875-5
179  - remove problematic __attribute__ use for label (bug #105034)
180
181* Sun Jul  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.875-3vl1
182- based on Rawhide 1.875-3
183- s/Copyright/License/
184
185* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.75-2vl1
186  - new upstream release
187  - merged with rawhide release
188    * Thu Nov 21 2002 Tim Waugh <twaugh@redhat.com> 1.75-2
189    - Run 'make check'.
190    - Apply patch from bison-patches to fix bash compilation.
191    * Thu Oct 17 2002 Florian La Roche <Florian.LaRoche@redhat.de>
192    - update to 1.75
193
194* Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
195- 1.35-2vl1: synced with rawhide
196
197* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
198- 1.28-5vl1
199- rebuilt with new %%{_mandir} definition
200- added Japanese summary and description
201
202* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.28-5vl1
203- build on Vine Linux with gcc-2.95.3
204
205* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
206- automatic rebuild
207
208* Sun Jun 18 2000 Than Ngo <than@redhat.de>
209- rebuilt in the new build environment
210- FHS packaging
211
212* Sat May 27 2000 Ngo Than <than@redhat.de>
213- rebuild for 7.0
214- put man pages and info files to correct place
215
216* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
217- rebuild to gzip man page.
218
219* Fri Jul 16 1999 Jeff Johnson <jbj@redhat.com>
220- update to 1.28.
221
222* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
223- auto rebuild in the new build environment (release 3)
224
225* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
226- configure with datadir=/usr/lib (#1386).
227
228* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
229- updated text in spec file.
230- update to 1.27
231
232* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
233- build for glibc 2.1
234
235* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
236- translations modified for de, fr, tr
237
238* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
239- built for Manhattan
240- added build root
241
242* Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
243- various spec file cleanups
244
245* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
246- built against glibc
247
Note: See TracBrowser for help on using the repository browser.