source: projects/specs/trunk/b/bison/bison-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A GNU general-purpose parser generator.
2Summary(ja): GNU 汎用構文解析器生成プログラム
3Name: bison
4Version: 2.4.1
5Release: 2%{?_dist_release}
6License: GPL
7Group: Development/Tools
8Source: http://ftp.gnu.org/gnu/bison/bison-%{version}.tar.bz2
9Patch1: bison-2.4-reap_subpipe.patch
10URL: http://www.gnu.org/software/bison/
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: m4 >= 1.4
14Requires(post): install-info
15Requires(preun): install-info
16
17Vendor:        Project Vine
18Distribution:  Vine Linux
19
20%description
21Bison is a general purpose parser generator which converts a grammar
22description for an LALR(1) context-free grammar into a C program to parse
23that grammar.  Bison can be used to develop a wide range of language
24parsers, from ones used in simple desk calculators to complex programming
25languages.  Bison is upwardly compatible with Yacc, so any correctly
26written Yacc grammar should work with Bison without any changes.  If
27you know Yacc, you shouldn't have any trouble using Bison. You do need
28to be very proficient in C programming to be able to use Bison).  Bison
29is only needed on systems that are used for development.
30
31If your system will be used for C development, you should install Bison
32since it is used to build many C programs.
33
34#'
35%description -l ja
36bison は汎用構文解析器を生成するプログラムで,LALR(1) 文脈自由文法で
37書かれた文法記述を元に,その記述を解析する C プログラムを生成します.
38bison は簡単な電卓から複雑なプログラミング言語まで,幅広い種類の
39言語解析器を開発するのに使うことが出来ます.
40bison は yacc の上位互換ですので,yacc で書かれた文法を修正すること
41なしに解析することが出来ます.yacc を知っているのであれば,bison を
42使って困ることは何もないでしょう.bison を使うには C プログラミングの
43豊富な知識が必要となります.bison は開発を行うシステム以外では特に
44必要にならないでしょう.
45
46C 言語による開発を行う場合は,多くの C プログラムの作成に使われるので
47bison をインストールして下さい.
48
49
50%prep
51%setup -q
52%patch1 -p1
53
54
55%build
56%configure
57make
58make check
59
60
61%install
62rm -rf $RPM_BUILD_ROOT
63%makeinstall
64
65# Remove unpackaged files.
66rm -f $RPM_BUILD_ROOT/%{_bindir}/yacc
67rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
68rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/yacc*
69
70%find_lang %{name}
71
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76
77%post
78/sbin/install-info %{_infodir}/bison.info.gz %{_infodir}/dir \
79    --entry="* bison: (bison).                        The GNU parser generator."
80
81%preun
82if [ $1 = 0 ]; then
83  /sbin/install-info --delete %{_infodir}/bison.info.gz %{_infodir}/dir \
84      --entry="* bison: (bison).                        The GNU parser generator."
85fi
86
87
88%files -f %{name}.lang
89%defattr(-,root,root)
90%doc AUTHORS COPYING ChangeLog NEWS OChangeLog README THANKS TODO
91%{_bindir}/bison
92%{_libdir}/liby.a
93%{_datadir}/bison
94%{_datadir}/aclocal/*.m4
95%{_datadir}/locale/*/LC_MESSAGES/%{name}-runtime.mo
96%{_mandir}/*/bison*
97%{_infodir}/bison.info*
98
99
100%changelog
101* Wed Feb 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-2
102- rebuilt with new toolchain
103
104* Tue Feb  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.1-1
105- new upstream release
106- import Patch1 from Fedora
107
108* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
109- new upstream release
110- spec in UTF-8
111
112* Sun Apr 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.3-1
113- rebuild with new toolchain.
114- apply new versioning policy.
115
116* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl1
117- new upstream release
118
119* Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-0vl1
120- new upstream release
121
122* Thu Jun 09 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-6vl1
123- new upstream release
124- dropped Patch1
125- added %doc files
126- updated URL
127
128* Sun Feb 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.875-6vl1
129- add Patch1 from fedora
130- add Requires: m4
131  * Thu Oct 30 2003 Roland McGrath <roland@redhat.com> 1.875-6
132  - add dependency on m4 (bug #108655)
133  * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 1.875-5
134  - remove problematic __attribute__ use for label (bug #105034)
135
136* Sun Jul  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.875-3vl1
137- based on Rawhide 1.875-3
138- s/Copyright/License/
139
140* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.75-2vl1
141  - new upstream release
142  - merged with rawhide release
143    * Thu Nov 21 2002 Tim Waugh <twaugh@redhat.com> 1.75-2
144    - Run 'make check'.
145    - Apply patch from bison-patches to fix bash compilation.
146    * Thu Oct 17 2002 Florian La Roche <Florian.LaRoche@redhat.de>
147    - update to 1.75
148
149* Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
150- 1.35-2vl1: synced with rawhide
151
152* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
153- 1.28-5vl1
154- rebuilt with new %%{_mandir} definition
155- added Japanese summary and description
156
157* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.28-5vl1
158- build on Vine Linux with gcc-2.95.3
159
160* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
161- automatic rebuild
162
163* Sun Jun 18 2000 Than Ngo <than@redhat.de>
164- rebuilt in the new build environment
165- FHS packaging
166
167* Sat May 27 2000 Ngo Than <than@redhat.de>
168- rebuild for 7.0
169- put man pages and info files to correct place
170
171* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
172- rebuild to gzip man page.
173
174* Fri Jul 16 1999 Jeff Johnson <jbj@redhat.com>
175- update to 1.28.
176
177* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
178- auto rebuild in the new build environment (release 3)
179
180* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
181- configure with datadir=/usr/lib (#1386).
182
183* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
184- updated text in spec file.
185- update to 1.27
186
187* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
188- build for glibc 2.1
189
190* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
191- translations modified for de, fr, tr
192
193* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
194- built for Manhattan
195- added build root
196
197* Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
198- various spec file cleanups
199
200* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
201- built against glibc
202
Note: See TracBrowser for help on using the repository browser.