source: projects/specs/trunk/b/bison/bison-vl.spec @ 12417

Revision 12417, 6.9 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

bison-3.6.4-1

libexif-0.6.22-2

libvncserver-0.9.13-1

nodejs-12.18.0-1

perl-5.26.2-3

php74-7.4.7-1

postfix-3.5.4-1

Line 
1%bcond_without check
2
3Summary:        A GNU general-purpose parser generator.
4Summary(ja):    GNU 汎用構文解析器生成プログラム
5Name:           bison
6Version:        3.6.4
7Release:        1%{?_dist_release}
8Group:          Development/Tools
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        GPL
13Source:         https://ftp.gnu.org/gnu/bison/bison-%{version}.tar.xz
14URL:            https://www.gnu.org/software/bison/
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  flex
19
20Requires:       m4 >= 1.4
21Requires(post): install-info
22Requires(preun): install-info
23
24%description
25Bison is a general purpose parser generator which converts a grammar
26description for an LALR(1) context-free grammar into a C program to parse
27that grammar.  Bison can be used to develop a wide range of language
28parsers, from ones used in simple desk calculators to complex programming
29languages.  Bison is upwardly compatible with Yacc, so any correctly
30written Yacc grammar should work with Bison without any changes.  If
31you know Yacc, you shouldn't have any trouble using Bison. You do need
32to be very proficient in C programming to be able to use Bison).  Bison
33is only needed on systems that are used for development.
34
35If your system will be used for C development, you should install Bison
36since it is used to build many C programs.
37
38#'
39%description -l ja
40bison は汎用構文解析器を生成するプログラムで,LALR(1) 文脈自由文法で
41書かれた文法記述を元に,その記述を解析する C プログラムを生成します.
42bison は簡単な電卓から複雑なプログラミング言語まで,幅広い種類の
43言語解析器を開発するのに使うことが出来ます.
44bison は yacc の上位互換ですので,yacc で書かれた文法を修正すること
45なしに解析することが出来ます.yacc を知っているのであれば,bison を
46使って困ることは何もないでしょう.bison を使うには C プログラミングの
47豊富な知識が必要となります.bison は開発を行うシステム以外では特に
48必要にならないでしょう.
49
50C 言語による開発を行う場合は,多くの C プログラムの作成に使われるので
51bison をインストールして下さい.
52
53
54%prep
55%setup -q
56
57
58%build
59%configure
60make %{_smp_mflags}
61
62
63%if %{with check}
64%check
65make check
66%endif
67
68
69%install
70rm -rf $RPM_BUILD_ROOT
71%makeinstall
72
73# Remove unpackaged files.
74rm -f $RPM_BUILD_ROOT/%{_bindir}/yacc
75rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
76rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/yacc*
77
78rm -f pkgdoc
79cp -af %{buildroot}%{_docdir}/%{name} ./pkgdoc
80rm -rf %{buildroot}%{_docdir}/%{name}
81rm -f pkgdoc/COPYING
82
83%find_lang %{name}
84%find_lang %{name}-gnulib
85
86cat %{name}-gnulib.lang >> %{name}.lang
87
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92
93%post
94/sbin/install-info %{_infodir}/bison.info.gz %{_infodir}/dir \
95    --entry="* bison: (bison).                        The GNU parser generator."
96
97%preun
98if [ $1 = 0 ]; then
99  /sbin/install-info --delete %{_infodir}/bison.info.gz %{_infodir}/dir \
100      --entry="* bison: (bison).                        The GNU parser generator."
101fi
102
103
104%files -f %{name}.lang
105%defattr(-,root,root)
106%license COPYING
107%doc pkgdoc/*
108%{_bindir}/bison
109%{_libdir}/liby.a
110%{_datadir}/bison
111%{_datadir}/aclocal/*.m4
112%{_datadir}/locale/*/LC_MESSAGES/%{name}-runtime.mo
113%{_mandir}/*/bison*
114%{_infodir}/bison.info*
115
116
117%changelog
118* Thu Jun 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.4-1
119- new upstream release.
120
121* Tue Nov 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.2-1
122- new upstream release.
123
124* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-1
125- update to 2.7.1
126
127* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 2.5-1
128- new upstream release
129
130* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.3-1
131- new upstream release
132- delete Patch1
133
134* Wed Feb 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-2
135- rebuilt with new toolchain
136
137* Tue Feb  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.1-1
138- new upstream release
139- import Patch1 from Fedora
140
141* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
142- new upstream release
143- spec in UTF-8
144
145* Sun Apr 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.3-1
146- rebuild with new toolchain.
147- apply new versioning policy.
148
149* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl1
150- new upstream release
151
152* Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-0vl1
153- new upstream release
154
155* Wed Jun 09 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-6vl1
156- new upstream release
157- dropped Patch1
158- added %doc files
159- updated URL
160
161* Sun Feb 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.875-6vl1
162- add Patch1 from fedora
163- add Requires: m4
164  * Thu Oct 30 2003 Roland McGrath <roland@redhat.com> 1.875-6
165  - add dependency on m4 (bug #108655)
166  * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 1.875-5
167  - remove problematic __attribute__ use for label (bug #105034)
168
169* Sun Jul  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.875-3vl1
170- based on Rawhide 1.875-3
171- s/Copyright/License/
172
173* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.75-2vl1
174  - new upstream release
175  - merged with rawhide release
176    * Thu Nov 21 2002 Tim Waugh <twaugh@redhat.com> 1.75-2
177    - Run 'make check'.
178    - Apply patch from bison-patches to fix bash compilation.
179    * Thu Oct 17 2002 Florian La Roche <Florian.LaRoche@redhat.de>
180    - update to 1.75
181
182* Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
183- 1.35-2vl1: synced with rawhide
184
185* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
186- 1.28-5vl1
187- rebuilt with new %%{_mandir} definition
188- added Japanese summary and description
189
190* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.28-5vl1
191- build on Vine Linux with gcc-2.95.3
192
193* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
194- automatic rebuild
195
196* Sun Jun 18 2000 Than Ngo <than@redhat.de>
197- rebuilt in the new build environment
198- FHS packaging
199
200* Sat May 27 2000 Ngo Than <than@redhat.de>
201- rebuild for 7.0
202- put man pages and info files to correct place
203
204* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
205- rebuild to gzip man page.
206
207* Fri Jul 16 1999 Jeff Johnson <jbj@redhat.com>
208- update to 1.28.
209
210* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
211- auto rebuild in the new build environment (release 3)
212
213* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
214- configure with datadir=/usr/lib (#1386).
215
216* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
217- updated text in spec file.
218- update to 1.27
219
220* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
221- build for glibc 2.1
222
223* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
224- translations modified for de, fr, tr
225
226* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
227- built for Manhattan
228- added build root
229
230* Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
231- various spec file cleanups
232
233* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
234- built against glibc
235
Note: See TracBrowser for help on using the repository browser.