source: projects/specs/trunk/b/bison/bison-vl.spec @ 12310

Revision 12310, 6.7 KB checked in by tomop, 4 years ago (diff)

updated 18 packages

bind-9.11.12-1

bison-3.4.2-1

clisp-2.49.93-1

exiv2-0.27.2-1

firefox-68.2.0-1

galera-26.4.3-1

gcr-3.28.1-1

glib2-2.62.2-1

golang-1.13.4-1

incron-0.5.12-3

libgexiv2-0.12.0-1

libsecret-0.18.8-2

mariadb-10.4.10-1

perl-Bit-Vector-7.4-1

perl-Class-Accessor-0.51-1

seahorse-3.34-1

thunderbird-68.2.1-1

wireshark-3.0.6-1

Line 
1%bcond_without check
2
3Summary: A GNU general-purpose parser generator.
4Summary(ja): GNU 汎用構文解析器生成プログラム
5Name: bison
6Version: 3.4.2
7Release: 1%{?_dist_release}
8License: GPL
9Group: Development/Tools
10Source: https://ftp.gnu.org/gnu/bison/bison-%{version}.tar.xz
11URL: https://www.gnu.org/software/bison/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: flex
16
17Requires: m4 >= 1.4
18Requires(post): install-info
19Requires(preun): install-info
20
21Vendor:        Project Vine
22Distribution:  Vine Linux
23
24%description
25Bison is a general purpose parser generator which converts a grammar
26description for an LALR(1) context-free grammar into a C program to parse
27that grammar.  Bison can be used to develop a wide range of language
28parsers, from ones used in simple desk calculators to complex programming
29languages.  Bison is upwardly compatible with Yacc, so any correctly
30written Yacc grammar should work with Bison without any changes.  If
31you know Yacc, you shouldn't have any trouble using Bison. You do need
32to be very proficient in C programming to be able to use Bison).  Bison
33is only needed on systems that are used for development.
34
35If your system will be used for C development, you should install Bison
36since it is used to build many C programs.
37
38#'
39%description -l ja
40bison は汎用構文解析器を生成するプログラムで,LALR(1) 文脈自由文法で
41書かれた文法記述を元に,その記述を解析する C プログラムを生成します.
42bison は簡単な電卓から複雑なプログラミング言語まで,幅広い種類の
43言語解析器を開発するのに使うことが出来ます.
44bison は yacc の上位互換ですので,yacc で書かれた文法を修正すること
45なしに解析することが出来ます.yacc を知っているのであれば,bison を
46使って困ることは何もないでしょう.bison を使うには C プログラミングの
47豊富な知識が必要となります.bison は開発を行うシステム以外では特に
48必要にならないでしょう.
49
50C 言語による開発を行う場合は,多くの C プログラムの作成に使われるので
51bison をインストールして下さい.
52
53
54%prep
55%setup -q
56
57
58%build
59%configure
60make %{_smp_mflags}
61
62
63%if %{with check}
64%check
65make check
66%endif
67
68
69%install
70rm -rf $RPM_BUILD_ROOT
71%makeinstall
72
73# Remove unpackaged files.
74rm -f $RPM_BUILD_ROOT/%{_bindir}/yacc
75rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
76rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/yacc*
77
78rm -f pkgdoc
79cp -af %{buildroot}%{_docdir}/%{name} ./pkgdoc
80rm -rf %{buildroot}%{_docdir}/%{name}
81rm -f pkgdoc/COPYING
82
83%find_lang %{name}
84%find_lang %{name}-gnulib
85
86cat %{name}-gnulib.lang >> %{name}.lang
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91
92%post
93/sbin/install-info %{_infodir}/bison.info.gz %{_infodir}/dir \
94    --entry="* bison: (bison).                        The GNU parser generator."
95
96%preun
97if [ $1 = 0 ]; then
98  /sbin/install-info --delete %{_infodir}/bison.info.gz %{_infodir}/dir \
99      --entry="* bison: (bison).                        The GNU parser generator."
100fi
101
102
103%files -f %{name}.lang
104%defattr(-,root,root)
105%license COPYING
106%doc pkgdoc/*
107%{_bindir}/bison
108%{_libdir}/liby.a
109%{_datadir}/bison
110%{_datadir}/aclocal/*.m4
111%{_datadir}/locale/*/LC_MESSAGES/%{name}-runtime.mo
112%{_mandir}/*/bison*
113%{_infodir}/bison.info*
114
115
116%changelog
117* Tue Nov 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.2-1
118- new upstream release.
119
120* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-1
121- update to 2.7.1
122
123* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 2.5-1
124- new upstream release
125
126* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.3-1
127- new upstream release
128- delete Patch1
129
130* Wed Feb 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-2
131- rebuilt with new toolchain
132
133* Tue Feb  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.1-1
134- new upstream release
135- import Patch1 from Fedora
136
137* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
138- new upstream release
139- spec in UTF-8
140
141* Sun Apr 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.3-1
142- rebuild with new toolchain.
143- apply new versioning policy.
144
145* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl1
146- new upstream release
147
148* Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-0vl1
149- new upstream release
150
151* Wed Jun 09 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-6vl1
152- new upstream release
153- dropped Patch1
154- added %doc files
155- updated URL
156
157* Sun Feb 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.875-6vl1
158- add Patch1 from fedora
159- add Requires: m4
160  * Thu Oct 30 2003 Roland McGrath <roland@redhat.com> 1.875-6
161  - add dependency on m4 (bug #108655)
162  * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 1.875-5
163  - remove problematic __attribute__ use for label (bug #105034)
164
165* Sun Jul  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.875-3vl1
166- based on Rawhide 1.875-3
167- s/Copyright/License/
168
169* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.75-2vl1
170  - new upstream release
171  - merged with rawhide release
172    * Thu Nov 21 2002 Tim Waugh <twaugh@redhat.com> 1.75-2
173    - Run 'make check'.
174    - Apply patch from bison-patches to fix bash compilation.
175    * Thu Oct 17 2002 Florian La Roche <Florian.LaRoche@redhat.de>
176    - update to 1.75
177
178* Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
179- 1.35-2vl1: synced with rawhide
180
181* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
182- 1.28-5vl1
183- rebuilt with new %%{_mandir} definition
184- added Japanese summary and description
185
186* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.28-5vl1
187- build on Vine Linux with gcc-2.95.3
188
189* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
190- automatic rebuild
191
192* Sun Jun 18 2000 Than Ngo <than@redhat.de>
193- rebuilt in the new build environment
194- FHS packaging
195
196* Sat May 27 2000 Ngo Than <than@redhat.de>
197- rebuild for 7.0
198- put man pages and info files to correct place
199
200* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
201- rebuild to gzip man page.
202
203* Fri Jul 16 1999 Jeff Johnson <jbj@redhat.com>
204- update to 1.28.
205
206* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
207- auto rebuild in the new build environment (release 3)
208
209* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
210- configure with datadir=/usr/lib (#1386).
211
212* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
213- updated text in spec file.
214- update to 1.27
215
216* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
217- build for glibc 2.1
218
219* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
220- translations modified for de, fr, tr
221
222* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
223- built for Manhattan
224- added build root
225
226* Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
227- various spec file cleanups
228
229* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
230- built against glibc
231
Note: See TracBrowser for help on using the repository browser.