source: projects/specs/trunk/b/bind/bind-vl.spec @ 9666

Revision 9666, 22.1 KB checked in by iwamoto, 9 years ago (diff)

bind: update to 9.9.7-P1 with security fix

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind
5%define pversion 9.9.7.P1
6%define sversion 9.9.7-P1
7%define bind_epoch 1
8# fixed <BTS:VineLinux:1139>
9%define old_bind_version 1:9.9.2p2-1vl7
10
11%define bind_uid  25
12%define bind_gid  25
13
14%bcond_with readline
15
16Summary: A DNS (Domain Name System) server.
17Summary(ja): DNS (Domain Name System) サーバ
18Name: %{pname}
19Version: %{pversion}
20Release: 1%{?_dist_release}
21Epoch: %{bind_epoch}
22License: ISC and BSD and Public Domain
23Group: System Environment/Daemons
24URL: http://www.isc.org/bind.html
25
26Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
27Source1: bind-manpages.tar.bz2
28Source2: named.sysconfig
29Source3: named.init
30Source4: named.logrotate
31Source5: keygen.c
32Patch1: bind-9.3.3rc2-rndckey.patch
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35BuildRequires: openssl-devel glibc-devel libtool
36BuildRequires: libxml2-devel
37BuildRequires: libcap-devel
38%if %{with readline}
39BuildRequires: readline-devel
40%endif
41Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
42Requires(pre): shadow-utils
43Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
44Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
45Requires(post): coreutils, chkconfig
46Requires(preun): initscripts, chkconfig
47Conflicts: bind9 <= 9.2.1-0vl5, bind-current
48Obsoletes: bind9 <= 9.2.1-0vl5
49Obsoletes: bind-current < 1:9.9.4-1
50
51Vendor: Project Vine
52Distribution: Vine Linux
53Packager: daisuke
54
55%description
56BIND (Berkeley Internet Name Domain) is an implementation of the DNS
57(Domain Name System) protocols. BIND includes a DNS server (named),
58which resolves host names to IP addresses, and a resolver library
59(routines for applications to use when interfacing with DNS).  A DNS
60server allows clients to name resources or objects and share the
61information with other network machines.  The named DNS server can be
62used on workstations as a caching name server, but is generally only
63needed on one machine for an entire network.  Note that the
64configuration files for making BIND act as a simple caching nameserver
65are included in the caching-nameserver package. 
66
67Install the bind package if you need a DNS server for your network.  If
68you want bind to act a caching name server, you will also need to install
69the caching-nameserver package.
70
71
72%package libs
73Summary: Libraries used by various DNS packages
74Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
75Group: System Environment/Libraries
76Obsoletes: bind-current-libs <= %{old_bind_version}
77
78%description libs
79Contains libraries used by both the bind server package as well as the utils packages.
80
81
82%package utils
83Summary: Utilities for querying DNS name servers.
84Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
85Group: Applications/System
86Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
87Conflicts: bind9-utils <= 9.2.1-0vl5
88Conflicts: bind-current-utils
89Obsoletes: bind9-utils <= 9.2.1-0vl5
90Obsoletes: bind-current-utils <= %{old_bind_version}
91
92%description utils
93Bind-utils contains a collection of utilities for querying DNS (Domain
94Name Service) name servers to find out information about Internet hosts.
95These tools will provide you with the IP addresses for given host names,
96as well as other information about registered domains and network
97addresses.
98
99You should install bind-utils if you need to get information from DNS name
100servers.
101
102
103%package devel
104Summary: Include files and libraries needed for bind DNS development.
105Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
106Group: Development/Libraries
107Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
108Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
109Conflicts: bind9-devel <= 9.2.1-0vl5
110Conflicts: bind-current-devel
111Obsoletes: bind9-devel <= 9.2.1-0vl5
112Obsoletes: bind-current-devel <= %{old_bind_version}
113
114%description devel
115The bind-devel package contains all the include files and the
116library required for DNS (Domain Name Service) development for
117BIND versions 9.x.x.
118
119You should install bind-devel if you want to develop bind DNS
120applications. If you install bind-devel, you'll also need to install
121bind.
122#'
123
124%prep
125%setup -n bind-%{sversion} -q
126%patch1 -p1 -b .key
127perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
128
129%build
130libtoolize --copy --force
131aclocal
132autoconf
133%configure \
134  --with-libtool \
135  --with-openssl=/usr \
136%if %{without readline}
137    --without-readline \
138%endif
139  --disable-openssl-version-ceck \
140  --enable-threads \
141  --enable-ipv6 \
142  --with-pic \
143  --with-dlz-dlopen \
144  --enable-filter-aaaa \
145  --enable-fixed-rrset
146make %{?_smp_mflags}
147
148%install
149rm -rf $RPM_BUILD_ROOT
150mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
151mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
152mkdir -p ${RPM_BUILD_ROOT}/var/named
153mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
154mkdir -p ${RPM_BUILD_ROOT}/var/run/named
155
156make DESTDIR=$RPM_BUILD_ROOT install
157install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
158install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
159install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
160install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
161touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
162gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
163cd $RPM_BUILD_ROOT%{_mandir}
164tar xjf %{SOURCE1}
165# newer version is contained in source
166rm -f man5/named.conf.5.gz
167mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
168cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
169
170chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
171
172rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
173
174%clean
175rm -rf $RPM_BUILD_ROOT ${RPM_BUILD_DIR}/%{name}-%{version}
176
177
178%pre
179if [ "$1" -eq 1 ]; then
180  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
181  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
182fi;
183:;
184
185%post
186/sbin/ldconfig
187/sbin/chkconfig --add named
188if [ "$1" -eq 1 ]; then
189  if [ ! -e /etc/rndc.key ]; then
190    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
191  fi
192  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
193  # rndc.key has to have correct perms and ownership, CVE-2007-6283
194  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
195  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
196
197  # Check DNSSEC settings if this is a fresh install
198  if [ -r /etc/sysconfig/dnssec ]; then
199    . /etc/sysconfig/dnssec
200    [ -x /usr/sbin/dnssec-configure ] && \
201      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
202        /dev/null 2>&1
203  fi;
204fi
205:;
206
207%preun
208if [ "$1" -eq 0 ]; then
209   /sbin/service named stop >/dev/null 2>&1 || :
210   /sbin/chkconfig --del named ||:
211fi
212exit 0
213
214%postun
215if [ "$1" -ge 1 ]; then
216        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
217fi
218/sbin/ldconfig
219
220%triggerpostun -- bind < 8.2.2_P5-15
221/sbin/chkconfig --add named
222/sbin/ldconfig
223
224%triggerpostun -- bind-current < 1:9.9.4-1
225/sbin/chkconfig --add named
226/sbin/ldconfig
227
228%post libs -p /sbin/ldconfig
229
230%postun libs -p /sbin/ldconfig
231
232
233%files
234%defattr(-,root,root)
235%doc CHANGES README
236%doc doc/arm doc/misc
237%config(noreplace) %{_sysconfdir}/logrotate.d/named
238%config %{_sysconfdir}/rc.d/init.d/named
239%config(noreplace) %{_sysconfdir}/sysconfig/named
240%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
241%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
242%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
243
244%{_sbindir}/dnssec*
245%{_sbindir}/lwresd
246%{_sbindir}/named
247%{_sbindir}/named-bootconf
248%{_sbindir}/named-check*
249%{_sbindir}/named-compilezone
250%{_sbindir}/rndc*
251%{_sbindir}/dns-keygen
252%{_sbindir}/arpaname
253%{_sbindir}/ddns-confgen
254%{_sbindir}/genrandom
255%{_sbindir}/isc-hmac-fixup
256%{_sbindir}/named-journalprint
257%{_sbindir}/nsec3hash
258
259%{_mandir}/man1/arpaname.1*
260%{_mandir}/man5/resolv.conf.5*
261%{_mandir}/man5/named.conf.5*
262%{_mandir}/man5/rndc.conf.5*
263%{_mandir}/man8/rndc.8*
264%{_mandir}/man8/named.8*
265%{_mandir}/man8/lwresd.8*
266%{_mandir}/man8/dnssec*.8*
267%{_mandir}/man8/named-checkconf.8*
268%{_mandir}/man8/named-checkzone.8*
269%{_mandir}/man8/named-compilezone.8*
270%{_mandir}/man8/rndc-confgen.8*
271%{_mandir}/man8/ddns-confgen.8*
272%{_mandir}/man8/genrandom.8*
273%{_mandir}/man8/isc-hmac-fixup.8*
274%{_mandir}/man8/named-journalprint.8*
275%{_mandir}/man8/nsec3hash.8*
276
277%attr(-,named,named) %dir %{_var}/named
278%attr(-,named,named) %dir %{_var}/run/named
279     
280
281%files libs
282%defattr(-,root,root)
283%{_libdir}/*.so.*
284
285%files utils
286%defattr(-,root,root)
287%{_bindir}/dig
288%{_bindir}/host
289%{_bindir}/nslookup
290%{_bindir}/nsupdate
291%{_mandir}/man1/host.1*
292%{_mandir}/man1/nsupdate.1*
293%{_mandir}/man1/dig.1*
294%{_mandir}/man5/resolver.5*
295%{_mandir}/man1/nslookup.1*
296%{_mandir}/man8/nslookup.8*
297
298%files devel
299%defattr(-,root,root)
300%{_libdir}/*.so
301%{_libdir}/*.a
302%{_includedir}/*
303%{_mandir}/man3/*
304%{_mandir}/man1/bind9-config.1*
305%{_mandir}/man1/isc-config.sh.1*
306%{_bindir}/bind9-config
307%{_bindir}/isc-config.sh
308
309%changelog
310%changelog
311* Thu Jul  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
312- new upstream release with secrity fix (CVE-2015-4620)
313
314* Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
315- rebuilt without readline to avoid GPL infection
316
317* Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
318- new upstream release with secrity fix (CVE-2015-1349)
319- added BR: readline-devel
320
321* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
322- new upstream release with secrity fix (CVE-2014-8500) 
323- used "3" as release number because of being newer than Vine Linux/6 updates
324
325* Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
326- update to 9.9.4(ESV)
327
328* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
329- update to 9.9.2-P2
330- remove .la
331- remove Conflicts/Obsoletes from libs subpackage.
332- add configure options
333  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
334
335* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
336- new upstream release.
337- added an option "--with-dlz-dlopen".
338
339* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
340- Obosoletes: bind.* < 1:9.6.ESV.R1
341 - fixed <BTS:VineLinux:1139>
342
343* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
344- new upstream release with security fix (CVE-2011-1910)
345
346* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
347- add BuildRequires: libxml2-devel, libcap-devel
348
349* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
350- new upstream release with security fix (CVE-2011-1907)
351- fix changelog typo
352
353* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
354- Obosoletes: bind.* < 1:9.6.ESV.R1
355
356* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
357- update to 9.8.0
358- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
359
360* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
361- rebuild with openssl-1.0.0c
362
363* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
364- fix Req: in bind package
365
366* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
367- change package name bind -> bind-current
368- add epoch 1
369- new upstream release
370
371* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
372- new upstream release
373
374* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
375- rebuilt with gcc-4.4.3-3 on ppc
376
377* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
378- rebuilt with new toolchains (for VineSeed)
379- s/BuildPrereq/BuildRequires/
380
381* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
382- add man1/isc-config.sh.1 into devel file list
383
384* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
385- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
386
387* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
388- new upstream release with security fix (CVE-2009-4022)
389
390* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
391- new upstream release with security fix
392
393* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
394- new upstream release
395- clean up %%post/%%pre scriptlet
396  - create named user and group in %%pre
397  - don't remove named user/group in %%preun
398  - use rndc-confgen to create rndc.key
399
400* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
401- new upstream release
402- drop patch0 and patch14, merged in upstream
403
404* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
405- new upstream release with security fix
406
407* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
408- new upstream release with security fix
409- new versioning policy
410
411* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
412- new upstream release with security fix
413
414* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
415- new upstream release
416- build with new openssl/toolchain
417
418* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
419- new upstream release with security fix
420
421* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
422- new upstream release
423
424* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
425- add Prereq sed
426
427* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
428- new upstream release for security fix (CVE-2006-4095,4096)
429
430* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
431- separate -libs package
432- remove old named.conf.5.gz
433  - newer version is contained in source
434
435* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
436- add bsdcompat patch (Patch4)
437- add fix_h_errno patch from FC
438  - h_errno not being accessed / set correctly in libbind
439
440* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
441- new upstream release
442
443* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
444- added PreReq to bind-utils (see: [VineSeed:09555])
445
446* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
447- new upstream release
448
449* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
450- fix /etc/init.d/named to use rndc
451
452* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
453- rebuild to remove unneeded dependancy
454
455* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
456- new upstream release
457
458* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
459- new upstream release
460
461* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
462- fix dependancies.
463
464* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
465- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
466- change package name to bind for VineSeed.
467- use more macros.
468
469* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
470- fixed some macros
471- add conflicts: to bind-* in bind9-devel and bind9-utils
472- add provides: bind = %%{version}
473
474* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
475- use %%configure macros
476
477* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
478- fixed inconsistent dependency
479
480* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
481- updated to 9.2.2rc1
482
483* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
484- updated to bind9(9.2.1), test packages ;)
485        -- based on Rawhide's bind-9.2.0-8
486        -- changed name bind9
487        -- added Conflicts: bind
488
489* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
490- release 8.3.1 includes security fixes
491
492* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
493- Upgraded to current stable release 8.3.0
494
495* Mon Oct  8 2001 <zn@mbf.nifty.com>
496- 8.2.5-0vl0: Upgraded to new upstream version.
497
498* Thu May 24 2001 <sagami@vinelinux.org>
499- 8.2.4-0vl1: eliminate CVS related files from %%doc
500
501* Thu May 17 2001 <sagami@vinelinux.org>
502- 8.2.4-0vl0
503
504* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
505- 8.2.3-1vl2
506- built on VineSeed
507
508* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
509- add doc/old
510- build for Vine 2.1
511
512* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
513- 8.2.3, fixes several security problems
514
515* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
516- static libraries may be used in shared objects. Build with -fPIC on ia64
517
518* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
519- 8.2.2-P7 (fixes Bug #20546)
520
521* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
522- condrestart fixes
523
524* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
525- change the init script to take condrestart, not cond-restart
526- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
527  the %pre and %post scripts
528
529* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
530- Don't prereq /etc/init.d
531
532* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
533- move initscript back
534
535* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
536- automatic rebuild
537
538* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
539- add "exit 0" for uninstall case
540
541* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
542- add prereq init.d and cleanup install section
543
544* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
545- fix the init script
546
547* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
548- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
549
550* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
551- Fix up the initscript (Bug #13033)
552- Fix build with current glibc (Bug #12755)
553- /etc/rc.d/init.d -> /etc/init.d
554- use %%{_mandir} rather than /usr/share/man
555
556* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
557- fix conflict with man-pages
558- remove compatibilty chkconfig links
559- initscript munging
560
561* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
562- modify logrotate setup to use PID file
563- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
564- actually bump the release this time
565
566* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
567- FHS compliance
568
569* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
570- clean up restart patch
571
572* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
573- provide /var/named (fix for bugs #9847, #10205)
574- preserve args when restarted via ndc(8) (bug #10227)
575- make resolv.conf(5) a link to resolver(5) (bug #10245)
576- fix SYSTYPE bug in all makefiles
577- move creation of named user from %%post into %%pre
578
579* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
580- Fix TTL (patch from ISC, Bug #9820)
581
582* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
583- fix typo in spec (it's %post, without a leading blank) introduced in -6
584- change SYSTYPE to linux
585
586* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
587- pick a standard < 100 uid/gid for named
588
589* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
590- Pass named a '-u named' parameter by default, and add/remove user.
591
592* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
593- fix host mx bug (Bug #9021)
594
595* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
596- rebuild to fix dependencies
597- man pages are compressed
598
599* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
600- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
601
602* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
603- Fix up location of named-bootconf.pl and make it executable
604  (Bug #8028)
605- bind-devel requires bind
606
607* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
608- update to 8.2.2-P5
609
610* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
611- update to 8.2.2-P3
612
613* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
614- add patch to stop a cache only server from complaining about lame servers
615  on every request.
616
617* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
618- use real stop and start in named.init for restart, not ndc restart, it has
619  problems when named has changed during a package update... (# 4890)
620
621* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
622- chkconfig --del in %preun, not %postun
623
624* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
625- initscript munging
626
627* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
628- fix installed chkconfig links to match init file
629
630* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
631- conflict with new (in man-1.24) man pages (#3876,#3877).
632
633* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
634- fix named.logrotate (wrong %SOURCE)
635
636* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
637- update to 8.2.1.
638- add named.logrotate (#3571).
639- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
640- vet file list.
641
642* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
643- don't run by default
644
645* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
646- nslookup fixes (#2463).
647- missing files (#3152).
648
649* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
650- nslookup patched:
651  to count numRecords properly
652  to fix subsequent calls to ls -d
653  to parse "view" and "finger" commands properly
654  the view hack updated for bind-8 (using sed)
655
656* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
657- add ISC patch
658- add quick hack to make host not crash
659- add more docs
660
661* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
662- add probing information in the init file to keep linuxconf happy
663- dont strip libbind
664
665* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
666- auto rebuild in the new build environment (release 3)
667
668* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
669- removed 'done' output at named shutdown.
670
671* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
672- version 8.2
673
674* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
675- patch to use the __FDS_BITS macro
676- build for glibc 2.1
677
678* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
679- change named.restart to /usr/sbin/ndc restart
680
681* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
682- install man pages correctly.
683- change K10named to K45named.
684
685* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
686- don't start if /etc/named.conf doesn't exist.
687
688* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
689- autmagically create /etc/named.conf from /etc/named.boot in %post
690- remove echo in %post
691
692* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
693- merge in 5.1 mods
694
695* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
696- Several essential modifications to build and install correctly.
697- Modified 'ndc' to avoid deprecated use of '-'
698
699* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
700- Used buildroot
701- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
702  on Redhat 5.0 instead of <nlist.h>
703
Note: See TracBrowser for help on using the repository browser.