source: projects/specs/trunk/b/bind/bind-vl.spec @ 9333

Revision 9333, 21.5 KB checked in by inagaki, 9 years ago (diff)

2015-02-06 Ryoichi INAGAKI <ryo1@…>

  • bind, ntp, procmail: security fix


Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind
5%define pversion 9.9.6.P1
6%define sversion 9.9.6-P1
7%define bind_epoch 1
8# fixed <BTS:VineLinux:1139>
9%define old_bind_version 1:9.9.2p2-1vl7
10
11%define bind_uid  25
12%define bind_gid  25
13
14Summary: A DNS (Domain Name System) server.
15Summary(ja): DNS (Domain Name System) サーバ
16Name: %{pname}
17Version: %{pversion}
18Release: 3%{?_dist_release}
19Epoch: %{bind_epoch}
20License: distributable
21Group: System Environment/Daemons
22URL: http://www.isc.org/bind.html
23
24Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
25Source1: bind-manpages.tar.bz2
26Source2: named.sysconfig
27Source3: named.init
28Source4: named.logrotate
29Source5: keygen.c
30Patch1: bind-9.3.3rc2-rndckey.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33BuildRequires: openssl-devel glibc-devel libtool
34BuildRequires: libxml2-devel
35BuildRequires: libcap-devel
36Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
37Requires(pre): shadow-utils
38Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
39Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
40Requires(post): coreutils, chkconfig
41Requires(preun): initscripts, chkconfig
42Conflicts: bind9 <= 9.2.1-0vl5, bind-current
43Obsoletes: bind9 <= 9.2.1-0vl5
44Obsoletes: bind-current < 1:9.9.4-1
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: daisuke
49
50%description
51BIND (Berkeley Internet Name Domain) is an implementation of the DNS
52(Domain Name System) protocols. BIND includes a DNS server (named),
53which resolves host names to IP addresses, and a resolver library
54(routines for applications to use when interfacing with DNS).  A DNS
55server allows clients to name resources or objects and share the
56information with other network machines.  The named DNS server can be
57used on workstations as a caching name server, but is generally only
58needed on one machine for an entire network.  Note that the
59configuration files for making BIND act as a simple caching nameserver
60are included in the caching-nameserver package. 
61
62Install the bind package if you need a DNS server for your network.  If
63you want bind to act a caching name server, you will also need to install
64the caching-nameserver package.
65
66
67%package libs
68Summary: Libraries used by various DNS packages
69Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
70Group: System Environment/Libraries
71Obsoletes: bind-current-libs <= %{old_bind_version}
72
73%description libs
74Contains libraries used by both the bind server package as well as the utils packages.
75
76
77%package utils
78Summary: Utilities for querying DNS name servers.
79Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
80Group: Applications/System
81Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
82Conflicts: bind9-utils <= 9.2.1-0vl5
83Conflicts: bind-current-utils
84Obsoletes: bind9-utils <= 9.2.1-0vl5
85Obsoletes: bind-current-utils <= %{old_bind_version}
86
87%description utils
88Bind-utils contains a collection of utilities for querying DNS (Domain
89Name Service) name servers to find out information about Internet hosts.
90These tools will provide you with the IP addresses for given host names,
91as well as other information about registered domains and network
92addresses.
93
94You should install bind-utils if you need to get information from DNS name
95servers.
96
97
98%package devel
99Summary: Include files and libraries needed for bind DNS development.
100Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
101Group: Development/Libraries
102Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
103Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
104Conflicts: bind9-devel <= 9.2.1-0vl5
105Conflicts: bind-current-devel
106Obsoletes: bind9-devel <= 9.2.1-0vl5
107Obsoletes: bind-current-devel <= %{old_bind_version}
108
109%description devel
110The bind-devel package contains all the include files and the
111library required for DNS (Domain Name Service) development for
112BIND versions 9.x.x.
113
114You should install bind-devel if you want to develop bind DNS
115applications. If you install bind-devel, you'll also need to install
116bind.
117#'
118
119%prep
120%setup -n bind-%{sversion} -q
121%patch1 -p1 -b .key
122perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
123
124%build
125libtoolize --copy --force
126aclocal
127autoconf
128%configure \
129  --with-libtool \
130  --with-openssl=/usr \
131  --disable-openssl-version-ceck \
132  --enable-threads \
133  --enable-ipv6 \
134  --with-pic \
135  --with-dlz-dlopen \
136  --enable-filter-aaaa \
137  --enable-fixed-rrset
138make %{?_smp_mflags}
139
140%install
141rm -rf $RPM_BUILD_ROOT
142mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
143mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
144mkdir -p ${RPM_BUILD_ROOT}/var/named
145mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
146mkdir -p ${RPM_BUILD_ROOT}/var/run/named
147
148make DESTDIR=$RPM_BUILD_ROOT install
149install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
150install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
151install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
152install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
153touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
154gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
155cd $RPM_BUILD_ROOT%{_mandir}
156tar xjf %{SOURCE1}
157# newer version is contained in source
158rm -f man5/named.conf.5.gz
159mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
160cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
161
162chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
163
164rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
165
166%clean
167rm -rf $RPM_BUILD_ROOT ${RPM_BUILD_DIR}/%{name}-%{version}
168
169
170%pre
171if [ "$1" -eq 1 ]; then
172  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
173  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
174fi;
175:;
176
177%post
178/sbin/ldconfig
179/sbin/chkconfig --add named
180if [ "$1" -eq 1 ]; then
181  if [ ! -e /etc/rndc.key ]; then
182    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
183  fi
184  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
185  # rndc.key has to have correct perms and ownership, CVE-2007-6283
186  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
187  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
188
189  # Check DNSSEC settings if this is a fresh install
190  if [ -r /etc/sysconfig/dnssec ]; then
191    . /etc/sysconfig/dnssec
192    [ -x /usr/sbin/dnssec-configure ] && \
193      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
194        /dev/null 2>&1
195  fi;
196fi
197:;
198
199%preun
200if [ "$1" -eq 0 ]; then
201   /sbin/service named stop >/dev/null 2>&1 || :
202   /sbin/chkconfig --del named ||:
203fi
204exit 0
205
206%postun
207if [ "$1" -ge 1 ]; then
208        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
209fi
210/sbin/ldconfig
211
212%triggerpostun -- bind < 8.2.2_P5-15
213/sbin/chkconfig --add named
214/sbin/ldconfig
215
216%triggerpostun -- bind-current < 1:9.9.4-1
217/sbin/chkconfig --add named
218/sbin/ldconfig
219
220%post libs -p /sbin/ldconfig
221
222%postun libs -p /sbin/ldconfig
223
224
225%files
226%defattr(-,root,root)
227%doc CHANGES README
228%doc doc/arm doc/misc
229%config(noreplace) %{_sysconfdir}/logrotate.d/named
230%config %{_sysconfdir}/rc.d/init.d/named
231%config(noreplace) %{_sysconfdir}/sysconfig/named
232%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
233%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
234%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
235
236%{_sbindir}/dnssec*
237%{_sbindir}/lwresd
238%{_sbindir}/named
239%{_sbindir}/named-bootconf
240%{_sbindir}/named-check*
241%{_sbindir}/named-compilezone
242%{_sbindir}/rndc*
243%{_sbindir}/dns-keygen
244%{_sbindir}/arpaname
245%{_sbindir}/ddns-confgen
246%{_sbindir}/genrandom
247%{_sbindir}/isc-hmac-fixup
248%{_sbindir}/named-journalprint
249%{_sbindir}/nsec3hash
250
251%{_mandir}/man1/arpaname.1*
252%{_mandir}/man5/resolv.conf.5*
253%{_mandir}/man5/named.conf.5*
254%{_mandir}/man5/rndc.conf.5*
255%{_mandir}/man8/rndc.8*
256%{_mandir}/man8/named.8*
257%{_mandir}/man8/lwresd.8*
258%{_mandir}/man8/dnssec*.8*
259%{_mandir}/man8/named-checkconf.8*
260%{_mandir}/man8/named-checkzone.8*
261%{_mandir}/man8/named-compilezone.8*
262%{_mandir}/man8/rndc-confgen.8*
263%{_mandir}/man8/ddns-confgen.8*
264%{_mandir}/man8/genrandom.8*
265%{_mandir}/man8/isc-hmac-fixup.8*
266%{_mandir}/man8/named-journalprint.8*
267%{_mandir}/man8/nsec3hash.8*
268
269%attr(-,named,named) %dir %{_var}/named
270%attr(-,named,named) %dir %{_var}/run/named
271     
272
273%files libs
274%defattr(-,root,root)
275%{_libdir}/*.so.*
276
277%files utils
278%defattr(-,root,root)
279%{_bindir}/dig
280%{_bindir}/host
281%{_bindir}/nslookup
282%{_bindir}/nsupdate
283%{_mandir}/man1/host.1*
284%{_mandir}/man1/nsupdate.1*
285%{_mandir}/man1/dig.1*
286%{_mandir}/man5/resolver.5*
287%{_mandir}/man1/nslookup.1*
288%{_mandir}/man8/nslookup.8*
289
290
291%files devel
292%defattr(-,root,root)
293%{_libdir}/*.so
294%{_libdir}/*.a
295%{_includedir}/*
296%{_mandir}/man3/*
297%{_mandir}/man1/bind9-config.1*
298%{_mandir}/man1/isc-config.sh.1*
299%{_bindir}/bind9-config
300%{_bindir}/isc-config.sh
301
302%changelog
303* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
304- new upstream release with secrity fix (CVE-2014-8500) 
305- used "3" as release number  because of being newer than Vine Linux/6 updates
306
307* Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
308- update to 9.9.4(ESV)
309
310* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
311- update to 9.9.2-P2
312- remove .la
313- remove Conflicts/Obsoletes from libs subpackage.
314- add configure options
315  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
316
317* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
318- new upstream release.
319- added an option "--with-dlz-dlopen".
320
321* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
322- Obosoletes: bind.* < 1:9.6.ESV.R1
323 - fixed <BTS:VineLinux:1139>
324
325* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
326- new upstream release with security fix (CVE-2011-1910)
327
328* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
329- add BuildRequires: libxml2-devel, libcap-devel
330
331* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
332- new upstream release with security fix (CVE-2011-1907)
333- fix changelog typo
334
335* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
336- Obosoletes: bind.* < 1:9.6.ESV.R1
337
338* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
339- update to 9.8.0
340- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
341
342* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
343- rebuild with openssl-1.0.0c
344
345* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
346- fix Req: in bind package
347
348* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
349- change package name bind -> bind-current
350- add epoch 1
351- new upstream release
352
353* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
354- new upstream release
355
356* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
357- rebuilt with gcc-4.4.3-3 on ppc
358
359* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
360- rebuilt with new toolchains (for VineSeed)
361- s/BuildPrereq/BuildRequires/
362
363* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
364- add man1/isc-config.sh.1 into devel file list
365
366* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
367- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
368
369* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
370- new upstream release with security fix (CVE-2009-4022)
371
372* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
373- new upstream release with security fix
374
375* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
376- new upstream release
377- clean up %%post/%%pre scriptlet
378  - create named user and group in %%pre
379  - don't remove named user/group in %%preun
380  - use rndc-confgen to create rndc.key
381
382* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
383- new upstream release
384- drop patch0 and patch14, merged in upstream
385
386* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
387- new upstream release with security fix
388
389* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
390- new upstream release with security fix
391- new versioning policy
392
393* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
394- new upstream release with security fix
395
396* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
397- new upstream release
398- build with new openssl/toolchain
399
400* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
401- new upstream release with security fix
402
403* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
404- new upstream release
405
406* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
407- add Prereq sed
408
409* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
410- new upstream release for security fix (CVE-2006-4095,4096)
411
412* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
413- separate -libs package
414- remove old named.conf.5.gz
415  - newer version is contained in source
416
417* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
418- add bsdcompat patch (Patch4)
419- add fix_h_errno patch from FC
420  - h_errno not being accessed / set correctly in libbind
421
422* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
423- new upstream release
424
425* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
426- added PreReq to bind-utils (see: [VineSeed:09555])
427
428* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
429- new upstream release
430
431* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
432- fix /etc/init.d/named to use rndc
433
434* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
435- rebuild to remove unneeded dependancy
436
437* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
438- new upstream release
439
440* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
441- new upstream release
442
443* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
444- fix dependancies.
445
446* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
447- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
448- change package name to bind for VineSeed.
449- use more macros.
450
451* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
452- fixed some macros
453- add conflicts: to bind-* in bind9-devel and bind9-utils
454- add provides: bind = %%{version}
455
456* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
457- use %%configure macros
458
459* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
460- fixed inconsistent dependency
461
462* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
463- updated to 9.2.2rc1
464
465* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
466- updated to bind9(9.2.1), test packages ;)
467        -- based on Rawhide's bind-9.2.0-8
468        -- changed name bind9
469        -- added Conflicts: bind
470
471* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
472- release 8.3.1 includes security fixes
473
474* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
475- Upgraded to current stable release 8.3.0
476
477* Mon Oct  8 2001 <zn@mbf.nifty.com>
478- 8.2.5-0vl0: Upgraded to new upstream version.
479
480* Thu May 24 2001 <sagami@vinelinux.org>
481- 8.2.4-0vl1: eliminate CVS related files from %%doc
482
483* Thu May 17 2001 <sagami@vinelinux.org>
484- 8.2.4-0vl0
485
486* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
487- 8.2.3-1vl2
488- built on VineSeed
489
490* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
491- add doc/old
492- build for Vine 2.1
493
494* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
495- 8.2.3, fixes several security problems
496
497* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
498- static libraries may be used in shared objects. Build with -fPIC on ia64
499
500* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
501- 8.2.2-P7 (fixes Bug #20546)
502
503* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
504- condrestart fixes
505
506* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
507- change the init script to take condrestart, not cond-restart
508- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
509  the %pre and %post scripts
510
511* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
512- Don't prereq /etc/init.d
513
514* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
515- move initscript back
516
517* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
518- automatic rebuild
519
520* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
521- add "exit 0" for uninstall case
522
523* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
524- add prereq init.d and cleanup install section
525
526* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
527- fix the init script
528
529* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
530- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
531
532* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
533- Fix up the initscript (Bug #13033)
534- Fix build with current glibc (Bug #12755)
535- /etc/rc.d/init.d -> /etc/init.d
536- use %%{_mandir} rather than /usr/share/man
537
538* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
539- fix conflict with man-pages
540- remove compatibilty chkconfig links
541- initscript munging
542
543* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
544- modify logrotate setup to use PID file
545- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
546- actually bump the release this time
547
548* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
549- FHS compliance
550
551* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
552- clean up restart patch
553
554* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
555- provide /var/named (fix for bugs #9847, #10205)
556- preserve args when restarted via ndc(8) (bug #10227)
557- make resolv.conf(5) a link to resolver(5) (bug #10245)
558- fix SYSTYPE bug in all makefiles
559- move creation of named user from %%post into %%pre
560
561* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
562- Fix TTL (patch from ISC, Bug #9820)
563
564* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
565- fix typo in spec (it's %post, without a leading blank) introduced in -6
566- change SYSTYPE to linux
567
568* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
569- pick a standard < 100 uid/gid for named
570
571* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
572- Pass named a '-u named' parameter by default, and add/remove user.
573
574* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
575- fix host mx bug (Bug #9021)
576
577* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
578- rebuild to fix dependencies
579- man pages are compressed
580
581* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
582- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
583
584* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
585- Fix up location of named-bootconf.pl and make it executable
586  (Bug #8028)
587- bind-devel requires bind
588
589* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
590- update to 8.2.2-P5
591
592* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
593- update to 8.2.2-P3
594
595* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
596- add patch to stop a cache only server from complaining about lame servers
597  on every request.
598
599* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
600- use real stop and start in named.init for restart, not ndc restart, it has
601  problems when named has changed during a package update... (# 4890)
602
603* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
604- chkconfig --del in %preun, not %postun
605
606* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
607- initscript munging
608
609* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
610- fix installed chkconfig links to match init file
611
612* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
613- conflict with new (in man-1.24) man pages (#3876,#3877).
614
615* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
616- fix named.logrotate (wrong %SOURCE)
617
618* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
619- update to 8.2.1.
620- add named.logrotate (#3571).
621- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
622- vet file list.
623
624* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
625- don't run by default
626
627* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
628- nslookup fixes (#2463).
629- missing files (#3152).
630
631* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
632- nslookup patched:
633  to count numRecords properly
634  to fix subsequent calls to ls -d
635  to parse "view" and "finger" commands properly
636  the view hack updated for bind-8 (using sed)
637
638* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
639- add ISC patch
640- add quick hack to make host not crash
641- add more docs
642
643* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
644- add probing information in the init file to keep linuxconf happy
645- dont strip libbind
646
647* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
648- auto rebuild in the new build environment (release 3)
649
650* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
651- removed 'done' output at named shutdown.
652
653* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
654- version 8.2
655
656* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
657- patch to use the __FDS_BITS macro
658- build for glibc 2.1
659
660* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
661- change named.restart to /usr/sbin/ndc restart
662
663* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
664- install man pages correctly.
665- change K10named to K45named.
666
667* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
668- don't start if /etc/named.conf doesn't exist.
669
670* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
671- autmagically create /etc/named.conf from /etc/named.boot in %post
672- remove echo in %post
673
674* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
675- merge in 5.1 mods
676
677* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
678- Several essential modifications to build and install correctly.
679- Modified 'ndc' to avoid deprecated use of '-'
680
681* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
682- Used buildroot
683- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
684  on Redhat 5.0 instead of <nlist.h>
685
Note: See TracBrowser for help on using the repository browser.